Реклама на сайте English version  DatasheetsDatasheets

KAZUS.RU - Электронный портал. Принципиальные схемы, Datasheets, Форум по электронике

Новости электроники Новости Литература, электронные книги Литература Документация, даташиты Документация Поиск даташитов (datasheets)Поиск PDF
  От производителей
Новости поставщиков
В мире электроники

  Сборник статей
Электронные книги
FAQ по электронике

  Datasheets
Поиск SMD
Он-лайн справочник

Принципиальные схемы Схемы Каталоги программ, сайтов Каталоги Общение, форум Общение Ваш аккаунтАккаунт
  Каталог схем
Избранные схемы
FAQ по электронике
  Программы
Каталог сайтов
Производители электроники
  Форумы по электронике
Удаленная работа
Помощь проекту

Автоматика и аппаратура связи Дистанционное и непосредственное управление исполнительными механизмами, сотовая, а также радиосвязь.

 
Опции темы
Непрочитано 02.10.2009, 08:15  
Gn0me
Временная регистрация
 
Регистрация: 15.08.2006
Сообщений: 54
Сказал спасибо: 3
Сказали Спасибо 3 раз(а) в 3 сообщении(ях)
Gn0me на пути к лучшему
По умолчанию проблема при работе с Bluetooth модулем

Добрый день. Купил для экспериментов Bluetooth модуль Bluenicecom IV. Подал питиние как в мануале, скорость UART настроил ножками OP3-OP5 на 9600 кбит/с. Во первых реальная скорость обмена получилась 10400 кбит/с (замерял логическим анализатором LOGIC-U). Может там с кварцами что-то напутано. Я так подумал, потому что 10400/9600=13/12, а в руководстве по программированию как раз что-то говорится про кварцы 12 и 13 МГц.
Обмен на скорости 10400 ведется нормально, модуль отвечает на запросы, производит изменение EEPROM, но тут возникает другая проблема: ни модуль не может найти другие bluetooth устройства, ни они не могут найти его. Может это из-за частоты кварца как раз и происходит, а может еще из-за чего я никак не могу разобраться. Для связи с модулем использую фирменную программу Simply Blue Commander. Перепробовал уже кучу настроек, так же возвращал модуль к заводским настройкам. Ничего не помогает. Может кто работал с этими модулями, подсажите в чем проблема. Может сам модуль не исправен.
Реклама:
Gn0me вне форума  
Непрочитано 02.10.2009, 09:33  
Gn0me
Временная регистрация
 
Регистрация: 15.08.2006
Сообщений: 54
Сказал спасибо: 3
Сказали Спасибо 3 раз(а) в 3 сообщении(ях)
Gn0me на пути к лучшему
По умолчанию Re: проблема при работе с Bluetooth модулем

Проблема обнаружена. Делал все на макетной плате навесом и не подключил один из выводов к VCC. Надо быть предельно внимательным. Тему можно закрыть.
Gn0me вне форума  
 

Закладки
Опции темы

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход

Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Проблема при запуске Atmega16 zamsv Микроконтроллеры, АЦП, память и т.д 5 02.10.2009 12:52


Часовой пояс GMT +4, время: 20:10.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd. Перевод: zCarot