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Chapter 1: Program Basics
The Advanced Design System design environment includes all the tools you need to
manage your projects, create and edit schematics, and simulate your designs easily
and efficiently. The program basics described here include:

• “Documentation Conventions” on page 1-1

• “Basic Terminology” on page 1-2

• “Starting the Program” on page 1-3

• “The Design Environment” on page 1-5

• “Naming Conventions” on page 1-20

• “Using Keyboard Shortcuts and Accelerator Keys” on page 1-34

• “Setting Preferences for Miscellaneous Options” on page 1-34

• “Exiting the Program” on page 1-36

Note For installation instructions, refer to the Advanced Design System Installation
manual for your platform.

Documentation Conventions
To help you locate and interpret information easily, Advanced Design System
manuals employ consistent visual cues, a few standard text formats, and some
special terminology. Table 1-1 describes the typographic conventions used throughout
the manual set.

Table 1-1. Typographic conventions

Type style Used for

italic Signals a new term; identifies directory names, filenames, and
program names; highlights commands used within text.
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Program Basics
Basic Terminology
Your familiarity with the terms described in Table 1-2 will make the concepts and
procedures presented here easier to understand.

ALL CAPITALS Acronyms

bold Menu names, command names, items from a list, filenames or
project names that you choose when following a procedure.

Also used to denote the names of buttons you press or anything you
type, including equations.

Keys on the keyboard that are pressed are shown in bold.

Table 1-2. Basic terminology

Term Meaning

Click To quickly press and release the left mouse button

Choose To click a menu or command name

Directory A collection of files

Double-click To click the mouse button twice in rapid succession

Drag To hold down the mouse button while you slide the mouse

Icon (1) A picture (on a button) that represents the action that will be carried
out or the component that will be chosen when you press that button;
(2) the small box on your screen that represents an entire window; (3)
a graphic symbol used on the PC to start a program.

Menu A collection of related commands.

Press To hold a mouse button down, usually combined with dragging, before
releasing to complete some action

Project name A designation for the location of files or directories on your disk.

Select To mark an item by clicking on or near it with a mouse. For example,
you might select an item and then choose the Delete command to
remove the item from the drawing area.

Table 1-1. Typographic conventions (continued)

Type style Used for
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Starting the Program
To start the program:

• UNIX, from the terminal window type:

hpads

Note Starting ADS in this manner assumes you have established a path to the
ADS installation directory. If you have not, type <installation_dir>/bin/hpads,
where <installation_dir> represents your complete installation path. For
details on establishing a path statement, refer to Chapter 2 of the Installation
on UNIX Systems manual.

• Windows, from the Start menu choose:

Programs  > Advanced Design System 2002  > Advanced Design System

to bring up the Advanced Design System Main window, which provides access
to all features of the Advanced Design System. Alternatively, choose one of the
other commands to access these specific features of the Advanced Design
System:

Hint The first time you start the program, a window appears displaying information
on new features in this release.

ADS Tools Displays a list of ADS tools such as Digital Filter Designer, DSP Synthesis,
Library Translator, or LineCalc. Choose the tool you want to launch.

ADS Documentation Launches the online documentation viewer and displays the primary window
for accessing documentation from:

Disk, if you chose to install it during Setup
or
CD-ROM, with the documentation CD-ROM in place

RF Designer Launches the ADS Main window for use with the RF Designer product (the
base ADS product for RF design)
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Selecting a Design Type

The first time you launch the application, you are prompted to select which type of
components you want loaded on start-up: Analog/RF Only, Digital Signal Processing
Only, or Both. Choosing either of the first two categories limits your choice of
components, for the current session, to the selected category. Choosing Both allows
both types of design work in the same session.

If you select Both (Both, With Default:), you must also specify a default design type.
This default design type serves the following purposes: defines the components
available by default in a design window and defines the default design type that
appears in the New Design dialog box. (This choice only serves as a default and can
be changed any time you start a new design (File > New).

Note You can change these options at any time through Options > Advanced Design
System Setup in the Main window. When you change these options, you are changing
them for the subsequent session and you are prompted to exit the application and
restart it to effect the change. The selections remain valid until you explicitly change
them again.

When you dismiss the setup dialog box, the Advanced Design System Main window
appears.
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The Design Environment
The design environment is made up of windows. All operations take place within the
framework of windows.

Main window . Contains a title bar with the name of the window (Advanced Design
System), a menu bar, and a toolbar for quick access to common operations. In
addition it provides a tree-like view of directories, and where applicable, the designs
comprising a hierarchical design.

From the Main window you can:

• Create and manage projects and designs

• Set program preferences

• Change toolbar configuration and keyboard shortcuts for the Main window

• Change the type of components loaded on start-up

• Playback macros created through Applications Extension Language (AEL)

• Issue AEL commands

• Launch a text editor

• Open a data display window

• Display all types of files and open as desired through context-sensitive menu
The Design Environment 1-5



Program Basics
Design windows . The Schematic and Layout windows have the same basic
appearance: title bar, menu bar, toolbar, palette, prompt panel, and drawing area.

From the Schematic window you can:

• Create and edit schematics

• Create variables and equations

• Simulate and optimize

• Open a data display window

• Generate a layout from the schematic

From the Layout window you can:

• Create and edit layouts

• Generate a schematic from the layout

• Create and edit parameterized artwork macros

• Define design rules and verify the design meets the established rules

• Launch Momentum

• Open a data display window

Data Display window . Contains a title bar, a menu bar, a toolbar, a palette, and a
graphics area. This window enables you to view and compare simulation data.

Message/Status window . Appears whenever a simulator is launched and displays
messages about the status of the current process as well as warning messages.

Hint As you work with multiple windows, you may find it helpful to minimize the
Status window to clear additional space on your screen. To quickly restore it to the
screen, choose Window > Simulation Status from any program window.
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Working in the Main Window

The Main window enables you to create and manage projects. Projects are central to
the operation of all the simulators and allow you to organize your related designs.

From the Main window you can:

• Create and manage projects and designs

• Quickly open example projects (File > Example Project)

• Set program preferences

• Change toolbar configuration and keyboard shortcuts

• Change the type of components loaded on start-up

• Playback macros created through Application Extension Language (AEL)

• Issue AEL commands

• Launch the text editor

• Open a data display window

• Pop obscured windows to the top (from the Window menu)

• Display all types of files and open as desired through context-sensitive menu
(View > Show All Files). Click right to open different types of files in the
appropriate type of window (including a text editor for .ael, .cfg, etc.).

For a detailed discussion of projects, refer to Chapter 2, Managing Projects and
Designs.
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Working in Design Windows

A design window is where you create and edit all of your designs. You can resize and
move these windows in the workspace. You can enlarge one window to fill the entire
workspace and you can shrink each window to an icon. The following illustration
shows the parts of a design window.

• The Title bar displays the window type, design type, filename, and a number
identifying which window of that type it is

• The Menu bar displays the menus available in that window

• The Toolbar contains buttons for frequently used commands and for choosing
the appropriate orientation for components. The collection of buttons on the
toolbar is configurable (Options > Menu/Toolbar Configuration) and can be
toggled on and off (View > Toolbar).

When you move your pointer slowly over the buttons on the toolbar, a balloon
appears with a label identifying the function of that button. By default, the
option that controls the display of this label is turned on. To turn this option off,
choose Options > Preferences in the Main window and turn off Balloon Help.

Component Palette Title Bar

Drawing area

Menu Bar

Prompt Panel

Component History

Palette List

Component Orientation
Toolbars

Access with
a right-click
anywhere in
the drawing
area

Pop-up menu
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Hint To change the timing for the display of the balloon, set the variable
BALLOON_HELP_TIMEOUT in the file de_sim.cfg.

• The Palette List enables you to choose a category of components to place on the
Component Palette

• The Component History drop-down list is continuously updated to reflect the
components you have placed in your design. It provides a quick method of
placing another instance of a component in your design and can be used as a
starting point for creating a custom palette.

• The Drawing area is where you create your designs

• The Component Palette contains buttons for placing components

• The Prompt panel provides messages to assist you during the execution of most
commands, as well as various pieces of information to assist you in creating a
design.

• The Pop-up menu lets you access many common commands with a minimum of
mouse movement. You access the pop-up menu by pressing the right mouse
button in the drawing area of any design window. The context-sensitive
commands appear on the pop-up menu when the pointer is positioned over
certain shapes or text and you click right.

Table 1-3 describes the actions of the pop-up menu commands. Not all windows
support all of these commands. Most of the commands can be given at any time
without interrupting other commands in progress.

Table 1-3. Pop-up menu shortcuts

Command Action

End Command Cancels the active command

Deselect All Deselects anything in the window that is selected

Redraw View Refreshes the screen without affecting window magnification

View All Scales the view of your drawing so that all of it fits inside the
current drawing area

Pan View Moves a point you specify to the center of the window

Zoom Area Enables you to define a window of the drawing to fill the
drawing area

Zoom In x2 Zoom in by a factor of 2 around a point you specify
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Hint The display of the following options can be toggled on and off through these
View menu commands by these names:

Toolbar, Component Palette, Status Bar, Coordinate Readout

Zoom Out x2 Zoom out by a factor of 2 from a point you specify

Delete Deletes the selected object(s)

Arc (clockwise) Enables you to draw a clockwise arc

Arc (counterclockwise) Enables you to draw a counterclockwise arc

Undo Vertex Removes the last arc or vertex entered

Context-sensitive commands

Polygon Layer Enables you to select a different layer for the polygon

Polyline Layer Enables you to select a different layer for the polyline

Rectangle Layer Enables you to select a different layer for the rectangle

Edit Component Artwork Enables access to selecting different artwork for the selected
component

Wire Layer Enables you to select a different layer for the wire

Edit Circle Enables you to select a different layer for the circle, change its
radius and its resolution

Edit Arc Enables you to select a different layer for the arc and change
its resolution

Edit Text Enables you to select a different layer for the text, edit the text
itself, change the font, size, justification, and angle

Set As Text Default Values Uses the new settings as defaults
(same as Options > Preferences > Text)

Edit Path/Trace Enables you to modify Path/Trace characteristics such as
Width, Layer, and Corner Type

Set as Path/Trace Default
Values

Uses the new settings as defaults

Symbol Pin Edit
(Symbol view only)

Enables you to edit a pin’s name, number, angle, and type

Table 1-3. Pop-up menu shortcuts (continued)

Command Action
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Opening Design Windows

There are several ways to open design windows and the method you use is based on
what you want to do in that window.

• New design—To open a Schematic or Layout window for creating a new design
or editing an existing design not currently in memory, click the New Schematic
or New Layout button or choose the command (by the same name) from the
Window menu in the Main window.

• Additional window—To open an additional Schematic or Layout window for a
design that is already open, choose the Schematic or Layout command from the
Window menu in that window.

Hint You can also open a new Data Display window from the Main window.

Note that Schematic and Layout windows are numbered sequentially as they are
opened throughout a session. If Schematic window number three is open (the title bar
reflects (Schematic):3) and you open a dialog box from that window, the title bar of
the dialog box will also reflect :3. This is to assist you in identifying which design
window you are about to make changes to.

Opening Multiple Design Windows for the Same Design

The design environment enables you to use multiple Schematic and Layout windows
at the same time. For example, you can open two Schematic windows with different
designs making it easy to copy and paste parts from one design to another. Or the
windows can contain the same design making it easier to accomplish certain design
tasks.

Hint When you want to open a window for creating a new design or editing an
existing design, use the Window menu in the Main window; when you want to open
an additional window for the current design, use the Window menu in that window
(Schematic or Layout).

Figure 1-1 illustrates how you can connect components in a large schematic when the
components are far apart and the pins difficult to see. You can open an additional
window containing the same design. In the first window, zoom in on one of the
components. In the second window, zoom in on the other component. Choose the
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desired Wire command and draw the wire by clicking the appropriate pin in one
window, moving the pointer to the second window and clicking the appropriate pin
there.

Figure 1-1. Connecting components using multiple windows

Pins too small to select

2.Zoom in on pins
in each window

4.Close second
Schematic window,
View All

1.Open second
Schematic window

3.Wire pins from
first window to
second window

Schematic (1)

Large
Schematic

Schematic (2)

Large
Schematic

Schematic (1)

Large
Schematic

Schematic (2)

Large
Schematic

Schematic (1)

Large
Schematic

Schematic (1) Schematic (2)
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Using the Component Palette

The Component Palette contains buttons that provide a quick method of placing items
to create your design.

Hint All palette items can also be placed through the Library. Some items are only
available through the Library.

Detaching the Component Palette

The component palette can be detached from the window and moved anywhere on the
screen. You may find this helpful in temporarily providing additional space in the
drawing area.

To detach the component palette:

Choose View > Component > Detach Component Palette . Window borders and a title
bar appear. Where applicable, scroll bars also appear. This window can now be
moved around and manipulated like any other window.

Click the button for the item you
want to place

Click here to view a drop-down list
for selecting a different category of
items to place on the palette
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To attach the palette to the window again:

Choose View  > Component  > Attach Component Palette . The palette is once again
integrated with the design window.

Hint On the PC only, you can detach and re-attach using the mouse. Position the
pointer over a blank area between buttons on the palette and press the left mouse
button. A border appears. Drag the palette to the desired location and release. To
re-attach, position the pointer in the title bar of the detached palette and press the
left mouse button. Drag the palette toward its original location, positioning the title
bar just under the bottom of the palette drop-down list and release.

Moving Toolbars (PC Only)

The toolbars can be repositioned anywhere on the screen. You can move them away
from the window and use them like floating palettes or you can dock them along the
window’s edges.

Hint When the title bar of a toolbar is visible, positioning your pointer within the
title bar for the drag operation simplifies the docking process. If a title bar is not
visible, move the toolbar away from the window’s edge and release; when it is not
docked, a title bar appears.

To float a toolbar away from the window:

1. Position the pointer over a blank area between icons on the toolbar and press
the left mouse button.

2. Drag the toolbar to the desired location and release. When you release the
toolbar, a title bar appears at the top of it.

To dock a toolbar on a window border:

1. Position the pointer over a blank area between icons and press the left mouse
button.

2. Drag the toolbar toward the desired window border and notice that the ghost
image of the toolbar changes as needed to fit in a vertical or horizontal space.
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3. When the ghost image reflects the proper orientation, release the mouse button
and refine the toolbar’s position by dragging as necessary.

To reattach a toolbar near the top of the window:

1. Position the pointer in the title bar of the toolbar and press the left mouse
button.

2. Drag the toolbar toward the top of the window and when your pointer is
overlapping the menu bar, or another toolbar, release.

For details on customizing and creating toolbars, refer to the section, “Configuring
Toolbars” on page 9-31.

Schematic Window

The Schematic window is where you create your schematic designs. You create your
design by placing components, ports, data items, units, variables, equations, etc.

The program is shipped with a set of standard defaults and parts libraries. These
differ depending on program options. However, all defaults can be modified on a
system-wide, or project basis. Before beginning any serious design effort, you can
customize these defaults to better match the typical designs done at your site.
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The most important thing you can do before starting your design is to configure your
setup correctly. There are many ways to configure the program defaults. The best
configuration for you depends on the type of designs you create, the options you have,
and the type of final output you require.

Layout Window

Although the Layout window has many things in common with the Schematic
window, it also has many important differences. For details on the Layout option,
refer to the Layout manual.

Closing Design Windows

To close an individual design window, but keep the design in memory:

From the Window menu in that window, choose Close .

Status Message Window

The Simulation/Synthesis Message window appears whenever a simulator is
launched and displays messages about the status of the current process, as well as
warning messages. Each simulation generates its own set of messages which are
stored in memory during the current session. These sets of messages can be
distinguished from one another by the number displayed in the title bar of the
window.

The window contains two information panels:

• Simulation/Synthesis Messages

• Status/Summary

The Simulation/Synthesis Messages portion of the window displays detailed
messages about problems encountered during a simulation or synthesis, and where
possible, what you can do to solve the problem.
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Hint Watch for a message that prompts you to click to view the source of the
problem. Clicking this message highlights the component(s)—in the Schematic
window—causing the problem.

The Status/Summary portion of the window displays a Simulation finished message,
statistics such as how long the simulation or synthesis took, and the system
resources used.

Viewing Simulation Status and Error Messages

When the simulation/synthesis is finished, you can save the displayed information to
file or you can send it directly to the printer.

To save the currently displayed information to file with a default filename:

Choose File  > Save Design and click OK. The default filename consists of the
simulation process number (from the title bar of the window), with a prefix of the
string sessloghpeesofsim and a file extension of .txt. The file is saved to the current
project directory.

To save the currently displayed information to file with a filename of your choosing:

Choose File  > Save As . Supply a filename and click OK. The file is saved to the
current project directory.

Note If you have changed projects during the current session, the file may be
written to the initial project opened in this session.
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To send the information directly to the printer:

1. If needed, choose File  > Print Setup  to establish the desired setup and click OK.

2. Choose File  > Print . The displayed information is sent to the printer.

For details on print setup, refer to Chapter 11, Printing and Plotting.

Because each simulation generates a set of messages identified by unique names, you
can view any messages generated during the current session. You can view these one
at a time in the same window, or you can open multiple windows and display different
ones all at the same time.

To view messages generated by another simulation:

1. Optionally, choose Window  > New Window .

2. From the Window menu, select the simulation information you want to view, as
identified by the unique number displayed in the title bar associated with each
simulation. The display changes to reflect your selection.

To close any individual status window:

Choose Window  > Close Window .
1-18 The Design Environment



Using the Data Display Window

You can open a Data Display window to see the results of your simulation analysis.
To view a graph, choose Window > New Data Display from the Main or Schematic
window. After you open a window, you can select an independent swept variable,
select dependent measurements, scale the data, and add captions to your graph.
Then you can print or plot the graph.

You can open one or more Data Display windows at a time inside the same work
space. For example, you can view the same data on a graph and in a tabular format at
the same time. Each graph appears in a separate window.

For detailed information on working with data displays, refer to the Data Display
manual.
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Using the File/Instrument Window

The Instrument window enables you to read data from sources such as a network
analyzer or a Touchstone file into Advanced Design System as a dataset. The
Instrument Server can also write data from a dataset out to an instrument or file. To
display the Instrument Server window, choose Window > File/Instrument Server. For
details on using the Instrument Server, refer to the Using Instruments with ADS
manual.

Naming Conventions
Prior to Advanced Design System 1.5, user-supplied names throughout the software
were restricted in numerous ways. Not only were names restricted with respect to the
allowable set of characters, but you could not have any duplication of names among
certain types of items, such as node names and instance names. Using the same
name for the following items is now allowed:

• Variable names (created in VarEqn and MeasEqn components)

• Node names/Wire labels

• Instance Names

• Component names (includes supplied components and models, and your designs
used as subnetworks)

Note The names of supplied components cannot be used as design names. If you
receive an error message stating the supplied design name is reserved for Advanced
Design System, you have most likely used a name that is reserved for a component.
To review these names, see the component libraries or the component manuals.

The following illustration shows how these terms are used.
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User-supplied names that were previously restricted to alphanumeric and
underscore (_) characters (hereafter referred to as the standard character set), can
now take advantage of an extended character set that incorporates additional special
characters. The extended character set (a superset) consists of the following
characters:

alphanumeric _ + - = ^ ` @ # & $ %

In addition, you can now use a numeral as the first character in many names.

Supplied
components

Supplied
Models

Designs used
as subnetworks

Component names
Instance names

Variable names

Variable name

Node name/
wire label
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The following table denotes where the extended set and numeric prefixes can be used,
as well as several exceptions:

Name
Character
Set Exceptions

Numeric
Prefix

Variable (VarEqn,
MeasEqn)

Standard No

Node/wire label Extended Yes

Instance Extended An underscore cannot be used as the first character.

The following components are restricted to the
standard character set for their Instance Name:

SweepPlan, ParamSweep,
DC, AC, S_Param, HB, LSSP, P2D
XDB, Envelope, Transient,
Options, YieldSpec, Goal, Yield,
Optim, YieldOptim, MeasEqn, VarEqn,
DataAccessComponent

Yes

Component Extended Yes

Design Extended Design names may not contain $ or %. These
characters are reserved for ADS environment
variable substitution.

Note: If a design name includes special characters or
starts with a numeral (such as "00a" or "@"),
optimization results are not updated

Note: If a design name consists solely of numerals,
The transistor device operating points dialog box
cannot be displayed.

Yes

Project Standard Yes
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Limitations

• When the extended character set is used to define a name, and that name
becomes part of a variable name in a dataset, the data cannot be accessed
directly with respect to either data displays or measurement equations. A
special access function called var(), must be used. For example, if you name a
node V++ then to display its magnitude you must use the expression:

mag(var(''V++''))

where var() is passed the name of the variable as a string. The var() function
interprets the passed string as the name of a variable, which prevents any
expression processing of the string. Note that using this function limits you to
accessing datasets in the data directory of the current project. Data Display
automatically adds var() when required to access names defined using the
extended character set.

• Substrate Instance Names—If a leading number is used as a substrate ID, then
that substrate cannot be referenced by its corresponding set of distributed
models.

• Model Instance Names—Currently, the characters $ and % are not allowed in
Instance Names for model items, such as BJT_Model, R_Model, etc.

• Dataset Names—Special characters from the extended set are not allowed in
dataset names (standard set, with non-numeric first character, is required).
Thus, if you have two or more designs whose names are distinguishable from
one another only with respect to the use of special characters, you should supply
unique dataset names prior to simulating. If you do not, and you perform
successive simulations of these designs, the dataset resulting from the first
simulation will be overwritten by the next (because the special characters will
be dropped from the automatically derived dataset names).

Note: If your design name begins with a number, the default dataset name will
be the design name with an underscore character (_) added to the front.

• Optimization Goals—Special characters currently cannot be referenced by an
Optimization Goal or Yield spec. If a design name includes special characters or
starts with a numeral (such as "00a" or "@"), optimization results are not
updated.

• Operating Point Annotation—The transistor device operating points dialog box
does not come up when a design has a numeric name such as "0000" or "1234".
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• Spaces are not allowed in project and design names

Note An invalid character is changed to ''_'' (underscore).

Global Node Naming Conventions

If you use an exclamation point (!) as the last character in a node name, it denotes
that the node is a global node.

Creating an Electronic Notebook
The Electronic Notebook enables you to generate a portable notebook containing
screen captures of schematic and layout designs, as well as data displays, for a given
project. You can add descriptions for every page in the notebook, and you can include
text and graphics from other sources. The annotated body of design work can then be
viewed in a browser, enabling you to share your designs with others, without running
ADS. You can also zip the set of files generated by the notebook to facilitate
transferring them.

To create an electronic notebook:

1. From a Schematic window in the project of interest, choose Tools  > Electronic
Notebook . A dialog box appears providing a brief description of the notebook
basics.

2. Click OK and the main Electronic Notebook Editor dialog box appears. The
notebook displays the default notebook structure, which includes every design
and data display in the current project, as well as a single Description page for
the notebook.

At this point, you can click Generate and generate the actual HTML, based on
the default structure and default options, but the notebook editor contains
several features that enable you to customize it. For details, refer to the
following topics of interest:

• “Deleting Pages from the Notebook” on page 1-26

• “Adding Descriptions to the Notebook” on page 1-26

• “Adding Pages to an Existing Notebook” on page 1-27
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• “Reorganizing Pages in the Notebook” on page 1-28

• “Adding External Images to the Notebook” on page 1-28

• “Changing Image Capture Settings in the Notebook” on page 1-29

3. To generate a new notebook using the defaults, click Generate. An information
message appears with important guidelines regarding the status of ADS
windows during the HTML generation process. After reading these messages,
click OK and the HTML generation process begins. When the generation is
complete, the first page of the notebook is displayed in your browser. The
following illustration identifies the basic layout of the notebook using an
individual Schematic page as an example.

Refer to the following topics for descriptions of additional features:

• “Saving Changes to the Notebook” on page 1-31

• “Viewing an Existing Notebook” on page 1-31

• “Updating an Existing Notebook” on page 1-32

• “Zipping the Files of a Notebook” on page 1-32

Notebook Title
Banner
Image

Engineer

Company

Copyright

Actual
Content

Navigation

Among

Pages Description

Bottom Description
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Deleting Pages from the Notebook

By default, when you create a new notebook, it includes pages for every design and
data display in the project, but you can easily delete designs from the notebook.

To delete individual designs from the notebook:

Select the design you want to delete and click Delete Page . If you change your
mind, click Add Page, select the appropriate Page Type, select the design from the
drop-down list, and click OK to add it back.

Adding Descriptions to the Notebook

To add descriptive text to a specific page of the notebook:

1. Select the page from the list of pages on the left and enter the desired text in
the Description area(s) on the right. For individual design pages, you are
provided with two text boxes: Description and Bottom Description, which are
added above and below, respectively, the captured image.

Hint To include existing text from another source: on UNIX, highlight that text
and use the middle mouse button to paste it, or on the PC, copy the desired text
and use the pop-up menu available from within the Description text boxes to
paste it. On the PC only, you can copy and paste text among the various
description text boxes using this pop-up menu.

2. Optionally, you can use HTML in any of the description text boxes, enabling you
to format it as you please. Some basic HTML shortcuts are provided, but you
can enter most standard HTML tags directly in the text boxes.

To use the shortcut HTML tags, highlight the desired text and click the desired
shortcut icon. The associated HTML tags appear.

Heading 3
Heading 2
Heading 1Center

Italicize
Bold
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Note Due to differences in individual browsers and the fonts installed on your
operating system, these formats may not always produce the expected results.

3. When you are through making changes, click Generate  and these descriptions
will be incorporated in the notebook.

Adding Pages to an Existing Notebook

You can add a number of page types to the notebook. You can add new (since the
notebook was generated) or previously deleted Schematic, Layout, and Data Display
pages. You can also add a page that combines a Schematic and a Data Display on the
same page. And you can add an Image page for displaying a graphic from a source
other than ADS.

To add a page to the notebook:

1. Click the Add Page  button.

2. Select the desired Page Type. The dialog box changes, based on the selected
Page Type.

• If adding a Description page, no additional action is needed yet.

• If adding a Schematic, Layout, or Data Display page, select the name of the
design (to appear on that page) from the drop-down list.

• If adding a combined Schematic/Data Display page, select both the
schematic design name and the data display name from the respective
drop-down lists.

• If adding an Image page, enter the filename or use the browser to select it
(refer to “Adding External Images to the Notebook” on page 1-28).

3. Click OK and the page appears among the list of other notebook pages.

Hint If an individual design is highlighted when you add the page, the new
page appears under that design. If a group is highlighted, the new page appears
at the bottom of that group. You can then move it up and down, as well as left
and right, to position where you want it.
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Reorganizing Pages in the Notebook

To reorganize the designs in the notebook to reflect the design hierarchy:

1. Select the top-level design and click the Left arrow to make it a folder.

2. Use the Up and Down arrows to move the subnetwork designs under it, in the
desired order.

Moving a design/display from one group to another (such as, moving a data display
into the schematic group) requires making it a folder temporarily. To group related
schematic/layout designs and data displays together:

1. Select the design and click the Left arrow button (to make it a folder).

2. Use the Up and Down arrow buttons to move it above or below the design you
want to group it with, and click the Right arrow button to move it in again.

Adding External Images to the Notebook

You can include an image from an external source by adding an Image page, and you
can add descriptive text above and below it, just as you can with other types of pages.
You can also replace the Agilent logo with an image of your own.

To add an Image page to your notebook:

1. Click Add Page  and select Image  as the Page Type. A field for a filename
appears.

2. Type the path and filename or use the browser to select the file.

3. Optionally, click View  to verify you have the image you want.

4. Click OK.

Hint The image will be copied to the notebook directory, so if you change this
image in its original location, and want those changes to be part of the
notebook, be sure to import it to a new image page, copy and paste descriptions,
etc., and then delete the image page containing the older image.

5. Optionally, reposition the image page within the notebook using the Up and
Down arrows, and add any desired descriptive text.
1-28 Creating an Electronic Notebook



6. When you are through making changes, click Generate and the new image page
will be incorporated in the notebook.

To replace the Agilent logo with your own image:

In the Banner Image field, type the path and filename, or use the browser to select
one. Click Generate when you have made all other desired changes.

Changing Image Capture Settings in the Notebook

During the HTML generation, screen captures are taken of all schematics, layouts,
and data displays that are part of the notebook. By default, these screen captures will
be 700 pixels wide x 500 pixels high, with a normal zoom (see illustration that
follows). You can establish default settings for all new screen captures, and override
these defaults for individual designs.

To set a default capture size and zoom for all designs in the project:

1. From the Notebook Properties pane, click Preferences .

Default dimensions of a new
Schematic window. Adjust as
needed for larger or smaller
designs.

No zoom capability. Best suited to
small, simple designs.

Capture taken in four parts (without
overlaps). Zoom in on each quadrant.

Capture taken in nine parts (with
overlaps). Zoom in for a better view of
a portion of a complex design.

1 2 3
4 5 6

7 8 9

1 2

3 4
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2. Change the capture dimensions and zoom setting as desired and click OK.
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To override the default capture size and/or zoom for an individual design:

1. Select the design of interest and click Capture Options .

2. Change the settings as desired.

Hint If after experimenting you decide you want to go back to the original
settings, click Restore Defaults.

• For a new notebook, click OK in the Capture Options dialog box. When you
generate the notebook as a whole, these settings will be used for this design.

• If you are updating an existing notebook, click Recapture Image . A message
appears explaining that if you proceed, the currently saved image will be
replaced by a new capture, using the new capture settings. If this is what you
want to do, click Yes to continue and click OK in the Capture Options dialog
box. The next time you generate the notebook, this design will be recaptured
using the new settings.

Note The Recapture Image capability only works if the option Update images
automatically is enabled (the default state).

Saving Changes to the Notebook

Whenever you Generate the notebook, the information is saved automatically. But
any time you have made changes to the notebook (such as modifying descriptions or
reorganizing pages) that you want to keep, and you have not regenerated, click Save
to explicitly save the changes.

Viewing an Existing Notebook

Whenever you want to view an existing notebook in the browser, launch the notebook
(Tools > Electronic Notebook) and click View. Note that if you have made changes to
any of the designs, or to the notebook itself, you must Generate to see those changes.
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Updating an Existing Notebook

To modify or update an existing notebook:

1. From a Schematic window in the project of interest, choose Tools  > Electronic
Notebook .

2. When the notebook appears, make the desired changes.

• By default, any design that has changed will be updated when you Generate.
This behavior is controlled by the option Update images automatically, which
is set individually for every page in the notebook.

If you do not want a given image to be updated, disable this option.

• If you have made changes to the individual image capture settings of several
designs, you can click Recapture All Images (from the Notebook Properties
pane) to enable the notebook to recapture these images when the notebook is
regenerated.

Note The Recapture All Images capability only works for designs where the
option Update images automatically is enabled (the default state).

• Modify any descriptions or rearrange pages as desired.

3. Click Generate . The notebook is regenerated to incorporate the changes, and is
displayed in your browser.

Zipping the Files of a Notebook

To zip the files comprising the notebook so that they can be easily shared:

1. Click Zip HTML . You are prompted for a filename and location.

2. Changes paths as desired, supply a filename, and click Save.

The recipient of the file can view the notebook by unzipping it and opening
index.html.
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Verifying License Status
The license information tool enables you to view the current status of your ADS
licenses. There are two ways to launch the viewer:

• From the ADS Main window, through Help  > License Information

• UNIX—From a terminal window, type $HPEESOF_DIR/bin/aglmtool , where
$HPEESOF_DIR represents your complete installation path.

• PC—From Windows Explorer, locate <install_dir>/bin and double-click
aglmtool.exe  where <install_dir> represents your complete installation path.

Environment Lists environment/license variables and machine information that
affect your ADS license configuration. This information can be very helpful when
debugging license trouble. Use the Compact View option to wrap the lines making it
easier to see where multiple path statements start and stop.

Licenses Lists all licenses found in the license.dat file installed on your computer, or
in the case of a network installation, the license server. Use the Compact View option
to wrap the lines making it easier to view complete license statements. Click Refresh
if the license.dat file has been modified while viewing license information.

Servers Lists all license servers serving Agilent EEsof licenses on your network.
You can expand any given server to see the licenses served by that server.

Usage This pane enables you to view the current status of all installed licenses. You
can sort by Licenses (multiple licenses for a single feature) or by Users (select the
User Info option first). Select All to view a complete list of installed licenses. Select
Available to view only those licenses that are currently available. Select In Use to
view only those licenses that are currently in use.

Lists all licenses installed

Lists machine info and license variables

Lists licenses installed on specific servers

Lists license usage
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Using Keyboard Shortcuts and Accelerator Keys
Keyboard shortcuts are available for every command and are identified by the
underlined character in every command on every menu. Accelerator keys are
available for many menu commands and are identified by a key combination listed to
the right of the command, where applicable.

• For a table listing the default assignments, refer to Appendix B, Shortcut Keys.

• For details on changing the default assignments, refer to the section
“Customizing Keyboard Shortcuts” on page 9-30.

Setting Preferences for Miscellaneous Options
The Preferences dialog box, accessed through the Options menu in the Main window,
enables you to establish preferences for a variety of features that affect you
throughout the design environment.

• Warning Bell —The system beeps anytime you receive a pop-up window with a
warning message.

• Error Bell —The system beeps anytime you receive a pop-up window with an
error message.

• Balloon Help —As you move your pointer over the toolbar and palette buttons, a
small balloon appears with text describing that button’s purpose (or a
component’s name).

• Design Synchronization Checking —You are warned if you attempt to simulate a
design that is not fully synchronized.

• Large Toolbar Bitmap —A set of large bitmaps is placed on the toolbar. Turn this
option off to place a set of small bitmaps on the toolbar (better for monitors with
lower screen resolution). This change will be evident in any subsequently
opened windows. To see the change take effect in a currently open window, open
the Menu/Toolbar Configuration dialog box, click the Toolbar tab, and click OK.

• Display Project Listing —Filters the contents of the selected directory to display
only project directories under the Project Listing heading.

• Save Project State on Exit —The setup of the project you are exiting is saved,
including all design windows. The group of windows, and their positions on the
screen, are restored the next time you open the project.
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• Create Initial Schematic Window —A Schematic window opens automatically each
time you create a project.

• Create Initial Layout Window —A Layout window opens automatically each time
you create a project.

• New/Open Design in New Window —Sets a default in the New Design dialog box
(File > New Design) that determines whether to open a new window for the new
design or use the currently open window.

Changing this setting does not affect the default setting in currently open
Schematic/Layout windows, but will take affect in any subsequently opened
Schematic/Layout windows.

• Add Project Extension —The extension you want appended to project names to
clearly identify them as projects (default is _prj).

• External Text Editor —Specifies the text editor to be launched when you choose
Options > Text Editor in the Main window.

• Wire Thickness —The thickness (Thin, Medium, Thick) of all wires drawn in a
Schematic window.

To change any of these settings:

1. Choose Options  > Preferences , in the Main window, and a dialog box appears.

2. Change any or all options as desired, and click OK. All changes take effect
immediately, except as noted in the descriptions.
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Exiting the Program
You can exit the program from the design windows or the Main window.

To close your project and exit the program:

Choose File  > Exit Advanced Design System  in any window.

• Click Yes to exit Advanced Design System

• Click No if you do not want to exit Advanced Design System

To save all designs in all windows, choose File > Save All in the Main window.

If any files with unsaved changes exist, a dialog box appears listing one of the files
and offering the following choices:

• Yes—Click this to save changes to the named file and to be prompted
individually for any additional files with unsaved changes

• No—Click this to disregard changes to the named file and to be prompted
individually for any additional files with unsaved changes

• Yes To All—Click this to save changes to all files without being prompted
individually

• No To All—Click this to disregard changes to all files without being prompted
individually

• Cancel—Click this to cancel the command
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Chapter 2: Managing Projects and Designs
This chapter describes the project directory concept, managing projects and design
files, and the basics of importing and exporting designs. For information on these
topics, review the following sections:

• “Working in Projects” on page 2-1

• “Importing and Exporting” on page 2-12

• “Managing Design Files” on page 2-15

Working in Projects
All design work must be done in a project directory. Working in project directories
enables you to organize related files within a predetermined file structure. This
predetermined file structure consists of a set of subdirectories. These subdirectories
are used in the following manner:

• networks contains schematic and layout information, as well as information
needed for simulating

• data is the default directory location for input and output data files used or
generated by the simulator

• mom_dsn contains designs created with the Agilent EEsof planar
electromagnetic simulator, Momentum

• synthesis contains designs created with DSP filter and synthesis tools

• verification contains files generated by the Design Rule Checker (DRC), used
with Layout

Creating a Project

You can create any number of project directories.

To create a project directory:

1. Choose File > New Project and a dialog box appears. By default, the path is set to
your start-up directory.
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Note Spaces are not allowed in project paths or project names.

2. Type a new path directly in the Name field or use the Browser to specify the
location for the new project.

3. Enter a project name in the Name field.

Note By default, the suffix _prj is automatically added to the project name you
supply. This behavior is defined by the option Add Project Extension. You can
change this option through Options> Preferences in the Main window.

4. Click Length Units  and select the appropriate setting.

This unit setting serves as a default for all designs in this project and is both:

• The unit of measure for parameters with physical length (in both Schematic
and Layout windows)

• The design unit (grid display and cursor snapping) in the Layout window

Hint The design unit (grid display and cursor snapping) in the Schematic
window is inches.
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5. Click OK to establish Length Units.

6. Click OK to create the specified project. When the directory structure is
complete, the path and the project name appear at the bottom of the Main
window.

Hint By default, a Schematic window opens on creation of a project. This
behavior is defined by the option Create Initial Schematic Window. You can turn
this option off through Options> Preferences in the Main window.

Opening a Project

The directory that appears as the current directory when you start the program
varies by platform:

• UNIX—the directory from which you started the program. Once you have
created project directories, you can start the program from a project directory, if
desired.

• PC—the path you specified as the Work Directory during installation (by
default, c:\AdvDesSys). You can set a different work directory through file
Properties. (Right-click a program’s shortcut icon and adjust the path in the
Start field.) If you want to open a specific project directory while starting the
program, use that project directory’s name in the Start in field.
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Once the Main window appears, there are two ways to open a project directory:

• Use the File > Open Project command

• Double-click the project name in the Project Listing pane of the Main window

To open a project using the Open Project command:

1. Choose File  > Open Project  and a dialog box appears. All projects in the current
directory are listed in the Files list box.

2. Change directories as needed to find the directory containing the project.

3. Select the project name and click OK. Once the project is open, the right-hand
group of toolbar buttons is activated and the path and project appear in the
status panel at the bottom of the window.
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To open a project using the File Browser:

1. Change directories as needed in the File Browser pane to locate the directory
containing the project.

2. Choose View  > Project Listing . All projects in the current directory are listed
under the Project Listing pane. (For information on the Project Listing
preference, refer to the section, “Setting Preferences for Miscellaneous Options”
on page 1-34.)

3. Double-click to open the desired project. Once the project is open, the
right-hand group of toolbar buttons is activated and the path and project
appear in the status panel at the bottom of the window.

The windows that open when you open a project vary based on the following options:

• If the Save Project State on Exit option was enabled for this project, any design
windows that were open when you last exited the project are restored

• If the Save Project State on Exit option was not enabled for this project, but the
option Create Initial Schematic window was enabled (the default), a blank
Schematic window appears.

• If neither of the aforementioned options was enabled, you must manually open
a Schematic window. (Click the New Schematic Window toolbar button or
choose Window > New Schematic.)
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Hint For descriptions of these options, refer to “Setting Preferences for
Miscellaneous Options” on page 1-34.

Copying a Project

The Copy Project command copies a project directory and its contents, to a new
project directory with a name you specify.

Note Copying projects should only be done through the program, as described here.
Copying projects outside the program may result in invalid projects.

To copy a project:

1. Choose File  > Copy Project.

2. Locate the project you want to copy.

Hint To copy an example project, click the Example Directory button to quickly
set the path to the examples directory.

Click Browse  next to the From Project field.

3. In the dialog box that appears, change directories as needed to locate the
project.

4. Select the project you want to copy and click OK.

5. Specify the destination directory for the copied project.

Hint To copy the project to your start-up directory, click the Startup Directory
button to quickly set the path to your start-up directory.

Click Browse  next to the To Project field.

6. In the dialog box that appears, select the destination path, and click OK.

7. Supply a project name, if desired, in the To Project field (following the path).
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Hint If you want the copy to use the same name as the original project, you do
not need to specify a name in the To Project field.

8. If the project you are copying is hierarchical, and you want to preserve the
hierarchy, leave the Copy Project Hierarchy option enabled.

Note When copying a hierarchical project, you are prompted for each included
project to confirm whether or not you want to copy that project. If you do not
copy an included project (Skip), a reference to its source location is created in
the copied project hierarchy. You are also prompted to supply a path and name
for each copied project in the hierarchy. Click Browse to adjust the path without
typing.

9. Click OK.

Deleting a Project

The Delete command enables you to delete a project directory and all its contents.

Note Deleting projects should only be done through the program, as described here.
Deleting projects outside the program may result in program errors.

To delete a project:

1. Choose File  > Delete Project  and a dialog box appears.

2. Change the path as needed to locate the project directory you want to delete.

Note You cannot delete the current project directory.

3. Select the project and click OK. You are prompted to confirm that you want to
delete that project directory.

4. Click Yes to delete it; click No to keep it.
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Using an Example Project

An extensive set of example projects is provided to demonstrate designing for various
technologies.

To view the list of example projects:

1. In the Main window, click the Examples  button on the toolbar. The File
Browser pane changes to display the categories of examples available.

2. Click the category of interest to view the projects in that category.

To open an example project:

1. Use any of these methods:

• Double-click the project name listed in the File Browser pane on the left.

• Double-click the project name listed in the Project Listing pane on the right.
(Refer to the Project Listing option described in “Setting Preferences for
Miscellaneous Options” on page 1-34.)

• Choose File  > Example Project . Select the appropriate category and then the
desired example.

2. Example projects are saved in a particular state and one or more designs will
open automatically.

• UNIX-Notice that when the Schematic window appears, the title bar reflects
that the example is READ-ONLY. To simulate or modify designs in this
project, make a copy of the project.

Categories Projects in the MW_Ckts category
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• PC-To preserve the example designs, make a copy of the project before
modifying any of the designs in it.

Creating a Hierarchical Project

You can create hierarchical projects using the Include/Remove Projects command.
This command creates a reference, or link, to another project. Hierarchical projects
offer several benefits, including:

• The ability to create hierarchical designs by referencing designs from other
projects

• The ability to maintain a single source of a design referenced by other users.
Other users can Include the project containing the design of interest, and
benefit from updates to the original design, since they are only linking to it, not
copying it.

• Reduced disk space required for shared designs.

An example of a hierarchical project is shown next.

To include a project:

1. Open the project directory under which you want to include other projects.

2. Choose File  > Include/Remove Projects .

3. Use the File Browser to locate and select the project you want to include.

4. Click the Include  button. The project is added to the Project Hierarchy listing.

5. Repeat as needed, then click OK.

rec_front_end_prj

amplifiers_prj

filters_prj

mixers_prj
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To remove an included project:

1. Open the project that includes the project to be removed.

2. Choose File  > Include/Remove Projects .

3. Under Project Hierarchy, select the project you want to remove from the
hierarchy and click the Remove  button. The Project Hierarchy display is
updated.

If your hierarchical project includes other hierarchical projects, projects at
lower levels cannot be removed unless the project in which they were originally
included is the current project. For example, in the illustration shown next, you
cannot remove the project amp1_prj from the hierarchy when rec_front_end_prj
is the current project; you must make amplifiers_prj the current project first.

4. Repeat as needed, then click OK.

Working with Hierarchical Projects

Observing the following tips may simplify working with hierarchical projects:

• The title bar of the Schematic window displays the source of a project/design.
This tip may help orient you when working with hierarchical designs within
hierarchical projects. If you Push Into Hierarchy to view a design being
referenced, the title bar displays the source of the design.

• If the project name in the title bar of the Schematic window does not match the
current project name shown in the prompt panel of the Main window,
simulation of that design is not allowed. This situation would occur, for
example, if you place an instance of a design (as a subnetwork) from a project
that is included in another project, and push into that subnetwork and attempt
to simulate.

rec_front_end_prj

amplifiers_prj

amp1_prj

amp2_prj

filters_prj

mixers_prj
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Archiving a Project

You can create a single file for a project, making it easy to transfer the project to
another file system or another location on the same file system.

To archive a project:

1. In the Main window, choose File  > Archive Project .

2. Use the Archive Project Browser and select the project you want to archive.

3. Use the To File Browser and select a path for the archived file. (Hint: You
cannot archive directly to a floppy disk; you need more space for the process.)

4. Supply a name for the archived file. The extension .zap is automatically
appended to the filename you supply.

5. If the project is hierarchical and you want to preserve the hierarchy, select the
Archive Project Hierarchy option.

6. Click OK.

Hint If transferring projects back and forth between UNIX and PC, keep in mind
that UNIX is case-sensitive and the PC is not. The PC does not always preserve case,
so filenames going back and forth should be unique.

Unarchiving a Project

To unarchive a project:

1. In the Main window, choose File > Unarchive Project . (Hint: When you unarchive
it, the project will be restored in the directory containing the archived file.) The
file listing displays all files in the current directory with the extension .zap.

2. Change directories as needed to locate the archived project file.

3. Select the file and click OK. If the project is hierarchical, all projects are
restored with their original name(s).

Hint The directory you use to unarchive the project cannot contain any subdirectory
or filename of the same name as the archived project(s).
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Importing and Exporting
The Import and Export commands enable you to import and export HP IFF files, as
well as files in a variety of formats produced by other software. You can import files
through the Main, Schematic, and Layout windows; exporting is done from Schematic
and Layout. The listing below shows the available formats.

• For details on these formats and descriptions of the options associated with
each, refer to the Importing and Exporting Designs manual

• For details on importing and exporting SPICE files, refer to the Spice Netlist
Translator manual

• For details on importing Series IV designs, refer to the Series IV Migration
manual

Table 2-1. Program Windows and Available Import/Export Formats

Main Schematic Layout

Import HP IFF EGS Generate DXF (hierarchical)

Netlist HPGL/2 EGS Archive

HP IFF EGS Generate

Mask File (.msk) GDSII Stream Format

Netlist File HPGL/2

HP IFF

IGES

Mask File (.msk)

Export HP IFF DXF (hierarchical), (flattened)

EGS Archive

EGS Generate

GDSII Stream Format

Gerber

Gerber Viewer

HPGL/2

HP IFF

IGES
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Importing a Design

To import a design:

Note You must open a project before importing a design.

1. Choose File > Import .

2. In the dialog box that appears, select the appropriate file format from the File
Type drop-down list.

3. To define options for the imported file, click More Options and dialog box
appears.

Note The program translators are controlled by translator options files. A
system-wide options file exists for each translator. These files can be found in
the $HPEESOF_DIR/config directory. The default system file is automatically
read when you click More Options in the Import dialog box (unless a local
options file already exists in the current project directory). When you make
changes in the options dialog box and click OK, a local copy of the options file is
written to the current project directory.

4. To specify the path and filename of the file you want to import, click Browse .

5. Double-click as needed to locate the directory containing the design. By default,
all files are listed that have the file suffix appropriate for the chosen file format.

6. Select the design you want to import and click OK. You are returned to the
Import dialog box and the selected filename appears in the field labeled Import
File Name (Source).

7. Where applicable, type a new name for your imported design in the New Design
Name (Destination) field. Note: For certain file types, the translator uses the
existing filename to determine the new design name.

Mask File (.msk)

MGC/PCB

Table 2-1. Program Windows and Available Import/Export Formats (continued)

Main Schematic Layout
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8. Click OK to import the design and dismiss the Import dialog box.

Exporting a Design

To export a file:

1. Choose File  > Export .

2. In the dialog box that appears, select a file format from the File Type drop-down
list.

3. To set export options, click More Options  and a dialog box appears.

Note The program translators are controlled by translator options files. A
system-wide options file exists for each translator. These files can be found in
the $HPEESOF_DIR/config directory. The default system file is automatically
read when you click More Options in the Export dialog box (unless a local
options file already exists in the current project directory). When you make
changes in the options dialog box and click OK, a local copy of the options file is
written to the current project directory.

4. Change options as needed and click OK.

5. To specify a path for the exported file, click Browse .

6. Double-click as needed to locate the directory for the exported design. By
default, all files are listed that have the file suffix appropriate for the chosen file
format.

7. Click OK.

8. Type a new filename in the Export dialog box, following the path, and click OK.
The file is written to the specified directory.
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Managing Design Files
Before you begin your design work, you should understand the basics of file
management within the design environment.

Creating a Design File

You can begin your design work in an untitled design window or supply a filename
before you begin. When selecting a filename, keep in mind the guidelines described in
the section, “Naming Conventions” on page 1-20.

To create a design file:

1. In a Schematic (or Layout) window, choose File  > New Design  and a dialog box
appears.

2. Enter a design name in the Name field. The program automatically adds the
extension .dsn to your filename.

Note If a project created on UNIX contains two or more designs whose names
are only distinguishable from one another by differences in case, do not archive
and transfer this project to a PC without renaming the designs such that they
all have unique names. This requirement is due to the fact that the PC is case
insensitive.

3. Where applicable (you selected Both in the initial or setup dialog box), select the
design type.

Analog/RF Network or Digital Signal Processing Network

This affects the type of components available for design work.

Hint The choices presented here reflect the setting in the Advanced Design
System Setup dialog box (Main window, Options menu).

4. Select the New Window option to create the new design in its own window. (This
step is only required if you chose File > New in a window containing a design
and you want to keep that design open in addition to creating a new design.)
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5. Optionally, select a Design Template as a starting point for your design. (For
details, refer to the section, “Using a Template” on page 2-16.)

6. Click OK. The design name is reflected in the title bar of the window.

Using a Template

Several simulation templates are provided as a convenience to help you create
designs more quickly. You can turn any of your own designs into a template using the
Save Design As Template command.

To start a new design with an existing template:

Choose File  > New Design , select a template from the list, and click OK.

To add an existing template to an existing design:

Choose Insert  > Template , select a template from the list, and click OK.

To create a new design for use as a template:

1. Create the design just as you would any other design.

2. Choose File  > Save Design As Template . (The program automatically adds the
extension .tpl to your filename.) The design is saved to your local templates
directory and will now appear in the list of available templates (File > New
Design and Insert > Template) when you choose to use one.

To modify a supplied template or one you have created:

1. Choose Insert  > Template , select that template from the list, and click OK.

2. Make the desired changes and choose File  > Save Design As Template .

Note To associate an AEL macro file with a template, give it the same name as the
template file, add underscore tpl (_tpl), and an .ael extension. Example: For a
template filename of my_amp.tpl, name the AEL macro file my_amp_tpl.ael. Place
this file in home/hpeesof/circuit/templates (or home/hpeesof/hptolemy/templates),
along with the template file, and it will be loaded when you insert the template in
another design.
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Saving a Design File

There are three commands related to saving files: Save Design, Save Design As, and
Save Design As Template.

• The Save Design command enables you to save changes to an existing file. (If
you choose Save in an untitled window, the Save Design As dialog box appears.)

• The Save Design As command enables you to save an existing file with a new
name. For example, to make a copy of an existing design so that you can edit it
while preserving the original, use the Save Design As command to create a copy
of the file with another name.

• Use the Save Design As Template command to save a design, at any stage, for
use as a template. (Select a template for use through File > New Design or
Insert > Template.) The program automatically adds the extension .tpl to your
filename.

If you have made changes to a design and want to discard those changes, but
continue working with the previously saved version of the design, choose File > Revert
to Saved Design .

To save changes to an existing file:

Choose File > Save Design . If the file was previously saved (it resides on the disk), a
dialog box appears.

• If you want to overwrite the old version with the new version, click Yes.

• If you do not want to overwrite the old version, click No and use the Save
Design As command to save the design to another name.

To save an existing file with a new name, or to save a new file you have not yet
named:

1. Choose File > Save Design As and a dialog box appears prompting you for a New
File Name.

2. Enter a name for the design and click OK. The file is saved and automatically
assigned an extension, which varies depending on the window
(Schematic/Layout uses .dsn; Data Display uses .dds).
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Note The Save Design As command names or renames all files associated with
the design (.dsn, .ael, etc.) and is therefore the preferred method for saving a
design to a new name. Therefore we recommend you use the design
environment for all file management operations.

Saving All Designs in Memory

To save any designs currently in memory, including data displays, that have not been
saved since changes were made:

In the Main window, choose File  > Save All .

Opening an Existing Design

There are several ways to open existing designs:

• Double-click it in the Main window (from the Design Information pane)

• Double-click it from the Design Hierarchy dialog box (View > Design
Hierarchies)

• Use the File > Open Design command in the appropriate design window

• If it is one of the last four designs opened, it appears on the file list at the
bottom of the File menu and you can click there to open it

• If the design is currently open (in memory), it appears on the list at the bottom
of the Window menu and you can click there to open it. You can also open it
using the Designs Open command (on the Window menu).

To open an existing design from the browser in the Main window:

1. In the File Browser pane, click once to expand the networks directory and a list
of all designs in that directory appears.

2. Double-click to select a design name. If the design is hierarchical, the hierarchy
is listed under Design Information on the right side of the window; if the design
is not hierarchical, its complete path and name appear under Design
Information.

3. Double-click the design name from the right pane to open it.
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To open an existing design from the File menu in a design window:

1. Choose File  > Open Design  and a dialog box appears.

By default, the files displayed in this dialog box are located in the current
project directory and have a .dsn extension.

2. Select the design you want to open from the Files list box, and click OK. The
design appears in the window.

Important To make a complete set of files for a design in another project
directory, use the File > Copy Design command in the Main window.

To view a design currently open (in memory) from the Window menu:

Choose Window  (in the Schematic or Layout window) and select the design of
interest from:

• The list of files at the bottom of the Window menu

or

• The dialog box that appears when you choose Designs Open

Note that when the number of designs in memory exceeds the number of
designs displayed at the bottom of the Window menu, an additional menu
choice, More, appears. Choose More to see a complete list of designs in memory.

Hint The number of designs displayed on the Window menu (by default, nine)
can be customized by setting the variable DESIGN_LIST_COUNT equal to the
desired value. For details, refer to Chapter 1, Customizing the ADS
Environment, in the Customization manual.
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Copying a Design

The Copy Design command copies all files associated with the design and is therefore
the preferred method for copying designs.

Note Copying designs should only be done through the program, as described here.
Copying designs outside the program may result in invalid designs.

To copy a design:

1. Choose File  > Copy Design  and click Browse  (From Design).

2. Change directories as needed to locate the directory containing the design you
want to copy.

3. Select the design and click OK.

4. Click Browse  (To Path) and change directories as needed to specify the path for
the copied design. Click OK.

5. Supply a name, following the path, for the copied design.

6. If the design is hierarchical, and you want to preserve the design in its entirety,
select the Copy Design Hierarchy option.

7. When the From and To fields in the Copy Design dialog box reflect the
appropriate paths and filenames, click OK.
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Deleting a Design

To delete a design:

1. Choose File > Delete Design and a dialog box appears. By default, all .dsn files in
the current project are listed.

Note Deleting designs should only be done through the program, as described
here.

2. Change directories as needed to locate the project containing the designs/files
you want to delete.

3. Change the File Type as needed to locate the designs/files you want to delete.
You can select a different file type from the drop-down list, or type a file
extension and press Enter  or click Filter .

4. Select the design/file you want to delete and click Apply (or OK if this is the only
file you want to delete). You are prompted to confirm you want to delete that
file. Click Yes to delete it; click No to keep it.

Important If you delete a design that serves as a subnetwork in other designs,
remember to delete all occurrences of that subnetwork in those designs.

Clearing a Design from Memory

Every design you open is stored in memory until you explicitly clear it from memory
or exit the program. There are two ways to clear designs from memory: Close Design,
Delete All. This distinction enables you to clear an entire design (both schematic and
layout information, which are stored in the same file) from memory, or clear only
schematic information or only layout information from memory.

• Close Design—File menu—clears the entire design file from memory

If any unsaved changes are detected, you are prompted, Design not saved, clear
anyway?

• If you want to clear the design without saving, click Yes.

• If you do not want to clear the design without saving, click No, and then
select Save Design  from the File menu.
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• Delete All—Edit menu—clears the current schematic information, if issued
from the Schematic window, or the layout information, if issued from the
Layout window

Hint As with other commands found on the Edit menu, the Undo command
works on Delete All.

Clearing All Designs from Memory

To clear all designs, including data displays, currently in memory:

In the Main window, choose File  > Close All .

If any files with unsaved changes exist, a dialog box appears listing one of the files
and offering the following choices:

• Yes—Saves changes to the named file and prompts you individually for any
additional files with unsaved changes

• No—Discards changes to the named file and prompts you individually for any
additional files with unsaved changes

• Yes To All—Saves changes to all files without prompting you for each one

• No To All—Discards changes to all files without prompting you for each one

• Cancel—Stops the Close All command
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Chapter 3: Creating Designs
This chapter describes creating designs in the Advanced Design System
environment. The starting point of this chapter assumes you have started the
program, as described in Chapter 1, Program Basics, and that you are familiar with
the project directory concept and design file management, as described in Chapter 2,
Managing Projects and Designs.

Although you can perform a wide variety of editing operations on your design as you
create it or once the design is complete, you can set numerous options before you
begin your design work to minimize the need for editing. These options can be set
through the Preferences dialog box (Options > Preferences) from a design window.
Listed below are some of the options that can be set in advance to assist you in
creating your designs:

• “Setting Placement Options” on page 9-9

• “Setting Entry/Edit Options” on page 9-12

• “Setting Grid/Snap Options” on page 9-6

These options, as well as others, are described in Chapter 9, Setting Design
Environment Preferences.

Because all shapes and text are entered on layers, you may also want to modify layer
definitions before beginning your design work. For details refer to the section,
“Specifying Layer Definitions” on page 9-22.

For details on adding a drawing sheet to the design window, refer to the section,
“Adding a Drawing Sheet” on page 7-1.
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Defining Units for a Design
The design environment uses Units in a number of ways, differentiated as follows:

• Layout Units—the unit used for grid and snap features in the drawing area of
the Layout window (Options > Preferences > Layout Units)

Note The unit used for grid and snap features in the drawing area of the
Schematic window is inches, and cannot be changed. When you see choices in
various dialog boxes for screen pixels or schem units, the schem units are inches.

• Length Unit—the unit of measure for parameters with physical length in both
the Schematic and Layout windows, and by default, the Layout Units of the
Layout window

When you create a project directory, you choose the Length Unit to be used as a
default for all designs in that project. When working with the Layout option, we
recommend keeping the Length Unit and the Layout Units the same, thus the
Length Unit serves both purposes, by default.

Note You can choose a different Length Unit for an individual design
(Options > Preferences > Units/Scale) but a change made in this manner exists
only in memory unless you save the preferences to a file. For details, refer to the
section “Saving and Reading Preference Files” on page 9-20.

• Units/Scale—The scale factors shown in the Units/Scale tab of the Preferences
dialog box serves as defaults in a limited number of situations. For details refer
to the section, “Units/Scale Factors” on page 3-21.
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Placing Components
You create designs by placing items (such as, components, data items, measurements,
sources, simulation controls, etc.) in a design window. There are several ways to
access these items:

• Browsing—in the Component Library window

• Searching—in the Component Library window

• Component Palette—on the left side of the design window

• Component History—on the toolbar or as a dialog box

• Hot Keys—once you have added components to the Component submenu

Although there are several methods of access, the basic steps for placing a component
are the same.

To place a component in the design window:

1. Locate and click to select the component.

2. Move the pointer into the drawing area and click the orientation button to
rotate the symbol as necessary.

3. Click to place the symbol in the desired location.

For additional information on working with components, refer to the following
sources:

• For details on changing the orientation of a component, refer to the section,
“Rotating Components” on page 3-19.

• For details on connecting components, refer to the section, “Connecting
Components” on page 3-26.

• For details on changing component parameters, refer to the section, “Editing
Component Parameters” on page 6-2.

• For details on changing attributes of component text:

• Prior to placing components, refer to the section, “Setting Component
Text/Wire Label Options (in Advance)” on page 9-15.

• After placing components, refer to the section, “Changing Component Text
Attributes” on page 6-10.
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Browsing for Components

You can view the components that make up any individual library by selecting the
library name in the Component Library window. The libraries listed vary with the
current design type—Analog/RF versus. Digital Signal Processing.

In the following figure, the left side shows the top-level libraries (for the Analog/RF
design type) collapsed; the right side shows a partial listing of the Analog/RF
sub-libraries as it appears expanded.

To browse for a component:

1. From any design window, click the Library  button on the toolbar (or choose
Insert > Component > Component Library).

2. Click the plus sign in front of a library name to expand it and view its
sub-libraries.

In addition to these libraries, a library named Frequently Used Components is
filled, as you work, with the components you place, enabling you to quickly
place additional instances of those components. Note that the Frequently Used
Components library is project-specific; the library that is created in any given
project directory will remain until you explicitly clear it.

The Subnetworks library provides access to all the designs in the current
project for use as subnetworks in other designs in that project. (To enable access
to designs in other projects, create a hierarchical project as described in the
section “Creating a Hierarchical Project” on page 2-9.)

3. Select a sub-library and its components are displayed in the Components
section of the window. By default, a brief description for each component is also
displayed.

Layout
only
3-4 Placing Components



Additional component information is available once you select a library. For details,
refer to the section, “Customizing the Component Library Display” on page 3-8.

To place components from any library:

1. Select the library to display the list of components.

2. Select the component you want to place, move the pointer into the drawing
area, and click to place it.

Hint To clear the current list of frequently used components, select the Frequently
Used Components library and choose Edit > Clear Frequently Used Components.
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Searching for Components

You can search for a component (or group of components with something in common)
based upon text that is part of the component name or description.

To search for a component:

1. From any design window, click the Library  button on the toolbar (or choose
Insert > Component > Component Library).

2. In the Component Library window, choose Tools  > Find .

3. Type the word or phrase you want to search for.

Note Only the library currently highlighted in the Libraries pane will be
searched. By default, All libraries are searched. To narrow the search, select a
specific library or sub-library. Your choice is reflected in the Look in field.

When the search is complete, the components and/or descriptions matching the
search criteria are displayed.

The following figure shows the results of a search for the word pulse in all
libraries.
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To limit your initial search using case sensitivity:

1. Select the Case Sensitive  option.

2. Type the search text matching the case of the component name(s) as it appears
in the program.

Example: The component you are looking for contains the word BEND, as part
of its name, in uppercase and you want to search for all components that
include BEND as part of their name, but exclude components whose
descriptions contain the word Bend (mixed case).

To perform a secondary search on your initial search results to view some subset of
those results:

1. Select the Refine Search  option.

2. Change the search text in the Find field as needed and click Apply . The initial
results are searched for anything meeting the revised search criteria.

Example: Initiate a search through all libraries on the word amplifier. As you
scan the resulting list, you notice several amplifiers with drain current of
17 mA scattered throughout. To view only those amplifiers, type id=17ma in the
Find field, select the Refine Search option, and click Apply. The resulting subset
of amplifiers is displayed.
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Customizing the Component Library Display

Several features are provided to enable you to customize the Component Library
display. You can:

• Collapse/expand the display of libraries and sub-libraries to minimize scrolling

• Add new libraries

• Rearrange the libraries and sub-libraries using Cut, Copy, and Paste

• Show or hide the display of several types of component information

• Set defaults for the widths of the various component information displays

• Alphabetically sort the display of libraries and components

Once you customize the display to meet your needs, you can save the settings to file
and use those settings in any subsequent session. For details refer to, “Saving
Customized Library Displays” on page 3-12.

Note Several aspects of the browser display can be set for all projects (user) or on a
site-wide basis. For details, refer to the hpeesofbrowser.cfg file described in Chapter 1,
Customizing the ADS Environment, of the Customization and Configuration manual.

To expand a library so that its sub-libraries are displayed:

Click the plus sign in front of the library name. To collapse the library, click the
minus sign.

The expanding and collapsing of libraries can also be accomplished via toolbar
buttons or the View menu (View > Libraries).

Expand Libraries

Collapse Libraries

Collapse Selected Library

Expand Selected Library
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• Expand Libraries—Expands the view of all top-level libraries

• Collapse Libraries—Collapses the view of all top-level libraries

• Expand Selected Library—Expands the view of the currently selected library

• Collapse Selected Library—Collapses the view of the currently selected library

To add a new library:

1. Choose File  > New > Library .

2. Supply a library name and click Apply (or OK if only creating one library at this
time). The new library is added to the bottom of the current list of libraries.

To add a new sub-library:

1. Choose File  > New > Sub-Library .

2. Select from the drop-down list the library you want the new sub-library to be
part of.

3. Supply a sub-library name and click Apply  (or OK if only creating one
sub-library at this time). The new sub-library is added to the bottom of the
current list of sub-libraries.
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Rearranging Libraries

You can rearrange and delete libraries to make the library display better meet your
design needs:

• Use Cut and Paste to rearrange the order of libraries—relative to other
libraries, or the order of sub-libraries—relative to other sub-libraries. (Use Copy
and Paste to copy a sub-library to another location).

You can also turn a sub-library into a library by pasting it at the library level—
highlight All and paste.

• Use Cut to delete libraries (or sub-libraries) you do not use for a specific project
or are not licensed for, to help minimize scrolling.

Note that when you paste, the affected library or sub-library is pasted at the bottom
of the list. Once you make your changes, you need to save your customized views.
(“Saving Customized Library Displays” on page 3-12.)

To rearrange or delete libraries using Cut/Copy/Paste:

1. Highlight the library you want to move (or delete) and choose Edit  > Cut .

2. To paste it at the bottom of the list of All libraries, highlight All  and choose
Edit > Paste .

To rearrange sub-libraries using Cut/Copy/Paste:

1. Highlight the sub-library you want to move, copy, or delete.

Note Sub-libraries cannot be pasted within another sub-library.

2. Choose Edit  > Cut  (or Copy ), and:

• To paste the sub-library at the bottom of an existing library, highlight that
library.

• To paste the sub-library as a library (at the bottom of the list of all libraries),
highlight All.

3. Choose Edit  > Paste .
3-10 Placing Components



Setting Display Preferences

Several aspects of the Component Library display can be customized through
Options > Preferences.

Component Tree Width

To modify the width of the tree in the Library pane:

Enter the desired value (in characters). Note that the change will not take effect
until your next session of ADS.

Field Width

To set default widths (in characters) for the columns of component information:

In the Field Width section, set each field as desired. Note that these settings serve
as defaults, but the columns can be resized manually by dragging the cell border
one direction or the other. Setting the Field Width has no effect if the column
status is hidden (deselected). To make it visible, select it in the Show Columns
section of the dialog box.

Show Columns

The Component column is always visible. The Description column is the only optional
column that is visible by default.

To show or hide optional columns of component information:

1. In the Show Columns section select or deselect any of the following:

• Vendor—Displays the name of the manufacturer for the vendor parts in the
selected sub-library.

• Description—Provides a brief description of each component.

• Library Name—Lists the name of the library for each component listed. This
can be helpful if you find a component by searching, and want to know which
library it is from.

• Placement Status—Identifies for each component listed whether or not it is
used in layout

• Availability (Available/Obsolete)—Reserved for future use.

• Web-site Address—Reserved for future use.

• License Information—Reserved for future use.
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2. Click Apply .

Show Components

To change the Show/Hide status of obsolete or unlicensed components:

1. In the Show Components section of the dialog box, set these options as desired:

• Hide Obsolete Components

• Hide Unlicensed Components

2. Click Apply .

Sorting Libraries and Components

To alphabetically sort the list of libraries:

1. Highlight any library under All.

2. In the Library Sort section of the Preferences dialog box, select the desired
sorting method—Ascending or Descending (Unsorted is the default state) and
click Apply .

To alphabetically sort the list of components for a specific sub-library:

1. Highlight the sub-library whose components you want to sort.

2. In the Component Sort section of the Preferences dialog box, select the desired
sorting method—Ascending or Descending (Unsorted is the default state) and
click Apply .

Saving Customized Library Displays

When you first open the Component Library—in any given session of ADS—the view
of libraries is the Default view. This is the complete set of libraries as shipped.
Changes you make to this view will persist during the current session, however, the
next time you restart ADS, the Default view is restored. You can save any number of
customized views and restore them later. By default, customized view files are saved
to the current project directory, but you can save them in and restore them from any
other project directory.
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To save a customized view in the component library:

Choose View  > Save View As . Supply a filename and click Save.

To open a previously saved customized view:

Choose View  > Open View. Select the filename of the view you want to restore and
click Open .

To close any currently open customized view:

Choose View > Close View . If no other customized views are open, the Default view
is restored.

Resetting and Updating the Library Display

If during any given session, you cut libraries from the Default view and you want to
restore them (without exiting and restarting ADS), you can do so with the
Reset/Update command. This command will also update the library display with any
libraries that were created through AEL.

To restore libraries cut from the Default view and/or update the display with new
libraries:

Choose View  > Reset/Update .

Note Some additional information is available for libraries and components through
the Edit menu (Library Properties and Component Properties). These features will be
enhanced in a future release.
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Using the Component Palette

The palette, on the left side of each design window, is a quick method of placing
components if you know the name of the library containing the component. To change
the library of components on the palette, select a new one from the drop-down Palette
List.

Hint You can also bring the palette selection list up as a dialog box by selecting View
> Component > Select Component Palette. Leave it on the screen if you want to change
the palette frequently.

To use the Palette to place items:

1. Display the desired library on the palette by selecting it from the drop-down list
(in this example, TLines-Printed Circuit Board).

2. If necessary, scroll the new palette to locate the button representing the
component you want to place.

Component
Palette List
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Using Component History

As you place components in your design, a history of these components is created.
This dynamically created history enables you to quickly place additional instances of
components placed in the current session.

Hint This history serves as the starting point for creating a custom component
palette. For details refer to, “Creating a Custom Component Palette” on page 9-34.

To place items from Component History:

1. Click to access the drop-down Component History list or bring up the dialog box
(View > Component > Component History).

2. If necessary, scroll the list to locate the component you want to place.

Hint Once vendor components are placed, they are part of Component History which
can be used to create a custom palette containing these vendor parts.

Component History
Drop-down List
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Using Hot Keys to Place Components

You can place frequently used components via hot keys, by adding them to the
Component submenu (Insert > Component) and then assigning hot keys to them.
Components added to the menu in this manner apply to all projects. Customization of
this Component menu is done separately for the Schematic and Layout windows.

To add components to the Component submenu:

1. Choose Options  > Hot Key/Toolbar Configuration and in the dialog box that
appears, select the Component Menu/Hot Key  tab.

2. Select the components you want to add to the Component submenu from any of
the following lists:

• Available Components displays all the components contained in the current
design.

• Select any of the standard component libraries from the drop-down list.

• Select History (for a list of components placed in the current session) or
Selected Design Components (for a list of all currently selected components in
the active design).

Hint You can use the PC method of Shift+click to select a contiguous group of
components, or Ctrl+click to select components that are not contiguous.

3. Click Add  to add the selected component(s) to the Component Menu/Hot Key
list box.

Alternatively, you can select one or more components currently placed in the drawing
area of the desired (Schematic or Layout) window and choose Insert  > Component  >
Add Selected to Component Menu . All selected components are added to the
Component submenu.

To create hot keys for the menu-based components:

1. Choose Options  > Hot Key/Toolbar Configuration and in the dialog box that
appears, select the Component Menu/Hot Key  tab.

2. Select a component from the Component Menu/Hot Key list box.

3. Select the modifier key(s)—Ctrl, Alt, Shift—and type the letter(s) you want to
use in the Key field (UNIX is case-sensitive; the PC is not). If the combination
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you choose is currently assigned to another command sequence or component,
you are warned and given the choice to proceed or to select another key
sequence.

Note If you use Alt as the modifier key, and a letter that is already assigned as
an accelerator for a menu (see the underscored letters on the menu bar), the
menu accelerator is replaced by your custom shortcut (with no warning).

4. Click Apply . The shortcut appears next to the component.

5. Repeat as needed for each component.

To remove components from the Component submenu:

1. Choose Options  > Hot Key/Toolbar Configuration .

2. In the dialog box that appears, select the Component Menu/Hot Key  tab.

3. Select any component you want to delete from the Component submenu and
click Delete . (To delete all but the standard components—Port, GROUND,
VAR—click Delete All.)

Hint To remove a shortcut for a given component, select that component and
deselect the modifier key(s) and erase the letter(s), then click Apply.
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Placing Components at Specific Coordinates

The Coordinate Entry command enables you to place a component at specific
coordinates. Pin 1 of the symbol is placed at the coordinates you specify.

To use the coordinate entry method for placing components:

1. Choose Insert  > Coordinate Entry  and a dialog box appears. Move the dialog box
so that the desired design window is visible.

2. Select the component you want to place.

3. Select the desired orientation for this component.

4. Enter the desired X and Y coordinates in the dialog box.

Enter coordinates by typing them directly in the fields labeled X and Y, or use
the up and down arrows of the X Increment and Y Increment fields to increase
or decrease the values of the X and Y fields. By default, the X and Y Increment
fields are set to the current snap spacing, but you can use any increment that
meets your design needs.

5. Click Apply  and the component appears in the drawing area at the specified
location.
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Rotating Components
You can specify the orientation, or rotation, of components in a number of ways. To
change the orientation during or after placing it in the drawing area, use any of the
following methods.

• Click the Rotate By Increment  button on the toolbar.

• Press Ctrl+r .

• Choose Edit  > Rotate .

Each of these actions rotates the component n degrees clockwise, where n is the
increment specified in Options > Preferences > Entry/Edit > Rotation Increment
(angle). The default is 90 degrees.

In addition to the above methods of rotation, you can rotate a component during the
insertion process using any of the following commands:

• Choose Insert  > Component  > Set Component Orientation UP

• Choose Insert  > Component  > Set Component Orientation DOWN

• Choose Insert  > Component  > Set Component Orientation LEFT

• Choose Insert  > Component  > Set Component Orientation RIGHT

These directions refer to the direction the symbol is drawn relative to pin 1.

Hint Place these individual commands on the toolbar to have individual toolbar
buttons for each orientation. For details refer to “Configuring Toolbars” on page 9-31.
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Defining Parameters
As you place components in the drawing area, you will notice that some parameters
have default values and that other parameters are followed by an equal sign (=) and
nothing else. The lone equal sign indicates that a default value is defined elsewhere
for this parameter. Some of these parameter values are defined by the simulator,
while others are defined in various Simulation Control items. For details on where
the default value is defined and to review the guidelines for choosing other values for
that parameter, refer to the Circuit Components manual or the Signal Processing
Components manual.

Note The at symbol (@) must be used to suppress quotes when specifying a variable
as a parameter value, for example, use @freq1, where freq1 is a variable declared in a
VAR item.

You can change parameter values using the on-screen editor or through the
Component Parameters dialog box. To display the Component Parameters dialog box
for editing parameters after placing components:

• Position the pointer over the component you want to edit and double-click

or

• Select the component and choose Edit > Component > Edit Component
Parameters

Alternatively, you can specify parameters for each component as you create your
design. By default, the option controlling the automatic display of the Component
Parameters dialog box is turned off (in the Schematic window). To display the dialog
box automatically when you select a component, select the option Show Component
Parameter Dialog Box through Options > Preferences > Placement.

Hint To keep the dialog box on your screen for editing parameters of many
components, use the Apply button to effect changes for each component.

For details on the Component Parameters dialog box and using the on-screen editor,
refer to “Editing Component Parameters” on page 6-2.
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Units/Scale Factors

The fundamental units for ADS are shown in Table 3-1. An ADS parameter with a
given dimension is evaluated based on the corresponding units. For example, for a
resistance R=10, 10 is assumed to be 10 Ohms.

Variations on these fundamental units are referred to as scale factors. A scale factor
is a single word/abbreviation that begins with a letter or an underscore character (_).
The remaining characters, if any, consist of letters, digits, and underscores. The value
of a given scale factor is resolved using the following rules, in the order shown:

1. If the scale factor exactly matches one of the predefined scale-factor words (see
Table 3-2), then use its numerical equivalent

else

2. If a scale factor exactly matches one of the scale-factor units (see Table 3-3) with
the exception of m, then use its numerical equivalent

else

3. If the first character of the scale factor is one of the scale-factor prefixes (see
Table 3-4), then use its numerical equivalent

Table 3-1. Fundamental units in ADS

Dimension Fundamental unit

Frequency Hertz

Resistance Ohms

Conductance Siemens

Capacitance Farads

Inductance Henries

Length meters

Time seconds

Voltage Volts

Current Amperes

Power Watts

Distance meters

Temperature Celsius
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else

4. The scale factor is not recognized. When ADS does not recognize a scale factor it
issues a warning and uses a scale-factor value of 1.0.

Table 3-2 lists the ADS scale-factor words and their numerical equivalents.

Table 3-3 lists the ADS scale-factor units and their numerical equivalents.

Table 3-2. Predefined scale-factor words

Scale Factor Words Numerical Equivalent

mil 2.54e-5

mils 2.54e-5

cm 1.0e-2

in 2.54e-2

ft 12*2.54e-2

mi 5280*12*2.54e-2

nmi 1852

PHz 1.0e15

dB 1.0

Table 3-3. Scale-factor units

Scale Factor Unit Meaning Numerical Equivalent

A Amperes 1.0

F Farads 1.0

H Henries 1.0

Hz Hertz 1.0

meter meters 1.0

meters

metre

metres

Ohm Ohms 1.0

Ohms

S  Siemens 1.0
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Table 3-4 lists the ADS scale-factor prefixes and their numerical equivalents.

Notes:

• Scale factors are case sensitive. Note the different meanings for f and F, and a
and A in the preceding tables.

• The imperial units (mils, in, ft, mi, nmi) do not accept prefixes.

• Scale factors can be used anywhere in an expression (e.g., 1 GHz + 1 MHz).

When you select a parameter—with which a fundamental unit is associated—in the
Component Parameter dialog box, a drop-down list appears containing all available
scale factors for that particular parameter.

sec seconds 1.0

V Volts 1.0

W Watts 1.0

Table 3-4. ADS scale-factor prefixes

Scale Factor Prefixes Meaning Numerical Equivalent

a atto 1e-18

f femto 1e-15

p pico 1e-12

n nano 1e-9

u micro 1e-6

m milli 1e-3

_ (underscore) no scale 1

k, K kilo 1e3

M Mega 1e6

G Giga 1e9

T Tera 1e12

Table 3-3. Scale-factor units (continued)

Scale Factor Unit Meaning Numerical Equivalent
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Table 3-5 lists the available scale factors for parameters with which a fundamental
unit is associated.

Table 3-5. Available scale factors

Frequency none Hz kHz MHz GHz THz

Resistance none mOhm Ohm kOhm MOhm GOhm TOhm

Conductance none pS nS uS mS S

Capacitance none fF pF nF uF mF F

Inductance none fH pH nH uH mH H

Voltage none fV pV nV uV mV V kV

Current none fA pA nA uA mA A kA

Time none fsec psec nsec usec msec sec

Length none um mm cm meter mil in ft

Distance none meter km ft mi nmi

Power none pW nW uW mW W kW dBm dBW

Drop-Down List of
Scale Factors
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Notes:

• The option none means no scale factor is applied to the value.

• Although dBm and dBW appear on the drop-down lists, they are not valid scale
factors; built-in functions convert these values to Watts and Celsius.

• There is no scale-factor option for temperature.

This same set of scale factors (with the exception of none) appears in the Preferences
dialog box (Options > Preferences > Units/Scale). Note that these default settings are
only used in the following situations:

• When a parameter of a supplied component does not have a default unit and
you do not assign one (in the component parameter dialog box)

• When you supply a default parameter value without units while creating a
parametric subnetwork (File > Design Parameters)

Hint You will see both Length and Distance scale factors in the Preferences dialog
box. Length typically applies to parameters such as transmission line length, and
Distance is a much larger scale factor that applies to things like antenna path length.

For details on how preference settings are associated with designs, refer to the
section “Saving and Reading Preference Files” on page 9-20.
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Measuring Distance and Angle
The Measure command produces a dialog box that displays the cumulative distance
between points you specify in the design window. In addition, it displays the angle
from the first point to the current point.

To use the Measure command:

1. Choose Measure  from the Insert menu or the pop-up menu and a dialog box
appears.

2. Click on the desired points in the design window and observe the information
displayed in the dialog box.

• To clear the information but keep the command active, click Clear  or double
click in the design window.

• To stop the command and dismiss the dialog box, click Cancel .

Connecting Components
When you place a component in the design area, you will notice that each of the pins
is highlighted by a diamond-shaped outline. This shape identifies unconnected pins,
and disappears when a connection is made.

There are three ways to connect components:

• Directly, pin-to-pin

• With wires

• Without wires (with names)

unconnected

connected
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Hint When a connection is made, the pin color changes to the color designated as the
Connected Pin color (Options > Preferences > Pins/Tees). The color of the pin and the
diamond-shaped outline prior to connection is the color designated as the Highlight
color (Options > Preferences > Display).

Connecting Components Directly

To connect components directly:

1. Select the desired rotation for the component you are about to connect.

2. Position the pointer directly over the pin of the component you are connecting
to, and click.

Connecting Components with Wires

To connect components with wires:

1. Click the Insert Wire button or choose Wire  from the Insert menu. You are
prompted to enter the starting point.

2. Position the pointer at the desired location and click. You are prompted to enter
the next point.

3. Position the pointer at the desired location and click. A wire is drawn between
the specified points.

Tips:

• To specify an endpoint of an unconnected wire, double-click or press the space
bar.

• To move an unconnected endpoint of a wire, use Edit > Move > Move Wire
Endpoint.

• Wires are always routed on the grid unless items connected to them were placed
or moved off the grid. In this case, the shortest wire segment needed to make
the connection is drawn off the grid as required. This means the maximum
number of wires that connect to a single point is four.
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This is especially important to understand when using multiple input
components (such as Add and Mpy) in Signal Processing designs, because to
connect more than four wires to the input, you will need to connect additional
wires to one of the existing wires rather than to the input pin itself.

• Context-sensitive editing is available for wires with respect to changing the
layer on which the wire is drawn. Position the pointer over the wire, right click,
and select Wire Layer from the pop-up menu.

Connecting Components Without Wires

Connecting components without wires is accomplished by adding wire labels. Adding
wire labels to your schematic enables you to:

• Indicate connectivity without wires. Two or more pins in the same network,
with the same wire label, are connected as if they were wired.

• Identify node voltages— in an Analog/RF network—that you want output to the
dataset after simulation. Note that if you assign a wire label to a pin that is
connected to a wire, all pins connected to that wire will display that name.

• Create buses and bundles. For details, refer to the section that follows,
“Creating Buses” on page 3-29.

For information on naming conventions, refer to “Naming Conventions” on page 1-20.

Hint Using the same node name in nodes across subnetworks does not result in
connectivity unless a Global Node data item is placed in the design declaring that
node name global. A Global Node data item with the specified node name will connect
all nodes with that name across all subnetworks. This is useful for distribution of
signals such as supply voltages and clocks.

To connect without wires or identify a node voltage for output:

1. Choose Insert > Wire/Pin Label and a dialog box appears.

2. Enter a Name and click all pins you want to connect with this name. As you
click each pin, the name you have supplied appears near the pin.

To produce output from a single pin, assign a unique node name to that pin.

3. To name another node, supply a different name, and click each pin, as described
above. To dismiss the dialog box, click Close .
3-28 Connecting Components



To clear a node name:

1. Choose Edit  > Wire/Pin Label  > Remove Wire/Pin Label .

2. Click each pin or wire whose name you want to remove.

Alternatively, you can use the on-screen editor and the Backspace key.

Creating Buses
Using buses and iterated instances can greatly simplify the schematic representation
of your design. The following terms are used in describing how to create buses in
ADS:

• Net—In the broadest sense, any connection between the pins of different
electrical components

• Bus—A set of wires or a single wire carrying a set of signals. A bus is a kind of
net or collection of nets where all members share the same base name
(Data<1:4>⇒Data<1>, Data<2>,Data<3>,Data<4>).

• Wire Label—An identifying label used to name a net that enables referencing
that net by name. A simple wire label (A) merely labels a wire for identification
or connection purposes; a vectorized wire label (A<1:4>) identifies that wire as a
bus and enables connection by tapping, using the base name and an index
(A<2>). The vectors identify the bus width.

• Bundle—A collection of wires (or buses) that do not share the same base name
(Data<1>,A,B).

• Iterated Instance—A single instance on the schematic that represents multiple
instances. To iterate an instance you modify the Instance Name to include a
vectorized label (InstanceName<1:4>).

Note See the example project, Examples/Tutorials/wire_bus_prj.
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To represent a bus on an ADS schematic, add a vectorized wire label by supplying a
base name and vectors that identify the bus width.

To tap the individual bus wires, use the bus base name and an index.

To iterate an instance (connected to the bus), modify the Instance Name by adding
the vectorized portion of the bus wire label.

Add a vectorized wire label
and it becomes a bus.

Add a vectorized label
to the Instance Name.
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In the following illustration, the bus and iterated instance on the right are equivalent
to the four grounded sources connected to individual wires on the left.

The labels you use to identify the bus and everything connected to it must be added
using the appropriate syntax. The terminology shown in the following illustration
identifies the terms used to define this syntax.

Equivalent

Stop

Start

Base name

Bus Tapped WiresIterated Instance
Creating Buses 3-31



Creating Designs
Syntax:

Bus

base name<start:stop>

Example: InBus<1:4>

or

base name<start:stop:increment> for an increment other than 1. Use this to create
patterns such as {2,4,6,8} and {1,3,5,7}.

Example: InBus<2:8:2>

Tapped Wires

base name<index>

Example: InBus<1>

Iterated Instance

instance_name<start:stop>

where instance_name is the actual instance name you are using for this
component, and the vector information tracks with the bus vectors, including an
increment, where applicable.

Example: SRC1<1:4>

Note that pins and ports can be iterated in the same manner. For details refer to,
“Bus Pins and Iterated Ports” on page 3-37.

Important Be sure to use the correct syntax for all related parts of a bus; syntax
errors produce connectivity errors.
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The following illustration is a simple example using input and output buses
consisting of four wires each.

The basic steps to include this type of bus in your schematic are as follows:

• Designate the desired wire as a bus by adding a vectorized wire label, for
example, InBus<1:4>.

• Label the tapped wires of the bus by using the same base name you used for the
bus (in this example, InBus), and supplying an index to indicate which bus wire
it is.

• Add vectors (in this example, <1:4>) to the instance name of the component
connected to the bus (in this example, V_DC) to signify that it represents
multiple instances or an iterated instance.
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Notes:

• Occasionally the visual rendering of a bus wire might not appear as expected.
But as long as it is named correctly, connectivity will be correct.

• When a port is connected to an iterated instance, the port must be iterated as
well.

• Setting the value of a parameter of an iterated instance sets that parameter to
that value for all instances created by the iteration.

• Iterated instances cannot be tuned, swept, or optimized directly. To perform any
of these operations on an iterated instance, you must create an intermediate
variable representing the parameter of interest. You can then set the instance
parameter to this variable, and sweep/tune/optimize the variable, indirectly
sweeping/tuning/optimizing the instance parameter.

• It is not necessary to create a bus on the schematic that includes all of the array
indices. The simulator will collect all bus references with the same base name
into a single array (vector) with the required range of indices. For example a
schematic with A<0>, A<1>, A<2>, A<3> and A<4:15> will create a vector
A<0:15>.

• Negative indices are not allowed, although a negative increment is. You can
effect a countdown using indices such as A<4:1> which contains the nets A<4>,
A<3>, A<2>, A<1>, or use a negative increment if the increment is other than 1,
such as <8:2:-2> which contains the nets A<8>, A<6>, A<4>, A<2>.

• When choosing a bus base name, keep in mind that the name must adhere to
the same rules as node names. For details, refer to “Naming Conventions” on
page 1-20 in the User’s Guide.
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To create a bus or bundle:

1. Draw the wire and choose Insert  > Wire/Pin Label  and a dialog box appears.

• Bus—Enter the bus base name using the appropriate syntax and click the
wire that you want to designate as a bus.

• Bundle—Enter the names of the wires (or buses) that should be part of the
bundle and click the wire that you want to designate as a bundle.

2. The label appears and the rendering of the wire changes to a thicker line
indicating that the wire now represents a bus/bundle. Click Close .

To tap wires off the bus:

1. Draw the bus tap wire, choose Insert  > Wire/Pin Label  and a dialog box appears.

2. Enter the bus base name and the index for the bus wire you want to tap, and
click that wire. Increment the index in the dialog box as needed and click the
next wire. Continue in the same manner until you have tapped all desired wires
of the bus, then click Close .

To iterate an instance of a component/port or a symbol pin:

1. Double-click the instance or pin to display the dialog box for editing that item.

2. Add the appropriate iteration syntax to the instance name and click OK.

For components and ports, you can add labels using the on-screen editor; for
pins you must use the Edit > Symbol Pin dialog box (View > Create/Edit
Schematic Symbol).

Wire labels can be edited in the following ways:

• To move a wire label—Position the pointer over the bus/bundle label you want
to move. Press the left mouse button, drag the label (you will see a ghosted
image) to the desired location, and release. Note that moving a label a very
small amount is affected by whether the Snap Enabled option is on or off
(Options menu toggle), and the size of the Drag and Move threshold option
(Options > Preferences Entry/Edit). You can also use Edit > Move >
Move Wire/Pin Label.

• To set the color, size, and font of wire labels in advance—Use Options >
Preferences > Component Text/Wire Label.
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• To change the color, size, and font of existing wire labels—Choose one of the
following methods:

• Use Edit > Wire/Pin Label > Wire/Pin Label Attributes

• Double-click the wire label to display the dialog box

• Right-click and select Wire/Pin Label Attributes from the pop-up menu

• To delete a wire label, use one of the following methods:

• Invoke the on-screen editor and use the Backspace key (followed by Esc)

• Choose Edit > Wire/Pin Label > Remove Wire Label and click the wire whose
label you want to delete.

• To modify the label itself:

• Double-click the wire to display the Wire/Pin Label dialog box

Creating Bundles

A bundle is a collection of wires or buses that do not share the same base name. To
indicate a bundle on your schematic, add a wire label consisting of a list of the wire
labels and/or buses to be included in the bundle, separated by commas.

Syntax:

<wire_label/bus>, <wire_label/bus>, …

Any wire/bus in the bundle can be accessed by name. In the following example, if you
want to access A<4:5>, you can name a net A<4:5>.
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Bus Pins and Iterated Ports

A bus pin enables you to connect a bus or bundle to it. If you generate a symbol for a
design containing iterated ports, the symbol generator will create bus pins for you. If
you create a custom symbol for a design containing iterated ports, you must explicitly
assign an iteration to the symbol pins on your custom symbol.

Creating a Bus Pin via Iterated Ports and a Generated Symbol

When you iterate one or more ports on your schematic (by modifying the Instance
Name), then generate a symbol for it, the generated symbol is created with bus pins.

Creating a Bus Pin on a Custom Symbol

To explicitly create bus pins for a custom symbol representing a design containing
iterated ports, modify the pin name (Edit > Symbol Pin), using the same syntax as for
a bus or bundle (e.g., P1<1:4> or A,B) in symbol view (View > Create/Edit Schematic
Symbol). The number of iterated ports in the schematic must always equal the
number of symbol pins. This equivalence can be checked using Options > Check
Representation > Rep port vs Symbol port mismatch.

Design Created with Iterated Ports Generated Symbol

P1<0:2> P2<0:2>
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Buses in Ptolemy

Agilent Ptolemy provides a different use model for buses, and there are two types:
MultiPortHoles and the fixed-point data type (which uses components—not wires—
for bus manipulations).

A MultiPortHole is an ordered set of PortHoles that can be expanded dynamically. A
PortHole is equivalent to a pin in ADS. Pins that have double arrows are
MultiPortHoles that initially have zero PortHoles. As each connection is made on the
bus, a new PortHole is added to the MultiPortHole. Thus in this configuration, the
MultiPortHole pin represents a bus input.

A MultiPortHole can also be expanded (using netlist syntax) to a predefined size.
These MultiPortHoles are represented in the design environment as n separate pins
where n is the number of PortHoles in the MultiPortHole. All of the current
PortHoles and MultiPortHoles are directional, in contrast to the non-directional pins
of analog components. The following illustration shows the Agilent Ptolemy
multiplier components.

A MultiPortHole that is represented as a double arrow is equivalent to a bus pin with
unspecified size. To fix the size, add wire labels (in the schematic) just as you would
for an Analog/RF design, generate a symbol for it, and place it as a subnetwork, as
shown next.

Multiplies all of the signals
on the bus

Multiplies just two signals
3-38 Creating Buses



Checking Connectivity

Although a number of operations automatically perform a connection check, you can
explicitly test the bus-to-instance connections in a schematic through Options >
Check Representation > Bus Connectivity. The connection check attempts to resolve
all bus-instance connections, and highlights (on the schematic) any connections it is
unable to resolve. Connections that are part of a bus or bundle are verified using a set
of rules. The following terms are used in describing these rules:

• Connection Width—The total number of pins at a given port of an iterated
instance. Computed by multiplying the pin width at the port by the instance
width.

• Instance Width—The number of instances in an iterated instance (I<0:3>
represents 4 instances)

• Net Width—The number of individual wires in a bus/bundle (N<0:7> represents
8 wires)

• Pin Width—The number of pins at the given port of a component

Design Created with an Iterated Port Design Placed as a Subnetwork
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Resolving Connections Related to Names

When a net includes both named and unnamed wire segments, the unnamed
segments are considered to include every name that appears on all named segments.
In other words, the name implicitly assigned to an unnamed segment is the
intersection of all names on named segments.

In the following illustration, the segments 3, 5, and 7 are unnamed. A, B, C, D is the
intersection of all names on this net, and this is the name that is used for all three
unnamed segments.

D
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In an unnamed net (one with no named wires at all):

• If all instances to which this wire network is connected have a connection width
of N, then each wire in the network is given width N.

• If any instance to which this wire network is connected has a connection width
of 1, then the entire wire network is given width 1. Instances with connection
widths greater than 1 will be shorted together.

• If the instances to which this wire network are connected have mismatched
connection widths, and none of them have a connection width of 1, then there is
a connectivity error.

R1<0>, R2<0>, and R3<5> are connected
R1<1>, R2<1>, and R3<6> are connected
R1<2>, R2<2>, and R3<7> are connected
R1<3>, R2<3>, and R3<8> are connected

R1<0>, R1<1>, R1<2>, R1<3>, R2<0>,
R2<1>, R2<2>, R2<3> and R3<5> are
shorted together

Mismatched connection widths, none of
which is 1, result in a connectivity error
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Resolving Connections Related to Widths

To verify a connection, the net width of the bus is checked against the pin width of the
component, the instance width, and the connection width (where the connection
width represents the total number of pins: connection width = pin width * instance
width).

Agilent Ptolemy incorporates the concept of pins that can accept buses as inputs.
These pins are of arbitrary size and are annotated by double arrows on the pin stem.
For the Ptolemy MultiPortHole examples:

• Wires without names—connected to MultiPortHole pins—have unspecified
width.

• MultiPortHoles without a pin width have an unspecified pin width.

• Instances without an explicit width have an instance width of 1 (in other words,
the instance width can never be unspecified because it defaults to 1).

In the following descriptions of how various connection types are resolved, some
connection types apply only to Digital Signal Processing (DSP) designs while others
apply to both Analog/RF (A/RF) and DSP designs:

• “Unspecified net width, multiple input or multiple output connections (DSP
only)” on page 3-43

• “Unspecified input or output pin width, specified net width (DSP only)” on
page 3-45

• “Unspecified pin width, unspecified net width, specified instance width” on
page 3-45

• “Unspecified net width, pin width specified, instance width specified” on
page 3-45

• “Net width = connection width” on page 3-46

• “Net width = pin width” on page 3-47

• “Net width = 1” on page 3-47

If none of the conditions above apply, then the connection is not valid, and will be
flagged as an error. When an invalid connection is found during connection checking,
that invalid connection will be highlighted on the schematic.
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Unspecified net width, multiple input or multiple output connections (DSP only)

Agilent Ptolemy currently supports this connection type for instance widths equal
to one. Only the following two cases are supported: multiple outputs feeding a
multiport input and a single output feeding multiple inputs.

• Multiple outputs feeding a multiport input

• Net width = number of outputs

• Pin width of input = net width

• Pin width of any unspecified output pin = 1

This connection only works for commutative operators because it does not
guarantee the ordering of the bus.

To specify the exact ordering of the net, you must add wire labels or use the
BusSplit or BusMerge operators.

Net width = 6
Pin width = 3
Instance Width = 2

N<0> connects to P<0> of I<0>
N<1> connects to P<1> of I<0>
N<2> connects to P<2> of I<0>
N<0> connects to P<0> of I<1>
N<1> connects to P<1> of I<1>
N<2> connects to P<2> of I<1>

Add
I<0:1>
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• Output feeding multiple inputs:

• Net width = 1

• Pin width of output = 1

• Pin width of any unspecified input pin = 1

The problem with named nodes seen in the previous example does not occur in the
next example because the net width is resolved to 1. Ptolemy interprets this as a
single wire and replicates the output. The output here can be either a uniport or
multiport pin.

Net width = 1
Pin width = 1
Instance widths = 1 (G1 and G2)

N<0> connects to P<0> of G1
N<0> connects to P<0> of G2
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Unspecified input or output pin width, specified net width (DSP only)

If the pin width is unspecified and the net width is an integer multiple of the
instance width then:

• Pin width = net width/instance width

For the Add example above, the Ptolemy post-processor will need to recognize that
the input/output pin is connected to N<0>,N<1>,N<2> for I<0>, N<3>,N<4>,N<5>
for I<1> and N<6>,N<7>,N<8> for I<2>. An example netlist follows:

Options ResourceUsage=yes
UseNutmegFormat=no
TopDesignName="C:\test_prj\networks\buses"
_vAgilentEEsof_dSDF_nAdd_lsdfstars:I<0>  N<0>,N<1>,N<2>  _net1
_vAgilentEEsof_dSDF_nAdd_lsdfstars:I<1>  N<3>,N<4>,N<5>  _net2
_vAgilentEEsof_dSDF_nAdd_lsdfstars:I<2>  N<6>,N<7>,N<8>  _net3

Unspecified pin width, unspecified net width, specified instance width

Pin width is set to 1 and net width is set to the instance width.

Unspecified net width, pin width specified, instance width specified

Net width inherits connection width (pin width * instance width).

Instance width = 3
Net width = 9
Pin width = 3

N<0> connects to P<0> of I<0>
N<1> connects to P<1> of I<0>
N<2> connects to P<2> of I<0>
N<3> connects to P<0> of I<1>
N<4> connects to P<1> of I<1>
N<5> connects to P<2> of I<1>
N<6> connects to P<0> of I<2>
N<7> connects to P<1> of I<2>
N<8> connects to P<2> of I<2>
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For the next three cases, everything (pin, instance and net width) is specified. The
first case that applies (based on the order shown next) is the correct case.

• Net width = connection width

• Net width = pin width

• Net width = 1

Net width = connection width

The net width of the bus/bundle is the same as the connection width. This
connection is resolved and verified because the total number of pins (connection
width) matches the individual wires available.

Instance width = 3
Pin width = 3
Net width = 9
Connection width = 3*3 = 9

N<0> connects to P<0> of I<0>
N<1> connects to P<1> of I<0>
N<2> connects to P<2> of I<0>
N<3> connects to P<0> of I<1>
N<4> connects to P<1> of I<1>
N<5> connects to P<2> of I<1>
N<6> connects to P<0> of I<2>
N<7> connects to P<1> of I<2>
N<8> connects to P<2> of I<2>

example
I<0:2>

P<0:2>

N<0:8>
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Net width = pin width

If the net width and the pin width are the same, but the connection width is
different, then the connection is valid, but the wires making up the bus/bundle
must be repeated M times, where M is the instance width.

Net width = 1

If the net width is 1, and does not satisfy the previous two conditions, then the bus
(really a single wire) is repeated M times, where M is the connection width. Thus
this is the case when the pin width is greater than 1 and the net width is 1. This
case will issue a warning because although this is valid, we assume that a pin with
width connected to a single wire (shorted) may not be what the user intended.

Instance width = 3
Pin width = 3
Net width = 3
Connection width = 3*3 = 9

N<0> connects to P<0> of I<0>
N<1> connects to P<1> of I<0>
N<2> connects to P<2> of I<0>
N<0> connects to P<0> of I<1>
N<1> connects to P<1> of I<1>
N<2> connects to P<2> of I<1>
N<0> connects to P<0> of I<2>
N<1> connects to P<1> of I<2>
N<2> connects to P<2> of I<2>

example
I<0:2>

P<0:2>

N<0:2>

Instance width = 3
Pin width = 3
Net width = 1
Connection width = 3*3 = 9

N connects to P<0> of I<0>
N connects to P<1> of I<0>
N connects to P<2> of I<0>
N connects to P<0> of I<1>
N connects to P<1> of I<1>
N connects to P<2> of I<1>
N connects to P<0> of I<2>
N connects to P<1> of I<2>
N connects to P<2> of I<2>

example
I<0:2>

P<0:2>

N
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The following figure illustrates how the connections of a six-bit bus are mapped to
which pin of which instance, where there are—in essence—two instances, each with
three pins.

The next figure illustrates how the connections are made if you connect the
aforementioned instance to a three-bit bus instead, which is allowed because the
iterated instance has a three-bit pin.

Net Width = Connection Width

•Connect this instance to
a 6-bit bus A,B,C,D,E,F to
map the connections as
shown on the left.

Equivalent

A

B

C

D

E

F
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Adding Ports to a Design
1. Click the port symbol on the toolbar (or choose Insert > Port).

2. Select the appropriate rotation by clicking the toolbar button (Rotate By -90) as
needed.

3. Move the pointer into the drawing area, position the symbol as needed, and
click to place it there.

Hint Do not use the Move To Layer command to move ports to a different layer;
set the Layer parameter of the port to the desired layer.

Net Width = Pin Width

•Connect this instance to
a 3-bit bus A,B,C to map
the connections as shown
on the left.

Equivalent

A

B

C

A

B

C

Adding Ports to a Design 3-49



Creating Designs
Using Special Components
There are a number of commonly used components in ADS whose special features
must be understood to be used successfully. Please review the following topics, and
where applicable, the additional referenced topics:

• “Using Substrates” on page 3-50

• “Using Nonlinear Models” on page 3-51

• “Components that Allow File-Based Parameters” on page 3-52

Using Substrates

Substrates (such as microstrip, stripline, etc.) are specified by placing the required
substrate component in your design and then setting the substrate parameter (Subst)
of the associated circuit component(s) equal to the instance name of the substrate
component.

In the following example, the substrate parameters of the MSub1 instance are
associated with the Bend1 instance by assigning the instance name “MSub1” (of the
MSUB substrate component) to the Subst parameter of the MBEND2 component.

Note that the default value of the substrate parameter Subst, as well as the default
substrate instance name (in this example, MSub1), can be edited.
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Using Nonlinear Models

A nonlinear model can be associated with a nonlinear device instance by placing the
required nonlinear model item in your design and then setting the parameter Model
of the nonlinear device equal to the instance name of the nonlinear model item. This
is especially useful in a hierarchical design that contains multiple subnetworks, each
of which should reference the same model. In this case, place the _Model item in the
top-level design, and place an instance of the device in each of the subnetworks,
setting their Model parameter equal to the Instance Name of the _Model item.

In the following example, the model parameters of the BJTM1 instance are
associated with the BJT1 instance by assigning the instance name “BJTM1” (of the
BJT_Model item) to the parameter Model of the BJT4_PNP device.

Note The default value of the Model parameter—for any given device—is the same
as the default Instance Name of the related model (in this example, BJTM1). The
Instance Name of the model can be changed, like any other Instance Name. If you do,
be sure to change the Model parameter (of instances referencing that model)
accordingly.
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Components that Allow File-Based Parameters

Several components, such as DataAccessComponent (DAC), Deembed, and the SnP
components, enable you to set a parameter to reference a file-based set of values. For
details on the file formats of the data file types, refer to Chapter 20, Data File
Formats, in the Circuit Simulation manual.

To specify file-based parameters for these components:

1. Select the File  parameter.

2. Select the appropriate Parameter Entry Mode: Data filename  (DAC) or Network
parameter filename  (SnP, Deembed1, Deembed2).

3. Type the data filename, or Browse to select it. By default, only the files listed in
the current /data directory are displayed.

Alternatively, click Data files list to select a data file. The files listed are the files
found in the set of search paths assigned to the DATA_FILES variable (in
de_sim.cfg). The data directory of the current project is usually the first path.
For more information on setting variables refer to the section, Variables in
de.cfg, de_sim.cfg in the Customization manual.

4. Optionally, click Edit  to display the file (in your default text editor) for
modification.

5. Optionally, click Copy Template  to copy a data file of a specific format for use as
a template. This template can be a supplied template or one you have created.
By default, the program looks in the following location:

$HPEESOF_DIR/circuit/templates (for Analog/RF designs)

or

$HPEESOF_DIR/hptolemy/templates (for Digitial Signal Processing designs)
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Using the DataAccessComponent

Many component parameters, as well as variables, can be assigned a value from a
data file by using the DataAccessComponent (DAC). The basics of accessing
file-based parameters are as follows:

• Add a DAC component to your design

• Set the File parameter of the DAC equal to the data file of interest

• Set the parameter of the component of interest to reference the DAC (by its
Instance Name)

For details on setting the DAC’s parameters and some basic examples, refer to
DataAccessComponent in Chapter 1, Introduction, in the Circuit Components
manual.

Using Macros to Automate Tasks
You can record a macro (a series of AEL commands) by performing a sequence of
commands using the mouse, and then play it back later to repeat the sequence.

Note Not all commands/actions are supported in macro recording; therefore, we do
not recommend relying on this for recording complicated command sequences, but
rather as a tool for learning how to use AEL.

To record a macro:

1. In the Main window choose Options  > Start Recording Macro  and a dialog box
appears.

2. Enter a name for your macro—the file extension .dem will be added
automatically—and click OK.

3. Perform the desired sequence of commands.

4. When you are finished with the desired sequence, choose Options  > Stop
Recording Macro . The file is saved to your current project directory.
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To play back a macro:

1. Choose Options > Playback Macro and a dialog box appears displaying the macro
files in the current project directory (that match the filter).

2. Select the desired macro and click OK. (To run a macro stored in another project
directory, adjust the path as necessary, select the macro from the list, and click
OK.) The selected macro is executed.

Viewing and Entering AEL Commands
The AEL commands that are issued in response to your activity in the Main window
and the design windows are displayed in the Command Line dialog box. This
command summary is updated continuously as you work. You can view this summary
any time and you can issue previously executed commands from this list.

To view the command summary:

Choose Options  > Command Line  in the Main window and the dialog box appears.
As you execute commands, the corresponding AEL functions are displayed.

To execute AEL commands from this command summary:

• Type the command(s) in the Command >> field and press Return  or click Apply
after each to execute. (Note: All commands entered in the Command >> field
must be in AEL format.)

or

• Select a previously typed command from the list and press Return or click Apply
to execute.

or

• Double click any command in the list and the command is executed.

Click Cancel to dismiss the dialog box.

Note For configuration details on using AEL, refer to the AEL manual. For layout
artwork and usage, refer to the Layout manual.
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Creating a Netlist
By default, every time you simulate a design, you generate a netlist file, netlist.log, in
the current project directory, but it is possible to generate the netlist file without
simulating the design.

To generate a netlist without simulating:

1. Open the desired Schematic.

2. Choose Options  > Command Line  in the Main window and the Command Line
dialog box appears.

Hint Replace the number 1, shown in parentheses in the next step, with the
number of the window from which you want to generate a netlist. The number
of the window is displayed in the title bar.

3. Click in the Command >> field and type de_set_window(1);  and press Return .
Notice that what you type is echoed in the list above.

4. Click in the Command >> field and type de_netlist( );  and press Return  or click
Apply . After a short time, the netlist.log file is written to the project directory.

To use a different filename for any given project, you can insert the following line in
the de_sim.cfg file in that project directory and specify a filename other than
netlist.log.

NETLIST_FILE_NAME=netlist.log

Important If you edit your schematic after generating a netlist, you will need to
generate the netlist again, since nodes may be renumbered as you edit.
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Generating Reports
The Reports command enables you to generate a Bill of Materials (BOM) and a Parts
List. Examples of a BOM and a Parts List are shown below.

Note By default, you are supplied with one format for the BOM and two for the
Parts List, but these formats can be customized, and additional formats added,
through AEL. For details, refer to the AEL manual.

To generate a Bill of Materials:

1. Choose File  > Reports  > Bill of Materials .

2. By default, the design name and a .rpt.bom extension appear as the filename for
the generated file. Accept this name or supply another and click OK. The file is
displayed in a window on the screen.

Figure 3-1. Bill of Materials Example

3. To save it to file with the default filename, click OK; to save it to file with a
filename of your choosing, click Print . Supply a filename and click OK.

To generate a Parts List:

1. Choose File  > Reports  > Parts List .

2. Choose the desired Report Type.

• HP EEsof (HP EEsof PL format)—component name, ID, coordinates, angle,
and side

• HP EEsof (netlist format)—component names and parameters

Bill of Materials for: tee_atten    Tue Mar 31 14:22:19 1998

Item Qty Description Designators
===========================================================

RES          3      Resistor                       R2 R3 R1
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3. By default, a .rpt.pl (parts list) or .rpt.net (netlist) extension is automatically
added to the filename. Accept this name or supply another and click OK. The file
is displayed in a window on the screen. Figure 3-2 shows an example of the
parts list format.

Figure 3-2. Parts List Format Example

Figure 3-3 shows an example of the netlist format.

Figure 3-3. Netlist Format Example

4. Click OK to save it to file with the default filename. Click Print to print to file or
to the printer, based on your current Print Setup. If the current Print Setup is
set to print to file, a dialog box appears prompting you for a filename. Supply a
filename and click OK.

Parts list for: /networks/tee_atten Tue Mar 31 11:28:45 1998

Component    Ref ID     X, Y,            ANG     SIDE
=====================================================

R R1 1, 0.5 0 top
R R2 3.5, 0.5 0 top
R R3 2.75, -0.125 -90 top

Net list  Tue Mar 31 11:49:33 1998

TOP LEVEL DESIGN:  tee_atten

Design: tee_atten

Port P1 1
Num=1

Port P2 4
Num=2

GROUND G1 0

R R1 1 2
R=10 Ohm

R R2 2 4
R=10 Ohm

R R3 2 0
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Chapter 4: Creating Hierarchical Designs
You can use any network as a subnetwork within another network to create a
hierarchical design. There are two ways to create a subnetwork:

• Use the Create Hierarchy command and specify a portion of an existing design
to be copied to its own design file for use as a subnetwork

• Create a new design consisting of a network you want to use as a subnetwork

Hint To view design hierarchy in the current project, choose View > Design
Hierarchies from the Main window.

To access a design in one project for use as a subnetwork in a design in another
project, create a hierarchical project (File > Include/Remove, in the Main window).
For details, refer to “Creating a Hierarchical Project” on page 2-9.

Note The Update Component Definitions command (Edit > Component) enables you
to explicitly update component definitions (that you have changed) throughout the
current design. If you select the Update Component Definitions in Subnetwork option,
the design hierarchy will be traversed (downward) and components will be updated
throughout the hierarchy.)

Creating a Subnetwork from an Existing Design
The Create Hierarchy command copies the selected portion of your design to another
file, saves that new file, deletes the selected items in the original file and replaces
them with a default symbol representing the deleted items.

Hint You can create a custom symbol to use in place of the default symbol. For
details on symbols, refer to Chapter 10, Working with Symbols.

The example used to illustrate this command is based on a simple, 3-resistor
attenuator that is part of a larger design. In this example, the main design is named
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main_design and the file created using the Create Hierarchy command (containing
the 3-resistor attenuator) is named my_atten.

To create a subnetwork from an existing design:

1. Select the items you want to include in the subnetwork (represented here inside
the box drawn with a dashed line).

2. Choose Edit > Component  > Create Hierarchy  and a dialog box appears.

3. Provide a name for the new file, in this example, my_atten,  and click OK. (The
name you supply is the filename for the subnetwork as well as part of the
annotation for the symbol when you place it in a design—however, no
annotation is displayed in this example.)

The selected items disappear from your original design and are replaced by a
default symbol (in this example, a 2-port symbol). Wires are redrawn to
reconnect the remainder of the design to the symbol.

4. Save the file. The design used in this example appears as shown next.

default 2-port symbol
main_design.dsn—after
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If you want to use this network as a parametric subnetwork in a hierarchical design,
you must open this newly created file (my_atten.dsn) and define the parameters that
you want to be passed from the subnetwork to the network.

To define parameters for an existing subnetwork:

1. Open the file containing the subnetwork design.

2. Choose File  > Design Parameters  and a dialog box appears.

3. Supply a parameter name (not to exceed 8 characters), and select the
appropriate characteristics for that parameter.

4. When you are through assigning characteristics to that parameter, click Add
and the newly defined parameter is added to the Parameters list box.

5. Continue in this manner until you have assigned all the desired parameters for
this network and click OK.

For a more detailed discussion on defining parameters, refer to the section titled,
“Defining Parameters” on page 4-9.

Creating a Parametric Subnetwork
Any network can serve as a parametric subnetwork. A parametric subnetwork is any
network for which you define the control parameters that pass through to the
network into which you place the subnetwork. Once you have defined the parameters,
your subnetwork can serve as a template enabling you to assign parameter values
each time you place it in a design. You can construct whole libraries of re-usable
subnetworks in this manner.

The details of this process are presented using a simple design consisting of a
capacitor and a resistor in series and two ports. This subnetwork is called series_r_c
and is represented by the default 2-port symbol.
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Place subnetwork
within desired
design

series_r_c

Accept the default
symbol or assign a
custom symbol

default 2-port symbol

main_network

Amp 1 Amp 2

When you place the subnetwork within another design,
you have the opportunity to assign values to any
parameters you defined.

Define the design
characteristics

Create the
subnetwork

Define the
parameters

File > Design Parameters

F
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Creating the Subnetwork

You can create the subnetwork first, or define parameters and then create the
subnetwork. In this example, we create the subnetwork first.

To create the subnetwork:

1. Choose File  > New Design  in the Schematic window and assign a name, in this
example, series_r_c . This name becomes part of the annotation for the symbol
representing the subnetwork when you place it within another design.

2. Select Analog/RF Network  as the Type of Network and click OK.

3. Click the Library  button and select a category, in this example, Lumped
Components.

4. Select a component, in this example, C (Capacitor) .

5. Place the capacitor in the Schematic window. Note the component
parameter C is set equal to the default value of 1.0 pF. Click the End
Command  button.

6. Click the capacitance value to invoke the on-screen editor and use the Back
Space key to erase the 1.0 pF.

7. Type C and press Return . The parameter now reads C=C. (This C parameter will
be defined in the Design Parameters dialog box in a later step and serves as a
variable here.) The parameter C (capacitance) of this component will now pass
through to the network in which it is placed.

8. Place the next element, in this example, R (Resistor) , accepting the default
values. Connect it to pin 2 of the capacitor symbol.

9. Add ports and click the End Command button. The subnetwork should resemble
the illustration shown next.
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Defining Design Characteristics

Design characteristics include things such as the name of the symbol used to
represent the subnetwork and a library from which the subnetwork can be accessed.
In some cases you may find the default design characteristics acceptable (default
symbol and default current project as the library, for example). If this is the case,
proceed to the next section, “Defining Parameters” on page 4-9.

To alter the default characteristics:

1. Choose File  > Design Parameters  and a dialog box appears. In the General tab,
the current design name is reflected in the Name field at the top of the dialog
box.

2. The Description field also displays the current design name by default. You can
change this to a more helpful label defining the purpose of the network design.
The label you provide here will be displayed, together with the design name, as
a component to place from the designated library (Library Name field).

Optionally, add a description, in this example, cap and res .

3. The Component Instance Name default is X. The text in this field is used as a
prefix in building a unique name (ID) for every item. This prefix becomes part of
the annotation displayed with the symbol representing the parametric
subnetwork when you place it in a design.

Optionally, assign a unique name, in this example, para_sub .

4. Notice that the Symbol Name field reads SYM_2Port. This is the default symbol
for a 2-port design. In this example, we are using the default symbol, but you
can select one of the other symbols from the drop-down list, or click More
Symbols to select one by clicking an icon from the appropriate category. For
details refer to Chapter 10, Working with Symbols.

5. In the Library Name field, specify the name of the library in which you want the
subnetwork stored. This library name is the name that appears in the
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Component Library enabling you to select the subnetwork and place it in a
design. There are several ways to specify a library name:

• Accept the default Library Name—an asterisk (*). This means the design will
be available in the Component Library through the current project

• Type any name to create a new library

• Enter the name of any of the supplied libraries

• Select the name of any library you created previously

Create a new library name, in this example, my_subnetworks .

6. Turn on or off the following options, as required by your design.

• Allow Only One Instance—Specifies whether or not the subnetwork can be
placed more than once in a design. The default is off, meaning the
subnetwork can appear more than once in a design. Change to on if you want
to restrict placement of the subnetwork to once per design (seldom done).

• Include in BOM—Specifies whether or not the details of this design are
included when a BOM is generated. Without this option, only the top level
design information is included in the BOM.

• Layout Object—Analog/RF designs only. Defines the design as an object.
Layout objects have no parameters and are used to assign artwork to new
elements or designs with no default artwork. For details, refer to the Layout
manual.

• Simulate from Layout (SimLay)—Analog/RF designs only. The netlist
required for simulation is generated from either the Schematic or the Layout.
Select this option to generate the netlist from the Layout.
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The SimLay portion of this label will appear in the Status panel of the
Schematic and Layout windows if you select this option; the default is to
simulate from the Schematic, and the Status panel reflects SimSchem.

7. Layout only—select the appropriate Simulation method:

• Select Subnetwork, to use a schematic symbol you have created

• Select Built-in Component, to use a supplied simulator item.

Simulate As—Select a component name from the drop-down list, or type the
name of any component

Copy Component’s Parameters—Select this option to copy the parameters of
the selected component to use as a starting point

• Select Not Simulated, to create layout- or schematic-only non-simulated
items

8. Analog/RF layout designs only—select the appropriate artwork Type. For
details refer to Chapter 7, Artwork in the Layout manual.

9. Click Save AEL file to save the information defined so far. (This is
done automatically when you save the design file.)

Subnetwork
Built-in Component
Not Simulated

Synchronized
Fixed
AEL Macro
None
4-8 Creating a Parametric Subnetwork



Defining Parameters

When you define parameters for a network, the network serves as a template,
enabling you to assign new parameter values each time you use the network. This is
useful when a portion of the network is used several times in a design with certain
element value differences, or in constructing libraries of reusable networks.

Parameters of the network are generally referenced as variables by the elements of
the network. You can define the parameters before or after creating these variable
references.

Each parameter has characteristics that determine how it is handled when the
network is reused. These include the name and label displayed in the Item
Parameters dialog box, the unit of the parameter, the type of value assigned to the
parameter, the default value, and certain control attributes.

To define the parameters that should be passed to the upper-level network:

1. Click the Parameters  tab.

2. Optionally (Analog/RF designs only), you can click Copy Parameters From  as a
shortcut for defining parameters, if one of the supplied components has a
number of parameters in common. You can then cut any unwanted parameters,
as well as modify the characteristics of the remaining parameters.

3. The Parameter Name field contains the parameter name that will be referenced
in the subnetwork schematic. Parameter names become part of the annotation
of the symbol representing the parametric subnetwork when you place it in a
design.

Supply a Parameter Name (not to exceed 8 characters), in this example, C.

4. Select a Value Type from the drop-down list, in this example, Real.

5. Specify a Default Value, in this example, 5. This value can be changed at the
time you place the subnetwork.
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Hint If you do not specify a scale factor along with the default value, the
current setting in the Preferences dialog box is used (Options > Preferences >
Unit/Scale), based on the Parameter Type.

6. Optionally, select a Parameter Type for this parameter, in this example,
Capacitance . This can be a dimensional unit or a string for the parameter, if one
is needed. (String is used for assigning SMT artwork in layout.)

7. Optionally, supply a Parameter Description.

8. Select any of all of the following options, as they apply. Note that some options
are desensitized depending on the current Value Type.

• Display parameter on schematic—Select this option to display, on the
schematic, the parameter being defined.

• Optimizable—Select this option to allow this parameter to be optimized.

• Allow Statistical Distribution—Select this option to allow post-production
tuning for this parameter during yield analysis.

• Not edited—Select this option to prevent this parameter from appearing in
the Component Parameters dialog box for editing and always use the default
value assigned here instead.

• Not netlisted—Select this option to prevent a parameter from being
considered in simulation, but still be recognized for artwork generation
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9. Click Add  to add the newly defined parameter to the Select Parameter list box.
The parameter C is added to the Parameters list box.

• Use Add to add a new parameter to the list

• Use Cut to delete parameters

• Use Cut and Paste buttons to rearrange the order of the parameters.

Hint You can position these user-defined parameters to display somewhere other
than the default location of supplied parameters. For details refer to “Positioning
Parameters for Your Symbol” on page 10-14.

10. Optionally (Analog/RF designs only), you can click Add Multiplicity Factor (_M) to
enable simulation of this subnetwork as though it were x number of these
subnetworks—connected in parallel—where x is the value you assign to the
parameter _M.

11. Click OK to dismiss the dialog box and choose File  > Save Design .
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Placing the Subnetwork in a Design

Now you can place the subnetwork you just created into another network. The
parameter you assigned (capacitance in this example) will pass through to the
network.

To place a subnetwork:

1. Open the file containing the network in which you want to place the subnetwork
(in this example, main_network—not shown).

2. Click the Library  button (or choose Insert > Component > Component Library).

3. In the Component Library window, locate and select the library containing the
design, in this example, my_subnetworks .

4. Select the subnetwork, in this example, series_r_c , and place it in the drawing
area. Click End Command .

Notice that C = 5 F. This 5 is the value from the Default Value field (for the
parameter C) in the Design Definition dialog box. Because we did not specify a
scale factor, the default F (Farads), from the Preferences dialog box is used
(Options > Preference > Unit/Scale).

5. Using the on-screen editor, change the default capacitance value to the desired
value for the current design, in this example, 2. Press Return .

Design name you supplied for the subnetwork
Instance Name Prefix (plus 1, supplied by program)
Name of control parameter and assigned value
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Modifying a Design that Serves as a Subnetwork

If you make changes to a subnetwork that affect the component definition (any
changes in the Design Parameters dialog box—information that is saved in the .ael
file), that serves as a subnetwork in a higher-level design, you need to explicitly
update the higher-level design to recognize those changes.

To update a higher-level design that contains a modified subnetwork:

1. From the higher-level design, choose Edit  > Component  > Update Component
Definitions .

2. To traverse the hierarchy (downward) in search of any subnetwork designs
whose component definitions have been changed, select the option Update
Component Definitions in Subnetwork  and click OK. Changes to any subnetwork
designs are now reflected in the instance(s) in the main design.

Viewing the Network Represented by a Symbol

Whenever your design contains a symbol that represents a network, you can view the
actual network being represented by the symbol by using the Push Into Hierarchy
command.

To push into and then pop out of an item:

1. Select the item.

2. Choose View  > Push Into Hierarchy . The network represented by the symbol is
displayed.

The Pop Out of Hierarchy command is the reverse of pushing, and only works if
a design has been pushed into.

3. When you are through viewing the network, choose Pop Out of Hierarchy and
you are brought back to the item (or design containing the item).
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Chapter 5: Viewing Designs
The View menu commands enable you to change the current view of the drawing area
to aid you in working with the image in the window. Additionally, there are a number
of commands on the Options menu that display various aspects of design information.

• “Zooming In and Out” on page 5-1

• “Repositioning a Design to Fit the Window” on page 5-2

• “Moving the Center Point of a Window” on page 5-2

• “Redrawing the View in a Window” on page 5-3

• “Saving and Restoring Views” on page 5-3

• “Viewing Design Information” on page 5-4

Zooming In and Out
The Zoom commands enable you to enlarge or shrink the area being viewed. Zoom
Window enables you to specify your own view window for zooming, if the other zoom
commands do not meet your needs.

To zoom in on a specified point in the window:

Choose Zoom In Point .

Click to specify a point and the current view is magnified by a factor of two, moving
the point you specify to the center of the window.

To zoom out from a specified point in the window:

Choose Zoom Out Point .

Click to specify a point and the current view is decreased by a factor of two, moving
the point you specify to the center of the window.

To specify a particular factor by which to zoom:

Choose Zoom By Factor  and choose the appropriate command.

• Zoom In x2 (zooms in by a factor of 2)

• Zoom Out x2 (zooms out by a factor of 2)

• Zoom in x5 (zooms in by a factor of 5)
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• Zoom Out x5 (zooms out by a factor of 5)

• Zoom In by . . . (and specify the desired factor)

• Zoom Out by . . . (and specify the desired factor)

To specify a particular portion of the view for zooming:

1. Choose Zoom Area . You are prompted to enter the first corner.

2. Move the cursor to the point representing the upper-left corner of the desired
view window and click left. You are prompted to enter the second corner. As you
move the mouse, a flexible box, representing the view window, moves with it.

3. Move the cursor to the point representing the lower-right corner of the desired
view window and click left. The portion of your drawing enclosed by the view
window is magnified. (The magnification amount is determined by the size of
the view window you specified.)

To zoom to a selected object(s):

Select the object(s) and choose View  > Zoom  > Zoom To Selected .

Repositioning a Design to Fit the Window
To rescale and reposition your design so that it all fits in the window:

Choose View All . Your design is scaled as needed and repositioned to fit it all, plus a
five-percent border, in the viewing area.

Moving the Center Point of a Window
The Pan command moves a point you specify, to the center of your window.
Alternatively, you can use the scroll bars to move a different part of the window to the
center.

To change the center point:

1. Choose Pan View from the View menu or the pop-up menu. You are prompted to
enter the new window center.

2. Click once and the selected point becomes the new center point of the window.
Your design is redrawn accordingly.
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Redrawing the View in a Window
The Redraw View command refreshes the image in your window without changing
anything. Choose Redraw View from the View menu anytime you make changes and
see that an image is not completely drawn.

Saving and Restoring Views
It is possible to save multiple views of your design at various zoom settings.

• Save View enables you to save the current zoomed or panned view with a name

• Restore View enables you to retrieve a saved view

• Delete View enables you to delete a saved view

• Restore Last View enables you to restore the view that was in the window the
last time you issued a Pan or Zoom command

To save the current view:

1. Choose View  > Save View. A dialog box appears.

2. Supply a name for the view and click OK.

To restore a view that has been saved:

1. Choose View  > Restore View . A dialog box appears.

2. Supply the name of the view you want and click OK.

To delete a view that has been saved:

1. Choose View  > Delete View. A dialog box appears.

2. Supply the name of the view you want and click OK.

To restore the view that was in the window the last time you issued a Pan or Zoom
command:

Choose View  > Restore Last View .
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Viewing Design Information
You can display a variety of design information using commands found on the
Options menu:

• Hierarchy displays a listing of the hierarchical information of the current
design in the Schematic and Layout windows

• Info displays a detailed listing of design information including current units,
preference and layer file associated with design, instances by name and ID,
mask layer information, and a summary

• Identify lists detailed data for selected instances, shapes, or text

• Check Representation provides information on unconnected pins, port vs. pin
mismatch, and nodal mismatch

Viewing Detailed Design Information

The details on closed shapes include area, perimeter, and layer; for text, it includes
the string and font attributes; for polylines it includes length. For components, the
Name, ID, X, Y location, fixed/free status and equivalent element are displayed. A
short summary is included that shows the number of items and shapes, the layers
used, and the total selected area, length and perimeter.

To display detailed information for selected items:

1. Choose Options  > Info  and the Information dialog box appears.

2. To view details on items not selected initially, select and click Refresh . The
information is updated to display details of the newly selected item(s).

3. Optionally, click Print  to send the information to your default printer.

4. Click OK to dismiss the Information dialog box.

Viewing Detailed Instance Information

To display detailed information for selected instances:

1. Choose Options  > Identify  and a dialog box appears.

2. To print the information, click Print  and it is sent to the default printer.

3. Click OK to dismiss the dialog box.
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Viewing Hierarchical Design Information

There are two different ways to view hierarchical design information:

• At the design level, for the current project (View > Design Hierarchies, in the
Main window)

• At the component level, for the current design (Options > Hierarchy, in the
Schematic and Layout windows)

To view design hierarchies for the current project:

1. In the Main window, choose View  > Design Hierarchies .

If the project contains more top-level designs than can be displayed at one time,
the arrows on either side of the tabs enable you to cycle through the remaining
top-level designs to select the one you want.

2. Double-click any design to open it.
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To view the component hierarchy information for the current design:

1. Choose Options  > Hierarchy  and the Hierarchy dialog box appears.

Hierarchical levels are indicated by the level of indentation in the list. Top level
items are not indented; each nested level is indented with two spaces.

2. Click Print  to send the information to your default printer.

3. Click OK to dismiss the Hierarchy dialog box.

Viewing Connectivity Information

The Check Representation command provides access to information about any of the
following characteristics of your design:

• Open Connections—Displays the total number of unconnected pins and wires.
For each item with an unconnected pin, it lists the component name and ID, the
pin number and the coordinates of the unconnected pin. For each wire with an
open end, it displays the coordinates of the wire segment. The affected items are
highlighted in the design window.

• Nodal mismatches (layout vs schematic)—Reports items that are connected
differently in one representation than they are in the other. The report lists the
name of the item, the pin that is connected differently and what the pin is
connected to. The affected items are highlighted in the design window.

• Pin mismatches (instance vs symbol)—Schematic only. Checks every instance in
the design (against the source design it represents) and reports any discrepancy
between the number of pins on the symbol in the current design and the
number of ports on the schematic in the source design.

• Port/Pin mismatch (schematic vs symbol)—Schematic only. Compares the
number of pins on a given symbol to the number of ports on the schematic the
symbol represents and reports any discrepancy.

• Wires in layout—Layout only. Reports all items connected to pins that are
interconnected with a wire, or a zero-width trace.

• Overlaid components—Reports the IDs of any overlapping items where the
items contain the same number of pins and pin 1 of each item is placed in the
same location.

• Overlap wires (Overlap wire/traces in layout)—Highlights any wires (or traces)
that overlap, that are not part of the same node.
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• Bus connectivity—Reports failed connections listing the bus or bundle, its
width, and the Instance Name of the component to which you have attempted to
connect the bus or bundle.

To view this information:

1. Choose Options  > Check Representation  and a dialog box appears.

2. Select the desired information category (or categories) and click OK. A dialog
box appears displaying the requested information.

3. Click Print  to print the report, if desired.

4. Click OK to dismiss the report dialog box.
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Chapter 6: Editing Designs
While editing, keep in mind that most edit commands allow you to select the item(s)
before you select the edit command, or vice versa. Take note also that many editing
commands are repeating commands, that is, once the command is chosen, it remains
active until another command is chosen or until it is explicitly canceled (Edit > End
Command).

You will find it easier to edit your designs if you understand some of the features
provided to assist you in selecting the item(s) you want to edit. While there are
several features available to assist you in selecting objects for editing, there are three
distinct features you should know about:

• Using Selection Filters

• Changing the Pick Box Size

• Setting the Selection Status of Items Layer-by-Layer

These and other design entry and display preferences are described in Chapter 9,
Setting Design Environment Preferences.

Using the Undo Command
Selecting Undo undoes the last editing command. A stack of edit commands is
created enabling you to choose Undo repeatedly to return to an earlier state of your
design. A stack is maintained for each window, thus the Undo command works
independently from window to window. You can specify the number of commands you
want the stack to hold through Options > Preferences > Entry/Edit, Undo edit count.

Hint You can also press <Ctrl> u to issue the Undo command.

Deleting Items
To delete selected items, click the Delete button on the toolbar, or press the Delete key
on the keyboard, or choose Delete from the Edit menu. Deleted items can be restored
using the Undo command.
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Editing Component Parameters
There are several methods for changing component parameters. The simplest
methods involve editing parameters for individual components:

• Using the on-screen editor

• Using the component parameter dialog box

Additional methods that accommodate editing parameters in specific situations are:

• Searching for a particular parameter—a parameter whose value is stated as a
reference to another component (Search/Replace Reference)—and then
replacing that parameter throughout the design

• Changing the value of a particular parameter common to components
throughout the design (Group Edit Parameter Value)

Note The at symbol (@) must be used to suppress quotes when specifying a variable,
for example, @freq1, where freq1 is a variable declared in a VAR item.

Editing Component Parameters On-screen

You can use on-screen parameter editing to change parameter values. In addition,
you can change the Value Type from nominal to variable, and vice-versa. If you need
to change a parameter’s Value Type to anything other than nominal or variable, refer
to the next section, “Editing Component Parameters Through the Dialog Box” on
page 6-3.

Hint When you click the component name, you initiate the Swap Components
command.

To edit one or more parameters for a component using the on-screen method:

1. Position the pointer over the parameter you want to change and click. The
editable portion of the parameter takes on the current Highlight color (Options
> Preferences > Display). You will also see that a vertical bar (|), representing a
text insertion cursor, appears in the parameter line.
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2. Use the mouse, arrow keys, and backspace key as necessary, to change the
parameters.

3. To end the parameter editing command, move the pointer away from the
component and click once. (If the parameter is the last one in a list of
parameters or is the only parameter for this component, pressing Return also
ends the command.)

Hint When editing several parameters for one component, you can click each
individual parameter you want to edit, or you can press Return as many times
as needed to get to the next parameter you want to edit. Pressing Return for the
last parameter in the list ends the parameter editing command.

Editing Component Parameters Through the Dialog Box

Despite variations for some components, certain basic guidelines apply to completing
the component parameters dialog box for most components. Note the following
features of this dialog box:

• The input fields change based on the individual parameter selected.

• A default ID for a given instance of a given component appears in the Instance
Name field. This ID is unique for every component in the design. You can use
the default name or supply any name of your choosing.

• Some parameters offer the ability to use data from a referenced data file. For
details refer to the section, “Components that Allow File-Based Parameters” on
page 3-52.

• You can turn the display of individual parameters on or off. You can also use
Component Options to set or clear the display of all parameters for the
component at once. For details, refer to the section, “Changing the Visibility of
Component Parameters on a Schematic” on page 6-5.

• For details on Optimization/Statistics Setup, refer to the section Specifying
Component Parameters for Optimization in Chapter 2, Performing Nominal
Optimization, in the Tuning, Optimization and Statistical Design manual.
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To edit one or more parameters for a component through the dialog box:

1. Choose one of the following methods for displaying the dialog box:

• Choose Edit > Component > Edit Component Parameters and click the
component symbol

• Click the Edit Component Parameters button on the toolbar and click
the component symbol

• Double-click the component symbol

Hint Use the following shortcut to edit parameters for most or all components: select
everything in the drawing area (Select > Select All) and choose Edit > Component >
Edit Component Parameters. Click Apply to accept parameter changes for one
component, and another component is displayed for editing.

2. Select the parameter you want to change from the Select Parameter list box.

Default Unique ID for
this Component
(Automatically
Incremented)

Parameters
for this
Component

Appropriate
Choices for
the Current
Parameter

Value of
Selected
Parameter
Displayed
for Editing
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3. Type the new value in the parameter value editing field.

4. Press Return . The Parameters list box is updated to reflect the new value and
the value of the next parameter is displayed for editing.

5. When you are through editing parameters, click OK to dismiss the dialog box.

Changing the Visibility of Component Parameters on a Schematic

You can change the visibility status of all parameters of a given component through
the Component Options dialog box (accessed through the component parameters
dialog box).

• Set All—Displays all parameters for this component on the schematic. Use this
option to display all, or almost all, parameters for this component. To display
most—but not all—parameters, select Set All and then go back and turn off the
display of individual parameters as desired.

• Clear All—Clears the display of all parameters for this component from the
schematic. Use this option to turn off the display of all, or almost all,
parameters for this component. To display a small subset of parameters, select
Clear All and then go back and turn on the display of individual parameters as
desired.

Referencing VAR Data Items and Model Items in Hierarchical Designs

The Scope option applies to the VAR (Variables and Equations) data item and most
model items (such as R_Model, BJT_Model, BSIM3_Model). Exception: it does not
apply to multilayer models. Scope indicates the levels, from a hierarchical
standpoint, that recognize the expressions defined in the VAR data item or model
item.

• Nested—VAR or model item expressions are recognized within the design
containing the VAR or model item, as well as within any subnetworks (designs
at lower levels) referenced by the design containing the VAR or model item.

• Global—VAR or model item expressions are recognized throughout the entire
design, no matter what level in the design hierarchy the VAR or model item is
placed.
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Editing Common Parameters for a Group of Items

The Group Edit Parameter Value command enables you to select a group of
components with one or more common parameters, select a parameter that applies to
them all, and change that parameter’s value for all selected components.

To edit every occurrence of a parameter for selected components:

1. Select all components containing the parameter you want to edit.

2. Choose Edit > Component > Group Edit Parameter Value and a dialog box appears.

3. Click Name Options  and a dialog box appears listing all parameters in your
design by name.

4. Select the desired parameter from this list and click OK. The selected
parameter appears in the Parameter Name field.

5. If the value type of the selected parameter is numeric, type the new value in the
Parameter Value field; otherwise, click Value Options  and a dialog box appears.
The contents of the dialog box vary depending on the value type of the chosen
parameter.

Note You can only change the nominal value of the parameter, not the Value
Type.

6. Select the desired parameter value and click OK.

7. Click Apply in the Group Edit Parameter Value dialog box (or click OK if you are
through with this dialog box) and the design is updated accordingly.
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Breaking Wire Connections Between Components
To break connections:

1. Select the component(s) whose connections you want to break.

2. Choose Edit > Component > Break Connections . The interconnections of selected
components are deleted.

Swapping Components
The Swap Components command enables you to select any number of components,
with any number of ports, and replace them all with another component.

To swap components:

1. Select all components you want to replace.

Hint Use the Select > Select By Name command to quickly select every
component of a particular type.

2. Choose Edit  > Component  > Swap Components  and a dialog box appears.

3. Click Select  and the Component Library window appears.

4. Select the appropriate library and desired component. The component name
appears in the New Component Name field of the dialog box.

5. Click Edit Parameters  and the component parameters dialog box appears.

6. Change any parameters as desired and click OK.

Before After

Selected item
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7. To keep the IDs of the original components, select the option Keep the original
component ID(s); to let the program replace the IDs with new ones, deselect this
option. Click OK. All selected components in the design window are replaced by
the new component with the specified parameters.

Searching and Replacing References
The Search/Replace Reference command enables you to replace every occurrence of a
parameter value where that parameter value is a reference, such as a reference to a
data item. For example, if your design contains two MSUB data items, MSUB1 and
MSUB2, you can replace every reference to MSUB1 with a reference to MSUB2
instead. You can replace references to data items or variables.

To search and replace references to data items or variables in your design:

1. Choose Edit  > Component  > Search/Replace Reference  and a dialog box appears.

2. Select the desired Reference Type, Component or Variable .

3. Under the heading Search For, click Select and a dialog box appears. The listing
varies according to the selected reference type.

Hint To highlight these references prior to replacing any, use the Search Only
option and click Apply.

4. Select the Instance Name or Variable name representing the item you want to
search for and click OK. The selected reference appears in the Search For field.

5. Under the heading Replace With, click Select .

6. Select the Instance Name or Variable name representing the desired
replacement and click OK. The Replace With field is updated.

7. Click Apply  (or OK if you are through with the Search/Replace dialog box). All
occurrences of the selected reference are updated in your design.
6-8 Searching and Replacing References



Moving Component Text
You can reposition the component text, collectively, of any component with the Move
Component Text command. In addition, you can change the layer assignment of
individual pieces (Name, ID, Parameters) with the Change Component Text Layer
command.

To move component text:

1. Choose Edit  > Move > Move Component Text. You are prompted to enter a
reference location.

2. Click the component whose component text you want to move. You are
prompted to enter an offset location.

3. As you move the pointer, a ghost image representing the component text moves
with it. Click again to reposition the component text in the new location.

Hint The function key F5 initiates the Move Component Text command. Press
F5, click the component symbol, move the pointer and a ghost image of the
component text moves with it. Position the image in the desired location and
click again to place it there.

To change the component text layer:

1. Choose Insert  > Entry Layer  and select the desired destination layer from the
list.

2. Choose Edit  > Component > Change Component Text Layer .

3. Click any individual piece (Name, ID, Parameters) of component text. Its layer
is changed to the current entry layer and the component text immediately takes
on the characteristics of the current entry layer.

Note To change the layer on which component text is placed in advance of
placing components, use Options > Preferences > Component Text/Wire Label to
specify the desired layer for each type of component text. For details, refer to
the section, “Setting Component Text/Wire Label Options (in Advance)” on
page 9-15.
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Changing Component Text Attributes
You can change the attributes of existing component text through the Edit menu.
This command only affects existing component text. To establish attributes for all
subsequent component text, specify the desired settings through Options >
Preferences > Component Text/Wire Label. For details on changing text you have
added to your design, refer to “Editing Existing Text and Text Attributes” on
page 6-34.

To change component text attributes:

1. Select the components whose component text you want to edit.

2. Choose Edit > Component  > Component Text Attributes .

3. Make any desired changes to the text attributes.

• Font Type—All True Type fonts (Schematic only) installed on your system
are available. Select the desired font from the drop-down list.

Note On UNIX, if you want to add additional True Type fonts that were not
supplied with ADS, copy them to $HPEESOF_DIR/lib/fonts.

• Point—Represents the size of text in traditional units used in printing.

• Parameter Rows—The maximum number of rows of parameters before
another column is created.

9 rows maximum per column

12 rows maximum per column
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4. Click OK and the component text is immediately updated to reflect the changes.

Editing Symbol Pins
The Symbol Pin command enables you to change the name, number, and orientation
angle of existing pins.

To edit characteristics of existing pins:

1. Select a pin for editing and click Edit  > Symbol Pin . A dialog box appears.

2. Change any of the characteristics as desired and click Apply  (or click OK to
accept the changes and dismiss the dialog box).

For details on pin characteristics, refer to, “Adding Pins to Your Symbol” on
page 10-9.

Selecting and Deselecting Items
While you can always use the mouse to select and deselect items, several commands
found on the Select menu can assist you in selecting and deselecting items more
quickly.

Note Only objects on selectable layers can be selected for editing. If the select status
(Sel) of a given layer is disabled (through the Layer Editor dialog box), the select
commands have no effect on items on that layer.

Selecting/Deselecting All Items in the Drawing Area

To select all items in the drawing area:

Choose Select > Select All . Boxes are drawn around all items (that match the filter
selection) showing that they are currently selected.

To deselect all selected items that match the filter selection:

Choose Select  > Deselect All

or click anywhere inside the window, away from the selected objects.
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Selecting/Deselecting Items by Name

The commands Select By Name and Deselect By Name ignore the selection filters.

To select items by name:

1. Choose Select  > Select By Name . A dialog box appears. By default, a list of each
type of item in the design is displayed by Component Name. You can also view a
list of individual items by selecting by Instance Name. The following illustration
shows the listings of a simple network.

2. Select the desired list type and click the item(s) from the list that you want to
select. Click Apply . The specified items are selected in the design window.

If you have a very long list of components, you can use the wildcard field to filter
the list for items of the same type. For example, to list all transmission line
elements in the design, type TLIN (for a listing by Component Name) or TL*
(for a listing by Instance Name), and click Apply.

by Component Name by Instance Name
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To deselect items by name:

1. Choose Select > Deselect By Name and a dialog box appears. By default, a list of
each type of item selected in the design is displayed by Component Name. You
can also view a list of individual selected items by selecting by Instance Name.

2. Select the desired list type and click the item(s) from the list that you want to
deselect. Click Apply . The specified items are deselected in the design window.

Hint Alternatively, you can use the wildcard field to filter the list for selected
items of the same type. For example, to list all selected transmission lines in the
design, type TLIN (for a listing by Component Name) or TL* (for a listing by
Component ID), and click Apply.

Selecting/Deselecting With a Selection Window

You can include several objects at once for selection/deselection by enclosing them in
a selection window.

To select items using a selection window:

1. Position the pointer at one corner of a window that will enclose the desired
items, and press the left mouse button.

2. As you move the mouse, keeping the button depressed, a ghost image of the
selection window is drawn. Release the button to specify the opposite corner of
the window. All items totally enclosed within the selection window, that match
the filter selection, are now selected and are identified by taking on the Select
color chosen under Option > Preferences.

To deselect items using a selection window:

1. Choose Select  > Deselect Area .

2. Draw a selection window enclosing the items you want to deselect. All items in
the selection window (that match the filter selection) are deselected.
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Using the Vertices Filter

By default, the Vertices filter is turned on. This means that when you use a selection
window to encompass a portion of a given shape, the shape itself is not selected, but
rather only the vertices that fall within the selection window. To modify this behavior
so that individual vertices are not selected when you click an individual vertex or use
a selection window, turn off the Vertices filter through Options > Preferences > Select.

The illustration that follows shows what happens when the Vertices filter is on, you
draw a selection window enclosing parts of shapes on two different layers, and then
choose Edit > Move > Move Using Reference.

Hint When the Vertices filter is turned on, all selected vertices are identified by a
marker. You can change the size of this marker with the Selected Vertex option
through Options > Preferences > Select.
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Copying and Pasting Items
There are several Copy commands that enable you to copy and paste items in
different ways:

• Cut—Enables you to delete one or more items from one window, and paste in
another window.

• Copy—Enables you to copy items in a given design window and then paste
those items within the same design window or another design window. On the
PC only, it also copies the items to the Windows clipboard enabling you to paste
the item(s) as a graphic in a Windows application.

Hint To enable pasting the item using coordinates as the reference point,
choose Options > Preferences > Entry/Edit and select the option Show Set Paste
Origin Dialog for Copy command.

• Paste—Enables you to paste items that you previously cut or copied

Advanced Copy/Paste

• Copy Using Reference—Enables you to copy selected items, prompting for a
reference point and a destination point. The copied items can then be placed
anywhere within the same design window.

• Copy Relative—Enables you to copy items a specified distance from the
original items

• Copy To Layer—Enables you to copy items from one layer to another, within
the same design window

• Step And Repeat—Enables you to create a copy in the form of an array, with
the number of rows and columns you specify

To copy an item and paste it on the same layer:

1. Select the item(s).

2. Choose Edit  > Copy  (or click the Copy  button on the toolbar).

If you enabled the aforementioned option, Show Set Paste Origin Dialog for
Copy command, a dialog box appears enabling you to specify a reference point
for pasting. (The default reference point for pasting a component, or group of
components, is the first unconnected pin; when pasting shapes, the default
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reference point is the lower left corner.) Specify the X and Y coordinates. (These
are the positional coordinates identifying the position of the pointer in relation
to the total window.) Click OK.

3. Choose Edit > Paste from the desired design window. As you move the pointer, a
ghost image of the copied item moves with it.

4. Click again to specify the destination point.

To copy items using a reference point:

1. Select the item(s).

2. Choose Edit  > Advanced Copy/Paste  > Copy Using Reference .

3. You are prompted to enter a reference point. Click the point on the item (or
group of items) you want to use as a reference point for positioning the copy.

4. You are prompted to enter the offset location. Click to place the item(s) in the
desired location.

To create a copy in a specific position, relative to the selected item:

1. Select the item you want to copy.

2. Choose Edit  > Advanced Copy/Paste  > Copy Relative . A dialog box appears
enabling you to specify the distance from the original that the copy should be
placed.

The values you specify here are with respect to the units of the window, schem
or lay. For example, using the default inches of the Schematic window, if you
supply 1.0 for both X and Y, the reference point of the copied item will be placed
1 inch in the direction of X and 1 inch in the direction of Y from the reference
point of the original item.

Reference Point of Original

Reference Point of Copy

1 Inch in X

1 Inch in Y
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Hint The reference point on symbols is the first unconnected pin; the reference
point on shapes is the lower left corner.

3. Specify the desired units in X and Y and click Apply . A copy appears at the
specified location.

To copy from one layer and paste to another:

1. Select the item(s).

2. Choose Edit > Advanced Copy/Paste  > Copy To Layer .

3. Select the desired destination layer from the dialog box that appears and click
Apply .

Important Clicking Apply enables you to continue copying items from the
current layer to any other layer. If this is the only layer you want to copy the
selected shape to, then click Cancel; if you click OK, you will paste an additional
copy on the last layer selected.

The Step and Repeat command enables you to select an item or items you would like
multiple copies of and then specify how many copies and how many rows and/or
columns. This command also enables you to specify the distance between the items in
X and Y coordinates.

To copy items using the Step and Repeat command:

1. Select the item or items you want to copy.

2. Choose Edit  > Advanced Copy/Paste  > Step and Repeat . A dialog box appears.

3. By default, the current snap spacing is displayed as the X and Y spacing in this
dialog box. You can either accept the default spacing or change these numbers
by typing or clicking the up and down arrows.

4. Specify the number of rows and columns by typing or by clicking the up and
down arrows.

5. To automatically connect the pins of these items with one another, select the
option Connect overlapping pins and change the X or Y spacing field to 0, based
upon the component and the desired configuration.
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6. Click Apply . As you move the pointer into the drawing area, a ghost image of the
items moves with it. The lower left corner of the group serves as the reference
point for placement.

Hint The Step and Repeat command is a repeating command; you can place this
same configuration as many times as you like. Or you can change the configuration
each time and choose Apply before placing.

An illustration using a 2 × 4 array of BJTs is shown next.

During

After
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Moving Items
The quickest way to move objects is with the mouse:

1. Position the pointer over the object(s) you want to move.

Hint To move several items at once, select them using a selection window. To
add additional items to (or delete items from) a selected group, use Shift+Click.

2. Press the left mouse button, drag to the new location, and release. When
moving items using the drag method, the move must be more than the distance
specified as the Threshold for it to be recognized as a move.

This option (Options > Preferences > Entry/Edit) protects you from moving an
item unintentionally if you click to select it and accidentally move the pointer.

There are several additional Move commands that enable you to move components
and shapes in specific ways:

• Move Using Reference—Enables you to move selected items, prompting for a
reference point and a destination point

• Move Edge—Enables you to stretch the edge (between two vertices) of an
existing shape

Hint This movement can be restricted by setting the option Maintain adjacent
angles for Move Edge command. Refer to “Setting Entry/Edit Options” on
page 9-12.

• Move Relative—Enables you to move items by specifying coordinates, relative to
0,0

• Move & Disconnect—Breaks connections as you move selected components

• Move To Layer—Enables you to move items from one layer to another
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• Move Wire Endpoint—Enables you to manipulate an unconnected end of a wire

To move items specifying the reference and destination locations:

1. Select the item(s) you want to move.

2. Choose Edit  > Move > Move Using Reference . You are prompted to enter a
reference location.

3. Specify a reference point by clicking the point on the item (or group of items)
you want to use when specifying the destination. If you are moving component
symbols, clicking a pin as a reference point will help you align and connect the
items.

As you move the mouse, a ghost image of the selected objects follows. You are
prompted to enter an offset location.

4. Click again to place the items in the new location. Where applicable, wires are
redrawn maintaining connections.

Hint The manner in which wires are redrawn is controlled by the option
Reroute entire wire attached to moved component. For more information, refer to
the section, “Setting Entry/Edit Options” on page 9-12.

To move an item a specific amount, relative to the coordinates 0,0:

1. Select the item you want to move.

2. Choose Edit  > Move > Move Relative .

3. Specify the amount in X and the amount in Y (in inches) you want to move the
selected object and click Apply . The item is moved, using the default reference
point, by the specified amount.

Hint The default reference point of an item varies depending on the nature of
the item—for a component, it is pin 1; for a shape, it is the lower left corner.
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To move and disconnect:

1. Select the items you want to move.

2. Choose Edit > Move > Move & Disconnect . You are prompted to enter a reference
location.

3. Specify a reference point by clicking on or near the selected items. If you are
moving component symbols, clicking on a pin as the reference point will help
you align and connect the items.

As you move the mouse, a ghost image of the selected items follows. You are
prompted to enter an offset location.

4. Click again to place the items in the new location. The connections of the items
moved and the items left behind, are deleted. The interconnections among the
items moved, remain intact.

To move shapes or text to another layer:

1. Select the object you want to move.

Note Do not use the Move To Layer command to move ports to a different
layer; set the Layer parameter of the port to the desired layer.

2. Choose Edit > Move > Move To Layer . A dialog box appears with a list of currently
defined layers. Select the desired layer and click OK. The selected object
immediately takes on the color and other display characteristics of the selected
layer.

Note The following items can be moved to another layer using the
context-sensitive menu that appears when you right-click with the pointer
positioned over any of these items: Polygon, Polyline, Rectangle, Circle, Arc,
Text, Arrow, Wire, Construction Line, Path, Trace.
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Rotating Items
There are several commands to assist you in rotating components and shapes. The
Advanced Rotate commands are more often used for shapes than components, but
they do operate on components. For details on basic component rotation, refer to
“Rotating Components” on page 3-19.

Use any of the following methods to rotate components and shapes by a specified
increment:

• Click the Rotate By Increment  button on the toolbar.

• Press Ctrl+r .

• Choose Edit  > Rotate .

Each of these actions rotates the component n degrees clockwise, where n is the
increment specified in Options > Preferences > Entry/Edit > Rotation Increment
(angle). The default is 90 degrees.

The Mirror About X and Mirror About Y commands enable you to rotate objects
across an axis you specify.

Advanced Rotate

• Rotate Around Reference enables you to rotate components and shapes using
the mouse, specifying the reference point and the destination point.

• Rotate Relative enables you to rotate components and shapes by a specific
number of degrees, relative to the 0,0 coordinates of the drawing area.

• Set Rotation Angle rotates the selected item by the number of degrees specified,
in conjunction with the Rotate command. Note that setting this angle resets the
Rotation Increment (angle) in Options > Preferences > Entry/Edit.

Hint The Rotate and Rotate Around Reference commands can both be used on
either components or shapes, but the Rotate command is typically better for
working with components (the reference point is specified by the program)
whereas the Rotate Around Reference command is typically better for working
with shapes (you are prompted to specify the reference point around which to
rotate).
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Rotating Items Around a Specified Point

To rotate a selected object around a specified point:

1. Select the object.

2. Choose Edit  > Advanced Rotate > Rotate Around Reference . You are prompted to
enter a reference location.

3. Click once on the object at the point around which you want to rotate it. You are
prompted to enter the offset location. As you move the mouse, a ghost image of
the object moves with it. The pointer snaps in increments of the number of
degrees specified in the Rotation Increment (angle) field in the Preferences
dialog box (Options > Preferences > Entry/Edit).

4. Move the pointer until you are satisfied with the angle of rotation and click to
place it.

Rotating Items in Degrees, Relative to 0,0

To rotate a selected object by a specific number of degrees, relative to 0,0:

1. Select the object.

2. Choose Edit  > Advanced Rotate  > Rotate Relative .

3. In the dialog box that appears, enter the number of degrees by which you want
the object rotated.

Hints:

• Positive values rotate the object in a counterclockwise direction; negative
values rotate the object clockwise.

• The reference point for rotating shapes is the lower left corner.

• The reference point for rotating components is the left-most pin 1.

• Values entered here are rounded up or down to the nearest incremental value
in accordance with the number of degrees specified in the Rotation Increment
(angle) field in the Preferences dialog box
(Options > Preferences > Entry/Edit).
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Rotating Objects Across a Specified X- or Y-axis

To rotate selected objects across a specified X-axis (mirror):

1. Select the object.

2. Choose Edit  > Mirror About X . You are prompted to enter a point on the X-axis.

3. Click to specify the X-axis over which you want the object rotated. The selected
object is rotated.

To rotate selected objects across a specified Y-axis:

1. Select the object.

2. Choose Edit  > Mirror About Y . You are prompted to enter a point on the Y-axis.

3. Click to specify the Y-axis over which you want the object rotated. The selected
object is rotated.
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Rotating Objects Using an Absolute Angle

You can specify an absolute angle of rotation using the Set Rotation Angle command.
This command is used in conjunction with the Rotate command.

Note The angle you specify here becomes the new Rotation Increment (angle) in
Options > Preferences > Entry/Edit.

To rotate an object using an absolute rotation angle:

1. Select the object you want to rotate.

2. Choose Edit  > Advanced Rotate > Set Rotation Angle . The Set Rotation Angle
dialog box appears.

3. Specify the desired rotation angle in degrees.

4. Click Apply and click the Rotate  button. The object is rotated by that amount.
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Editing Shapes
There are several ways you can edit or manipulate various shapes after you have
added them to your design:

• “Converting Circles/Arcs to Simple Polygons” on page 6-26

• “Editing Polygons and Polylines” on page 6-28

• “Adding a New Vertex” on page 6-29

• “Moving a Vertex” on page 6-29

• “Deleting a Vertex” on page 6-30

• “Converting a Vertex to an Arc” on page 6-30

• “Converting a Vertex to a Mitered Edge” on page 6-31

• “Stretching a Wire or an Edge of a Shape” on page 6-32

• “Scaling an Object Using a Scaling Factor” on page 6-33

• “Scaling an Object Relative to the Design Window Units” on page 6-33

Converting Circles/Arcs to Simple Polygons

Circles and arcs can be converted to simple polygons allowing vertex editing. The
smoothness of the converted circle or arc is determined globally by the setting
Arc/Circle Resolution (degrees) in Options > Preferences > Entry/Edit. You can use
different settings for individual shapes using Edit > Modify > Arc or Edit > Modify >
Circle.

45°5°
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To convert a selected circle to a polygon:

Choose Edit  > Modify > Convert To Polygon .

To edit the characteristics of a selected circle:

1. Choose Edit  > Modify > Circle .

2. Select the desired mode for changing the radius:

• Absolute Radius—Select this option to scale a circle by an absolute amount.
For example, if your circle has a radius of .75 inches and you specify a Radius
of 1, the circle is scaled such that the radius is 1 inch.

• Delta Radius—Select this option to scale a circle by a relative amount. For
example, if your circle has a radius of .75 inches and you specify a Radius of
1, the circle is scaled such that the radius is 1.75 inches.

3. Specify the Radius, the amount by which you want the circle scaled.

4. Specify a new number for resolution, if desired. (See the illustration at the
beginning of this section.) Note: This changes the resolution for the selected
circle only, independent of the global setting made through the Preferences
dialog box, Options > Preferences > Entry/Edit.

5. Specify a different layer for the circle, if desired.

6. Click Apply  (or OK if you are done editing circles).

To edit the characteristics of a selected arc:

1. Specify a new number for resolution, if desired. (See the illustration at the
beginning of this section.) Note: This changes the resolution for the selected arc
only, independent of the global setting made through the Preferences dialog
box, Options > Preferences > Entry/Edit.

2. Specify a different layer for the arc, if desired.

3. Click Apply  (or OK if you are done editing arcs).
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Editing Polygons and Polylines

Several commands found on the Edit > Modify menu can assist you in editing
polygons and polylines.

• The Join command allows selected polylines with coincident endpoints to be
joined into a single polyline. If a closed shape results, the joined polylines are
converted to a polygon.

• The Break command converts a selected polygon into a single polyline.

• The Explode command converts selected polygons or polylines into two-point
polylines.

To join multiple polylines into a single polyline:

1. Select the individual polylines you want to join.

2. Choose Edit  > Modify  > Join . All coincident endpoints are joined. You can verify
what has been joined by clicking on the shape to select it and observing whether
or not the entire shape is selected.

To convert a polygon into a single polyline:

1. Select the polygon.

2. Choose Edit > Modify > Break . The starting and ending points of the polygon are
broken, identified by a marker, and you can now manipulate the shape as a
polyline.

Starting and
ending points
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To convert a polygon or polyline to individual, two-point line segments:

1. Select the polygon or polyline.

2. Choose Edit  > Modify  > Explode . All vertices are disconnected leaving you with
individual line segments that you can edit as needed.

Adding a New Vertex

To add a new vertex to a polygon or polyline:

1. Choose Edit  > Vertex > Add .

2. Click a point between two existing vertices, and move the pointer. A flexible line
is drawn between the vertices and the pointer.

3. Click again to specify the new vertex and the shape is redrawn.

Moving a Vertex

To move a vertex on a polygon or polyline to change its shape:

1. Click to select the vertex and drag the pointer in the desired direction. A flexible
line is drawn from the affected vertex to the pointer.

2. Click again to specify the new location of the vertex and the shape is redrawn.

Vertices
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Deleting a Vertex

To delete a vertex on a shape you have drawn, be sure the Vertices filter is turned on
(Options > Preferences > Select) and draw a selection window enclosing all vertices
you want to delete. Click the Delete button on the toolbar and the shape is redrawn
without those vertices.

Clicking anywhere on an arc deletes the arc and connects the former endpoints of the
arc with a straight line.

Converting a Vertex to an Arc

You can convert any vertex to an arc and specify the desired radius of the arc, with
respect to the units of the window.

To convert a vertex to an arc:

1. Choose Edit > Vertex > To Arc . You are prompted enter location of the vertex and a
dialog box appears.

2. Change the radius as desired and click Apply .

3. Click any vertex you want to convert to an arc. The vertex is redrawn
accordingly.

You can continue converting vertices in this manner using a different radius each
time if desired, but you must click Apply each time you change the radius. When you
are through making these changes, click OK to dismiss the dialog box.

Before During After

Before After
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Converting a Vertex to a Mitered Edge

You can convert any vertex to a mitered edge and specify the desired length of the
mitered edge, with respect to the units of the window.

To convert a vertex to a mitered edge:

1. Choose Edit  > Vertex > Miter. You are prompted enter location of the vertex and a
dialog box appears.

2. Change the miter length as desired and click Apply .

3. Click any vertex you want to convert to a mitered edge. The vertex is redrawn
accordingly.

You can continue converting vertices in this manner using a different miter length
each time if desired, but you must click Apply each time you change the length. When
you are through making these changes, click OK to dismiss the dialog box.

Before Arc with
.10 inch
radius

Arc with
.30 inch
radius

Arc with
.60 inch
radius

Miter Length

Before After

Snap Spacing = 0.125
Grid Display = 2
Miter Length = 0.5
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Stretching a Wire or an Edge of a Shape

The Move > Move Edge command enables you to change the shape of an existing wire,
or to redefine a shape by stretching an edge (a segment between two vertices).

To stretch an edge:

1. Choose Edit  > Move > Move Edge . You are prompted to enter the location of the
line.

2. Click the edge you want to stretch. As you move the pointer, a ghost image
moves with it and showing how the shape will be redrawn.

3. Click again to define the new shape.
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Scaling an Object Using a Scaling Factor

To scale an object using a scaling factor:

1. Choose Edit  > Scale/Oversize > Scale  and the Scale dialog box appears.

2. Enter scaling factors for both X and Y.

Scaling factors must be positive. Scaling factors greater than 1.0 increase the
size of objects, while factors less than 1.0 decrease the size of objects. To scale
the objects uniformly, enter the same scaling factor for both X and Y.

3. Click OK and you are prompted to enter a reference point on the object around
which to scale.

4. Click to specify the reference point and the object is scaled.

Scaling an Object Relative to the Design Window Units

There are two commands, Oversize and Copy & Oversize, that enable you to scale an
object with respect to the design units, for example, inches or mils. The Oversize
command replaces the original image with a scaled image. The Copy & Oversize
command places a copy of the selected object, using the size you specify, on the
current entry layer, preserving the original object.

To scale the object itself, in Schem or Layout units:

1. Select the object.

2. Choose Edit  > Scale/Oversize > Oversize  and a dialog box appears.

This field enables you to specify an amount by which the selected object should
be scaled (in all directions). A positive number increases the size of the object by
that amount; a negative number decreases the size of the object by that
amount.
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This field enables you to specify a cutoff angle for mitering corners. Any angle of
a polygon smaller than the specified cutoff angle is mitered. The default cutoff
angle is 45 degrees.

3. Make any necessary changes in the dialog box, and click OK.

To make a scaled copy of an object, in Schem or Layout units:

1. Select the object.

2. Choose Edit  > Scale/Oversize > Copy & Oversize  and a dialog box appears.

3. Specify the desired angle and click OK.

Editing Existing Text and Text Attributes
There are two methods of editing text you have added to your design: you can use the
on-screen editor or edit through a dialog box. Note: To edit text attributes, you must
use the dialog box method.

To edit text using the on-screen method:

1. Position the pointer over the text you want to edit and click. Notice the
following changes:

• The text takes on the color currently defined for Highlight in the Preferences
dialog box (Options > Preferences > Display).

• The status panel prompt changes to read, On-screen Text Editor: in progress

• A vertical bar (|) representing a text insertion cursor appears in the line of
text.

1.0” 1.2”

In this example, a 1 inch square
was oversized by 0.1 resulting in
a 1.2 inch square.
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2. Use the arrow keys or the mouse to reposition the cursor, as needed, near the
text you want to change. Use the backspace key, as necessary, to make your
changes.

3. When you are through, move the pointer away from the text and click once to
end the text editing command.

To edit text using the dialog box method:

1. Choose Edit  > Edit Text . The dialog box appears and you are prompted to enter
the location of the text.

2. Click to select the text you want to edit. The selected text appears in the dialog
box for editing. (If you type multiple lines as a block of text, that block appears.)

3. Make any desired changes to the text.

4. Make any desired changes to the text attributes.

• Font Type—Schematic only—All True Type fonts installed on your system
are available. Select the desired font from the drop-down list.

Note On UNIX, if you want to add additional True Type fonts that were not
supplied with ADS, copy them to $HPEESOF_DIR/lib/fonts.

• Point—Represents the size of text in traditional units used in printing.

• Layer—Enables you to select a different layer for the text.

• Placement Angle—Enables you to rotate existing text by specifying an angle
in degrees. Positive values rotate the text counterclockwise; negative values
rotate it clockwise.

• Non-rotating (when in hierarchy)—Select this option to prevent text on a
symbol or design from being rotated when the symbol is rotated.

• Justification, Horizontal—This setting represents two types of justification:
one is how individual lines of text in a block of text are aligned with one
another; the second is how an individual line of text or block of text is
positioned horizontally, relative to the reference point you specified to begin
typing the text.

• Justification, Vertical—This setting aligns a string or block of text vertically,
relative to the reference point you specified to begin typing the text.
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5. Click Apply . Changes to the selected text are reflected immediately in the
drawing area.

You can continue to select text and make changes, but you must click Apply for
each set of changes for those changes to take effect.

6. When you are through making changes to text, click OK to dismiss the dialog
box.

Editing Wire/Pin Label Attributes
To change the color, size, and font of existing wire labels, choose one of the following
methods:

• Use Edit > Wire/Pin Label > Wire/Pin Label Attributes

• Double-click the wire label to display the dialog box

• Right-click and select Wire/Pin Label Attributes from the pop-up menu

Forcing Objects Back onto the Grid
If an object is offset from the current grid spacing, you can force it back to the nearest
grid point with the Modify > Force to Grid command. If the selected object is an item
with pins, pin 1 is forced to the nearest grid point.

To force an object back onto the grid:

1. Select the object.

2. Choose Edit  > Modify  > Force to Grid . The selected object snaps to the grid.
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Chapter 7: Annotating Designs
You can annotate your schematic by adding a drawing sheet, inserting a variety of
shapes, and adding text (including system variables such as date, time, etc.). For
details, refer to the following topics:

• “Adding a Drawing Sheet” on page 7-1

• “Adding Text” on page 7-2

• “Drawing Shapes” on page 7-4

Adding a Drawing Sheet
If you want to use a drawing sheet that contains any constant information or
graphics, such as a company logo, you will probably want to save it as a template
enabling you to insert it in any design where it is needed.

To create a drawing sheet:

1. Choose File  > New Design .

2. Supply a name for the file.

3. Choose Insert  > Component  > Component Library .

4. Select the Drawing Formats  category.

5. Select the appropriate drawing sheet size, for example, FORMATA .

6. Click OK and move the pointer into the drawing area.

7. Note that the lower left corner serves as the reference point. Position the image
of the drawing sheet as required and click to place it there.

To move the drawing sheet after placing it, you must be able to select it, and by
default, the Drawing Format filter is turned off. To turn it on, choose Options >
Preferences > Select and enable the Drawing Format option. If you do enable this
filter, you will probably want to disable it again after moving the drawing sheet,
before beginning your design work.
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Hint If you want to reposition the lower left corner of the drawing sheet at the
coordinates 0,0 (to assist in placing items using exact measurements), you can use
the Set Origin command. Choose Edit > Modify > Set Origin and click the lower left
corner of the drawing sheet. Use View All if necessary to bring the entire sheet into
view.

8. Add all desired information.

9. Choose Save Design As Template to make it available for insertion in any design.

Adding Text
Once you have established the desired text attributes, you can add text to your design
using the Text command on the Insert menu or the Text button on the toolbar. Prior
to adding text, you should change the current entry layer to text1 (or a text layer you
have created) and place all text on that layer. For details on which type of objects are
placed on which layers, refer to the section, “Specifying Layer Definitions” on
page 9-22.

To change the current entry layer:

Choose Insert > Entry Layer  > text1 .

Any text you add, or object you draw, will now be placed on the text1 layer until you
change to another entry layer. Text will take on the characteristics defined in the
Preferences dialog box (except for color, which is defined through the Layer Editor).
For details on changing attributes of text:

• Prior to adding it to the drawing area, refer to the section, “Setting Text Options
(in Advance)” on page 9-17.

• After adding it to the drawing area, refer to the section, “Editing Existing Text
and Text Attributes” on page 6-34.

To add text to your design:

1. Choose Insert > Text . The status panel prompt changes to read, New_Text: Enter
location for new text.

2. Position your cursor in the desired location, click once, and begin typing.
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If necessary, use the arrow keys, the backspace and spacebar to make changes.
(You can drag the mouse across text to highlight it and type over it or use the
spacebar or backspace to delete it.) To continue the text on the next line, press
Enter and continue typing.

• To type text in another location, click in that location and begin typing.

• To stop the text command, press Esc  or move the pointer away from the new
text and click once—to signify the end of that text block—then click the End
Command button.

Hint Context-sensitive editing is available for text. Position the pointer over
the text, right click, and select Edit Text from the pop-up menu.

Using Variables to Display Design and System Information

You can add any of the following variables to your design to display the type of
information indicated:

To add variables to your text:

1. Choose Insert  > Text .

2. Click to begin typing text and include any of the variables shown above as
desired. For example:

@dname = Design name

@pname = Full path to design

@ddate = Date design was last saved

@dtime = Time design was last saved

@cdate = Current date

@ctime = Current time

@SIM_HOST = Name of machine hosting the simulation

@SIM_DDS = Name of the simulation data set

This version of @dname was last
saved on @ddate at @dtime.
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3. Press Esc  to stop the Text command and the variables are replaced by their
equivalents.

Drawing Shapes
The Insert menu contains commands that enable you to draw a variety of shapes and
lines to help annotate your schematic. Select End Command from the pop-up menu
(or click the End Command toolbar button, or press Esc) during execution of any
draw command, to terminate the command and remove the partial shape.

Hints:

• Several shapes that require you to specify multiple points (such as polygons,
polylines, arcs) allow you to specify the last point by pressing the space bar.

• Context-sensitive editing is available for several shapes (rectangle, polygons,
polylines) with respect to changing the layer on which the shape is drawn.
Position the pointer over the shape, right click, and select the layer command
from the pop-up menu.

• You can change the thickness of the lines of the following shapes drawn in the
Schematic window (schematic view): polygons, polylines, rectangles, circles,
arrows, and all arcs. (Edit > Modify > Line Thickness)

• You can set (in advance) the thickness of the lines of the following shapes drawn
in the Schematic window (symbol view): polygon, polyline, rectangle, circle. To
edit line thickness subsequently, choose Edit > Modify > Line Thickness.

To draw a rectangle (or square):

1. Choose Insert  > Shape  > Rectangle  (or click the Rectangle  button). You are
prompted to enter the first corner.

2. Click to specify the first corner. You are prompted to enter the second corner.

3. As you move the mouse, a flexible box stretches from the anchor point to the
position of the mouse, expanding and contracting as you move. When you are
satisfied with the size, click to finish.
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To draw a polygon:

1. Choose Insert  > Shape  > Polygon  (or click on the Polygon button). You are
prompted to enter a vertex.

2. Click to anchor the starting point of the polygon.

3. Move the cursor to the position where you want the first line segment to end,
and click. A line appears between the two points.

• At any time during entry of a polygon, you can choose one of the Arc
commands to include an arc in your polygon.

• You can use the Undo Vertex command to backtrack to the previous point
anytime you want to erase the segment or arc you have just drawn.

Hint If you want all line segments to be drawn perfectly horizontal or vertical,
choose Options > Preferences > Entry/Edit Mode and check Orthogonal.

4. Continue in this manner until you are ready to draw the final line segment(s)
completing your polygon.

• To draw all but the last line segment, double-click or press the space bar
while the pointer is still positioned over the last vertex.

• To draw all but the last two line segments, move the pointer so that it is
positioned over the next vertex, and double-click or press the space bar.

The polygon is automatically closed. The illustration demonstrates the latter
method.

To draw a polyline (a series of connected line segments):

1. Choose Insert  > Shape  > Polyline  (or click on the Polyline button). You are
prompted to enter a vertex.

2. Click to anchor the starting point of the polyline.

click

click

click

Position your pointer (using the mouse
or arrow keys) at the point identifying the
missing endpoint for the final line
segments and press the space bar. The
last two segments are drawn.
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3. Move the cursor to the position where you want the first line segment to end,
and click. A line appears between the two points.

• At any time during entry of a polyline, you can choose one of the Arc
commands to include an arc in your polyline.

• You can use the Undo Vertex command to backtrack to the previous point
anytime you want to erase the segment or arc you have just drawn.

4. When you have drawn the final line segment, double-click or press the space
bar to end the Polyline command.

To draw an Arc:

1. Choose Insert  > Shape  > Arc (clockwise  or counterclockwise) . You are prompted
Enter the start point of the arc.

2. Move the cursor into the drawing area and click left to specify the start point of
the arc. You are prompted Enter the arc center.

3. Click to specify the center point of the arc. A flexible arc appears as you move
your cursor. You are prompted Enter the ending point of the arc.

4. Click to specify the end point. If you are through drawing arcs, click End
Command .

Hint Context-sensitive editing is available for arcs. Position the pointer over
the arc, right click, and select Edit Arc from the pop-up menu.

You can also draw an arc by specifying the start point, end point, and circumference.
To draw an arc in this manner:

1. Choose Insert  > Shape  > Arc (start, end, circumference) . You are prompted Start
pt of arc.

Start angle
(0 degrees)

End angle
(135 degrees)

Center point
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2. Move the pointer into the drawing area and click left to specify the start point of
the arc. You are prompted End pt of arc.

3. Click to specify the end point of the arc. You are prompted Circ point of arc. A
flexible arc appears as you move the pointer.

4. Click to specify the final size of the arc.

To draw a circle:

1. Choose Circle  from the toolbar or from the Insert menu. You are prompted to
enter the circle center.

2. Click to specify the center point.

3. Drag the mouse until the circle is the desired size and click.

Hint Context-sensitive editing is available for circles. Position the pointer over
the circle, right click, and select Edit Circle from the pop-up menu.

To draw an arrow:

1. Choose Insert  > Arrow . You are prompted to enter the first point. In the dialog
box that appears, set the following options as needed:

• Number of Arrowheads

• Polygon arrowhead—select to draw arrowhead as a polygon

• Arrowhead length in schematic units:

• Arrowhead width in schematic units:

One Two

Polyline arrowhead Polygon arrowhead

Arrowhead width increased (from default of 0.08) to 0.125

Arrowhead length decreased (from default of 0.25) to 0.125
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Hint To restore the default values/options, click Default.

2. Click Apply .

3. Click to specify the first point of the arrow. You are prompted to enter the
second point.

4. Move the pointer as needed to identify the endpoint of the line segment and
click.

To change the line thickness of an existing shape:

1. Select the shape.

2. Choose Edit  > Modify  > Line Thickness .

3. Select the desired thickness and click OK.

Drawing Shapes Using Specific Coordinates

The Coordinate Entry command enables you to draw a variety of shapes by specifying
coordinates for each vertex.

To use the coordinate entry method for drawing:

1. Choose Insert  > Coordinate Entry  and a dialog box appears. Move the dialog box
so that the desired design window is visible.

2. Choose the required drawing or editing command.

3. Enter the X and Y coordinates for the first point.

You can enter coordinates by typing them directly in the fields labeled X and Y,
or you can use the up and down arrows of the X Increment and Y Increment
fields to increase or decrease the values of the X and Y fields. By default, the X
and Y Increment fields are set to the current snap spacing, but you can use any
increment that meets your design needs.
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Hint If using the Rectangle command, specify coordinates for two corners
opposite each other.

4. Click Apply .

5. Continue specifying all desired points, clicking Apply for each.

Hint When drawing polygons with coordinate entry, click Apply for the final segment
of the shape to be drawn automatically.

0,0

2,2
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Chapter 8: Simulating and Viewing Results
The information presented here explains only the basics of simulating and viewing
results in the Advanced Design System. Simulation is described in detail in the
Circuit Simulation and Agilent Ptolemy Simulation manuals. Viewing results is
described in detail in the Data Display manual.

All simulations are performed from the Schematic window. If you are simulating
typical microwave/RF circuits, you may want to set up your simulation using the
Smart Simulation Wizard; for other types of simulation you will probably need to set
them up manually. Refer to one of the following sections, based on your needs:

• “Using the Smart Simulation Wizard” on page 8-1

• “Setting up a Simulation Manually” on page 8-6

Using the Smart Simulation Wizard
The Smart Simulation Wizard is provided to assist new ADS users, as well as those
who use it infrequently, in setting up simulations for typical microwave/RF circuits.
The wizard will guide you through the process of:

• Selecting an application-specific design (or your own design)

• Selecting predefined simulation setups

• Specifying simulation settings (frequency, bias, etc.)

The wizard then configures the sources and simulation controls and begins the
simulation(s). When multiple simulations—requiring different configurations—are
requested, the wizard automatically reconfigures the subnetwork for the appropriate
sources, terminations, and simulation controls. When the simulation is finished,
simply click to display the results. Note that although basic simulation setups are
provided with the various simulator licenses, additional simulation setups require
specific DesignGuide licenses. These differences are identified in the wizard.

To invoke the Smart Simulation Wizard:

From the Schematic window in the project of interest, choose Simulate  >
Smart Simulation Wizard .

Step 1 prompts you to select one of several different application types.
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Step 2 prompts you to select one of the following design types:

• A sample design provided by the Smart Simulation Wizard

• An existing ADS subnetwork design

• A new subnetwork design

Step 3 varies based on the choice made in Step 2. You are prompted to select an
existing design, enter a name for a new design, or select one of the following
application-specific designs.

Device Characterization

BJT Characterization

FET Characterization

MOSFET Characterization

Amplifier

Amplifier

Mixer

Single-Ended Mixer

Linear Circuit

Linear 2-port

Linear 4-port
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Device Characterization

BJT Characterization

NPN BJT NPN BJT model, biased with IBB = 60 uA, VCE = 2.7V.

PNP BJT PNP BJT model, biased with IBB = -60 uA, VCE = -2.7V.

FET Characterization

GaAs MESFET Statz Model Statz FET model for device FLC301XP.

EEFET Model EEFET3 FET model for device FLC081XP.

GaAs MESFET Model Basic MESFET model.

HEMT Model Basic HEMT model.

JFET Model Basic JFET model.

MOSFET Characterization

NMOSFET Model Basic BSIM3 model for NMOSFET.
Width = 1e-5, Length = 2.5e-7.

PMOSFET Model Basic BSIM3 model for PMOSFET.
Width = 1e-5, Length = 2.5e-7.

Amplifier

Amplifier

MOSFET Power Amplifier Power Amplifier with a single MOSFET, 14 dB gain between
750 - 800 MHz.

BJT Power Amplifier Power amplifier with 8 BJTs, 12 dB gain at 2 GHz.

Behavioral Model Amplifier Ideal amplifier with Behavioral model. Gain, S-parameters
and noise figure can be specified directly.

Mixer

Single-Ended Mixer

MESFET Gilbert Cell Mixer MESFET Gilbert Cell Mixer internally matched to 50 ohm at
900 MHz.

FET Mixer Single-ended MOSFET Mixer.

BJT Gilbert Cell Mixer Single-ended BJT Gilbert Cell Mixer.

Behavioral Model Mixer Ideal Mixer Behavioral model.
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Step 4/Step 5 varies based on your previous choices. For an existing ADS design, you
are prompted to identify the port type for each port in your design (input, output,
base, collector, etc.). For all design types, the wizard then describes how to view the
network associated with the schematic symbol and how to access the simulation
setup portion of the wizard.

When you click Finish, the top-level design appears, and you will see that it consists
of two main parts: a schematic symbol representing the subnetwork to be simulated
and a simulation setup symbol.

Note If working with a sample design, the top-level and subnetwork designs, as well
as the related data displays, are copied to the current project. If you select an existing
design from a different project (via an Included project), that design is copied to the
current project.

• Schematic symbol—A schematic symbol representing the subnetwork to be
simulated, is visually connected to the simulation setup symbol. Push into the
symbol to view, edit, or create the subnetwork.

When you push into most of the schematic symbols, you will notice that the
subnetwork designs contain cautions against deleting or renumbering of ports.

• Simulation setup symbol—The simulation setup symbol is similar to the one
shown next. Double-click (or right-click and select the first choice from the
pop-up menu) to specify the simulation setup details.

Linear Circuit

Linear 2-port

Simple Lowpass Filter Simple LC lowpass filter with cut-off frequency at 10 MHz.

Microstrip Bandpass Filter Simple bandpass filter composed of two concatenated
microstrip subnetworks.
Center frequency: 12 GHz. 10% bandwidth.

S-Parameter Data File Two-port subcircuit defined by an S-parameter file
nec71000.dat.

Linear FET Linear FET model for small-signal modeling.

Linear 4-port

Linear FET Modeling Matching a linear FET model to measured S-parameters.
Measured data file nec71000.s2p.
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Each simulation is marked with one of two icons, as shown next.

You can highlight any selected simulation (from the list box on the right) and
click Show Schematic to view the design containing the simulation setup.

From the Simulation Settings tab you can specify the desired settings for the
simulation parameters such as frequency, power, bias, etc. When you have
selected all the desired simulations and specified the desired settings, click
Simulate to proceed. The progress window appears and is dynamically updated

Only the appropriate simulator license is required for this simulation

A specific DesignGuide license is required, in addition
to the appropriate simulator license, for this simulation
Using the Smart Simulation Wizard 8-5



Simulating and Viewing Results
to indicate which simulations have completed and which remain. When all
simulations are complete click Display Results to view the data displays. Note
that the results for each simulation are displayed on separate pages, which can
be accessed individually from the Page menu.

Hint After simulating a given design once, you can display the results from the
previous simulation via the pop-up menu. Position the pointer over the simulation
setup symbol, click right, and select Display Data from Last Simulation.

Setting up a Simulation Manually
These are the basic steps for setting up a simulation:

• Add the required circuit sources (Analog/RF designs only)

• Specify points for collecting data

• Place the appropriate simulation control item(s) in your design

• Specify a name for the dataset generated by your simulation

Optionally, you can establish a name for the resulting data display. You can also
select a remote machine for simulating on.

If using the Load Sharing Facility (LSF) utility, you can break up a sweep and run
the simulation on multiple machines, in parallel. You can also use this utility to select
the fastest available machine.
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Placing Simulation Control Items in Your Design

Simulating with the Advanced Design System is accomplished by placing simulation
control items in the Schematic window along with your design (no connection
required). The control items available vary with the current design type. Some of the
categories of control items for each design type are listed next.

Analog/RF Designs

• Frequency-Domain Sources

• Time-Domain Sources

• Noise Controlled Sources

• Modulated Sources

• DC Simulation

• AC Simulation

• S-Parameter Simulation

• Harmonic Balance Simulation

• Large-Signal S-parameter (LSSP) Simulation

• Gain Compression (XDB) Simulation

• Envelope Simulation

• Transient Simulation

Digital Signal Processing Designs

• Data Flow Controller

• Sweep Plan

• Parameter Sweep

• Performance Optimization Controller

For Digital Signal Processing designs, you must also connect a Sink component or an
Interactive Controls and Displays component to the output of your schematic. A Sink
collects data or performs a measurement. The data can then be displayed via the
Data Display window.
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Controlling Simulation Data

All data produced by a given simulation is stored collectively as a dataset. Every
dataset has a name associated with it. You can assign a name prior to simulating or
you can accept the default dataset name. The default name is the name of the current
design, with the extension .ds automatically appended.

Note If you accept the default dataset name and perform multiple simulations, the
dataset will be overwritten each time. To collect separate datasets for each
simulation, specify a unique name (for the data set you are about to create) prior to
each simulation.

For details on selectively sending data to the dataset, refer to “Selectively Saving and
Controlling Simulation Data” on page 1-15 in the Circuit Simulation manual.

For information regarding the naming of datasets, refer to “Limitations” on page 1-23
(under Naming Conventions).

To specify a dataset name prior to simulating:

1. Choose Simulate  > Simulation Setup .

2. Supply a name in the Dataset field. (Click Browse to view existing dataset
names in the current project.)

Hint Datasets are stored in the /data subdirectory of a project. This means
that you should provide unique names for the datasets that will be generated
from the different designs in the same project directory.

3. Supply a name in the Data Display field, or accept the default name.

Data Display—The name you specify here will be the title of the Data Display
window that is opened, and the default filename should you choose Save As
(from the Data Display window). The default name shown is based on the
current design name.
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Open Data Display when simulation completes—If enabled, a Data Display
window will open automatically when the simulation is complete. For details
refer to the section, “Automatically Displaying Simulation Data” on page 8-10.

4. Select the desired Simulation Mode:

• To simulate on a single machine, select Single Host . Select the Single tab and
select the desired Simulation Host Type, Local or Remote. If you select
Remote, you can then select Specify to choose a specific server by name, or
select Find Fastest and let the Load Sharing Facility (LSF) choose the most
suitable remote host.

• To break up your sweep and simulate individual parts simultaneously on
remote machines, select Parallel Hosts . Select the desired Sweep Variable
from the drop-down list and set the desired Start, Stop and Step values.
Individual sweep points are run on each machine and the results are
combined into a single dataset on the local machine.

• To break up a signal processing BER simulation over multiple hosts, select
the Parallel BER option from the Parallel tab and, in the Number of Partitions
field, specify the number of hosts to be used. This feature is only available
when berMC or berMC4 components are used. For more information, refer to
the documentation of these components in the Signal Processing Components
manual.

Taking advantage of the LSF utility requires the installation and configuration
of that software on the necessary files/machines. For details on setting up your
remote and local machines for remote processing, refer to the appropriate
appendices:

• Appendix E, Using Remote Simulation in the Installation on PC Systems
manual

• Appendix D, Using Remote Simulation in the Installation on UNIX Systems
manual.

5. Click Simulate .
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Automatically Displaying Simulation Data

When setting up your simulation (Simulate > Simulation Setup, in the Schematic
window), you can enable an automatic display of your results.

Select the Open Data Display when simulation completes option to force a Data
Display window to open automatically when the simulation is complete. The data
display that appears in that window depends on the simulation setup and the status
of display templates:

• If you specify the name of an existing display to open, that display is opened.

• If you specify a new name, then a blank Data Display window opens.

• If one or more data display templates are associated with the current design,
then the Data Display window opens and inserts each template on its own page.
A data display template can be associated with a design in one of two ways:

• By default, if your design includes a supplied schematic template, and a data
display template is associated with that schematic template.

• Explicitly, if you create your own data display template (File > Save As
Template in the Data Display window) and associate that template with your
design via the DisplayTemplate component. (Refer to the next section, “Using
a DisplayTemplate Component” on page 8-11.)

• If none of the above criteria are met, but you select the option, then a blank
Data Display window opens.
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Using a DisplayTemplate Component

The DisplayTemplate component (available from most simulation libraries) enables
you to associate one or more data display templates with a given design. (If you
include one of the supplied schematic templates in your design, it most likely has a
data display template associated with it.)

The starting point of this procedure assumes you have already created a data display
file for use as a template, by setting up the Data Display window as desired and
choosing File > Save As Template.

To associate a data display template with the current design:

1. Place a DisplayTemplate component in the Schematic window.

2. Select String and Reference  as the Parameter Entry Mode.

3. Enter the name of the template (the filename you supplied in the Data Display
window) and click Add .

Hint You can specify multiple templates for the same data display and
subsequently access them from the Page menu).

4. When you are through specifying display templates for the current design, click
OK.
Setting up a Simulation Manually 8-11



Simulating and Viewing Results
Manually Displaying Simulation Data

If you do no want the Data Display window to open automatically, disable the option
Open Data Display when simulation completes in the Simulation Setup dialog box.

To open a new window for displaying and manipulating data:

Choose Window  > New Data Display  from the Main, Schematic, or Layout windows.

To save a graph for later viewing/manipulating:

Choose File  > Save.

To save a graph for use as a template:

Choose File  > Save As Template .

To open a previously saved data display:

1. Choose Window  > Open Data Display  from the Main, Schematic, or Layout
windows. In the dialog box that appears, the path is automatically set to the
current project directory and the filter displays all saved graphs (*.dds).

2. Double-click the graph you want to open or select it and click OK.

For details on working with simulation data, refer to the Data Display manual.

Simulating
To simulate using current data set name:

Choose Simulate  > Simulate . The Status window appears and displays messages
about the simulation as it progresses. When the simulation is complete, it will
display the message, Simulation finished.

To highlight a specific node on your schematic:

Choose Simulate  > Highlight Node . The list box that appears displays a list of all
nodes on the schematic. Select any node name from the list and that node is
highlighted on the schematic. (The highlight color can be changed through
Options > Preferences > Display > Highlight).

To clear one or more highlights, choose Simulate  > Clear Highlighting .
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Excluding Individual Items from the Simulation

You can deactivate items in the Schematic window, excluding them from a simulation
without deleting them from your design.

To deactivate an item:

1. Click the Deactivate  button on the toolbar or choose Edit  > Component >
Deactivate .

2. Click the item or items you want to deactivate. A box with an X drawn through
it appears over each item.

Hint The color of this identifying box is the Highlight color defined through
Options > Preferences > Display.

To activate a deactivated item:

1. Click the Activate  button on the toolbar or choose Edit  > Item > Activate .

2. Click the item or items you want to activate. The box disappears and theses
items are considered in a subsequent simulation.

Clearing Highlights from Items Causing Simulation Errors

When an error occurs during simulation, a box is drawn around each item causing an
error. To clear all highlights, choose the Clear Highlighting command from the View
menu in the appropriate window.

Hint The color of this identifying box is the Highlight color defined through
Options > Preferences > Display.
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Simulating and Viewing Results
Tuning

Advanced Design System’s tuning capability enables you to change one or more
design parameter values and quickly see the effect on the output without
resimulating the entire design. Multiple plots generated from various tuning trials
can be overlaid in the Data Display window. This can help you find the best results
and the most sensitive components or parameters more easily.

Basic tuning consists of the following steps:

1. Build the design you want to tune.

2. Simulate your design.

3. Set up the Data Display window to display the results you want from your
design.

4. Choose Simulate  > Tuning  or click the Tuning icon (tuning fork) on the
toolbar. When the initial analysis is complete, the Tune Control dialog
box appears.

5. Select the parameter you want to tune by clicking it on the schematic.

6. Select one of the following tune analysis modes from the Perform Analysis
drop-down list:

• After each change

• After pressing Tune

• While slider is moving

7. Change the tunable parameter by moving the slider, clicking the left/right
arrows, or typing the value in the box. Depending on the selected tuning mode,
your results will be updated as soon as the new simulation is completed.
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Chapter 9: Setting Design Environment
Preferences
You can easily customize many aspects of design entry and display through the
Preferences and Layer Editor dialog boxes accessed through the Options menu. Some
of the options set here serve as defaults and can be changed on an individual basis
through the Edit menu.

Some of the things you can customize are:

• The default settings for color of the grid, pins/tees, highlighted and selected
objects, and the background and foreground of the design windows

• The sizes of pins/tees, the selection pick box, and the size of the marker drawn
when you have the Vertices filter turned on and select the vertices of objects in
the drawing area

• The display of the Component Parameters dialog box, coordinate readouts, pin
names and numbers, and pins/tees

When you change the settings in this dialog box and click Apply, the design window is
updated with the changes, and these changes will serve as defaults for all designs in
this project. For details on saving changes to a file so that specific preferences can be
associated with specific designs, refer to, “Saving and Reading Preference Files” on
page 9-20.
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Setting Design Environment Preferences
Specifying Design Entry and Display Preferences
To change design entry and display preferences:

Choose Options  > Preferences  in any design window.

Many options relating to the size of an item displayed on the screen offer a choice of
specifying the size in terms of screen pixels or schem units (or layout units, in the
Layout window).

screen pixels—Use this setting to specify sizes in terms of pixels on the screen. For
example, if you set 10 screen pixels for the Pick Box size, the pick region will be 10
pixels by 10 pixels.

schem units—Use this setting to specify sizes in terms of inches, in the Schematic
window. In the Layout window, select layout units to specify a size with respect to
the design units of the Layout window.

Click to see additional tabs
9-2 Specifying Design Entry and Display Preferences



Setting Select Options

The Select options can assist you in editing your designs by modifying how items are
selected.

Using Selection Filters

Selection filters enable you to specify types of items you want included in or excluded
from your selections. For example, if you turn on only Components and Wires, none of
the other types of items in the drawing area will be available for selection. By default,
all types of items are turned on except Drawing Format.

To change the default settings:

Select the types of items you want available for selection, and deselect the types of
items you want excluded from selection.

Hints:

• Any item type that is turned off will not be selected when you click it
individually, attempt to enclose it in a selection window, or choose the Select All
command.

• Only the Select By Name and Deselect By Name commands ignore the selection
filters.

• To enable most filters, choose Set All to quickly select all filters, then deselect
those you want excluded.

• To disable most filters, choose Clear All to quickly deselect all filters, then select
those you want included.
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Changing the Select Mode for Polygons

• Choose By Edge to be able to select polygons by clicking on the outer edge.

• Choose Inside if you want to be able to select polygons by clicking anywhere
inside the shape.

Changing the Pick Box Size

The pick box is a region you define that determines how close your cross cursor must
be to an object before clicking will select that object. You can choose a size in
schem/layout units, relative to the units of the design window, or you can choose a
size in screen pixels.

Figure 9-1 shows an example of the region defined by a pick box specified in inches.

Figure 9-1. Pick region based on schem Units

In Figure 9-1, the pick box size was set to 0.25 inch (the same as the default grid
display).
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When you define the region using n screen pixels, the pick region is a square of n
pixels × n pixels, centered around the spot where you click. For example, if you specify
20, the pick region extends 10 pixels beyond the spot where you click, horizontally
and vertically.

Hint  It may be necessary to use a very small number in designs where items are
tightly spaced.

Changing the Selected Vertex Size

When the Vertices filter is enabled, and you select a vertex (or vertices), a marker
appears identifying each selected vertex. You can change the size of the marker from
the Select tab of the Preferences dialog box.

To change the size of the marker that identifies selected vertices:

1. Choose the desired units from the drop-down Units list box.

2. Change the value as desired.

Changing the Select Color

When objects in the drawing area are selected, a box is drawn around them
identifying them as being selected. By default, this highlight color is black, but you
can change it from the Select tab of the Preferences dialog box. This color is also the
color of the marker that identifies selected vertices.
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Setting Design Environment Preferences
Setting Grid/Snap Options

The display grid and cursor snap features are provided to assist you in creating and
editing your designs more quickly and accurately.

By default, snap mode is turned on and the cursor snaps to pins and to the grid
defined by the snap spacing. The default snap spacing is 0.125 inch (in the Schematic
window) with a display factor of 2. This means that although the cursor snaps every
0.125 inch, the dots only appear every 0.25 inch. If you set the display to anything
smaller than 0.25 inch, the grid will be too dense to display without zooming in on it.

Hint The default component symbols have been created uniformly, in 0.125-inch
increments. Thus, if you keep the default settings while creating your design, you
should be able to connect all symbols with minimal effort.

Display

Spacing

Snap Grid Distance (in schem units) represents the snap spacing, where the number
you specify determines the distance (in design units, or inches) between the points
to which the cursor snaps.

Snap Grid per Display Grid represents the spacing between the dots (or lines) on the
display grid in terms of a factor of the snap spacing. The smaller the number, the
finer the grid.

Select Dots or Lines to display a visible grid made up of dots or lines

Select None if you want no visible grid

Click to access a palette for choosing a grid color
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Hint If the display factor you specify makes the grid too dense to display, it is
invisible unless you zoom in. To see the grid without zooming, choose a larger
display factor.

Snap Distance - all other modes  represents how close to an object the cursor must
be before it will snap to that object.

Active Snap Modes

This section enables you to restrict the manner in which the cursor snaps. You can
activate any combination of choices. If you select more than one, the cursor snaps
to the nearest one. By default, Grid and Pin are turned on to assist you in quickly
creating schematics.

• Enable Snap —Toggles snap mode on and off. You can also toggle snap mode on
and off from the Options menu itself (Snap Enabled).

To select all or most snap modes:

Click Set All  and then deselect those you want excluded.

To deselect all or most snap modes:

Click Clear All  and then select those you want included.

Hint All snap modes (except Grid) rely on the cursor being within the distance
specified as Snap Distance (Diameter).

• Pin—When the pin of an object you are positioning gets within the snap
distance of a pin on an existing object, the pins are automatically connected. Pin
snapping takes priority over all other snap modes.
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Setting Design Environment Preferences
Note Angle Snapping automatically occurs when only Pin snapping is enabled
and you place a part so that the pin at the cursor connects to an existing part.
The placed part rotates so that it properly aligns with the connected part.

• Vertex —When the object you are positioning gets within the snap distance of a
vertex on an existing object, the object you are positioning is automatically
placed at that vertex. This snap mode is especially helpful if something was
originally drawn or placed on the grid and then moved off, or the grid spacing
has been changed.

• Grid —The cursor snaps to points on the grid defined by snap spacing. All other
snap modes have priority over grid snap mode.

Hint The Reset button returns settings to their defaults (if you have not yet
clicked Apply).
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Setting Placement Options

Set the following options—related to placing components in the drawing area—in a
manner that suits the way you work:

Defining the Placement Mode for Schematic and Layout Representations

When you are working with both schematic and layout representations, you can
select the simultaneous placement mode that works best for you. For schematic
only design work, use the default option, Single Representation.

• Single Representation (schematic OR layout)

When you place an item in one representation, nothing is placed automatically
in the other representation.

• Dual Representation (schematic AND layout)

When you place an item in one representation and move the pointer into the
window for the other representation, the equivalent component is already
selected. Position the pointer as desired and click to place it. (If a window for
the other representation—containing the same design—is not open, one will be
opened automatically.)

• Always Design Synchronize (schematic AND layout)

Causes the program to fully synchronize both representations after each part is
placed, ensuring all parts are fully interconnected. This takes more time than
the Dual Representation mode and may move or rearrange the layout of the
schematic to preserve connectivity.
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Setting Design Environment Preferences
Displaying the Component Parameter Dialog Box by Default

When you place a component in the drawing area, you can change parameters
using the on-screen editor. Alternatively, you can make changes through the
Component Parameter dialog box. By default, in the Schematic window, the option
that controls the automatic display of the component parameter dialog box is
turned off. You can turn this option on if you want the dialog box to be displayed
every time you select a component (Options > Preferences > Placement).

• Show Component Parameter Dialog Box

Controls whether or not the Component Parameters dialog box appears every
time you select an item to place in the drawing area.

• Show Component Parameter Dialog Box for components without parameters

Select this option if you want the Component Parameters dialog box to be
displayed even for components that do not have parameters (for example, a
design used as a subnetwork for which no parameters have been defined
through File > Design Parameters). By default it is off and the dialog box does
not appear.

Setting a Default for Component Swapping

• Keep the original instance name(s) when swapping components

Retains the component ID of the original component when using the Swap
Components command. (Tip: this setting serves as a default; it can be changed
for any given operation through the Swap Components dialog box.)
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Setting Pin/Tee Options

You can change several options relating to pins/tees through Options > Preferences >
Pin/Tee.

• Pin Size

Enables you to change the size of the pins drawn on all components.

• Tee Size

Enables you to change the size of the Tee connections between interconnected
wires.

• Color

Enables you to specify colors for the items shown here. Click each to display a
color palette with the available selections.

• Visibility

Enables you to change the visibility status of pin numbers and names, and
whether or not pin connections are identified by markers.

Connected Pins—Select this option to display a marker identifying a pin
connection. The marker is drawn using the size specified in the Pin/Tee tab of
the Preferences dialog box.

Pin Numbers—Select this option to display pin numbers.

Pin Names—Select this option to display pin names.
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Setting Entry/Edit Options

This group of options allows you to control several aspects of shape entry and editing
including the angle at which lines and wires are drawn, the resolution of arcs and
circles, and how wires are routed relative to component text.

Note Changes made to the settings in this dialog box exist only in memory unless
you save them to a file. For details on saving to a file, refer to the section, “Saving and
Reading Preference Files” on page 9-20.

• Reroute entire wire attached to moved component

When this option is selected, the wire connection is allowed to be completely
redrawn and rerouted as needed. When this option is deselected, only the
segment (up to the first bend) of the wire attached to the component you are
moving is rerouted; the remainder of the wire is unaffected.

• Route around component text

By default, wires are routed through component text. If you want wires routed
around component text, select this option. Note that routing around pins, wire
endpoints, and collinear wires takes precedence. If the program cannot route
wires around these items, as well as the component text, it will route wires
through the component text.

• Polygon Entry Mode: Any angle

Enables you to draw polylines, polygons, and wires using all angles.

Turned off—Only
segment up to first
bend is rerouted

Turned on—Entire wire
is redrawn
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• Polygon Entry Mode: 45 degree angle only

Restricts shape entry to 45 degree rotation increments.

• Polygon Entry Mode: 90 degree angle only

Restricts shape entry to horizontal or vertical.

• Show Coordinate Entry Dialog for Insert and Edit commands

Select this option to force the Coordinate Entry dialog box to be displayed when
invoking the following commands:

Insert (Shape)—Polygon, Polyline, Rectangle, Circle, Arc (clockwise and
counter-clockwise), Text, Construction Line, Symbol Pin, Path, Trace.

Edit—Move Wire Endpoint, Mirror X, Mirror Y, Move & Disconnect, Step
And Repeat, Set Origin, Move Component Text.

• Show Set Paste Origin Dialog for Copy Command

Select this option to force the Set Paste Origin dialog box to be displayed when
you choose the Copy command. This dialog box enables you to specify X and Y
coordinates to be used as a reference point when pasting.

• Polygon self-intersection checking

Prevents you from placing additional points on a polygon if overlapping lines
will result.

• Maintain adjacent angles for Move Edge command

Restricts the Move Edge command to stretch an edge while maintaining the
adjacent angles of the edge being stretched to other edges adjacent to that edge.

• Arc/Circle Resolution (degrees)

This setting determines how smoothly curves are drawn. The length of each line
segment making up the arc is determined by the size of the angle drawn using
the specified number of degrees.

Specify this angle45°5°

Arc drawn with 5
degrees

Arc drawn with
45 degrees
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In general, the smaller the number of degrees, the smoother the shape, but the
longer it will take to redraw the screen.

Note This setting only affects circles in that the number specified here is used
if you convert a circle to a polygon.

• Auto-backup edit count

Your file is automatically saved every time the number of edits you have
performed reaches the number in this field.

• Undo edit count

This option represents the maximum number of commands held in the stack.
Selecting Undo from the Edit menu or clicking the Undo button on the toolbar
undoes the last editing command. A stack of edit commands is maintained for
each window, thus the Undo command works independently from window to
window. You can choose Undo repeatedly to return to an earlier state of your
design. You can specify the number of commands you want the stack to hold
using the Undo edit count option.

• Rotation Increment (angle)

This option forces objects you rotate to snap—during rotation—in n-degree
increments, where n is the number you specify here. For details on how this
default is used, refer to the section “Rotating Items” on page 6-22.

• Drag and Move

This option is designed to prevent you from moving an item when you click to
select it (for any purpose) and unintentionally move the pointer in the process.
By default, a move less than 10 screen pixels is not recognized as a move. An
intentional move must be more than the distance specified here for it to be
recognized as a move.
9-14 Specifying Design Entry and Display Preferences



Setting Component Text/Wire Label Options (in Advance)

Component text is the text associated with components selected from a Library or
Palette. This text appears automatically when you place the component in the
drawing area and consists of a name, a unique ID, and parameters (where
applicable).

There are two ways to change component text attributes:

• In advance of placing components, through the Options menu (Options >
Preferences > Component Text/Wire Label). This setting serves as a default, but
attributes of component text for an individual component, or all components,
can be changed later through the Edit menu.

• After placing components, through the Edit menu (Edit > Component >
Component Text Attributes). Refer to “Changing Component Text Attributes” on
page 6-10.

You can specify the following display characteristics of component text: font, point
size, maximum numbers of rows displayed in a single column, precision, and the
layer on which each type of text is placed.

• Font Type

All TrueType fonts installed on your system are available. Select the desired
font from the drop-down list. When printing to an HP-GL/2 file, text
information will not be saved if the font is a TrueType font. To preserve the text
in your output file, convert it to HersheyRomanNarrow before saving to
HP-GL/2.

Note On UNIX, if you want to add additional TrueType fonts that were not
supplied with ADS, copy them to $HPEESOF_DIR/lib/fonts.

• Point

Represents the size of text in traditional units used in printing.

• Apply To Layer

Each of the three types of component text resides on its own layer. This enables
you to quickly change the appearance of the component text by changing the
attributes of a layer, or making a layer invisible. For more information on
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changing layer attributes, refer to the section, “Specifying Layer Definitions” on
page 9-22.

To change the layer for any given type of component text, click the arrow and
select a new layer from the drop-down list.

• Parameter Rows

Represents the maximum number of rows of component text displayed in one
column. Using a relatively small number here is helpful for large parameter
sets so you can view the parameters in several short columns.

• Wire/Pin Label

Enables you to select defaults for the font, point size, and color of wire labels.

Sample of component
text for a capacitor
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Setting Text Options (in Advance)

You can establish text attributes—prior to adding text to your design—that affect all
subsequently added text. Establishing attributes in advance is done through the
Options menu; editing attributes of existing text is done through the Edit menu (refer
to “Editing Existing Text and Text Attributes” on page 6-34).

To establish text attributes:

1. Choose Options  > Preferences  > Text . and set the text attributes as desired.

• Font Type —All TrueType fonts installed on your system are available. Select
the desired font from the drop-down list. When printing to an HP-GL/2 file,
text information will not be saved if the font is a TrueType font. To preserve
the text in your output file, convert it to HersheyRomanNarrow before saving
to HP-GL/2.

Note On UNIX, if you want to add additional TrueType fonts that were not
supplied with ADS, copy them to $HPEESOF_DIR/lib/fonts (where
$HPEESOF_DIR represents your complete installation path).

• Point —Represents the size of text in traditional units used in printing.

• Justification, Horizontal —This setting represents two types of justification:
one is how individual lines of text in a block of text are aligned with one
another; the second is how an individual line of text or block of text is
positioned horizontally, relative to the reference point you specified to begin
typing the text.

• Justification, Vertical —This setting aligns a string or block of text vertically,
relative to the reference point you specified to begin typing the text.

• Placement Angle —The angle at which all text subsequently added to your
design will be drawn.

• Non-rotating (when in hierarchy) —Select this option to prevent text on a
symbol or design from being rotated when the symbol is rotated.

2. Change any or all options as desired and click Apply  (or OK if you are not
changing any other preferences).
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Setting Display Options

The Display tab enables you to change the Foreground, Background, and Highlight
colors.

• Foreground

The color of the lines making up polygons, polylines, and arcs while they are
being drawn.

• Background

The color of the drawing area background in the design window.

• Highlight

The color used to identify problem items (with respect to simulation), orphaned
items in schematic and layout representations, and unconnected pins.

• Minimum Object Size To Display (in pixels)

The minimum size—in pixels—an object must be before it is actually drawn in
the Schematic window. Objects smaller than this are not visible.
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Setting Units/Scale Options

With the exception of the Resistance setting, the settings in the Units/Scale tab of
the Preferences dialog box serve as defaults only in the following situations:

• When a parameter of a supplied component does not have a default unit and
you do not assign one (in the component parameter dialog)

• When you supply a default parameter value without units while creating a
parametric subnetwork (File > Design Parameters)

The Resistance setting can be changed to serve as a default for all resistors
(subsequently) placed in this project. For details on how units/scale factors are
handled by ADS simulators, refer to “Units/Scale Factors” on page 3-21.

Setting Tuning Options

The Tuning settings in the Preferences dialog box serve as defaults and can be
changed during tuning in the Tune Control and Tune Control Details dialog boxes.

Select the Tune Analysis mode that you want to serve as the default:

• Analysis Mode

Single—Perform analysis after each change

Multiple—Perform analysis only after the Tune button is clicked. This is
designed for tuning after multiple changes, but can be used for single changes.

Continuous—Perform analysis while the slider is moving

• Trace History

Number of traces to display—Set the default number of traces to be displayed
on your plots
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Set the following Slider options to the desired defaults:

• Range Min and Max —Set the minimum and maximum range to the initial
parameter value plus or minus the percent you enter here

• Step Size —Enter a percentage of the initial parameter value

• Slider Scaling —Choose Linear or Logarithmic

Saving and Reading Preference Files

When you create a project, the files schematic.prf (for schematics) and layout.prf (for
layouts) are copied to the new project from the installation directory. By default, all
designs in a given project use the preference file by this name. You can customize
these preference files, as well as create additional preference files by other names.

• To use the same set of customized preferences for every design in the project,
customize the files with the default filenames (schematic.prf and layout.prf).

• To use a different preference file for any given design in a project, open that
design, customize the preferences as needed, and save them to a preference file
with a unique name. To associate this customized preference file with a another
design, open that design, read the customized preference file, and save the
design.

You can save any number of files containing customized preferences. Whenever you
open a design, the last preference file associated with it is automatically read.

Note When you save a preference file, all the current settings found in the
Preferences dialog box are also saved, with the following exception: Options that may
be set differently within individual designs, such as text height, are not saved in the
preference file.

To customize preferences while retaining the default filenames:

1. Choose Options  > Preferences .

2. Change preferences as desired and click OK. The preference files with the
default filenames are updated. Every design in the project will now use these
preferences unless you explicitly associate a unique preference file with a given
design.
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To create customized preference files with unique filenames:

1. Choose Options  > Preferences .

2. Change any desired settings and click Save. The Save Preference File dialog box
appears displaying the default filename, schematic.prf.

3. Enter a name of your choosing (the .prf extension is added automatically) and
click OK.

Hint If you have a design open when you create a customized preference file,
that design will take on the preferences just saved when you click OK in the
Preferences dialog box. However, this association is only in memory unless you
save the design file.

To associate a previously saved preference file with a specific design:

1. Open that design.

2. Choose Options  > Preferences  and click Read. The Read Preference File dialog
box appears.

3. Select the desired preference file from the list of files, and click OK. (You can
read in preference files from other project directories.)

4. Save (File > Save) the design.

Hint The variable that defines the search path for these files is
PREFERENCES_PATH. For details refer to Appendix D, Customizing the ADS
Environment
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Specifying Layer Definitions
All shapes and text are entered on layers. By placing various groups of items on
different layers, each of which may be assigned different characteristics, you can
customize and easily alter the overall visual effect of the design in the viewing area.
The Layer Editor dialog box enables you to:

• Change display characteristics on a layer-by-layer basis

• Define new layers

• Change the plotting priority of layers (Layout window)

• Turn the display of items on and off on any specified layer. For example, you can
turn on and off the display of any or all the parts making up component text—
Name (labels), ID (identifiers), Parameters (parameters).

• Protect items on any given layer from being selected, that is, when clicking in
the drawing area to select items, those items on a protected layer cannot be
selected as you edit your design. This is helpful when you have a lot of editing to
do on certain kinds of items, but not others, in a crowded design.

• Save the layer definitions to the default schematic.lay file or to a unique
filename.lay file

At any time during the modification of layer definitions, if you have not yet clicked
Apply, you can click Reset to return to the previous settings.

Note The layer number—not the name—is the common identifier used in both the
design file and the layer file, and should not be changed.

The order in which layers are plotted is determined differently in the Schematic
window than it is in the Layout window.

• In the Schematic window, layers are plotted in numerical sequence—based on
the layer number—beginning with zero and ending with the highest number.
You can rearrange layers in the list for your convenience, but it will have no
effect on the plotting order.

• In the Layout window, the position of the layers in the list, relative to each
other, indicates their priority when plotted. Higher priority layers are plotted
on top of lower priority layers—the lower in the list, the higher the priority.
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The following figure shows the list of default defined layers. These are the default
layers in the Schematic window; for details on layers in the Layout window, refer to
the Layout manual.

Important Be sure to use compatible layer definitions for related designs, especially
designs that are related hierarchically.
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Setting Design Environment Preferences
To move a layer within the layer list:

1. Click once to highlight the layer ID or Name.

2. Click Cut . The name and number disappear from the list.

3. Highlight the layer you want to paste the cut layer above, click Paste  and click
Apply .

To delete a layer:

Note Do not delete the supplied, default layer definitions; the ability to delete is
provided to enable you to redefine layer definitions you have created. Deleting
supplied layer definitions will degrade the appearance of your schematic, as parts
whose layer has been deleted will now be drawn on the default layer.

1. Click once to highlight the layer ID or Name.

2. Click Cut . The name and number are deleted from the list, and that number is
now available for a new layer. (Hint: If you change your mind, use Paste to add
the layer back.)

To change a layer’s name:

1. Click in the Name field and change the name as desired.

2. Click Apply .

To add a layer:

1. Click New from the group of buttons labeled Layer.

The layer list scrolls to the bottom and a new layer is added. The layer number
is the next available, sequential number, and a default name appears that
includes the layer number.

2. Rename the layer as desired and click Apply .
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Setting Colors and Fill Patterns

The Color/Pattern columns of the Layer Editor dialog box enable you to choose colors
and fill patterns of items, on a layer-by-layer basis.

To change color and/or pattern settings for any given layer:

1. Click to access the available colors or patterns (PC—click the arrow for the
drop-down list; UNIX—click the color bar itself) from the color or pattern box of
the layer you want to modify.

2. Click the desired color or pattern (UNIX—click OK).

3. The new color is displayed in the Layer Editor dialog box. To see the change in
the drawing area, click Apply .

Note When choosing Fill Patterns, keep in mind that the patterns produced by
a Postscript printer are Postscript fill patterns and will vary somewhat from
those on your screen.
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Setting Shape Display Characteristics Layer-by-Layer

All shapes are drawn with one of the following display types:

• Both (both an outline and a fill pattern)

• Outline (an outline with no fill pattern)

• Filled (a fill pattern with no outline)

The following illustration shows the shape display Both, where you see both the fill
pattern and the outline.

The Shape Display drop-down list for each layer enables you to choose the shape
display of items, on a layer-by-layer basis.

Hint For details on changing the shape display globally for all layers, refer to the
section, “Setting Layer Characteristics Globally” on page 9-28.

Setting Line Style Characteristics Layer-by-Layer

When you include the Outline of shapes as part of Shape Display on ay given layer,
you can also choose a line style for that outline. Click to select a different line style
from the drop-down list.

Hint For details on changing the line style globally for all layers, refer to the section,
“Setting Layer Characteristics Globally” on page 9-28.

Fill pattern

Outline
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Setting the Visibility of Items Layer-by-Layer

The Vis (visible) column enables you to turn on and off the display of items on any
given layer. For example, if you want to print or plot your schematic without
component annotation, you could make the labels, identifiers, and parameters layers
invisible. By default, all layers are visible.

Hint For details on changing the visibility globally for all layers, refer to the section,
“Setting Layer Characteristics Globally” on page 9-28.

Setting the Selection Status of Items Layer-by-Layer

If you need to edit certain types of items (that reside on a given layer) and not others
(that reside on other layers), and the selection filters do not meet your needs, you can
prevent items from being selected by disabling the Sel (select) option for any layers as
needed.

When you disable the select status for any given layer, items on that layer will not be
selected as you edit your design.

Hint For details on changing the shape display globally for all layers, refer to the
section, “Setting Layer Characteristics Globally” on page 9-28.
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Setting Layer Characteristics Globally

This section of the Layer Editor dialog box enables you to change the Selection,
Visibility, Shape Display, and Line Style status of all layers at once. For example, if
you want to prevent selection on all layers except one or two of them, use Select None,
then select the individual layers you want access to, and turn on the Select status for
those layers.

Miscellaneous Layer Editor Features

• The Ins (insert) column enables you to change the current entry layer while
working in the Layer Editor dialog box so that you can quickly see the effect of
your changes.

• The Reverse button toggles the display of the layer list top-to-bottom, or vice
versa.

• The Visibility tab enables you to reduce the size of the Layer Editor dialog box
while keeping the most commonly used features of it available for editing.
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Saving and Reading Layer Files

The default layer definitions are contained in the files schematic.lay (for schematics)
and layout.lay (for layouts). These files are read automatically—from the installation
directory—every time you open a design, unless you have explicitly associated
another layer file with that design. To associate a customized layer file with a specific
design, open the design, read the customized layer file, and save the design.
Whenever you open a design, the last layer file associated with it is automatically
read.

You can create any number of files containing customized layer definitions, and
subsequently read in any of these files for any design.

To save customized layer files:

1. Make all the desired changes in the Layer Editor dialog box and click Save. The
Save Layer File dialog box appears, displaying the default filename,
schematic.lay.

2. To use the default filename for the current settings, click OK.

For another layer file, enter a name of your choosing (the .lay extension is added
automatically) and click OK.

To read in a previously saved layer file:

1. Click Read from the Layer Editor dialog box. The Read Layer File dialog box
appears.

2. Select the desired file from the list of files, and click OK. (You can read in layer
files from other project directories.)

Hint The variable that defines the search path for these files is LAYERS_PATH. For
details refer to Chapter 1, Customizing the ADS Environment, in the Customization
manual.
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Changing the Current Entry Layer

To change layers:

1. Choose Insert  > Entry Layer  and a dialog box appears listing all the currently
defined layers.

2. Select a layer that is appropriate for the task at hand.

3. Click OK. Anything you draw now is drawn on this layer. The name of the layer
is displayed in the status panel of the Schematic window.

Customizing Keyboard Shortcuts
You can redefine default keyboard shortcuts as well as create new ones. These
shortcuts are maintained individually for the different ADS windows.

To change or add a keyboard shortcut:

1. Choose Options  > Hot Key/Toolbar Configuration  and click the Hot Key  tab in the
dialog box that appears.

2. Select the menu name or menu/command sequence from the Category list box.

3. Select the command from the Item list box. If a shortcut currently exists for the
item, the current assignment is displayed.

4. Select the modifier key(s)—Ctrl, Alt, Shift—and type the letter(s) you want to
use in the Key field (UNIX is case-sensitive; the PC is not). If the combination
you choose is currently assigned to another command sequence, you are warned
and given the choice to proceed or to select another key sequence.

Note If you use Alt as the modifier key, and a letter that is already assigned as
an accelerator for a menu (see the underscored letters on the menu bar), the
menu accelerator is replaced by your custom shortcut (with no warning).
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5. To replace the assignment with your own choice, continue, otherwise choose a
new key combination and click Apply. When you are through making all
keyboard changes, click OK to dismiss the dialog box.

For a list of default keyboard shortcuts, refer to Appendix B, Shortcut Keys.

Configuring Toolbars
By default, the toolbar in each design window contains:

• A drop-down list for selecting the group of components you want to place on the
palette (Palette List)

• A dynamically updated list of components you have placed in that window
(Component History)

• In the Layout window, a drop-down list for selecting a different entry layer
(Entry Layer List)

• A button for choosing the orientation of the component you are about to place

• Buttons representing frequently used commands

You can reconfigure these default toolbars and create your own to better meet your
design needs (Options > Hot Key/Toolbar Configuration).

Customizing an Existing Toolbar

To reconfigure an existing toolbar:

1. Choose Options  > Hot Key/Toolbar Configuration  and click the Toolbar tab in the
dialog box that appears.

2. In the Toolbar Group list box, select the name of the toolbar you want to change.

3. To add or delete icons, use one of the following methods:
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• To delete an icon from the toolbar, select the associated command in the Tool
Item list box, and click the Cut button.

• To add an icon to the toolbar, select the appropriate menu/command sequence
from the Menu Category list box, select the command from the Menu Item
list box, and click the Add button. The command is added to the Tool Item list
box.

Hint When you add a button to the toolbar, its position relative to the other
buttons is determined by its position in the Tool Item list box. Before you click
the Add button, be sure to highlight the command that the new command
should follow. In this example, Zoom In Point was highlighted before the Add
button was clicked so that Redraw View would take the place of Pan View
(deleted in the previous example).

4. If you want to edit another toolbar, click Apply to effect these changes and begin
the process again. When you are through making changes to the toolbars, click
OK.

Select the
command

Click the Cut button

When you select a command, its
default bitmap is displayed
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Creating a New Toolbar

To create a custom toolbar:

1. Choose Options  > Hot Key/Toolbar Configuration  and click the Toolbar  tab in the
dialog box that appears.

Hint The position of the new toolbar, relative to the position of any existing
toolbars, is determined by its position in the Toolbar Group list box; the new
name is added below the name that is highlighted when you click the Add
button. For example, if you keep both default toolbars and want to add a third
one below them, highlight the bottom one before you click the Add button.

2. Supply a name in the Toolbar Name field and click Add .

The name you supply is added to the Toolbar Group list box.

3. Select the desired Menu Category, select the desired Menu Item and click Add .
The command name is added to the Tool Item list box.

4. When you are through making changes to this toolbar, click Apply  to effect the
changes.

5. When you are through making changes to all toolbars, click OK.
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Creating a Custom Component Palette
Creating a custom component palette can speed up the design creation process by
grouping frequently used items in one or more palettes.

To create a custom palette:

1. Choose View > Component > Create Component Palette and a dialog box appears.

Hint By default, the components currently listed in Component History are
listed for inclusion in the new palette. If this list does not represent a significant
number of components you want to include on the new palette, use the Clear
Component History command to avoid individually selecting and cutting
components from the custom list.

2. Cut any components from the New Palette Group Components list box, as
necessary.

3. Select a palette, from the List of Palette Groups, that contains components you
want in the custom palette.

4. Select the desired component, from the Palette Group Components list box, and
click Add .

5. Repeat as needed to include additional components from any palette.

6. Provide a name for the new palette in the New Palette Group Description field.
This is the name that will appear in the drop-down Palette List enabling you to
place the custom group on the palette.

Turning On/Off the Coordinate Readout Display

There are two types of coordinate readouts, positional and differential.

• Positional—the X,Y coordinates of the cursor position in relation to the total
window. By default, the lower left corner is 0,0. This display also reflects the
current precision setting (in this example, 1,000).

• Differential—the distance in X,Y the cursor has traveled since the last click. Set
the starting point to 0,0 by clicking the left mouse button anywhere in the
drawing area.
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The X,Y coordinate readouts are displayed in the status bar of each window. By
default, Positional readouts are turned on in every window.

You can turn the coordinate readout on or off from the View menu.

Positional Differential
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Chapter 10: Working with Symbols
Symbols are used to represent individual components in a schematic and
subnetworks in hierarchical designs. Default symbols exist for schematics with 0 to
99 ports, but you might want to draw your own symbol for any of the following
reasons:

• You want a symbol you feel better represents the schematic

• You want to replace the default symbol of a simulator component with one of
your own

• You create a new simulator component (using the model builder) and need to
create a schematic symbol for it

Schematic symbols consist of a symbol body and, optionally, symbol pins
(interconnect points). If you are drawing a symbol to represent an electrical
component or a subnetwork for a hierarchical design, you must add pins to the
symbol body.

The default symbols have been created in a uniform manner. Custom symbols should
be created in a similar manner, that is, their overall length, from pin to pin, should be
a multiple of 0.125 inch. This ensures the custom symbol will connect easily to the set
of supplied symbols. In addition, pin 1 should be located at the coordinates 0,0 which
serve as the reference point when you place the symbol in a design.

A symbol can be defined in one of two ways:

• As part of a design file containing a schematic—when you need the symbol to
represent only that schematic

• In a design file containing nothing but the symbol—when you want the symbol
to be available to represent any schematic

An illustration representing these differences is shown next.
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For information on assigning a symbol to a schematic, refer to the section “Assigning
a Symbol to a Schematic” on page 10-15.
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Switching Between Schematic and Symbol Views
When you are creating a schematic, the View menu displays the command
Create/Edit Schematic Symbol. When you choose this command, you display the
symbol view of the current design. If you look at the View menu again, you will see
that the command name has changed to read Create/Edit Schematic. This enables
you to switch back and forth between these views.

If you place an instance of your schematic design as a subnetwork—without creating
a special symbol—a default symbol is used, based on the number of ports in your
design. If you want to create a custom symbol for your design, you can switch to
symbol view and:

• Accept the default generated symbol and then modify it

• Select one of the supplied symbols, which you can use as is or modify

• Click Cancel in the dialog box that appears and create your symbol from scratch

Refer to the following sections for details:

• “Generating a Symbol” on page 10-4

• “Using One of the Supplied Symbols” on page 10-5

• “Drawing a Custom Symbol” on page 10-6

Creating a Symbol for use with any Design
To create a symbol for use with any design:

1. Create a new (empty) design file.

2. Choose View  > Create/Edit Schematic Symbol .

• For details on how to copy and then modify one of the supplied symbols, refer
to “Using One of the Supplied Symbols” on page 10-5

• For details on creating a symbol from scratch, refer to “Drawing a Custom
Symbol” on page 10-6

3. When the symbol is complete, you can associate any schematic with this
symbol. For details refer to “Assigning a Symbol to a Schematic” on page 10-15.
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Generating a Symbol
You can generate a symbol for your completed schematic providing minimal
specifications.

To generate a symbol:

1. From the completed schematic, choose View  > Create/Edit Schematic Symbol .

2. In the dialog box that appears, select the Auto-Generate  tab and specify the
desired symbol characteristics (or accept the defaults). The symbol
characteristics are defined as follows:

Symbol Type

Dual—Restricts pins to two sides of symbol body

Quad—Allows pins on all four sides of symbol body

Order Pins by

Location—Numbers symbol pins in the same relative order as the ports on
the schematic

Number—Numbers symbol pins sequentially in a left-right, top-down order

Replace existing symbol —Replaces the current symbol, if one exists, with the
one you are about to generate

Lead Length —The length of any line drawn between the symbol body and a pin

Distance Between Pins —Distance between pins drawn on the same side of the
symbol body

3. Click OK. A symbol is drawn consisting of a symbol body, connecting lines, and
pins.

Hint To regenerate the symbol specifying different symbol characteristics, choose
Insert > Generate Symbol.

You can edit the generated symbol as desired at any time.

For details on drawing and editing shapes, refer to:

• “Drawing Shapes” on page 7-4

• “Editing Shapes” on page 6-26
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For details on symbol-specific editing, refer to:

• “Establishing Pin Characteristics” on page 10-12

• “Positioning Parameters for Your Symbol” on page 10-14

Using One of the Supplied Symbols
You can use any of the symbols we supply and modify them or use them as is.

To associate a supplied symbol with your network:

1. From the completed schematic, choose View  > Create/Edit Schematic Symbol .

2. In the dialog box that appears, select the Copy/Modify  tab.

3. Select the desired symbol category from the Symbol Category drop-down list
and the icons for that category are displayed. These categories represent the
basic component libraries, but note that not all individual components will be
displayed; if multiple components share the same symbol, only one of those
components is displayed.

4. Click the desired symbol icon and its name is displayed in the Symbol name
field.

Alternatively, you can type a name directly in the Symbol name field:

• Type an actual component name whose symbol you want to use

• Type the name of a design file containing a symbol (or select it using the
browser)

5. Click Apply to view the symbol in the design window and click OK when you are
satisfied with your symbol selection. The program compares the number of pins
on the symbol with the number of ports in the schematic view and reports any
discrepancies.

You can edit the supplied symbol as desired at any time.

For details on drawing and editing shapes, refer to:

• “Drawing Shapes” on page 7-4

• “Editing Shapes” on page 6-26
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Drawing a Custom Symbol
When you draw a custom symbol, you can draw it in a file containing a schematic,
where it will be dedicated to that schematic, or you can draw it in an empty file and
use it to represent any schematic.

Drawing Setup

Before you begin, you may find it helpful to review a number of the program’s
defaults, and you will most likely need to make a few changes.

Setting Snap and Grid Spacing

By displaying a grid and drawing with snap enabled, you can quickly draw objects
with great accuracy. To view or change these settings, use Options > Preferences >
Grid/Snap. Snap mode offers options for snapping to many different types of objects.
These options are all described in the section, “Setting Grid/Snap Options” on
page 9-6. When drawing a custom symbol, the most important option will probably be
Grid, however if you are drawing complex shapes, several other options may be
helpful.

The display grid can be made visible or invisible. When you turn on the grid display,
you should specify a sufficiently large factor of the snap spacing so that a grid is
displayed even when the snap spacing is very fine. For example, the default snap
spacing (in the Schematic window) is 0.125 which means the cursor snaps every 1/8
inch. The default display factor is 2 which means that the dots appear every 1/4 inch
(0.125 x 2).

Before you begin drawing, check to see if the current grid spacing is set to something
other than the default of 0.125 inch, and if it is, change it back to the default and
make sure Enable Snap is turned on. This step ensures that your custom symbol will
easily connect to the set of supplied symbols.

Hint Once you have drawn the symbol body and pins, you can change these settings
if desired. For example, you might want to turn snap off before adding text to your
design to give you more flexibility in the positioning of the text.
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Specifying the Drawing Layer

All shapes and text are entered on layers. The color and visibility of any shape is
controlled by the layer on which it is drawn. Before you begin drawing any part of the
symbol, change the current entry layer in accordance with the part you are about to
draw. For example, if you are creating a custom symbol, you should draw the symbol
body, pins, and lead lines on the symbody layer so that it will be on the same layer as
the supplied symbols, and subject to changes you make to that layer.

To change layers:

1. Choose Insert  > Entry Layer  and a dialog box appears listing all the currently
defined layers.

2. Select a layer that is appropriate for the task at hand.

3. Click OK. Anything you draw now is drawn on this layer. The name of the layer
is displayed in the status panel of the Schematic window.

Table 10-1 lists the default layers and the types of items placed on those layers (by
default).

Table 10-1. Layer Names, Numbers, and Descriptions

Layer name
Layer
number Description

default 0 Objects drawn on an undefined layer are plotted on this
layer. Also, if you delete a layer, any objects residing on that
layer are moved to this layer.

user_symbody 1 User-created schematic symbol

user_symtxt 2 User-created schematic symbol text

user_symbol 3 User-created schematic symbol

wire 4 Wires

text1 5 Available layer name for text

labels 6 Component or item names

identifiers 7 Unique ID of components or items

parameters 8 Parameters of components or items

pin_num 9 Pin numbers and names for symbols†

notes 10 Any additional descriptive information you want to add

symbody 11 Schematic symbol body outline

symdesign 12 Portion of schematic symbol contained within symbol body
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SPint 13 Signal Processing integer data††

SPfix 14 Signal Processing fixed point data††

SPfloat 15 Signal Processing floating point data††

SPcomplex 16 Signal Processing complex data††

SPtimed 17 Signal Processing timed data††

SPany 18 Signal Processing any data type††

SPother 19 Signal Processing user-defined data††

symtext 20 Text contained within schematic symbol body

symbodyFilled 21 Schematic symbol body with fill pattern

symbodySlash 22 The slash that identifies pin 1

† The pin_num layer is visible by default, but you must turn on Pin Numbers and/or Pin
Names in the Visibility (on/off) section of the Pin/Tee tab of the Preferences dialog box to
make pin numbers and names appear.
†† For details, refer to Chapter 15, Data Types for Model Builders, in the
Agilent Ptolemy Simulation manual.

Table 10-1. Layer Names, Numbers, and Descriptions (continued)

Layer name
Layer
number Description
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Drawing the Symbol Body

The commands you need to draw your symbol can be found on the Insert menu. In
addition, many of them are available on the default toolbar. For details on using these
commands, refer to the section, “Drawing Shapes” on page 7-4.

Note The Layer Editor dialog box enables you to determine the color and fill
pattern, shape display, and line style for objects drawn on each layer. For details,
refer to the section, “Specifying Layer Definitions” on page 9-22.

Adding Pins to Your Symbol

There are two kinds of pins:

• Symbol Pin—A pin that represents a port of a network, that is needed to
connect that network as a subnetwork in another design.

• Power Pin—A pin that also represents a port of a network, but does not appear
in the schematic. The connection created via a power pin is an implied
connection.

Symbol Pins

Remember that symbol pins should be located at 0.125-inch intervals so that your
custom symbol will connect easily to the set of supplied symbols. In addition, pin 1
should be placed at the coordinates 0,0. Choose any of the methods shown below to
accomplish this.

To specify 0,0 in the process of drawing pin 1:

1. Choose Insert  > Coordinate Entry  and a dialog box appears.

2. Choose Insert  > Symbol Pin  and a dialog box appears. Define the pin
characteristics as described in the section, “Establishing Pin Characteristics”
on page 10-12, and click Apply .

3. Enter the coordinates 0,0 in the Coordinate Entry dialog box and click Apply .
Pin 1 is placed at 0,0. You can now use the View All command to reposition the
image in your design window.
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To move 0,0 to the center of the window before you begin:

1. Choose Pan from the View menu or the pop-up menu.

2. Click the small cross identifying the 0,0 coordinates (lower left corner of the
drawing area). The 0,0 coordinates move to the center of your design window.

3. Choose Insert > Symbol Pin  and a dialog box appears. Define the pin
characteristics as described in the section, “Establishing Pin Characteristics”
on page 10-12.

To move pin 1 to 0,0 after you have placed it:

1. Choose Insert > Symbol Pin  and a dialog box appears. Define the pin
characteristics as described in the section, “Establishing Pin Characteristics”
on page 10-12, and click Apply.

2. Choose Edit  > Modify  > Set Origin .

3. Click the pin. The pin moves to 0,0. You can now use the View All command to
reposition the image in your design window.

Power Pins

Power pins, also called inherited pins, are added in symbol view, but do not appear in
the schematic. They create an implied connection. This connection is inherited from
subnetworks throughout the hierarchy.

Note There is no support for power pins in the IFF translator in the current release.

To add a power pin to your symbol:

1. From the subnetwork design of interest, choose View  > Create/Edit Schematic
Symbol .

2. If a symbol does not yet exist for the current design, the Symbol Generator
appears. Set the options as desired (refer to “Generating a Symbol” on
page 10-4) and click OK. A symbol is generated that includes one pin for each
port of the network.

If a symbol already exists for the current design, that symbol appears.

3. Delete the symbol pin you want to replace with a power pin.

4. Choose Insert  > Power Pin .
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Note The numbering sequence for all pins of a given design must follow this
rule: the symbol pin numbering sequence comes first, and the power pin
numbering sequence follows.

5. In the dialog box that appears, set the pin characteristics as needed (refer to
“Establishing Pin Characteristics” on page 10-12), including renumbering,
where applicable, and click Apply .

6. Position the pointer in the drawing area and click to position the power pin.

7. Define additional power pins for this design as needed, and click Cancel to close
the dialog box.

To override the default value of a power pin for a given instance:

1. Select the instance and choose Edit  > Properties .

2. If the instance has more than one property, select the desired property. All
power properties are inherited from instances throughout the hierarchy. All
properties of this type will be identified as inherited.

3. Supply the desired Value (the name of the node or pin to which the invisible
power pin should be connected).
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4. Retain the default Value Type setting of String and click OK.

Establishing Pin Characteristics

The pin characteristics are defined as follows:

• Name—Optional. The pin name is not displayed on your schematic unless you
select the Pin Names option in Options > Preferences > Pin/Tee.

• Number—Optional. A default pin number is displayed. This number is
automatically incremented as each pin is added. To display pin numbers on the
schematic, select Pin Numbers in Options > Preferences > Pin/Tee.

• Orientation Angle—Optional. This feature is only used by the program when
generating a schematic from a layout. It enables you to specify an orientation
angle for each pin that determines the orientation of an item connected directly
to that pin. Any angle from −90 to 180 degrees is allowed, but we recommend
90-degree increments. The recommended angles for schematic symbol pins are
shown in the following illustration.
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• Type

• Input—Identifies the pin as an input port

• Output—Identifies the pin as an output port

• Input/Output—Identifies the pin as an input or output port

• Power (<property>:<value>)—Power pins only. Supply a property or name (a
unique identifier) and a default value, such as the name of a global node
contained in the hierarchy, separated by a colon.

To edit existing pin characteristics:

1. From symbol view (View > Create/Edit Schematic Symbol), choose Edit  >
Symbol Pin  or for power pins, Edit  > Power Pin .

2. Click the pin of interest.

3. Change the settings as desired and click OK.

Note When you create a symbol for use with any design, it is only available in the
project directory in which you create it, unless you modify certain configuration files
(and for model builder usage, modify AEL files according to stated guidelines). If you
want the symbol to be available for all design work, refer to the section, “Making
Symbols Available Globally” on page 10-16.

0

-90

180

90
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Positioning Parameters for Your Symbol

By default, when you define parameters for your subnetwork (File > Design
Parameters), those parameters are positioned in the same manner as the parameters
of supplied components. You can position these parameters by adding references to
them using the onscreen editor in symbol view.

To position user-defined parameters for a subnetwork symbol:

1. Open the design for which you want to customize parameter positions.

2. In symbol view (Edit > Create/Edit Schematic Symbol), choose Insert  > Text  (or
click the Text icon on the toolbar).

3. Position the cursor where you want a given parameter to appear (relative to the
symbol) and click once.

4. Type the parameter name—as defined in the Design Parameters dialog box—
beginning with the at symbol (@). For example, if your subnetwork has a
parameter width, type @width. (Parameters names are case sensitive on
UNIX.)

5. To end the text string, do one of the following:

• Move the cursor away from the text and click once. (That string is done, but
the Text command is still in effect and you can click in a new location to add
another string.)

• Choose End Command. (That string is done and the Text command ends.)

Hint When using the onscreen editor to position individual parameters, do not
press Enter to move from one parameter to another; you must treat each
parameter as an individual text string.

When you place the subnetwork hierarchically, the parameters you positioned in
symbol view appear in the same position, relative to the network symbol.
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User-defined parameters positioned in this manner:

• Take on the color of the layer on which the @<parameter_name> string was
placed

• Take on the font and size defined for other parameters (in advance, through
Options > Preferences > Component Text/Wire Label or with editing, through
Edit > Component > Component Text Attributes)

Assigning a Symbol to a Schematic
Symbols are stored in design (.dsn) files. If you generate a symbol for a particular
schematic, or create one in a design file containing a schematic, then that symbol is
stored in the same design file as the schematic and that symbol is automatically
associated with that schematic, unless you explicitly specify the name of another
symbol (design file). You can verify the symbol being used for any given schematic by
opening that schematic and choosing File > Design Parameters, clicking the General
tab and noting the name in the Symbol Name field. If it reflects the current design
name (minus the .dsn extension), then the program will look in this file for the
symbol.

If you create a symbol in its own design file—which makes it available to represent
any schematic—you must assign that symbol to the desired schematic.

To assign a symbol to the schematic:

1. Open the schematic design.

2. Choose File  > Design Parameters  and the Design Definition dialog box appears.

Parameter positioned in symbol view Subnetwork placed hierarchically

Default location

User-specified
location
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Working with Symbols
3. In the Symbol Name field, type the name of the file (minus the .dsn extension)
that contains the desired symbol.

Hint The drop-down list of symbols can be modified to include any supplied
symbols as well as custom symbols. For details refer to the section, Modifying
the List of Available Symbol Names in the Customization manual.

4. Click OK.

Hint If you generate a symbol and then decide to use a custom one instead,
after you type the symbol filename in the Symbol Name field, click the Save
AEL button in the dialog box to save the change.

5. Choose File  > Save Design .

The next time you place this design within another design, the new symbol will
appear.

Making Symbols Available Globally
Custom symbols are only available in the project directory where you create them
unless you modify the search path of a particular variable in a configuration file. In
addition, if you want the names of these symbols to appear for selection within the
related dialog box, you must modify a certain AEL file.

While it is possible to leave all files containing custom symbols in the project
directories in which they were created, the aforementioned configuration changes
will be greatly simplified if you move all custom symbols to central locations, one
location for individual use and one for site use. (If necessary, see your system
administrator to create the directory for site use.) We recommend maintaining the
same directory structure used by Advanced Design System. Thus, the symbols should
be placed in the following locations, in accordance with their use (circuit vs.
hptolemy):
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Use these directories on UNIX:

Use these directories on the PC:

Note If you use a directory other than one of those shown in the tables, then you
must declare the variable USR_DSN_PATH and provide the search path.

To access custom symbols—if stored in a directory other than one of the defaults:

1. Using any text editor, open the file $HOME/hpeesof/config/de_sim.cfg.

2. Add the variable USR_DSN_PATH and set it equal to the path you have chosen
for your symbols directory.

3. Save the file.

Once you have created the symbols directory (regardless of where), move the files
containing the custom symbols from their current project directory locations into the
appropriate, newly created directory.

UNIX

Individual Use $HOME/hpeesof/circuit/symbols
$HOME/hpeesof/hptolemy/symbols

Site Use $HPEESOF_DIR/custom/circuit/symbols
$HPEESOF_DIR/custom/hptolemy/symbols

PC*

Individual Use %HOME%/hpeesof/circuit/symbols
%HOME%/hpeesof/hptolemy/symbols

Site Use %HPEESOF_DIR%/custom/circuit/symbols
%HPEESOF_DIR%/custom/hptolemy/symbols

* %HOME% represents the path you specified as the Home Folder
during installation (C:\users\default by default);
%HPEESOF_DIR% represents the path you specified as your
Program Folder during installation (C:\ADS2002 by default).
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Modifying Search Paths

Search paths that control the order of directories searched are defined by certain
program variables. These variables should be modified in a local copy of the
de_sim.cfg file. This file is written to the /config directory during installation and
should not be modified there. But you can open this file and copy the default variable
definition (where applicable), then paste it in your own local copy and modify it. (This
simplifies typing a lengthy search path.)

The program creates a de_sim.cfg file automatically in $HOME/hpeesof/config.
Settings modified here apply to all projects.

To modify the search path of the variable:

1. Using any text editor, open the de_sim.cfg  file in $HPEESOF_DIR/config.

2. Locate the variable definition, copy it, and close the file.

3. Open the de_sim.cfg file in your $HOME/hpeesof/config directory and paste the
variable definition.

4. Edit the variable definition as needed.

5. Save the file.
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Chapter 11: Printing and Plotting
This chapter describes printing and plotting from Advanced Design System. You can
send output to printers and plotters as well as to file in a variety of formats. When
printing to file, the format of the file is determined by the current output device and
the file is saved in the current project directory.

You can connect any output device that is supported by your operating system. To
connect additional printers and plotters, and select a default printer, choose the
appropriate method for your platform:

• Windows NT—Print Manager

• Windows 98 and 2000—Start menu > Settings > Printers

• UNIX—Choose File > Print Setup > Install > Add Printer

The basic Print commands are summarized next:

• Use the Print command to print the contents of the drawing area of the current
window

• Use the Print Area command to print a region of the drawing area

• Use the Print Setup command to establish a default printing configuration,
although you can modify it at the time of printing

Note For detailed information on printing and print setup options on the PC, refer to
your Windows documentation.

Because the print methods vary significantly between UNIX and the PC, this chapter
describes printing from these platforms separately. Refer to the appropriate section
for your platform:

• “Printing from UNIX” on page 11-2

• “Printing from the PC” on page 11-12
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Printing and Plotting
Printing from UNIX
Printing and plotting from Advanced Design System on UNIX is accomplished by
establishing the desired print setup and then choosing File > Print. The Print Setup
and related dialog boxes enable you to:

• Choose to send output to a printer/plotter or print to file

• Install additional printers

• Select a printer (if sending to printer) other than the default

• Select a file format (if printing to file)

• Select Portrait or Landscape orientation

• Scale the output

• Specify the number of copies

When you select a printer, you can change the following default printer-specific
options:

• Resolution

• Page Size

• Paper Tray

When you choose File > Print, you can select from the following additional options:

Hint Click Options in the Print dialog box as a shortcut back to the Print Setup
dialog box if you decide to make changes to the current setup.

Select this option to print to file using the HP-GL/2 format.

Select this option to print in color (on a color printer) or in
grayscale, rather than black and white (on a monochrome
printer)

Select this option to fill the printed page. If selected, this
option overrides any scaling factor you have set.
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Your print setup is saved in $HOME/.Xprinterdefaults. If you do not have a local
copy of this file, or the file .Xpdefaults (from a previous release), the default file is
read from the $HPEESOF_DIR/xprinter directory. When you change your print
setup, the changes are saved (as new defaults) to $HOME/.Xprinterdefaults. Note: If
you do have a file .Xpdefaults (from a previous release), the settings of this file are
copied to the new filename to serve as the starting point for your print setup. Both
files are valid, depending on which release of ADS you are using. The old file is
maintained for running an earlier version of ADS, but the new file is used when you
run ADS 1.5 (or later).

Adding a Printer

The basic steps required for adding a printer through the Print Setup dialog box are:
defining a port and associating a printer with that port.

To define a port and add a printer:

1. Choose File  > Print Setup  and a dialog box appears.

Close
Dialog Box
Without
Saving
Changes

Select
From
Installed
Printers

Add
Printers/P
orts

Reload Printer
Configuration
File

Close
Dialog Box
and Save
Changes

Close
Dialog Box
Without
Saving
Changes
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Printing and Plotting
2. Click Install  and a dialog box appears listing all currently installed printers.

Delete
Highlighted
Printer from
List

Close Dialog
Box Accepting
Changes

Close Dialog
Box Without
Accepting
Changes

Define Port and
Associate
Printer with it
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3. Click Add Printer  and a dialog box appears listing all available printer devices
and all currently defined ports.

Note For a list of supported printers, see Supported_Printers_XPV331.html in
$HPEESOF_DIR/xprinter.

Close Dialog Box
Accepting Changes

Provides Access to
Dialog Box for Defining
a New Port

Add Highlighted
Printer and Port to
List of Installed
Printers
Printing from UNIX 11-5



Printing and Plotting
4. Click Define New Port  and a dialog box appears listing all currently defined
ports.

5. Add all ports you want to access for printing:

• On HP 700 and Sun Solaris workstations, click Spooler and the list of ports is
automatically generated (based on your printcap file).

• On all other workstations, type the port definition in the Edit Port field using
the following syntax: printer name=print command (no spaces around equal
sign), where print command is the print alias, just as you would type it in the
terminal window. Click Add-Replace . Repeat for each desired port.

Note Port names can be any names you choose with the exception of
FILE: which is a reserved port name.

Close Dialog
Box Without
Accepting
Changes

Close Dialog
Box
Accepting
Changes

Automatically
List All Defined
Ports (HP 700
and Sun Solaris
Only)

Delete
Highlighted
Port from List

Update Ports list
with contents of
Edit Port field
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6. Click Dismiss  to accept the new port definitions and return to the Add Printer
dialog box. The Current Port Definitions list box is updated.

7. Select the desired printer from the list of Printer Devices.

8. Select the port you want to associate with this printer.

9. Click Add Selected . The Printer Installation dialog box is updated.

If you defined multiple ports, you can associate a printer with each, as just
described.

10. Dismiss  the Add Printer and Printer Installation dialog boxes. You will now be
able to select any of the installed printers, as needed.
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Selecting a Printer

To select a printer other than the current default:

1. Choose File  > Print Setup .

2. Select Printer  as the Output Format in the Print Setup dialog box.

3. Click Options  and a dialog box appears.

4. Select the desired printer from the Printer Name drop-down list. The
printer-specific options are updated to reflect the default options for the selected
printer.

5. Change any or all of these options as needed and click OK.

6. Set the following options, in the Print Setup dialog box, as desired for the
current printer:

• Orientation

• Scale (the value 2.0 would double the size; 0.5 would reduce it by half)

• Copies

Hint Like all other information in the setup-related dialog boxes, settings
made here become the new defaults for this printer.

7. Click OK and the current printer configuration information is saved.
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Sending Output to the Printer

To send the entire contents of the window to the printer:

1. Choose File  > Print  and a dialog box appears.

2. Select any print options as needed, and click OK.

Hint The Scale to fit page option will fill the printed page, regardless of the
current value in the Scale field of the Print Setup dialog box

Creating a Printer-specific Print File

You can create a print file in the format used by a particular printer by associating
that printer with the FILE: port. This port appears by default in the Add Printer
dialog box. Once you make the association, you can select this printer as the current
printer and create a print file for it.

To associate the desired printer with the FILE: port:

1. Choose File  > Print Setup .

2. Click Install  > Add Printer .

3. Select the desired printer and the FILE:= port definition.

4. Click Add Selected. The Printer Installation dialog box is updated.

5. Dismiss  the Add Printer and Printer Installation dialog boxes.
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To make this printer the current printer:

1. Click Options  and select the printer associated with FILE:  from the Printer
Name drop-down list.

2. Change any options as needed and click OK.

3. Click OK in the Print Setup dialog box.

To create the print file:

1. Choose File  > Print .

2. Select any print options as needed, and click OK. A dialog box appears
prompting you for a filename.

3. Change directories if desired—the file is written to the current project by
default—and supply a name in the Output To File field. Click OK. The file is
written to the specified directory.
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Printing to File in a Generic Format

You can send your output to file, in a limited number of generic formats, which can
then be imported in a variety of applications. The available formats are:

• Encapsulated Postscript

• PCL4

• PCL5

Note You have the option of converting to an HPGL/2 file when you choose
File > Print.

To establish a print setup for printing to file:

1. Choose File  > Print Setup .

2. Select File (Generic Only)  as the Output Format.

3. Select a different file type from the drop-down list as needed. The
default File Name is updated to reflect the selected file type.

4. Set the following options as desired:

• Orientation

• Scale

• Copies

5. Click OK in the Print Setup dialog box.

To print to file:

1. Choose File  > Print  and a dialog box appears offering additional options.

2. Select any or all of these options, as needed, and click OK.

3. The file is written to the current project directory, using the filename from the
Print Setup dialog box.
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Printing from the PC
This section describes some of the actual printing features available on the PC. For
information on basics (such as adding a printer), refer to your Windows
documentation.

Printing from Advanced Design System on the PC is accomplished by establishing
the desired print setup and then choosing File > Print (or Print Area). Listed below
are some of the more common options you can set through the Print Setup and
related dialog boxes:

Note The options available vary based on the printer/printer driver you select.

• Printer (select any installed printer)

• Paper size and source

• Orientation (Landscape is generally recommended for schematics and layouts)

• Number of copies

• Single- or two-sided printing

• Scaling

When you choose File > Print, you can select from the following additional options:

Select this option to send output to file for printing at a later time. Select
Enhanced Metafile, Windows Metafile, or HP-GL/2 as the file format
when the Print to File dialog box appears.

Select this option to print in color (on a color printer) or in grayscale,
rather than black and white (on a monochrome printer).

Select this option to place the image on the Windows clipboard (Bitmap)
for pasting in any Windows application.

Select this option to fill the printed page. If selected, this option overrides
any scaling percentage you have set.
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Establishing a Print Setup

To establish a print setup:

1. Choose File  > Print Setup .

2. Select the desired printer from the drop-down list.

3. Change any of the options here as desired, or click Properties  to set additional
options, such as Scaling. Note that the appearance of the Properties dialog box
varies depending on the selected printer.

4. Change any other options as desired and click OK to dismiss the Properties
dialog box.

5. Click OK in the Print Setup dialog box and you are ready to print.
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Basic Printing

To send the entire contents of the window to the printer:

1. Choose File  > Print  and a dialog box appears.

Note The Fit to page option overrides any scaling percentage set. Disable this
option if you have intentionally set a scaling percentage.

2. Change any print options as needed, and click OK.

To print a specific region of your schematic or layout:

1. Choose File  > Print Area . As you move your pointer into the drawing area, it
changes to a cross-hair cursor, and the Status panel prompt changes to read,
PrintArea: Enter the starting point.

2. Position the pointer at one corner of a window that will enclose the area you
want to print, and click. The Status panel prompt changes to read, PrintArea:
Enter the next point.

3. As you move the mouse, a ghost image of the window is drawn. Click again to
specify the opposite corner of the window and the Print dialog box appears.

4. Change any options as needed and click OK to print the specified region.
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Printing a Scaled Layout

To scale a layout for printing:

Note This process involves flattening and, potentially, scaling your layout in ADS.
You can do this to your actual design—and then close it without saving changes—or
make a copy of it before printing and make the changes to the copy.

1. Choose File  > Save Design As  to make a copy of the layout.

2. Choose Edit  > Component  > Flatten  to convert it to shapes-only information.
(Components are not scalable.)

3. Choose Insert  > Measure  and establish the size of the design.

4. Determine the appropriate scaling factor based on the actual size of the design
and the paper size you want to use.

Note The ability to scale a design for printing is a function of the printer driver
associated with the selected printer. In general, PostScript printer drivers
enable scaling while PCL printer drivers do not. Many printer drivers can be
downloaded from the Internet. If your printer driver does not allow a
sufficiently large scaling factor, you can also scale the design in ADS to reach a
combined scale factor appropriate for your layout.
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The example shown here is based on a design from the examples directory:
/examples/MW_Ckts/drc_via_prj/pwramp.

This design measures 1525 microns (or 0.1525 cm) across, and is close enough
to being square to use that measurement as the basis for determining a scaling
factor. In this example we want to basically fill ANSI E paper (34" x 44") and so
we convert the metric units to English units 0.1525 cm x 0.39370 = ~0.06
inches. To simplify this example, we settle on a 30 inch image, yielding a
required scaling factor of 500 (30 / 0.06 = 500).

5. To verify the maximum scaling factor your printer driver allows, choose File  >
Print Setup  and click Properties .
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6. Locate the Scaling option. It may appear on the tab displayed by default, or in
an Advanced tab, as shown in this example.

7. Select the Scaling  option and supply the desired scaling percentage in the field
provided.

In this example, we opted for 500% (factor of 5) scaling through the printer
driver, and a scale factor of 100 (for a total of 500) through ADS.

8. Select the Paper Size  option and select the appropriate size.

9. Change any other options as desired and click OK to dismiss the Properties
dialog box.

10. Click OK in the Print Setup dialog box.

11. If necessary, scale the design in ADS. Choose Select  > Select All ., then choose
Edit > Scale/Oversize > Scale . Supply the desired scaling factor, in this example,
100, and click OK.
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12. Choose View  > View All .

13. Choose File > Print Area and draw a border around the layout. (This is to ensure
best results, since printing otherwise begins at the coordinates 0,0 and may
include empty space.)

14. When the Print dialog box appears, select any other options as desired, such as
Color Output if your printer is a color printer.

Note The Fit to page option overrides any scaling percentage set. Disable this
option if you have intentionally set a scaling percentage.
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Chapter 12: Using the Text Editor
Hpeesofeedit is a general-purpose ASCII text editor capable of editing one file at a
time. It enables you to cut and paste, search for text, replace text, and go to a specific
line of text. You can access Hpeesofeedit from the Options menu in the Main window
or you can start it from any command shell. The topics described here are:

• “Starting the Text Editor Program” on page 12-1

• “Text File Management” on page 12-3

• “Editing Text Files” on page 12-5

• “Performing Search and Replace Operations” on page 12-6

• “Keyboard Mappings” on page 12-8

Starting the Text Editor Program
To start the text editor program:

• Choose Options  > Text Editor  in the Main window.

or

• Type hpeesofeedit  in any command shell, and press Return .

The Hpeesofeedit window appears.

The status bar displays warnings, the status of the search/replace operation, and the
current line number and character position. The copyright message is displayed in
the status bar until you begin typing. The text entry portion of the edit window
displays all text you type or paste into the window.

Status bar Current line number, character position
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Command Line Options

The Hpeesofeedit program accepts most standard X/Xt command line options. These
options are listed in Table 12-1. (For further details on these options, refer to your
UNIX documentation.)

To start the Hpeesofeedit program with a command line option:

In any command shell, type hpeesofeedit  <desired option> and press Return .

Alternatively, any of these resources can be specified in your resource file using
Hpeesofeedit as the class name. Hpeesofeedit is also the resource filename for the
program.

Note Any option not preceded by a dash (-) is treated as a filename and the program
will attempt to open a file by this name. If a file by this name does not exist, a new file
is created.

Table 12-1. Command line options

Option Argument Example

-background, -bg color_name -bg white

-foreground, -fg color_name -fg blue

-display display_name -display unix:0

-geometry geometry string -geometry 300x400+10+30

-iconic

-xrm X-resource -xrm "*background:blue"
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Text File Management
Basic file operations include creating new files, opening existing files, inserting
existing files into other files, and printing and saving files.

Creating a Text File

To crete a new text file:

1. Select File > New. If there is currently any text in the window, you are prompted
Text exists, clear?

• To avoid clearing the text in the window, click No and then take the desired
action.

• To clear it and start a new file, click Yes.

2. When the window is empty and labeled untitled, type the desired text. (You
assign a name to the file when you save it.)

Opening an Existing File

To open an existing file:

1. Select File  > Open . If there is currently any text in the window, you are
prompted Text exists, clear?

• To avoid clearing the text in the window, click No and then take the desired
action.

• To clear it and open a file, click Yes, and a dialog box appears.

The default file filter is an asterisk (*) so all files in the current directory are
listed.

2. Select the desired file and click Open . The file appears in the Hpeesofeedit
window for editing.
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Inserting One Text File into Another

The Insert command enables you to insert a text file, in its entirety, into another text
file.

To insert a text file into the currently open file:

1. Select File  > Insert . A dialog box appears.

2. Select the desired file and click Insert . The selected file is inserted at the current
cursor position in the currently open file.

Saving Text Files

The File menu contains two commands related to saving files: Save and Save As.

• The Save command enables you to save changes to an existing file.

• The Save As command enables you save a new file, and name it in the process,
or save an existing file with a new name. For example, if you would like a copy
of an existing file so that you can make changes to it while preserving the
original, you can use the Save As command to create a copy of the file with
another name.

To save an existing file:

Select File > Save. The file is saved and the number of bytes and path/filename are
displayed in the status bar.

To save a new file or to save an existing file with a new name:

1. Select File  > Save As...  and a dialog box appears.

2. Adjust the path, if desired.

3. Enter a name for the file in the Selection field.

4. Choose Save As . The file is saved.
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Printing Text Files

To print a text file:

Select File  > Print . The file is sent to the printer and a status window appears
briefly displaying the status of the print request and noting which printer was
used.

Note The setting of the environment variable PRINTER determines which printer
is used. If this variable is not set, the default printer is used.

Exiting the Text Editor

To exit the program:

Select File  > Quit . If the file has been modified since the last save, you are prompted,
File Modified, exit anyway?

• To exit without saving the file, click Yes.

• To cancel so that you can save the file, click No.

Editing Text Files
The Edit menu enables you to copy, cut, paste, and delete text.

To copy text from one location to another:

1. Select the text you wish to copy.

2. Select Edit  > Copy. The selected text is copied to the buffer.

3. Position the cursor in the desired location (in any window) and select Paste .

To move text from one location to another:

1. Select the text you wish to move.

2. Select Edit  > Cut . The selected text is removed from that location and placed in
the buffer.

3. Position the cursor in the desired location (in any window) and select Paste .

To paste text currently being held in the buffer:
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Position the cursor in the desired location (in any window) and select Edit  > Paste .
The contents of the buffer appear at the current cursor location.

To delete text:

Select the text you want to delete and select Edit  > Delete . The selected text
disappears.

Performing Search and Replace Operations
The Search menu contains commands to enable you to jump to a specified line
number in the text file and to search for and replace specified text strings.

To jump to a specific line number in the file:

1. Select Search  > Go To...  and a dialog box appears.

2. Type the desired line number and click OK. The cursor jumps to that line
number in the file.

To perform the search and replace operation:

1. Select Search > Search/Replace... and a dialog box appears. In the Search String
field, type the string of characters you want to search for, including wildcard
characters, if desired. (If you use wildcard characters, you must check the box
labeled Regular Expression.)
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2. In the Replace String field, type the string of characters you want to use to
replace the Search String characters.

3. Optionally, check this box if you want to search backward from the current
cursor position.

4. Optionally, check this box if you want to include wildcard characters in your
search.

Note For details on including Regular Expressions in your search, refer to your
UNIX documentation.

5. Click Search . If the requested text is found, it is highlighted; if it is not found, a
pop-up appears and displays the message String not found.

6. If you want to replace the highlighted occurrence with the contents of the
Replace String field, click Replace . The highlighted text is replaced.

Hint To clear the highlight from text at any time, simply click somewhere
inside the text editor window.

7. If you want to replace every occurrence of the specified search string at once,
click Replace All . Every occurrence is replaced.

8. When you are through using the Search and Replace function, click Cancel  to
clear any remaining highlights from text and dismiss the dialog box.
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Keyboard Mappings
The text entry area in the editor supports the complete Motif set of keyboard
mappings. These mappings are primarily controlled by the XKeysymDB file (or its
equivalent), which is typically found in /usr/lib/X11. Table 12-2 describes the
mapping of the Sun keyboard. (The mappings for the HP and IBM platforms follow
the Sun’s mappings with few exceptions.) Note that the Meta keys are labeled
differently on different keyboards, but are always the keys on either side of the space
bar.

Table 12-2. Keyboard mappings

Keyboard or Mouse Operation Action

Copy Copies selected text to the clipboard

Paste Pastes text from the clipboard to current insertion
point

Cut Cuts selected text to the clipboard

Arrow Keys Moves the insertion point cursor/scrolls window

Shift Arrow Keys Moves insertion point, selects text

Page Up/Down Moves the window up/down by the number of visible
lines

Home/End Moves cursor to beginning/ending of current line

Ctrl Home/End Moves cursor to first/last visible line in window

Back Space Deletes text to left of the insertion cursor

Meta Ctrl left arrow Moves cursor backward one word

Meta Ctrl right arrow Moves cursor forward one word

Meta Ctrl down arrow Moves cursor down one paragraph

Meta Ctrl up arrow Moves cursor up one paragraph

Left mouse button down/move Selects text range

Shift left mouse button down/move Extends selected text range
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Appendix A: Using Online Documentation
The Advanced Design System includes online help and a complete set of online
manuals, and is installed based on the software you choose to install.

The online documentation is in the form of HTML and can be viewed using Netscape
or Internet Explorer. (Other browsers may work but are not supported at this time.)
Most online manuals are also available as PDF files and can be viewed and printed
using Adobe Acrobat Reader.

Individual browsers provide information on using various browser features. To access
this information in Netscape, choose Help > Help followed by Index. In Internet
Explorer, choose Help > Contents and Index.

In the Adobe Acrobat Reader, you can access information on how to use the Reader by
choosing Help > Reader Guide.

Accessing Documentation
To access the online documentation, choose Help > Topics and Index from any ADS
window. The browser opens and displays the online documentation front page. You
can select a topic by clicking the appropriate link at the top of the page.

Searching
The online documentation provides the capability to search for a word or phrase in
the currently open document, a category of manuals, or the entire (installed)
documentation library.

To search for a word or phrase in the currently open document:

• From Netscape, select Edit  > Find In Page . When the Find dialog box opens,
enter the word or phrase in the Find field and click Find .

• From Internet Explorer, select Edit > Find (on this page) . In the Find dialog box,
enter the word or phrase in the Find What field and click Find Next .

To search for a word or phrase in the entire documentation library:

1. From any documentation page, click Search  from the set of links at the top of
the content pane (on the right).

2. Enter the word(s) in the Query field, and click Find .
Accessing Documentation A-1



Hint You can restrict the global search to a specific category of documentation
by selecting a category from the drop-down Search in list. Tips on searching are
provided in the search window itself.

Printing
You can print individual help topics or entire books.

To print a help topic, click once in the content frame (to make it the active frame) and:

• In Netscape, choose File > Print Frame . When the Print dialog box appears, make
the desired selections, and click Print .

• In Internet Explorer, choose File  > Print . When the Print dialog box appears,
make the desired selections, and click OK.

To print an entire book, or contiguous sections (formatted for printing):

Click the Print version of this book (PDF file) link at the top of any page of a
currently displayed manual. When the document is displayed, choose File  > Print .
In the Print dialog box, specify the desired print range.

Hint The page numbering of the PDF file is displayed in the status bar at the bottom
of the window.
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Appendix B: Shortcut Keys
Table B-1 lists the default keyboard shortcuts found in the Main, Schematic, Layout
and Data Display windows. Some of the ADS individual tools also offer the ability to
customize shortcut keys. For details on customizing these shortcuts, refer to the
section, “Customizing Keyboard Shortcuts” on page 9-30.

Table B-1. Shortcut Keys

Edit > Copy/Paste Commands

Cut Ctrl + x

Copy Ctrl + c

Paste Ctrl + v

Copy Using Reference Shift + C

View Commands

View All Ctrl + f

Restore Last View Ctrl + l

Zoom In x2 + (addition key)

Zoom Out x2 - (subtraction key)

Grid/Snap Commands

Grid Display, Minor Grid Display (toggle on/off) Ctrl + g

Minor Grid Display Ctrl + g

Major Grid Display Shift + g

Snap Enabled Ctrl + e

Move Commands

Move Using Reference Ctrl + m

Move Wire/Trace Endpoint Ctrl + Shift + m

Move Component Text (Edit > Move) F5

Rotate Commands

Rotate Shift + r

Mirror About X Shift + x

Mirror About Y Shift + y

Rotate -90 Ctrl + r
B-1



File Management Commands

New Design Ctrl + n

Open Design Ctrl + o

Save Design Ctrl + s

Window Commands

Close Window (Schematic and Layout windows) Ctrl + F4

Schematic (Schematic and Layout windows) Ctrl + Shift + s

Layout (Schematic and Layout windows) Ctrl + Shift + l

New Schematic (Main window) Ctrl + Shift + n

New Layout (Main window) Ctrl + Shift + a

Designs Open Ctrl + d

Shape Commands

Polygon (Insert) Ctrl + Shift + p

Rectangle (Insert) Ctrl + Shift + r

Undo Commands

Undo Ctrl + z

Undo Vertex Shift + z

Help Commands

What’s This? Shift F1

Topics and Index F1

Simulate Commands

Simulate F7

Select Commands

Select All (Select) Ctrl + a

Miscellaneous Commands

Print (File) Ctrl + p

Change Entry Layer To (Insert) Ctrl + Shift + c

Delete (Edit) Del

End Command (Edit) Esc

Text (Insert) Ctrl + Shift + t

Table B-1. Shortcut Keys (continued)
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Table B-2 lists the default shortcut keys, in alphabetical order, to enable you to see at
a glance which ones are in use. If you attempt to assign any of these to other
commands, you are warned and given the choice to proceed or to select another key
sequence (see footnote for Alt).

Clear Highlighting (View) F8

Wire (Insert) Ctrl + w

Trace (Insert) Ctrl + t

Exit Advanced Design System (File) Alt + F4

Table B-2. Sorted Default Shortcut Keys

Ctrl Ctrl + Shift Shift Alt* Others

Ctrl + a Ctrl + Shift + a Shift F1 a + (add key)

Ctrl + c Ctrl + Shift + c Shift + C d - (subtract key)

Ctrl + d Ctrl + Shift + l Shift + g e Alt + F4

Ctrl + e Ctrl + Shift + m Shift + r f Del

Ctrl + f Ctrl + Shift + n Shift + x h Esc

Ctrl + f4 Ctrl + Shift + p Shift + y i F1

Ctrl + g Ctrl + Shift + r Shift + z l F5

Ctrl + l Ctrl + Shift + s m F7

Ctrl + m Ctrl + Shift + t o F8

Ctrl + n r

Ctrl + o s

Ctrl + p t

Ctrl + r v

Ctrl + s w

Ctrl + t

Ctrl + v

Ctrl + w

Ctrl + x

Table B-1. Shortcut Keys (continued)
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Ctrl + z

* If you use Alt as the modifier key (when creating custom shortcuts), and a letter that is already
assigned as an accelerator for a menu (listed in this table), the menu accelerator is replaced by your
custom shortcut with no warning.

Table B-2. Sorted Default Shortcut Keys (continued)

Ctrl Ctrl + Shift Shift Alt* Others
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Appendix C: Using Advanced Design
System Across Platforms
A device library or design project stored on a shared volume can be accessed and
modified from either a PC or a UNIX workstation. In addition, files created on one
platform can be transferred and used on another.

When creating and modifying a file on a shared volume, keep in mind the following:

• You need read and write access to modify a file on a shared volume.

• Only one user can access a file at a time.

Files can be transferred electronically via FTP or they can be moved physically using
a medium such as floppy disks. When transferring libraries and projects from one
platform to another, keep in mind the following:

• Use a Binary (image) file transfer method.

• Maintain the original file and directory structure at all times.

• Copy all hidden files.

• Use the Archive Project command before copying a project to a diskette or
transferring it via FTP. For details, refer to “Archiving a Project” on page 2-11.

Note If a project created on UNIX contains two or more designs whose names
are only distinguishable from one another by differences in case, do not archive
and transfer this project to a PC without renaming the designs such that they
all have unique names. This requirement is due to the fact that the PC is case
insensitive.
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Opening Projects
To open a project, you need a licensed copy of Advanced Design System for your
current platform and access to the current location of the project files.

To open a project:

1. In the Main window, choose File  > Open Project  or click the Open Project button.

2. In the dialog box that appears, select the project and click OK.

Guidelines for Cross-platform Use
Use the following guidelines when creating libraries or projects for cross-platform
use:

• Use filename characters and conventions that are legal on both platforms. For
example, Windows does not recognize case-sensitive differences in filenames.

• Use only the standard ASCII character set for text.

• Use fonts that are standard on both platforms.

• Use colors that are standard on both platforms.
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Appendix D: Glossary
accelerator keys

See shortcut keys.

active design

The design currently displayed in any window.

active window

The window to which the next keystroke or command will apply. If a window is
active, its title bar changes color to differentiate it from other open windows.

AEL

Application Extension Language. A C-like general purpose interpreted language
used in Advanced Design System products to configure and define extensions to
the design environment. It is available to any application as a linkable library.

annotation

Old Series IV term used to denote explanatory text that is automatically placed
with a component. Now referred to as component text.

back annotation

Synchronizing values between optimization and the Schematic window, or
between a schematic and its associated layout.

background

The drawing area of a screen upon which a design or data display is placed.

bias-dependent analysis

Whenever a single-point DC bias analysis is required to carry out a linear
analysis, it is referred to as a bias-dependent analysis.

boot

To start or restart your computer by loading the operating system.

budget analysis

A single-tone bandpass analysis that determines the system internodal signal and
noise performance for components in the top level of a system network.
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bundle

A collection of wires (or buses) that do not share the same base name, for example,
Data<1>,ABC<1>.

bus

A set of wires or a single wire carrying a set of signals. For example, Data<1>,
Data<2>, Data<3> represents a bus because all three wires share the base name
Data.

bus pin

A vectorized pin is a component pin that represents multiple connections into the
component.

check box

A small box or circle inside a dialog box. A check box represents an option and it
can be turned on and off. When the option is selected, it appears darkened.

click

To press and release a mouse button quickly (most often, the left mouse button).

command

A word or phrase found on a menu or represented by a button on a toolbar, that
you choose to carry out an action.

component text

Explanatory text that is automatically placed with a component.

connection width

The total number of pins at a given port of an iterated instance. Computed by
multiplying the pin width at the port by the instance width.

convolution

A SPICE-type analysis involving the solution of a set of integro-differential
equations that express the frequency dependence of the currents and voltages of
the circuit under analysis. Convolution represents all the distributed elements in
the frequency domain to enable analysis of their frequency-dependent behavior. It
is based upon the premise that characterization of many RF and microwave
distributed elements is best accomplished in the frequency domain.
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cursor

A graphical representation of the location of the mouse. A cursor appears when the
location requires text input.

data display window

Window in which to view simulation results. A data display window can be opened
from the Main window, a Schematic window, or a Layout window.

data set

A file that contains data from a given simulation.

design environment

The entire group of windows used for creating and simulating designs and viewing
results for the Agilent EEsof simulator suite. It includes the Main window, all
Design windows, the Message/Status window, and the Data Display window.

design files

Project files, which include schematic and layout information. These files have
a .dsn extension.

design units

See layout units, schem units.

design windows

Schematic and Layout windows.

dialog box

A rectangular box that requests and/or provides information.

directory

A collection of files and subdirectories that are stored at the same location on a
disk. See also subdirectory.

double-click

To press and release a mouse button twice in rapid succession without moving the
mouse. Double-clicking carries out an action, such as displaying the dialog box for
editing component parameters.
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drag

To move an item on the screen by pressing and holding down the mouse button
and then moving the mouse. For example, you can move a window to another
location on the screen by dragging its title bar.

drawing formats

Templates for use as a design sheet that include a title block and space for design
information. Standard sizes include: A, B, C, D, E, and metric.

Electrical component models

Models based on circuit theory signal S-parameters and noise wave parameters.
Each port of any n-port electrical element has a bidirectional signal flow; that is,
each port has an input and output signal and noise characteristic. At any port of
an n-port electrical element, incident signal and noise produce reflected signal and
noise at the incident port; the incident signal and noise produce signal and noise
output at all other n-1 element ports.

component

An item placed in the Schematic or Layout window, typically an electrical
component or specification.

Functional, optical, and DSP component models

Models based on transformation of input signals and noise into output signals and
noise. Each component port is unidirectional, and is either an input port or an
output port.

graph

A diagram showing the values of a function.

grid

A set of evenly spaced horizontal and vertical dots or lines to aid in locating
specific points.

harmonic balance

An iterative method of analysis based on the assumption that for a given
sinusoidal excitation, there exists a steady-state solution that can be
approximated to satisfactory accuracy using a finite Fourier series.
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hierarchical design

A network design containing one or more subnetworks.

histograms

There are two types of histograms available with yield analysis: sensitivity and
measurement histograms.

• The sensitivity histogram plots percent pass versus parameter value bin. Each
sample has parameter values randomly assigned to those parameters with yield
value types.

• The measurement histogram plots percent of samples versus measurement
value bin. The random parameter values causes the measurements listed in a
MEAS_HIST item to be statistically distributed.

instance width

The number of instances in an iterated instance.

iterated instance

An instance whose instance name has been modified to include a vectorized label.
For example, Rx<0:2> refers to Rx<0>,Rx<1>,Rx<2>.

iterated pin

See bus pin.

keyboard shortcuts

See shortcut keys.

large-signal S-parameter analysis

The calculation of large-signal, power-dependent S-parameters of a 2-port
network, which can be stored in a P2D disk file for use in the system simulator.

layout units

The unit used for grid display and cursor snapping, usually the same as length
unit. (See also length unit and schem units.)
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length unit

In the Schematic and Layout windows, the unit of measure for parameters with
physical length. Also the unit used for grid display and cursor snapping in the
Layout window. (See also layout units and schem units.)

library

A collection of components sharing similar characteristics.

list box

A region within a dialog box that lists all available choices.

macro

A series of actions represented by AEL functions that can be played back using the
Playback Macro command on the Options menu of the Main window. May also
refer to AEL artwork macros that you can assign to networks or new components.

menu bar

The horizontal bar containing the names of all the menus. It appears below the
title bar.

message window

A window that is displayed during simulation and optimization. Messages
displayed within this window report on the status of the current operation.

meta key

The key on either side of the space bar. The label on this key varies depending on
the keyboard manufacturer.

mnemonics

A series of keys pressed to initiate a command. The key combination typically
includes a significant letter in the command name, such as Alt + F to access the
File menu. See also shortcut keys.

net width

The number of individual wires in a bus/bundle.

netlist

A textual listing of all the parts in a design showing how they are interconnected.
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network

A design consisting of interconnected components with input/output ports, and
with associated data, units, and optional variables and equation items. In general,
a network can have a schematic and a layout representation.

node

The connection of pins of two or more components or items.

nonlinear steady-state circuit analysis

An analysis performed by the Harmonic Balance, Oscillator, or Large-signal
S-parameter test benches. The types of analyses are:

• Harmonic balance analysis (single- and multi-tone)

• Mixer analysis

• Dynamic load-line analysis

• Oscillator analysis

• Large-signal S-parameter analysis

nonlinear transient time-domain circuit analysis

An analysis involving the solution of a set of integro-differential equations that
express the time dependence of the currents and voltages of the circuit under
analysis. The result is a nonlinear analysis with respect to time and, possibly, a
swept variable.

optimization

There are two kinds of optimization: performance optimization and yield
optimization.

• Performance optimization is the process of modifying parameter values in order
to satisfy predetermined performance criteria. Optimizers compare the
computed and desired responses and modify design parameter values to bring
the computed response closer to the desired response.

• Yield optimization involves a series of yield analyses where the yield variable
nominal values are adjusted to maximize the yield estimate. In yield
optimization, each yield improvement is referred to as a design iteration.
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oscillator analysis

A special kind of harmonic balance analysis in which the frequency of operation
varies as the algorithm progresses, allowing the simulator to zoom in on the actual
frequency of oscillation for a given oscillator circuit.

palette

A set of buttons with icons representing various commands that allow quick
execution of those commands (found on the left side of all design windows).

parameters

The characteristics defining a component.

parametric subnetwork

A network design with associated parameters that are passed to the main network
when it is placed as a subnetwork within the main network.

PDE

See project design environment.

pin

A terminal on a schematic or layout component.

pin width

The number of pins at the given port of a component. See also bus pin.

pointer

A graphical representation of the current location of the mouse

port

Refers to either a terminal on a network or symbol to indicate input or output.

post production tuning

A process that combines with yield analysis to allow certain parameter values to
receive additional tuning. Typically, post production tuning is used to ensure that
yield specifications are met.

project

A set of designs stored in a predetermined directory structure referred to as a
project directory. It contains subdirectories for different types of files.
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Project Design Environment

The entire group of windows used for creating and simulating designs and viewing
results for a project using the Agilent EEsof simulator suite.

schem units

In the Schematic window, the unit used for grid display and cursor snapping,
inches. (See also length unit and layout units.)

scroll bars

The bars at the bottom and right edge of a window or list box that appear when the
contents are not entirely visible. Each scroll bar contains a small box, called a
scroll box, and two scroll arrows to allow different directions in scrolling.

shortcut keys

A combination of one or more modifier keys (Ctrl, Shift, Alt, etc.) and a letter that
equates to a command. Pressing these keys initiates the command, for example,
Ctrl + r initiates the rotate command.

small-signal analysis

An alternate mode of analysis that often increases simulation speed. When used
for mixers, small-signal analysis assumes that amplitude of the RF signal is small
enough to generate negligible harmonics, and that the power level of the RF signal
is smaller than that of the LO signal.

spurious signals

Spurious signals are generated within RF systems by mixers, nonlinear
amplifiers, and spectrally impure oscillators.

statistical design

The process of varying a set of parameter values over specified probability
distributions to determine how many possible combinations satisfy predetermined
performance criteria. The statistical design methods used are yield analysis, yield
optimization.
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subnetwork

A network that is used as a component inside of another network.

symbol

A graphical representation of a component or subnetwork.

tap

A tap is a wire connected to a bus that splits a wire (or in the case of multi-wire
tapping, a new bus/bundle) off of a bus/bundle.

toolbar

A group of buttons with icons representing various commands that allow quick
execution of those commands (found at the top of all design windows).

units

See individual entries for design units, length units, layout units, and schem units.

user units

Old Series IV term for schem units or layout units.

vertex

A beginning or ending point, turn, or junction in a segment.

wildcard character

A character that represents another character. In filenames, you can use the
asterisk (*) as a wildcard character to indicate any character or group of
characters that might match that position in other filenames. For example, *.dsn
represents all files with the .dsn filename extension.

yield analysis

A process involving a yield estimation over a given number of trials in which the
yield variables have values that vary statistically about their nominal values
according to specified probability distribution functions.

yield optimization

See optimization.
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Index

Symbols
.lay files, 9-29
.prf files, 9-20

A
accelerator keys, B-1, D-9

customizing, 9-30
Activate command, 8-13
Add command (Edit > Vertex), 6-29
Advanced Design System Setup command,

1-4
Advanced Rotate commands (Edit menu)

Rotate Around Reference, 6-23
Rotate Relative, 6-23
Set Rotation Angle command, 6-25

annotation
adding system variables to your designs, 7-3

Arc (clockwise) command, 7-6
Arc (counter-clockwise) command, 7-6
Arc (start,end,circumference) command, 7-6
Archive Project command, 2-11
Arrow command, 7-7
Attach Component Palette command, 1-14

B
backup of design file, automatic, 9-14
balloon help

changing timing of display, 1-8
described, 1-8
turning on/off, 1-34

Bill of Materials
command, 3-56

bitmap size, changing, 1-34
Break command (Edit > Modify), 6-28
Break Connections command, 6-7

C
cancel

see End Command, 1-9
Change Component Text Layer command,

6-9
Check Representation command, 5-7
Circle command, 7-7
circles

converting to simple polygons, 6-26

Clear Component History command, 9-34
Clear Highlighting command, 8-13
Close All Designs command, 2-22
Close Design command (File menu), 2-21
Close View command (component library),

3-13
Close Window command (design windows),

1-16
colors

saving preference file, 9-21
Command Line command, 3-54
Component History command, 3-15
Component Library command, 3-4
Component Palette command, 3-14
Component Properties command

(component library), 3-13
component text

making visible/invisible, 9-27
Component Text Attributes command (Edit

> Component), 6-10
components

connecting, 3-26
editing parameters, 6-3
locating by browsing, 3-4
locating by searching, 3-6
orientation of, 3-19
parameters, displaying on schematic, 6-5
placing

at specific coordinates, 3-18
in drawing area, 3-3

rotating
after placing, 3-19
prior to placing, 3-19

text
changing layer/visibility, 9-15
editing attributes of existing, 6-10
establishing attributes in advance, 9-15
moving, 6-9

connecting
components, 3-26

context-sensitive commands, the pop-up
menu, 1-9

Convert To Polygon command, 6-27
Coordinate Entry command, 3-18, 7-8
Coordinate Readout command, 1-10
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coordinate readouts
differential, 9-34
display of, 9-34
positional, 9-34

Copy And Oversize command (scaling), 6-34
Copy command, 6-15
Copy command (component library), 3-10
Copy Design command, 2-20
Copy Project command, 2-6
Copy Relative command, 6-16
Copy To Layer command, 6-17
Copy Using Reference command, 6-16
Create Component Palette command, 9-34
Create Hierarchy command, 4-1, 4-2
Create/Edit Schematic command, 10-3
Create/Edit Schematic Symbol command,

10-3
Cut command, 6-15
Cut command (component library), 3-10

D
data displays

opening automatically, 8-10
date

system
annotating your designs with, 7-3

Deactivate command, 8-13
Delete All command (Edit menu), 2-21
Delete command, 6-1
Delete Design command, 2-21
Delete Project command, 2-7
Delete View command, 5-3
Deselect All command, 6-11
Deselect By Name command, 6-13
Deselect Window command, 6-13
deselecting a group, 6-13
deselecting by name, 6-12
Design Hierarchies command, 5-5
Design Parameters command, 4-6
design windows

defined, 1-8
opening multiple, 1-11

designs
copying, 2-20
creating, 2-15
deleting, 2-21
importing/exporting, 2-12
saving, 2-17

saving/clearing all at once, 2-18
Detach Component Palette command, 1-13
differential coordinate readout, 9-34
display, Schematic/Layout windows,

customizing, 9-1
documentation, online

printing, A-2
searching, A-1
using, A-1

Drag and Move option, 6-19, 9-14

E
Edit Component Parameters command, 6-4
Electronic Notebook command, 1-24
End Command, 1-9, 7-4
Entry Layer command, 7-2, 9-30
Example Project command, 2-8
example projects

copying, 2-6
Exit Advanced Design System command,

1-36
exiting

ADS, 1-36
Explode command (Edit > Modify), 6-29
Export command, 2-14
exporting

procedure described, 2-14
extensions

data display filenames, 8-12
data set filenames, 8-8
design filenames, 2-15
template filenames, 2-17

F
file-based parameters, 3-52
filename

extensions
data display files, 8-12
data set files, 8-8
design files, 2-15
template files, 2-17

filenames
restrictions, 1-20

files
See designs, 2-15

filters (selection)
changing through Preferences, 9-3

Find command (component library), 3-6
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fonts. See text
Force To Grid command, 6-36

G
Generate Symbol command, 10-4
Global Node command, 3-28
Grid/Snap command, 9-6, 10-6
grids

display
defined, 9-6
setting spacing, 9-6, 10-6

snap
defined, 9-6
setting spacing, 9-6, 10-6

Group Edit Parameter Value command, 6-6

H
help

balloon, described, 1-8
hierarchical designs

creating, 4-1
creating parametric subnetworks, 4-1, 4-3
parametric subnetwork, defined, 4-3
viewing detailed information of, 5-5

Hierarchy command, 5-6
Hot Key/Toolbar Configuration command,

9-31
hot keys, B-1

customizing, 9-30

I
Identify command, 5-4
Import command, 2-13
importing

data files of various formats, 2-12
Include/Remove Projects command, 2-9
Info command, 5-4
inherited pins. See pins, power
Insert Template command, 2-16

J
Join command (Edit > Modify), 6-28

K
keyboard

shortcuts
customizing, 9-30
defaults, B-1

keyboard shortcuts, B-1, D-9

L
layer files

customizing, 9-29
layers

defining/changing, 9-22
for drawing, 10-7
making visible/invisible, 9-27
protecting from selection, 9-27
saving custom definitions, 9-29

Layers command, 9-22
Layout command (Window menu), 1-11
layout.prf file, 9-20
Length Units

defined, 3-2
Library command, 3-9
Library Properties command (component

library), 3-13
licenses

viewing status of, 1-33
Line Thickness command, 7-8
Load Sharing Facility

using for simulation, 8-9
LSF utility, 8-9

M
macros

playing back, 3-54
recording, 3-53

Main window
overview, 1-7

Measure command, 3-26
Message window, 1-16
Mirror About X command, 6-24
Mirror About Y, 6-24
Mirror About Y command, 6-24
Miter command (Edit > Vertex), 6-31
mnemonics, B-1, D-6

customizing, 9-30
Modify commands (Edit menu)

Break, 6-28
Convert To Polygon, 6-27
Explode, 6-29
Force To Grid, 6-36
Join, 6-28
Set Origin, 10-10
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Move & Disconnect command (Edit >
Move), 6-21

Move commands (Edit menu)
Move & Disconnect, 6-21
Move Edge, 6-32
Move Relative, 6-20
Move To Layer, 6-21
Move Using Reference, 6-20
Move Wire Endpoint, 3-27

Move Component Text command, 6-9
Move Edge command (Edit > Move), 6-32
Move Relative command (Edit > Move), 6-20
Move To Layer command (Edit > Move), 6-21
Move Using Reference command, 6-20
Move Wire Endpoint command, 3-27
moving

a vertex, 6-29
component text, 6-9
components and shapes, 6-19
shortcut using mouse, 6-19

N
Name Node command, see Wire/Pin

Label, 3-28
netlist

creating a, 3-55
New command

Schematic/Layout window, 2-15
New Data Display command, 8-12
New Layout command (Window menu), 1-11
New Project command

Main window, 2-1
New Schematic command (Window menu),

1-11
nodes

identifying as output for dataset, 3-28
notebook, electronic, 1-24

O
online documentation

printing, A-2
searching, A-1
using, A-1

on-screen text editor, 6-34
Open command

Schematic/Layout windows, 2-19
Open Data Display command, 8-12
Open Project command

Main window, 2-4
Open View command (component library),

3-13
orientation of components, 3-19
Oversize command (scaling), 6-33

P
palettes

creating custom, 9-34
defined, 3-14
detaching from window, 1-13
re-attaching to the window, 1-14
selecting items from, 3-14
using and changing component, 1-13

Pan View command, 5-2
parameter editing, 6-2

group with common parameters, 6-6
on the screen, 6-2
through dialog box, 6-3

parameters
displaying on schematic, 6-5
editing component, 6-3
file-based, 3-52

Parameters command (File menu), 4-9
parametric

subnetwork, see hierarchical designs
Parts List command, 3-56
Paste command, 6-15
Paste command (component library), 3-10
PDE (Project Design Environment), 1-5
pick box

changing the size of, 9-4
defined, 9-4

Pin Snap, defined, 9-7
pins

adding to a symbol, 10-9
changing the color of, 9-11
defining characteristics of, 10-12
display of names, 9-11
display of numbers, 9-11
displaying connections, 9-11
power, 10-9, 10-10
symbol, 10-9

Playback Macro command, 3-54
Polygon command, 7-5
polygons

editing, 6-28
Polyline command, 7-5
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polylines
editing, 6-28

Pop Out of Hierarchy command, 4-13
pop-up menu, using as a shortcut, 1-9
positional coordinate readout, 9-34
Power Pin command, 10-10
Preferences command

design windows, 9-2
Main window, 1-34

Preferences command (library browser),
3-11

Print Area command, 11-1
Print command, 11-1
Print Setup command, 11-1
printing

online documentation, A-2
printing/plotting

a scaled layout, 11-15
adding a printer (UNIX), 11-3
PC (overview), 11-12
UNIX (overview), 11-2

Project Design Environment (PDE), 1-5
project directories

copying, 2-6
creating, 2-1
deleting, 2-7
described, 2-1
opening, 2-3

Project Listing command, 2-5
Properties command, 10-11
Properties command, see Momentum

documentation
Push Into Hierarchy command, 4-13

R
Read command

layers file, 9-29
preference file, 9-21

Rectangle command, 7-4
Redraw View command, 5-3
Remove Node Name command, 3-29
Reports command, 3-56
Reset/Update command (component

library), 3-13
Restore Last View command, 5-3
Restore Status command, 1-6
Restore View command, 5-3
Revert to Saved Design command, 2-17

Rotate command, 3-19
rotating

components
after placing, 3-19
prior to placing, 3-19

setting default snapping angle, 9-14
Rotation Increment (angle) option, 3-19, 6-22

S
Save All Designs command, 2-18
Save As command

design windows, 2-17
Save As Template command, 2-17
Save command

design windows, 2-17
layer file, 9-29
preference file, 9-21

Save View As command (component
library), 3-13

Save View command, 5-3
Scale command, 6-33
scale factors, 3-21
scaling

objects
using a scaling factor, 6-33
using design units, 6-33

Schematic
command (Window menu), 1-11
window, overview of, 1-15

schematic
symbols, see symbols

schematic.prf file, 9-20
screen, refresh, 5-3
search paths

modifying, 10-18
Search/Replace Reference command, 6-8
searching

for components, 3-6
online documentation, A-1

Select All command, 6-11
Select By Name command, 6-12
selecting

a group using a selection window, 6-13
by name, 6-12
controlling the process of, 9-3
using filters, 9-3

Set Component Orientation command (UP,
DOWN, LEFT, RIGHT), 3-19
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Set Origin command, 10-10
shapes

drawing using specific coordinates, 7-8
editing, 6-26
layer display, changing, 9-26

shortcut keys, B-1, D-9
Show All Files command, 1-7
Simulate command, 8-12
Simulation Setup command (Simulate

menu), 8-8
simulations

naming the resulting data set, 8-8
results

displaying automatically, 8-10
setting up to sweep on remote machines in

parallel, 8-9
using the wizard, 8-1

Smart Simulation Wizard command, 8-1
snap

spacing
setting, 9-6, 10-6

Snap Enabled, defined, 9-7
speed keys, B-1

customizing, 9-30
Start Recording Macro command, 3-53
Status Bar command, 1-10
Status window, 1-16
Step And Repeat command, 6-17
Stop Recording Macro command, 3-53
Sub-Library command, 3-9
subnetworks

See hierarchical designs
Swap Components command, 6-7
Symbol Pin command, 10-9
symbols

generating, 10-4
preparing to draw custom, 10-6
usage, 10-1

T
tees

changing the color of, 9-11
templates

creating, 2-16
saving, 2-17

text
adding to a design, 7-2
attributes

editing existing, 6-34
establishing in advance, 9-17

cutting and pasting, 7-2
on-screen editing, 6-34
See also component text, 9-15

Text command (Edit > Text), 6-35
Text command (Insert > Text), 7-2
text editors, launching from HP ADS, 12-1
time

system, annotating your designs with, 7-3
To Arc command (Edit > Vertex), 6-30
Toolbar command, 1-10
toolbars

configuring, 9-31
moving, 1-14

U
Unarchive Project command, 2-11
Undo command

how many times you can use, 9-14
Undo Vertex command, 7-6
units, 3-21

Length, defined, 3-2
Units/Scale (Preferences dialog), 9-19

V
variables

annotating your designs with, 7-3
system

annotating your designs with, 7-3
vertex

adding, 6-29
converting to a mitered edge, 6-31
converting to an arc, 6-30
deleting, 6-30
editing, 6-29
moving, 6-29

Vertex commands (Edit menu)
Add, 6-29
Miter, 6-31
To Arc, 6-30

vertices
specifying for editing, 6-14

Vertices filter
using for editing shapes, 6-14

View All command, 5-2
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W
windows

design
defined, 1-8
opening multiple, 1-11

moving the center point of, 5-2
opening and closing, 1-11
program, overview of, 1-7
repositioning design to view all, 5-2
screen refresh, 5-3

Wire command, 3-27
wire routing

around annotation, 9-12
wire thickness, setting, 1-35
Wire/Pin Label command, 3-28
wires

breaking connections, 6-7
connecting components with, 3-27
tips for working with, 3-27

wizard
smart simulation, 8-1

Z
Zoom Area command, 5-2
Zoom By Factor command, 5-1
Zoom In Point command, 5-1
Zoom Out Point command, 5-1
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