
Quick-start & Troubleshooting Installation Guide For Dynamic link

This Installation tutorial steps you through the process steps unique to the Demonstration
and Evaluation of ADS Dynamic Link to Cadence for setting up to simulate a circuit using

components from the ADS Dynamic Link library.  This is in addition to the Tutorial given in
the RFIC Dynamic Link Users Guide published by Agilent and found in the ADS

documentation.

Why a Quick Installation Guide For Dynamic Link

Getting a properly working ADS/DL installation.  The install process is dependent on the
existing Cadence infrastructure, which is heavily customized by each target customer.
Because of this customization, it is sometimes difficult for customers to get an ADS/DL

installation to work the first time.
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Introduction
This Installation guide steps you through the process steps unique to the Demonstration and Evaluation
of ADS Dynamic Link to Cadence for setting up to simulate a circuit using components from the ADS
Dynamic Link library.  This is in addition to the Tutorial given in the RFIC Dynamic Link Users Guide
published by Agilent and found in the ADS documentation.

Pre-Installation
Please read the guidelines listed in Quick Installation Guide below, this will tell you how much RAM,
disk space and other requirements needed to run the Dynamic Link to Cadence.

RFIC Dynamic Link Use Model
The RFIC Dynamic Link use-model coincides with that of both Cadence and ADS, with only a
few exceptions. The Affirma Analog Circuit design environment user interface is replaced by
ADS’ users interface.  The Affirma features that are not directly replaced by ADS are provided
on the ArtistUtilities pull-down menu in the Cadence Virtuoso Schematic window.

NOTE:  If the ArtistUtilities pull-down menu does not appear in the Cadence Virtuoso
Schematic window, choose Tools > ADS in the Cadence schematic window.

Usage assumes basic familiarity with the Cadence’s Virtuoso schematic capture and Affirma
Analog Circuit Design Environment, as well as basic familiarity with design and simulation in
ADS.



Quick Installation Guide

System Requirements
Minimum Hardware, software and licenses requirements

Minimum hardware requirements RFIC Dynamic Link
• RAM 256MB
• Swap Space 500MB
• Hard Disk 20MB free disk space for Installation

Software Requirements
• RFIC Dynamic Link version 2002 requires ADS 2002
• Operational cadence DFII environment

Dynamic Link is supported by Cadence DFII versions 4.4.3, 4.4.5, and 4.4.6.  And all UNIX operating
system:

• AIX 4.4.3,
• SunOS 5.6, 7, 8
• HP-UX 10.2, 11

NOTE: Cadence DFII 4.4.5,6 requires HP-UX 11 and 4.4.6 requires SunOS 5.8

Licenses
You need the standard Advanced Design System licenses, with the addition of:

RFIC Dynamic Link License
• trans_idf (for ADS 2002)

Cadence Licenses
• OASIS_Simualtion_Interface.  (OASIS License Feature can be share)
• 34510 – AFFIRMA.  (AFFIRMA License Feature is a one for one)
• 300 – Virtuoso, layout editor (if using layout)

The RFIC Dynamic Link supports the dynamic interaction between the
ADS 2002 and the DFII environments only between processes local to a
single workstation. The workstation used to run DFII is also the machine that
will start the ADS interface through dynamic link. Please make sure that your
machine has access to the two environments and can acquire the necessary
ADS and Cadence licenses. Remote simulations with simulators from each of
the particular environments (either ADS or DFII) have to be started from their
own interface.



Installation Procedure And Configuration User Account

Obtain your FLEXLm codewords (Codewords can be requested in the Web at:
http://eesof.tm.agilent.com/forms/codereqform.html

Become a root user
Insert the CD-ROM (1)
Mount your CD-ROM drive
#mount /cdrom
#cd /cdrom/UNIX
Shutdown any program that uses a lot of color (I.e. Netscape)
#./SETUP*
You are prompted to enter a full path to the directory where you would like to ADS to be
installed.  The default directory is /usr/local/ADS2002

EEsof Installation Manager starts. Select Complete Installation
(The Complete Installation includes the automatic installation of Dynamic Link, all Parts
Libraries and the Online Documentation; you’ll be prompted insert and mount the second disk.)
#cd /
#umount /cdrom (eject cdrom,  for Solaris)

NOTE:  Make sure the HPEESOF_DIR SHELL environment variable is set and
CDS_INST_DIR points to the Cadence DFII root directory.
After Installation is complete you will need to configure the Cadence Directory
(Be sure you have write permission in the Cadence root directory $CDS_INST_DIR)

• Run $HPEESOF_DIR/bin/idfConfigCadence
• Use $HPEESOF_DIR/bin/idfConfigCadence –h to display the help menu
• Use $HPEESOF_DIR/bin/idfConfigCadence –ls to indicates if Cadence is ready for

Dynamic Link

Create a License File for ADS
 (Recommended location for your license.lic file is $HPEESOF_DIR/licenses/license.lic)

• Place codewords in the license.lic file
• #cd $HPEESOF_DIR/licenses/license.lic
• #chmod 555 license.lic (You may need to edit your license.lic file to correct the SERVER

line (replace unknown with correct server name, and the VENDOR line agileesof)

NOTE: Verify that the required Cadence licenses are also present in your Cadence License
File.  (Usually found in $CDS_INST_DIR/share/license/license.<servser_id>)

Enable FLEXlm lmgrd on your Server Machine
(the lmgrd demon (lmgrd) is in HPEESOF_DIR/licenses/bin)

To run lmgrd
Change the directory to where lmgrd resides on the SERVER machine and execute

• $cd $HPEESOF_DIR/licenses/bin
• $./lmgrd -c ../license.lic



Verify available licenses, run lmstat
• cd $HPEESOF_DIR/licenses/bin
• ./lmutil  lmstat   -a   -c ../license.lic | more

Access To Cadence Libraries With ADS Simulation View
Set the variable $IDF_CDS_VERSION to have access to the following Agilent EEsof libraries:
Basic, AnalogLib, and Microwave

• Edit $HPEESOF_DIR/idf/examples/cds.lib and include the following lines

UNDEFINE analogLib
UNDEFINE basic
UNDEFINE microwave

DEFINE analogLib $HPEESOF_DIR/idf/cdslib/$IDF_CDS_VERSION/analogLib
DEFINE basic $HPEESOF_DIR/idf/cdslib/$IDF_CDS_VERSION/basic
DEFINE microwave $HPEESOF_DIR/idf/cdslib/$IDF_CDS_VERSION/microwave

NOTE: An easy way to introduce these is including a file with these lines at the end of your
local cds.lib file.

Other user specific libraries can be added (I.e. Cadence design kits) in a similar way.

Cadence and Dynamic Link Directory Structure
The idfConfigCadence configuration script creates four and modifies one file in the Cadence IC design
tree. The following four files are created:

<Cadence Installation Dir>/tools/dfII/etc/tools/ads/.cdsenv
<Cadence Installation Dir>/share/cdssetup/hierEditor/templates/ads
<Cadence Installation Dir>/tools/dfII/etc/skill/hnl/ads.ile
<Cadence Installation Dir>/tools/dfII/etc/skill/si/caplib/ads.ile

A 5th file,  <Cadence Installation Dir>/tools/dfII/etc/tools/auCore/.cdsenv
is edited to add ADS to the Tool Filter List of Simulators.



 

$ IDF_CDS_DIR 
($CDS_INST_DIR, 
` cds _root  icms ̀ ) 

tools.sun4v 
      symbolic 
      link 

tools 

doc 

share 

cdsdoc 
cds _root 
lmstat 
lic _error 
                  icfb 
bin              icms 
samples 
           tools      auCore     . cdsenv 
etc                    ads          . cdsenv 

           skill       hnl        ads. ile 
                        si      caplib     ads. ile 

hierEditor        templates    ads 
setup. loc 

license. dat 

bin 

dfII 

other 
Cadence 
products 

cdssetup 

license 
$IDF_CDS_DIR/tools/bin And $IDF_CDS_DIR/tools/dfII/bin  MUST BE IN THE PATH 

‘$HPEESOF_DIR/bin/idfConfigcadence’  Creates and Updates the five Dynamic Link setup files under Cadence



The Config Directory

• $HPEESOF_DIR/idf/config/idf.cfg
Dynamic Link comes with the default configuration file
Use this file to set site/user-specific options. The values in this file will be overridden by those in
./idf.cfg.

• $HPEESOF_DIR/idf/config/.cdsinit
For the ADS menu to appear, the .cdsinit file must be read.
(When using wrappers that will set your environment, you must load and update your custom
wrappers).  The following should be added to the .cdsinit file

loadi(strcat(getShellEnvVar(“HPEESOF_DIR”) “/idf/config/.cdsinit”))
Append it to or load it from the first available .cdsinit file from the list below:
• <Cadence Installation Dir>/tools/dfII/local/.cdsinit
• ./.cdsinit
• $HOME/.cdsinit

Environment Variables (Relevant To Dynamic Link)
The environment variables needed are the same as for a normal installation of Cadence DFII and ADS.
Be sure license file variables and paths are correct.  HPEESOF_DIR must be set, Cadence tool tree must
be in the search path, e.g. icms must be found by ‘which icms’ or ‘whence icms’ or ‘type icms’.

The 2002 Dynamic Link installation only requires additional variables if they are in use.  In
i.e., the cds.lib files like IDF_CDS_VERSION in the example above. (Page 5, Access to
Cadence Libraries With ADS Simulation View)

For Optional environments variables see, chapter 2-6 of the Dynamic Link 2002 Guide.

• CDS_INST_DIR - the Cadence installation root directory. Some Cadence users define this
variable and others don’t.   Depends on the Cadence DFII version used.  The variable was
required in DFII 4.4.3, but it is ignore by later Cadence startup scripts.

• HPEESOF_DIR - ADS installation root directory.

• PATH - the executables search path must include:

$HPEESOF_DIR/bin for ADS and for Cadence
 <Cadence_install_dir>/tools/bin and
 <Cadence_install_dir>/tools/dfII/bin.

• LM_LICENSE_FILE is only required if ADS license.lic is not under $HPEESOF_DIR/licenses/
or AGILEEESOF_LICENSE_FILE is not define.  And Cadence license file is not defined in any
of the following locations:
–$CDS_LIC_FILE
–<Cadence_install_dir>/share/license/clients
–<Cadence_install_dir>/share/license/license.dat

NOTE: If you’re using the C-shell, change export to setenv and remove the equal sign (=).



A Dynamic Link Example:
The following PowerAmp example steps you through a circuit from the Dynamic Link analogLib
library.

Setting up the PowerAmp example
From any directory enter:
$cp –r $HPEESOF_DIR/idf/examples ./
$cd examples
Type icms& or icfb& or msfb& at the UNIX prompt
In a few seconds the Command Interpreter Window (CIW).  Will appear.

From the CIW GUI choose
File > Open (File Open Gui appears)
Select the following:

Library Name > Examples
Cell Name > PowerAmp
View Name >schematic
Click OK



The Virtuoso schematic editing window will appear: examples PowerAmp Schematic

To open The ADS Design Main Window

From the Tools Pull Down menu select:
Tools > ADS

In a moment the ADS (Main) window
Will appear.  The examples _prj will open
automatically.

The Blank DS schematic should appear
with the Cadence menu, and it is
automatically title “untitled1”

To open The PowerAmp Design

In the schematic window:
Select File > Open Design…
An Open design:1 GUI pops
Select > select PowerAmp_test.dsn

OK the GUI to include the PowerAmp_test.dsn schematic
in the ADS Window

To add a symbol of the Cadence Cellview
From the Cadence pull down menu
Select the following from GUI:
Library Name > examples
Cell Name > PowerAmp
View Name > schematic
OK

An instance of the symbol is attached to the
cursor.  With the Left Mouse Button place
the symbol in the ADS schematic.



Now you are ready to add the Model Files

Select Cadence > Add Netlist Include
An instance of the Idfinclude icon is attached to the
cursor.  Place it and double click.

The Netlist File Include Gui pops

Select modelLibraryFiles[1]=
Click the Browse…

The Netlist File Include GUI Pops
Highlight modelLibraryFiles[1]=
And click Browse…

Navigate to the models directory
your_directory/examples/models

Locate the npnpwa1.ads model OK

An Information Message appears,
indicating a new path has been added
to the include path list

OK the dialogue Box

Notice that the Model Library File field contains the npnpwa1.ads
Click Apply to add the model

Click the Add to add the modelLibraryFiles[2]=
And Browse… again to locate the second model npnpwa2.ads model file
Click Apply to add the npnpwa2.ads model
OK the Gui



Now you are ready to perform a simulation
Now you are ready to perform a simulation

1. With the Right Mouse Button select the DC component
and in the ADS schematic window select the Activate
Components icon to activate the DC component

2. Select the Simulate icon to run a simulation.  A simulation
dialog box appears promptly, close window.  Window > Close
Window
After the simulation is complete, a Data display window appears

3. To Display the DC nodes on the Cadence Schematic:
Select the PowerAmp Symbol in ADS.  And choose Cadence > Annotate > Annotate DC
Solution to Selected Cellview.

-----------------------------------------------------------------------------------------------------------------------------

For detailed tutorial steps about the process of simulating circuits using The Dynamic Link, please
refer to the RFIC Dynamic Link User’s Guide, chapter 3.

For additional RFIC Dynamic Link for Cadence examples, please see refer to
http://eesof.tm.agilent.com/applications/latest.html#rfic_dynamic_link

NOTE:  We advise to be fully versed in the PowerAmp example above, before visiting the additional
examples.



Installation Test (idfenv) Is Cadence Ready For The ADS RFIC Dynamic Link?
To Output DL-related UNIX environment variables, run idfenv

• Run this script idfenv in a UNIX window
• Then type the following command in Cadence CIW to compare environment outside and inside

Cadence: system("$HPEESOF_DIR/bin/idfenv")

Installation Check list
After a Proper Dynamic Link installation, the following files and directory structure should exist:

$HPEESOF_DIR/idf/ael/ (Compiled AEL files)
$HPEESOF_DIR/idf/cdslib/4.4.6/analogLib/ (Cadence version specific Libraries: analogLib, artist, basic,

microwave)
(Same Directory $HPEESOF_DIR/idf/cdslib/ Structure for: 4.4.3,and 4.4.5,)

$HPEESOF_DIR/idf/config/ (DL Configuration Files, including the .cdsinit file)
$HPEESOF_DIR/idf/examples/ (Libraries, Projects, ADS models and examples files of: .cdsinit,

cds.lib, idf.cfg)
$HPEESOF_DIR/idf/skill/4.4.6/ads.ini (DL/cadence Version Specific)
$HPEESOF_DIR/idf/skill/4.4.6/ads.al (DL/Cadence Skill Files)
$HPEESOF_DIR/idf/skill/4.4.6/ads.cxt (DL/Cadence Context File)
(Same Directory $HPEESOF_DIR/idf/skill/ Structure for: 4.4.3, and 4.4.5,)

$HPEESOF_DIR/idf/components/ (nport s-parameter)

$HPEESOF_DIR/bin/idf
$HPEESOF_DIR/bin/idfmp
$HPEESOF_DIR/bin/idfConfigCadence
$HPEESOF_DIR/bin/idfenv

$HPEESOF_DIR/circuit/symbols/idfSymbol.dsn. (Required For Generating ADS Symbol of Cadence Cellview)
$HPEESOF_DIR/circuit/symbols/idfSymbol.dsn. (The Netlist file Include component)



Known problems & Solutions:

Cadence Pull Down Menu Disappears from ADS Schematic
To add the ADS menu in the Cadence, load Dynamic Link’s. cdsinit in the right place.  
Cadence will always read the first .cdsinit file found in this order

• $CDS_INST_DIR/tools/dfII/local/.cdsinit
• ./ .cdsinit
• $HOME/.cdsinit

If the Menu still is not visible add a loadi() call in the .cdsinit
$loadi(strcat(getShellEnvVar(“HPEESOF_DIR”)”/idf/Config/.cdsinit”))

 Failed to open the Cadence Schematic
When opening a new schematic in Cadence it is read only:
Locks may cause the problem.  Maybe you copied the Design from another user while
he opened his design. To release any lock files in DFII 4.4.5 or later, please do the following:

In your UNIX prompt, change the directory to your working library (library in which the newly
copied cell resides)

• $clsAdminTool
• $ ale .
• $are .

The command "ale.  " lists the cells in the current library that are presently locked. "." refers to
the current working library/directory.  The "are." Command releases the Locks.

Failed to invoke ADS license
A license validation failed error message in the CIW and an Agilent License Error Box will
appear if ADS fails to invoke.

NOTE: LM_LICENSE_FILE is not required if $HPEESOF_DIR/licenses/license.lic is valid
• $ls –l $HPEESOF_DIR/licenses/license.lic

Dynamic Link requires the FEATURE trans_idf in the ADS license.lic file

• $grep –i idf $HPEESOF_DIR/licenses/license.lic
(FEATURE trans_idf agilenteesof 2.0 01-jul-2002 uncounted HOSTID=DEMO \)



Cannot add instance of Cellview to ADS schematic
When trying to run the Power Amplifier example, ADS opens fine, but cannot add instance of
Cellview to ADS schematic.  Get the following error:
(de_iteminfo_new_instance) Failed to generate the annotation

To generate the annotation, ADS needs to create a dummy symbol file
<library>_<cell>_<view>.dsn.  This dummy symbol is created with the idfSymbol component.
If the idfSymbol.dsn or the idfInclude.dsn files are not located under
$HPEESOF_DIR/circuit/symbols, the user gets the message.

Once these files are installed, the component instantiates correctly, and the simulation runs fine.

Dangling idfmp processes when DFII crashes
When the Cadence DFII crashes and IDF is running, the IDF process "idfmp" is still running.

List the relevant processes with:
• ps -ef | grep idf        (use "ps -ax" on sunOS)
• Then "kill -9 <pid>" for all the IDF related processes.

Can not run hpeesofsim –help
The hpeesofsim command is available to list available devices and commands, that are set in the
$HPEESOF_DIR/bin/bootscript.sh script. Before attempting to use the hpeesofsim command,
you should source the bootscript.sh file using one of the following commands:

• . $HPEESOF_DIR/bin/bootscript.sh (If using the Korn shell)
• sh; . $HPEESOF_DIR/bin/bootscript.sh (If using the C shell)

DC Back-Annotation to Cadence failure
With a successful DC Simulation in ADS with Dynamic Link.   And select Annotate DC
Solution to Selected Cellview.  Error -No data is available DC Back-Annotation failed

Cadence adds a parameter to the CDF called Name Prefix with a default value of "X".  The user
never sees this default prefix on his Cadence schematic, this causes ADS netlist to be out of sync
with the Cadence schematic.

Check the CDF for EACH level of hierarchy and remove the value "X" from the Name Prefix
parameter.
Once these are done, re-run the DC simulation, should be able to back annotate to Cadence.

NOTE: The freeze parameter should be set to FALSE on the idfSymbol component for ADS to
regenerate a Cadence netlist.  The idfSymbol component is located on the design page created
when the Cadence schematic is instantiated into ADS schematic.

To learn more about the use of  “Freeze Mode” to simulate a Design in ADS standalone, see
Chapter 9-12 of the Dynamic Link 2002 Guide.



Trouble Shooting:
All errors, warnings, and other messages are directed to the Cadence CIW. All Error messages are also
logged in the idf.log file.  (Only if debug turned on).

Some known problems and solutions are listed in the following section. You may find this information
helpful in determining how to resolve a particular problem however, if you’re unable to resolve a
problem with the RFIC Dynamic Link using the information provided, contact Agilent EEsof-EDA
customer support.

• Obtain Dynamic Link Environment.  Run idfenv

• Is $HPEESOF_DIR/bin in your $PATH?

• Is icms, icfb in your $PATH?

• ADS License Validation.
Is your ADS license.lic file in the default $HPEESOF_DIR/licenses/ directory or is it set in
$LM_LICENSE_FILE?

• Your PATH and LM_LICENSE_FILE should be set in ~/.profile, ~/.kshrc  or other sourced
scripts

• Cadence License Validation:
$CDS_LIC_FILE <Cadence_install_dir>/share/license/clients
$LM_LICENSE_FILE <Cadence_install_dir>/share license/license.lic

The Cadence License File should contain the following features:
OASIS_Simulation_Interface (Dynamic Link can not netlist without an OASIS license

OASIS_Simualtion_Interface License
34510
300 (for layout)

• Does $HPEESOF_DIR/idf/config/.cdsinit exist?

Is $HPEESOF_DIR/idf/config/.cdsinit loaded in
<Cadence_installation_directory>/tools/dfII/local/.cdsinit?



Record A Terminal Session and capture problem with Dynamic Link
Dynamic Link manuals for setup assume the simplest setup for Cadence and Dynamic Link.  There are
customers that have extremely customized setups for Cadence, and then try to integrate Dynamic Link
into that setup.  There are problems ranges from not setting up the environment variables to using the
wrong license, to using the wrong version of ADS.  To save time trying to debug the customer's files,
follow these instructions, to record a terminal session and capture problems with Dynamic Link:

(From UNIX prompt type..)

script idf.script
Setup the Cadence and ADS variables, as you usually do in your company.

export IDF_DEBUG_MODE=TRUE  (Korn Shell)
IDF_DEBUG_MODE=TRUE; export IDF_DEBUG_MODE (Bourne Shell)
setenv IDF_DEBUG_MODE TRUE (C-Shell)

idfenv (Get DL-related environment outside of Cadence)
cp -r $HPEESOF_DIR/idf/examples .

cd examples (To use EEsof’s ./.cdsinit, cds.lib)

setenv IDF_DEBUG_MODE TRUE  (for csh)

export IDF_DEBUG_MODE=TRUE (for ksh)

icms & (Or any other Cadence tool)

From CIW, select Open>File "examples>PowerAmp", and Open ADS From the Schematic
(Run the PowerAmp example, till problem occurs)

Enter the following command in CIW:
system("idfEnv") (Does it match that of last idfenv?)

(From UNIX prompt)
cat idf.log
cat ~/CDS.log
exit

The customer then attaches the idf.script file, (which is out put of script) to email and sends it in to
customer support.

-



Installation FAQ’s:

• How can I change which ADS project is opened when I start up ADS from within Cadence?
Set it with the IDF_ADS_PROJ_DIR environment variable located in your ./idf.cfg file.

• I Can't find cds_root to install Dynamic Link
When the customer runs the Dynamic Link ".sh" installation file, he gets an error message that
the program can't find cds_root variable.

Make sure that before running the installation script, you have defined:
$HPEESOF_DIR and $PATH must include
$HPEESOF_DIR/bin:$HPEESOF_DIR/idf/bin:$CDS_INST_DIR/tools/bin:
$CDS_INST_DIR/tools/dfii/bin

• ADS flashes when running Dynamic Link
When ADS is run from Cadence, ADS looses colors and starts flashing as it comes up.

The screen was flashing possibly because the workstation ran out of colors.  Stop color intensive
programs like, e.g., Netscape when running DL or use them with their own private color map.
(netscape –install). Try one or more of the following:

Set HPEESOF_COLORMAP=private in $HOME/hpeesof/config/hpeesof.cfg or
/usr/hpeesof/config/hpeesof.cfg

export CDS_USE_PRIVATE_CMAP=true
export CDS_NUM_USER_COLOR=16 in $HOME/.profile, logout, then login  again
$HOME/.kshrc (run the command \`. $HOME/.profile).

setenv CDS_USE_PRIVATE_CMAP True
setenv CDS_NUM_USER_COLOR 16 in $HOME/.cshrc, logout, then login again
$HOME/.cshrc (run the command \`source $HOME/.cshrc').

Restart DL after exiting all other applications.

• Can I keep previous versions of ADS Dynamic Link?
Yes, HHPEESOF_DIR needs to be defined for previous versions
The $CDS_INST_DIR does not need to be reconfigured for each installation

Previous ADS Dynamic Link Versions do required license interface:
Idf_C_interface
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