
 
 

 

Expedition PCB Введение
Материалы обучения



Этот курс предназначен для обучения вас базовой последовательности разработки топологии простой печатной платы 
используя последнюю версию Expedition PCB. Вы рассмотрите окружение редакторов и основные концепции библиотек. Вы 
изучите как интегрировать с начальной схемой Design Capture, разместить и растрассировать печатную плату, затем 
верифицировать и выдать фотошаблон.
Руководство этого курса разделено на главы по процессам. Каждая глава содержит рассмотрение процесса и лабораторные 
работы. Лаб. работы снабжены компьютерными файлами. 
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Расписание

День 1
Введение в Expedition PCB
Обзор библиотеки и данных
Создание Padstack
Создание Cell

День 2
Создание Part
Создание Layout Template
Обзор редактора платы

День 3
Запуск редактора платы
Установка параметров топологии
Определение геометрии платы
Размещение компонентов

День 4
Проверка топологии
Трассировка
Генерация "заливок"

День 5
Отработка шелкографии
Генерация данных Gerber
Генерация данных для сверления



 
 

EXPEDITION PCB INTRODUCTION A-1 

A Введение
Обзор класса
Введение инструктор/студент
Front-to-back демо



 
 

EXPEDITION PCB INTRODUCTION B-1 

B Обзор библиотеки
Эта глава коротко объясняет вопросы связанные с 
библиотеками Expedition PCB.
Рассматриваются темы :
- Плата (PCB) и центральная библиотека (Central Library)
- Менеджер библиотек (Library Manager)
- Разделы (partitions)



Заметка: Детали могут называться также "PDBs".

 B-2 
 E XPEDITION PCB INTRODUCTION  WG2000 

 

 

 

Плата и центральная библиотека
Поверхностное рассмотрение вопросов связанных с 
библиотеками Expedition PCB и терминологией поможет 
в понимании какие данные и откуда они происходят на 
протяжении курса
Заметка: Курс "Менеджер Библиотек" рассматривает 
вопросы  управления и создания библиотек более 
подробно.

Padstack содержит все геометрии площадок (Pads) и 
отверстие для Вывода физического компонента. 
Определены необходимые формы/размеры для меди, 
защитной маски и клея. Если использован сквозной 
тип компонента, то  определены также 
формы/размеры отверстия. Площадки и 
дополнительно отверстия затем использованы для 
определения Padstack.

Padstacks

Ячейка (Cells)
Ячейка это графика посадочного места компонента 
представляющая физический компонент. Ячейка 
состоит из Padstacks, Номеров Выводов, Контуров, 
Текста и любой другой информации трубуемой для 
изготовления и документации. 

Символы это схемотехническое представление 
компонента

Символы (Symbols)

Заметка: Символы будут рассмотрены очень мало в 
этом курсе. Курс "Менеджер Библиотек" и "Design 
Capture для PCB" рассматривает  символы более 
подробно.

Деталь (Parts)
Деталь в Базе Данных Деталей (Parts Database) это 
информация которая связывает схемный символ и 
посадочное место (элемент). Эта информация 
основана на номере детали (part number)  и включает 
данные Вентили/Выводы плюс спец. свойства 
(properties) которые могут быть использованы в 
различных нисходящих процессах.

Заметка: Прямая Аннотация будет рассмотрена 
детально познее в этом курсе.

Центральная Библиотека (Central Library)
Центральная библиотека содержит Символы, Детали, 
Ячейки и Padstacks которые все взаимосвязанны. 
Внутри каждой области Символов, Деталей и Ячеек 
есть определяемые пользователем разделы (partitions). 
Может существовать более чем одна центральная 
библиотека, но проект платы связан только с одной 
центральной библиотекой.
Схема или список цепей проекта требуют конкретных 
деталей. Эти детали вместе с их элементами и 
padstacks выбираются из центральной библиотеки и 
"прямо аннотируются" в топологию платы.  

Центральная Библиотека конкретного проекта
Топология платы будет иметь библиотеку проекта 
(локальную) содержащую только Детали, Ячейки и 
Padstacks использованные в топологии. 
Редактирование внутри данных этой библиотеки будет 
обновлять только топологию, а не связанную с ней 
центральную библиотеку.



Менеджер Библиотек
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2. 

3.  

Менеджер Библиотек
Менеджер Библиотек служит как интерфейс для 
различных редакторов связанных с библиотекой. Он 
также контролирует создание и управление 
центральными библиотеками и их разделами.

Менеджер Библиотек может быть вызван ...
... из Design Capture. Здесь Менеджер Библиотек может 
быть использован для редактирования библиотечных 
данных связанных со схемой, таких как файлы свойств, 
символы и детали
... из Expedition PCB. Здесь Менеджер Библиотек 
может быть использован для редактирования 
библиотечных данных связанных с платой, таких как 
детали, padstacks, ячейки и шаблоны плат.
... как самостоятельный продукт. Здесь Менеджер 
Библиотек может быть использован для 
редактирования всех библиотечных данных, таких как 
файлы свойств, символы, детали, padstacks, ячейки и 
шаблоны плат. 

1 Используя Windows Explorer переместитесь в 
c:\mgtraining\common\libraries\master. 
<Двойной-щелчек> на файле master.lmc.

Открытие и закрытие Центральных Библиотек
Выбор File>Open из меню позволяет просмотреть и 
открыть файл Каталог Менеджера Библиотек (*.lmc). 
Файл Каталог Менеджера Библиотек управляет одной 
центральной библиотекой. Все операции Менеджера 
Библиоте с этой точки будут касаться библиотечных 
данных этой библиотеки.
Выбор File>Close из меню закрывает активную 
библиотеку. Все редакторы должны быть закрыты, чтобы 
закрыть центральную библиотеку или выйти из 
Менеджера Библиотек.

Создание новой Центральной Библиотеки
Выбор File>New из меню создает новый файл Каталог 
Менеджера Библиотек и связанную структуру директорий 
для центральной библиотеки.

Проводником найти директорию где должна быть 
создана центральная библиотека.

Файл Каталог Менеджера Библиотек будет размещен 
в этой директории с таким же именем как директория.
Заметка: Этот файл может быть переименован 
используя Window Explorer, при этом расширение 
останется lmc.
Когда новая центральная библиотека создана, она 
становится активной библиотекой для  Менеджера 
Библиотек. Все операции Менеджера Библиотек с 
этой точки будут касаться библиотечных данных этой 
библиотеки.
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Разделы
Библиотечные данные в центральной библиотеке 
разделены на разделы. Разделы организовывают 
данные так что библиотекарь и проектировщик/инженер 
могут легко найти то что им нужно. Например, Символы 
могут быть поделены на разделы основываясь на 
функции, Ячейки - по физическим аттрибутам, Детали - 
по функциям и сериям.

Редактор Разделов

2 Выберите Edit>Partition Editor из меню, чтобы 
появился диалог Partition Editor. В диалоге Partition 
Editor <кликните> вкладку Cells.

Разделы для Символов, Ячеек, PDBs и IBIS моделей 
могут быть определены здесь. По крайней мере один 
раздел для каждого библиотечного типа должен 
существовать, чтобы создать библиотечные данные 
этого типа.
Редактор Разделов показывает Имя Раздела Библиотеки, 
количество элементов в разделе, и если раздел в 
данный момент Забронирован (Reserved) (используется).

Заметка: Несколько пользователей могут иметь доступ 
к одной центральной библиотеке, но не одному и тому же 
разделу.

3На вкладке Cells <кликните> кнопку New чтобы 
создать новый раздел. Сразу замените имя New 
на имя temp. Это будет ваш рабочий раздел для 
последующих лаб. работ.

 <Кликнуть> на вкладке PDBs и создать temp раздел, 
также для использования в последующих лаб. работах.
<Кликните> кнопку OK в диалоге Partition Editor чтобы 
сохранить ваши новые разделы. 



EXPEDITION PCB INTRODUCTION C-1 

C Создание Padstacks
Эта глава является введением в создание графики 
площадок и определения сверления.
Рассматриваются темы:
- Что такое Padstack?
- Редактор Padstack
- Отверстия (Holes)
- Площадки (Pads)
- Padstacks 
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Padstack содержит все геометрии площадок (Pads) и 
отверстия для Вывода физического компонента. 
Определены необходимые формы/размеры для меди, 
защитной маски и клея. Если использован сквозной тип 
компонента, то  определены также формы/размеры 
отверстия. Площадки и отверстия затем использованы 
для определения Padstack

Что такое Padstack? Редактор Padstack

1 Если Вы не оставили открытым Менеджер Библиотек 
с Центральной Библиотекой master из предыдущей 
лаб. работы, то используя Windows Explorer 
переместитесь в 
c:\mgtraining\common\libraries\master далее
<Двойной-щелчек> на файле master.lmc.

Padstacks определяют используя Редактор Padstack.

В диалоге Менеджера Библиотек <кликнуть> 
кнопку Padstacks (Pads & Holes) , чтобы вызвать 
Редактор Padstack.
Редактор Padstack открывает базу данных padstack 
текущей Центральной библиотеки. Padstacks не могут 
быть разделены на разделы в Центральной 
Библиотеке. Однако они отличаются друг от друга по 
типу padstack.
Заметка: Внутри Expedition PCB Редактор Padstack 
вызывается выбором Setup>Padstack Editor из меню. 
Редактор Padstack открывает локальную базу данных 
padstack текущей топологии платы. 

Окружение Редактора Padstack
Редактор Padstack разделен на отдельные диалоги для 
определения Площадок (Pads), Отверстий (Holes) и 
Заказных Площадок & Символов Сверления (Custom 
Pads & Drill Symbols). Padstacks диалог потом 
используется для объединения этих отверстий и 
площадок в законченный padstack. 
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Отверстия
Отверстия должны быть определены для padstacks типа 
"сквозной", для padstacks типа межслойный переход (via) 
и для крепежных отверстий без площадок.

2  <Кликнуть> закладку Holes в 
диалоге Редактора Padstack чтобы 
определить отверстия и назначить 
символы сверления необходимые 
для ваших будущих padstacks.
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Список Отверстий
Для удобства, Фильтр списка отверстий (Filter hole list) 
позволяет отфильтровать список отверстий по типу 
отверстия. Типы бывают Все (All), Круглые (Round), 
Слотовые (Slot) и Квадратные (Square).
Для удобства, Фильтр списка единиц измерения (Filter 
units), позволяет отфильтровать список отверстий по 
единицам измерения отверстия - English and Metric, 
English или Metric.
Список Имен (Names) отображает запас определенных 
отверстий.

3 Выберите отверстие в Списке Имен  и посмотрите на 
него, но не изменяйте, Свойства (Properties) для этого 
отверстия с правой стороны диалога.
Посмотрите на какие-нибудь другие отверстия.

Отверстия могут быть созданны, скопированны, 
сортированны и удалены используя подходящие кнопки 
сверху Списка Имен.
Замечание: Отверстия не могут быть удалены если в 
данный момент используются в padstack.

4 Вам нужно отверстие для padstack, которое будет 
в итоге использованно для DIP корпуса.

<Клик> кнопку New Hole вверху списка Names чтобы 
начать.
При включенной опции Генерить Имя по свойствам 
(Generate name from properties), имена генерятся 
автоматически на основании Свойств определенных для 
отверстия. Если эта опция выключена имена 
определяются пользователем.
Замечание: Имена отверстий могут быть до 64 
буквенно-цифровых значений в длину и не могут 
содержать "\", "!" или "()".

Свойства Отверстий (Hole Properties)
Правая секция диалога используется для задания 
Свойств отверстий.

Единицы измерений (Units)
Каждое отверстие может иметь собственные Единицы 
измерения (Units). Единицы измерения бывают дюймы 
(in), тысячные (th), миллиметры (mm) и микроны 
(um).

Тип (Type)
Тип отверстия определяет как отверстие будет 
представлено в процессе изготовления - Сверленное 
(Drilled) или Перфорированное (Punched).

Металлизированное (Plated)
Эта опция определяет будет ли отверстие 
металлизироваться в процессе изготовления или нет.

Размер отверстия (Hole size)
Размер отверстия - Окончательная опция основанная 
на выбранном контуре - Круглое (Round), 
Квадратное (Square) или Слотовое (Slot).

- Круглое использует Диаметр, Допуск +/-.
- Квадратное использует Ширину, Допуск. +/-.
- Слотовое использует Ширину, Высоту, Допуск +/-.

Замечание: Допуск является опцией и появляется 
только в "таблице сверления" на чертеже сверления.
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5 С еще выбранным в списке вашим новым отверстием 
установите следующие Свойства (Properties) 
отверстия.

Во время выполнения проследите за тем как 
автоматически изменяется имя отверстия.
Установите Units в th.
Установите Type в Drilled.
Проверьте Plated.
Установите Diameter 34.
Установите +Tol и -Tol 3.

Символы Сверления (Drill Symbol)
Секция Назначения Символа Сверления (Drill Symbol 
assignment) предназначена для графики "Чертежа 
Сверления" ("Drill Drawing").
Есть следующие методы Назначения Символа 
Сверления :
-  Генерить буквы сверления в течении выдачи

(Generate drill characters during output) 
автоматически назначает буквенные значения в каждое 
отверстие в течении генерации чертежа сверления. 
Назначение делается по размеру сверла, начиная с 
самого малого и идя к самому большому.

-  Нет (None) игнорирует отверстие в течении 
генерации чертежа сверления.

-  Использовать букву как символ сверления
(Use character as drill symbol) требует выбора 
буквенного значения из ниспадающего списка 
Character и определения Размера (Size). Разрешенные 
значения от A до Z и от a до z.

-  Использовать символ сверления из списка
(Use drill symbol from list) требует выбора 
предопределенного Графического Символа Сверления  
и определения Размера (Size). Альтернотивно может 
быть выбран Заказной (Custom) символ сверления из 
ниспадающего списка, но размер его определен на 
этапе его создания.

6 В секции Drill Symbol assignment выберите из 
ниспадающего списка Use drill symbol from list.

Выберите понравившуюся графику для Drill Symbol ( 
исключая синие ... они уже используются).
Установите Размер (Size) символа в 50.
Выберите File>Save из меню.
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Площадки (Pads)

Все требуемые площадки должны быть определены 
перед построением padstacks. 

7 <Кликните> на вкладку Pads в 
диалоге Редактора Padstacks, 
чтобы определить контуры 
площадок необходимых для 
ваших будущих padstacks.
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Список площадок
Для удобства, Фильтр списка площадок (Filter pad list) 
позволяет отфильтровать список площадок по контуру 
площадок. Типы бывают Круглые (Round),  
Квадратные (Square), Прямоугольные (Rectangle) и 
Термо (Thermals) .
Для удобства, Фильтр списка единиц измерения (Filter 
units), позволяет отфильтровать список площадок по 
единицам измерения площадок - English and Metric, 
English или Metric.
Список Имен (Names) отображает запас определенных 
площадок.

8 Выберите площадку в Списке Имен  и посмотрите на 
нее, но не изменяйте, Свойства (Properties) для 
этого отверстия с правой стороны диалога.
Посмотрите на какие-нибудь другие площадки.

Площадки могут быть созданны, скопированны, 
сортированны и удалены используя подходящие кнопки 
сверху Списка Имен.
Замечание: Площадки не могут быть удалены если в 
данный момент используются в padstack.

9 Вам нужны площадки для padstack, которое 
будет в итоге использованно для DIP корпуса.

<Кликните> кнопку New Pad вверху списка Names чтобы 
начать.
При включенной опции Генерить Имя по свойствам 
(Generate name from properties), имена генерятся 
автоматически на основании Свойств определенных для 
площадки. Если эта опция выключена имена 
определяются пользователем.
Замечание: Имена площадок могут быть до 64 
буквенно-цифровых значений в длину и не могут 
содержать "\", "!" или "()".

Свойства Площадок (Pad Properties)
Правая секция диалога используется для задания 
Свойств площадок.

Единицы измерений (Units)
Каждая площадка может иметь собственные Единицы 
измерения (Units). Единицы измерения бывают дюймы 
(in), тысячные (th), миллиметры (mm) и микроны 
(um).
Контур Площадки (Pad shape)
Контур площадки выбирается из списка 16 
предопределенных графических контуров. Выбранный 
контур площадки определяет какие параметры 
площадки отображаются.
Параметры Площадки (Pad parameters)
Секция Pad parameters отображает выбранные 
графические контуры с полями для установки 
дистанций, таких как длина и ширина или диаметр (в 
зависимости от контура). Добавочно может быть 
установлен сдвиг от начала координат (Origin offset).

10 Сначала  создайте контур необходимый для 
площадок металла для DIP корпуса. С все еще 
выбранной вашей новой площадкой в списке 
установите следующие Свойства площадки.

Во время выполнения проследите за тем как 
автоматически изменяется имя площадки.
Установите Units в th.
Выберите Круглый (Round) граф. контур из списка 
контуров . (Круглый выбирается по умолчанию).
В секции Pad parameters поставьте диаметр 65.
Выберите File>Save из меню.
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11 Контур площадки "soldermask clearence" необходим 
чтобы в дальнейшем перейти к 65th контуру 
сделанному ранее.

<Кликните> кнопку New Pad и создайте Round площадку  
с диаметром 71.
Будет необходим квадратный контур площадки для "pin 1". 
<Кликните> кнопку New Pad и создайте Square площадку  
с длинной стороны 65.
Необходим квадратный контур площадки для "soldermask 
clearence". <Кликните> кнопку New Pad и создайте 
Square площадку  с длинной стороны 71.
Необходим контур площадки для "plane clearence". 
<Кликните> кнопку New Pad и создайте Round площадку  
с диаметром 85.
И в заключение, необходим контур площадки для "plane 
thermal". <Кликните> кнопку New Pad и создайте 4 Web 
Round Thermal - 45 площадку  с общим диаметром 85, 
зазором 10 и шириной перемычки 10. 
Проверьте каждую площадку, выбрав ее в Names списке и 
сделайте какие-либо изменеия. Когда все сделанно, 
выберите File>Save из меню, чтобы сохранить всю вашу 
работу .

Предупреждение! Будьте внимательны какое имя 
площадки выбранно в списке когда делаете изменения в 
ее свойствах. 12 Вам также будет необходим контур площадки для 

padstack который в дальнейшем будет использован 
для корпуса SOIC.

Установите Units в mm и создайте следующие площадки.
Незабывайте <Кликнуть> кнопку New Pad каждый раз 
иначе вы будете изменять ту же площадку.
Создайте Rectangle площадку  с высотой 2.2 и шириной 
0.6 для металлический медной площадки.
Создайте Rectangle площадку  с высотой 2.36 и шириной 
0.76 для soldermask clearance площадки.
Выберите File>Save из меню.
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Padstacks

13 <Кликните> вкладку 
Padstacks в диалоге 
Редактора Padstacks чтобы 
совместить площадки и 
отверстия сделанные ранее.

Padstack составлен из конкретных площадок на 
функциональных слоях платы и добавочно отверстия 
чтобы обеспечить вывод компонента, межслойный 
переход, монтажное отверстие или реперный элемент.
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Список Padstack
Для удобства, Фильтр списка padstack (Filter padstack 
list) позволяет отфильтровать список padstack по типу 
padstack.
Список Имен (Names) отображает запас определенных 
padstacks.

14 Выберите padstack в Списке Имен  и посмотрите на 
него, но не изменяйте, Свойства (Properties) для 
этого отверстия с правой стороны диалога.
Посмотрите на какие-нибудь другие padstacks.

Padstacks могут быть созданны, скопированны, 
сортированны и удалены используя подходящие кнопки 
сверху Списка Имен.
Замечание: Padstacks не могут быть удалены если в 
данный момент используются в ячейке компонента.

15 Чтобы начать сборку padstack <Кликните> 
кнопку New Padstack вверху списка Names.

Поскольку здесь нет опции авто-именования 
непосредственно наберите новое имя padstack SOIC. Он 
будет использован позднее для корпусов SOIC.
Если Вы ввели имя padstack (по умолчанию имя New), то 
чтобы просто переименовать его, <двойной-клик> на 
padstack в списке и начинайте набирать.

Замечание: Имена отверстий могут быть до 64 
буквенно-цифровых значений в длину и не могут 
содержать "\", "!" или "()".
Когда переименовываете padstack, имя будет 
динамически обновляться по всей Центральной 
библиотеке, где он использован.

Свойства padstack (Padstack Properties)
Правая секция диалога используется для задания 
Свойств padstack.

Тип (Type)
Тип padstack определен как Реперный Элемент 
(Fiducial), Монтажное Отверстие (Mounting Hole), 
Pin-SMD, Pin-Through  или Межслойный переход 
(Via) в ниспадающем списке Type.
Тип padstack диктует его использование в Редакторе 
Ячеек или Expedition PCB. Via padstack используется 
при трассировке. Mounting hole padstack появляется 
при выполнении команды "Place Mounting Hole" и т.д.
Тип padstack диктует также набор слоев здесь когда 
назначаете площадки и отверстия:

- Pin-Through, Mounting Hole и Via типы padstacks
 имеют поля Mountign side, Internal и Opposite side.
- Pin-SMD и Fiducial типы padstacks имеют поля
 Top mount и Bottom mount, но не Internal или
 Available holes (Доступные отверстия).
- Fiducial типы padstacks не имеют поля Plane
 clearance (освобождение на слое питания) или Plane
 thermal (тепловой контакт на слое питания). 

16 Пока ваш новый padstack выбран в списке, выберите 
Pin-SMD из ниспадающего списка Type в секции 
Свойства (Properties) диалога.
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Площадки (Pads)

17 Сначала  выберите пустой слой Top mount в списке 
Pads (в центре диалога).

Повторите процесс для слоя Bottom mount,используя туже 
площадку Rectangle 0.6x2.2. Поставьте ее же для слоев 
Top mount solderpaste и Bottom mount solderpaste.
Чтобы закончить ваш SMD padstack назначте Rectangle 
0.76x2.36 площадку в слои Top mount soldermask и Bottom 
mount soldermask.
Выберите File>Save из меню.

Список Площадок использован для назначения ранее 
созданных площадок в каждый слой padstack. Чтобы 
назначить площадки в слои padstack, сначала 
выберите слой или слои, затем выберите площадку из 
списка Доступных Площадок и в заключение 
<кликните> кнопку левой стрелки, чтобы назначить ее.
Список Доступных Площадок может быть 
отфильтрован по контурам площадок, чтобы было 
легче найти нужную площадку.

Чтобы убрать площадку из padstack слоя, просто 
выберите нужное поле слоя в Pads списке и 
<кликните> кнопку правой стрелки.

18 Padstack для DIP корпуса еще нужно определить. 
<Кликните> кнопку  New Padstack, назовите его 
34/65round

Измените тип padstack в Pin-Through.
Используя клавишу <Ctrl> выберите три пустых поля -   
Mountign side, Internal и Opposite side в Pads списке. Затем 
выберите Round 65 из списка Available pads справа. В 
заключение <кликните> кнопку левой стрелки чтобы 
вставить выбранную площадку в поле выбранного слоя.
Теперь назначте набор слоев в Pads списке как следует:
Plane clearance: Round 85
Plane thermal: Thermal Rnd 4x85 Width 10 WebClear 10
Mount side soldermask: Round 71
Opposite side soldermask: Round 71

Отверстия (Holes)
Список Достуных Отверстий (Available Holes) 
содержит все ранее определенные отверстия. 
Отверстие должно быть выбранно кроме случая 
если список будет не активным основываясь на типе 
padstack.

19 Чтобы закончить ваш Сквозной padstack выберите 
отверстие Rnd 34 +/-Tol 3 из Available Holes.

Выберите File>Save из меню.

Затем выберите Rectangle 0.6x2.2 из списка Available 
pads справа (используйте Pad filter для сокращения 
списка). В заключение <кликните> кнопку левой 
стрелки чтобы вставить выбранную площадку в поле 
выбранного слоя.
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20 Вам нужен похожий Сквозной Padstack с квадратной 
площадкой (индикатор вывода 1). 

Выберите 34/65round padstack если он уже не выбран. 
<Кликните> кнопку Copy Padstack назовите его 
34/65square.
С выбранным 34/65square padstack в списке Имен, 
выберите поля Mountign side и Opposite side используя 
клавишу <Ctrl>.
Теперь выберите Square 65 из списка Available pads и 
<кликните> кнопку левой стрелки.
Назначте площадку Square 71 в поля Mountign side 
soldermask и Opposite side soldermask.
Выберите File>Save из меню.

Предосмотр (Preview)
Пространство Предосмотра позволяет видеть любую 
выбранную площадку из списка Площадок.

21 В списке Имен padstack выберите SOIC padstack 
сделанный вами ранее. 

В списке Имен Площадок выберите только поля Top mount 
и  Top mount soldermask используя клавишу <Ctrl> и 
посмотрите на окно Предосмотра в правом-нижнем углу 
диалога. Показываются только выбранные площадки.
Без изменения выбранных слоев, выберите другие 
padstaks, которые Вы создали (34/65round и 34/65square).
Сделайте какие-либо необходимые изменения в трех 
ваших padstaks. Закройте Редактор Padstaks когда 
закончите.



EXPEDITION PCB INTRODUCTION D-1 

D Создание Ячеек (Cells)
Эта глава является введением в создание 
посадочного места компонента - "ячейки".
Рассматриваются темы:
- Что такое Ячейка?
- Редактор Ячеек
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Что такое Ячейка?
Ячейка это графическое изображение компонента или 
просто сгруппированная графика. В Expedition есть три 
типа ячеек - Корпус (Package), Механическая 
(Mechanical) и Чертежая (Drawing). 

Ячейка Корпус
Ячейка Корпус это посадочное место связанное с 
деталью в Базе Данных Деталей, таким образом 
использованно при упаковке схемы или списка цепей. 
Ячейка Корпус содержит пины (padstacks), места 
размещения для номера компонента (reference 
designator) и номера детали (part number), контуров 
компонента и каких-либо других важных данных.

Механическая Ячейка
Механические Ячейки изображают механические 
устройства, которые могут быть размещенны на плату 
как оборудование. Они не связанны с деталью в Базе 
Данных Деталей таким образом не возникают из схемы 
или списка цепей. Механические Ячейки могут иметь 
отверстия (padstacks) и они могут иметь какие-либо 
другие важные данные, такие как Номера Деталей. 
Механические Ячейки появятся в "Списке Материалов".

Чертежная Ячейка
Чертежные Ячейки используются только для 
документации. Чертежные Ячейки включают логотипы и 
форматки. Они составлены из графики и текста без 
пинов. Чертежные Ячейки не появятся в "Списке 
Материалов".

Редактор Ячейки
Редактор Ячейки вызывается из Менеджера Библиотек 
кликнув на иконку Ячеек. Редактор будет редактировать 
ячейки в разделе ячеек в Центральной Библиотеке.

В Expediton PCB Редактор Ячейки вызывается командой 
Setup>Cell Editor. Редактор будет редактировать 
библиотеку ячеек в локальном проекте.
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Когда первый раз вызываете Редактор Ячейки здесь есть 
окружение диалога которое выводит содержание 
активного раздела. Этот диалог может начать новую 
ячейку или редактировать существующую в списке 
ячейку.

Раздел (Partition)
Ниспадающее меню показывает список всех разделов 
ячеек в Центральной Библиотеке. Иконка в конце поля 
вызывает Редактор Разделов, позволяя создать новый 
раздел.

Иконки (Icons)
Новая Ячейка (New Cell) - Показывает диалог  для 
создания новой ячейки в разделе.
Копия Ячейки (Copy Cell) - Копирует ячейку выбранную 
в списке и изменяет ее имя, добавляя "_1" к 
оригинальному имени. Измените имя новой ячейки и 
затем редактируйте свойства и графику если 
необходимо.
Свойства - Показывает диалог  свойств для выбранной 
ячейки. Свойства могут быть изменены в диалоге.
Редактирование Графики - Открывает графическое 
окружение с выбранной ячейкой. Графика для ячейки 
может затем быть отредактирована.
Удалить Ячейку - Удаляет выбранную ячейку.

-

-

-

-

-
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Список Ячеек и Колонки
Список Ячеек имеет три вкладки для Ячеек Корпусов, 
Механических и Чертежных. Он показывает имена ячеек 
в активном разделе.
Список также содержит колонки которые показывают 
информацию по свойствам для ячеек. Ниже Списка 
Ячеек есть список колонок которые могут быть 
проверенны в таблице Списка Ячеек. Чтобы удалить 
колонку из списка нажмите и держите на заголовке 
колонки и перетащите в таблицу Доступых колонок. 
Чтобы добавить колонку в список нажмите и держите на 
заглавие  в таблице Доступых колонок перетащите ее в 
список.

Предосмотр
Когда ячейка выбрана в списке, графика ячейки 
отображается в окне предосмотра.
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Создание Новой Ячейки
Установка Раздела
Удостоверьтесь что Вы работаете в правильном разделе.

Иконка Новая (New Icon)
Чтобы создать новую ячейку кликните на кнопке 
Новая Ячейка (New CELL). Появится диалог для 
ввода свойств ячейки.

 

Диалог Создания (Create Dialog)
Чтобы создать новую ячейку - Выберите опцию Create 
new cell и добавте имя в поле ввода текста имени 
Ячейки. 
Чтобы создать ячейку из PDB данных - Выберите опцию 
Create cell from PDB data и появится список деталей 
которые ссылаются на не существующие Ячейки 
Упаковки в списке Неопределенных Ячеек. Выберите 
деталь из списка и Общее Количество пинов (Total 
number of pins) автоматически заполнится.
Введите количество в поле Общее Количество пинов.
Группа Корпуса (Package Group) помогает организовать и 
сортировать ячейки. Это важный параметр который 
также помогает определить доступный тип монтажа.
Тип Монтажа (Mount Type) помогает организовать и 
сортировать ячейки. Он описывает как ячейка 
монтируется.
Кнопка Свойства Ячейки вызывает диалог Свойства.
Вы можете использовать другую ячейку как шаблон, 
выбирая кнопку Browse вслед за полем Use Cell as 
template.

Выбор кнопки 
Продолжить 
( C o n t i n u e )  
з а к р ы в а е т  
диалог и вы 
попадаете в 
г р а ф и к у .  
Автоматически 
п о я в л я е т с я  
д и а л о г  
Размещения 
Пинов (Place 
Pins).
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Свойства Ячейки
Это диалог стандартных свойств для 
упаковочной ячейки и появляетя всегда 
когда нужны свойства ячейки. 
Большинство опций являются общими и 
в этом диалоге и в диалоге Редактора 
Ячеек. Изменения в одном отражаются 
в другом.
Секция Имя и описание (Name and 
descriptions) содержит имя ячейки и ее 
описание. Имя является 
редактируемым полем и Вы можете 
изменить имя ячейки. Для описания 
есть ограничение максимум 128 букв.
Поле Дата это дата когда ячейка была 
последний раз исправлена. Это поле не 
редактируемо.
Группа Корпуса (Package group) 
помогает организовать и сортировать 
ячейки.
Тип монтажа (Mount type) помогает 
организовать и сортировать ячейки. Он 
описывает как ячейка может 
монтироваться.
Поле Высота (Height) это 
максимальная высота ячейки в 
определенных единицах. Высота 
Корпуса может также быть определена 
в PDB как свойство компонента.  
Высота компонента назначенная в PDB 
подменяет высоту компонента из 
Редактора Ячеек.

Underside space это определенное 
пространство между поверхностью 
монтажа и низом ячейки. Оно 
используется как проверочное значение 
когда компоненты размещаются друг 
под другом. 
Поле Unit для задания единиц 
измерения для выбранной ячейки. 
Каждая ячейка может иметь 
собственные единицы измерения. 
Опции бывают in, mm, um, и th.
Number of pins - соответствует 
количеству пин. Это поле не 
редактируемо.
Список Pins # и Padstack Name 
содержит все пины по номерам и 
ассоциированные padstacks в данный 
момент заданные в ячейке. Эти колонки 
могут быть сортированны. Эти поля не 
редактируемы.
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Размещение Пин
В диалоге Create Package Cell 
кликните кнопку Next, чтобы 
продолжить создание ячейки. 
Вызовется графическое 
окружение и отобразится диалог 
Place Pins.
Этот диалог позволяет вам 
назначить padstacks в пины, 
разместить пины, изменить 
номера пин и видеть детали 
padstack. Здесь два вида вкладок: 
Parameter Place и Pattern Place.

Список Padstack
Первая колонка показывает 
состояние пина. P означает 
размещенный, U означает не 
размещенный. 
Колонка Pin# показывает 
буквенно-цифровой номер пина.
Вы можете изменить номера пин редактируя эту 
колонку или можете изменить множество номеров 
пин используя кнопку Renumber Pins. Номера пин 
могут быть изменены только если деталь PDB не 
связанна с ячейкой. Чтобы сделать это, сначала 
выберите пины, которые нужно изменить. Кликните 
кнопку Renumber Pins. Появится диалог для ввода 
параметров изменения номеров.
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Замечание: Если Вы создаете Корпусную Ячейку из 
PDB, номера этих пин предопределены. Эта колонка не 
редактируема если определена деталь которая 
использует ячейку. 
Колонка Padstack Name содержит ниспадающий список 
всех padstacks в активной библиотеке. Тип Padstack 
Пина фильтруется по свойству Стиль Монтирования 
Ячейки. Если Стиль Монтирования Поверхностный 
(Surface), то для выбора доступны только padstack типа 
Pin-SMD. Если Стиль Монтирования Сквозной 
(Through), то для выбора доступны только padstack типа 
Pin-Through. Если Стиль Монтирования Смешанный 
(Mixed), то для выбора доступны оба padstack типа Pin-
SMD и Pin-Through. Чтобы назначить один и тот же 
padstack для множества пин:

Выберите первый пин.
Удерживайте клавишу <Shift> и выберите последний пин. 
Продолжите удерживать клавишу <Shift>.
В поле последнего пина используйте ниспадающее меню 
для выбора корректного padstack.
Колонка Rotation для поворота пина. Вы можете ввести 
значение или выбрать значение из ниспадающего 
списка. Значения бывают 0, 90, 180 и 270.
Колонка Net Class может назначить Net Class, 
определенный в графическом окружении Редактора 
Ячеек для пина. Устройства интерактивной трассировки 
будут использовать этот Net Class в Редакторе Ячеек.
Кнопка Padstacks Details показывает диалог Padstacks 
Details.



 D-9 
 E XPEDITION PCB INTRODUCTION  WG2000 

 

 

Параметры Размещения
Чтобы разместить пины по параметрам 
местоположения пин, выберите вкладку Parameter 
Place.

Поля Row и Column позволяют определить количество 
рядов и колонок пин которые будут размещены. По 
умолчанию 1.
Поля Distance between pins X и Y позволяют 
определить дистанцию между центрами пин по Х и Y. 
По умолчанию 100th для X  и 300th для Y.
Кнопка Pin Sequence позволяет выбрать схему 
нумерации для компонента, кликая на подходящую 
кнопку.

После установки параметров, выберите все пины из 
списка пинов, чтобы разместить в последовательности. 
Кликните на кнопку Place.  Пины присоединятся к 
курсору в графическом окружении для размещения. 
Однажды присоединенные к  курсору, Вы можете 
поворачивать все пины как группу. Это делается 
выбором клавиши Action. 
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Шаблон Размещения
Чтобы разместить пины по шаблонам индустриальных 
стандартов, выберите вкладку Pattern Place.

Эта вкладка доступна если нет размещенных пин. Она 
позволяет выбрать все пины ячейки и разместить их по 
шаблону.
Вкладка Pattern Place показывает описание 
выбранного Типа Шаблона. Каждый тип шаблона имеет 
поля ввода, которые позволяют ввести значения 
ширины, высоты, растояния между центрами пин и т.д.
Пункт Include Assembly Outline позволяет включить или 
выключить контур сборки. Контур сборки представляет 
верхний вид компонента. Он используется в сборочных 
чертежах. Этот контур определен на слое Assembly.

Пункт Include Silkscreen Outline позволяет включить или 
выключить контур шелкографии. Контур шелкографии 
используется для представления шелкографии 
компонента.  Этот контур определен на слое Silkscreen.
Поле Rotation позволяет ввести трубуемый угол 
поворота. Если угол поворота выбран, то вся графика 
будет размещена с выбранным углом поворота.
Кликните на кнопку Place, чтобы разместить шаблон в 
графическом окружении.



 D-11 
 E XPEDITION PCB INTRODUCTION  WG2000 

 

  

Графическое окружение
Г р а ф и ч е с к о е  
окружение позволяет 
р е д а к т и р о в а т ь  
г р а ф и ч е с к о е  
п р е д с т а в л е н и е  
ячейки. Окружение 
это измененная 
версия окружения 
Expedition PCB.
Когда редактируете 
новую ячейку, 
г р а ф и ч е с к о е  
о к р у ж е н и е  
открывается при 
нажатии кнопки Next в 
диалоге New Cell.
Чтобы редактировать 
с у щ е с т в у ю щ у ю  
ячейку, выберите 
ячейку из списка 
ячеек в главном 
диалоге Редактора 
Ячеек, затем кликните 
и к о н к у  
Р е д а к т и р о в а т ь  
графику.
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Добавление Контуров
Есть четыре типа контуров, которые мугут быть 
добавлены в ячейку. Каждый из них служит для 
различных целей в Expedition PCB. Каждый 
добавляется используя команду Draw. Команды для 
автоматического запуска контуров находятся в меню 
Edit>Place.

- Assembly Outline - Определяет физическую форму
корпуса. Она представляет графику которая будет 
использована в сборочных чертежах. Ширина линии 
может быть назначена для контура сборки для 
печати.

- Insertion Outline - Определяет площадь необходимую
для головки установочной машины. Она используется 
для проверки правил проектирования, что Assembly 
Outline и Insertion Outline не соприкасаются.

- Placement Outline - Определяет место размещения
ячейки с целью проверки правил проектирования. 
Каждый контур может иметь заданную высоту и 
пространство снизу, для проверки правил 
проектирования. Если контур размещения не задан, 
то он создается автоматически, как прямоугольник 
покрывающий все площадки на монтировочном слое 
и  Assembly Outline.

- Silkscreen Outline - Определяет графику которая
будет нанесена как шелкография на плату. Графика 
может быть определена как для монтировочной 
стороны или оборотной стороны, так и для обеих.

Добавление Текста
Прорисованный текст может быть добавлен в ячейку. 
Текст может быть размещен на любом трассировочном 
слое или на слое пользователя.
Есть четыре типа текста, которые имеют "заполнитель" 
для данных проекта. Команды для автоматического 
запуска размещения этих "заполнителей" текстовых 
свойств находятся в меню Edit>Place.

- Assembly Ref Des
- Silkscreen Ref Des
- Assembly Part Number
- Silkscreen Part Number

Когда добавляете  "заполнитель" текстовых свойств 
фонт должен быть совместим с Gerber. Также текст 
должен иметь ширину для печати.
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Добавление Другой Информации
Определение ячейки может иметь и другие элементы, 
чтобы сделать ячейку более функциональной в 
окружении Expedition PCB. Эти элементы размещенны 
в похожей менере как в Expedition PCB. Команды для 
автоматического запуска размещения этих элементов 
находятся в меню Edit>Place.

- Contour
- Placement Obstruct
- Plane Obstruct
- Plane Shape
- Route Obstruct
- Test Point Obstruct
- Solder Mask Opening
- Glue Spots
- Fiducial
- Mounting Holes

Точки привязки
Есть две точки привязки, которые можно разместить в 
ячейке.

- Cell Origin - это начало координат (0,0) в проекте и
 координаты X и Y отсчитываются от этой точки.

- Assembly Origin - она привязана к Cell Origin.
Используется при извлечении местоположений 
компонентов.

Изменение в местоположении точки привязки делается 
в диалоге. Введите новые X, Y для точки привязки 
относительно текущей точки привязки ячейки.
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Редактирование пина
Если при редактировании ячейки, необходимо 
изменить назначение пина или его номер, 
возвратитесь в диалог Place Pins с помощью команды 
Edit>Place>Pins. Если нужно сдвинуть пин 
используйте команду Move Pin из панели меню.
При этом пин или группа пин должны быть заранее 
выбранны.
Выбранные пины можно вращать командой Rotate 
Pins 90 или Rotate Pins 180 из панели устройств
или клавишами действий. Клавиши действий доступны 
чтобы обеспечить координаты местоположения для 
графики выбранного пина.

Редактирование пина
Чтобы покинуть графическое окружение и 
возвратиться в главный диалог Редактора Ячеек 
используйте команду File>Exit Graphics. 
Замечание: Сохраняйте периодически свою работу в 
графическом окружении командой File>Save. Если 
ваша работа не была сохранена, когда будете покидать 
графическое окружение будет подсказка о 
необходимости сохраниться.

Проверка
Когда ячейка построена, он должна быть проверенна. 
Это делается ручным просмотром ячейки чтобы 
удостовериться что вся информация включена, 
использованны соответствующие padstacks и все 
размеры корректны. Когда ячейка проверенна, она 
должна быть отмеченна в библиотеке как проверенная.
Чтобы пометить ячейку как проверенная:

- Выбрать ячейку, кликнуть иконку Свойства и
изменить статус Verification в диалоге.

Или
- Добавить колонку Verified в Cell List в главном

диалоге, затем измените статус проверки для 
ячейки.



 D-15 
 E XPEDITION PCB INTRODUCTION  WG2000 

 

 

 

 

Лаб. - Создание Ячеек

1.

2.

Вы должны иметь открытой Центральную 
Библиотеку "master" в Менеджере Библиотек. 
<Кликните> кнопку Cells (Package, Draft & 
Mechanical) чтобы войти в Редактор Ячеек.

В диалоге Редактора Ячеек установите 
раздел temp.

Установка

Создание новой SMD ячейки
3.

4.

5.

6.

7.

8.

9.

10.

<Кликните> кнопку New Cell.

Выберите опцию Create new Cell (вверху диалога).

Введите имя ячейки 14SO.

Определите Total number pins 14. Задайте Layers 
while editing cell 2. Выберите IC-SOIC для Package 
group.

<Кликните> кнопку Cell Properties. Введите 
описание SOIC 14. Введите Units в mm. Определите 
Height 1.75.

В диалоге Package Cell Properties  <кликните> 
кнопку Close.
 
В диалоге Package Cell  <кликните> кнопку Next.

В диалоге Place Pins  <кликните> колонку Pin# 
чтобы пины отсортировались от 1 до 14.

11.

12.

13.

14.

15.

16.

17.

18.

19.

Выберите Padstack Name для пина 1. Нажмите и 
держите клавишу <Shift> затем выберите поле 
Padstack Name для пина 14.

Продолжая удерживать клавишу <Shift> 
<кликните> стрелку вниз в поле Padstack Name для 
пина 14 и выберите padstack SOIC из 
ниспадающего списка. Он должен быть назначен 
для всех пин.

<Кликните> на вкладку Pattern Place.

Установите Pattern Type в SOIC и введите 
следующие значения в форму шаблона:
Body Length = 8.75
Body width = 4
Pin to pin spacing = 1.27
Row to row spacing = 5.2

Удостоверьтесь что включенны опции Include 
Assembly Outline и Include Silkscreen Outline.

С выбранными пинами <кликните> кнопку Place.

<Кликните> кнопку Close в диалоге Place Pins.

Проверьте графику. Выберите File>Save из меню и 
затем выберите File>Exit Graphics из меню.

В главном диалоге Редактора Ячеек <кликните> 
кнопку Apply чтобы сохранить вашу работу. 
Проверьте в Предосмотре новую ячейку. 
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Создание новой Сквозной Ячейки
20.

21.

22.

23.

24.

25.

26.

27.

28.

29.

30.

<Кликните> кнопку New Cell.

Введите имя ячейки 14DIP.

Определите Total number pins 14. Задайте Layers 
while editing cell 2. Выберите IC-DIP для Package 
group.

<Кликните> кнопку Cell Properties. Введите 
описание DIP 14. Введите Units в th. Определите 
Height 100. <Кликните> кнопку Close.

В диалоге Create Package Cell  <кликните> кнопку 
Next.

Сдвиньте в сторону диалог Place Pins.

В графическом окружении выберите из меню 
Setup>Editor Control.

Выберите вкладку Grids. Задайте Route grid 25 и 
Drawing grid 25.

В диалоге Editor Control, <кликните> кнопку OK.

В диалоге  Place Pins, выберите поле Padstack Name 
для пина 1. Нажмите и держите клавишу <Shift> 
затем выберите поле Padstack Name для пина 14.

Продолжая удерживать клавишу <Shift> <кликните> 
стрелку вниз в поле Padstack Name для пина 14 и 
выберите padstack 34/65 round из ниспадающего 
списка. Он должен быть назначен для всех пин.

31.

32.

33.

34.

35.

36.

37.

38.

39.

<Кликните> на вкладку Parameter Place и 
установите введите следующие значения:
# Columns: 7            Spacing: 100
# Rows: 2            Spacing: 300
Pin Sequence=

<Кликните> кнопку Place.

Позиция курсора в пространстве прорисовки. Пины 
присоединены к курсору для размещения. 
<Кликните> непосредственно в начале координат 
чтобы разместить их там.

Выберите из меню View>Fit All.

В диалоге Place Pins измените Padstack Name для 
пина 1 в 34/65 SQUARE.

<Кликните> кнопку Close в диалоге Place Pins. 
Если все было сделанно корректно, графика 
покажет 14 пинный DIP с квадратным пином 1.

Выберите из меню Edit>Place>Assembly Outline. 
Используя Прямоугольный инструмент рисования 
внизу окна прорисуйте прямоуглольник внутри всех 
пин. Нарисуйте любую другую сборочную графику, 
какую хотите, выбрав другой инструмент рисования.

Выберите из меню Edit>Place>Silkscreen Outline. 
Прорисуйте прямоуглольник вне всех пин. 
Нарисуйте любую другую графику шелкографии, 
какую хотите.

Выберите из меню Edit>Place>Placement Outline. 
Прорисуйте прямоуглольник немного больше чем 
Silkscreen Outline.



 D-17 
 E XPEDITION PCB INTRODUCTION  WG2000 

 

 

40.

41.

42.

43.

44.

45.

Выберите из меню Edit>Place>Silkscreen Ref Des и 
разместите текст вне  Silkscreen Outline.

Выберите File>Save из меню.

Выберите File>Exit Graphics из меню.

Выберите каждую ячейку в списке, чтобы увидеть 
ее в окне Предосмотра.

<Кликните> кнопку OK в главном диалоге 
Редактора Ячеек, чтобы сохраниться и покинуть 
Редактор Ячеек.

Сдвиньте текст Reference Designator и Part 
Number как хотите, сначала выбрав текст 
размещая курсор на границу текста до тех 
пор пока не появится курсор сдвига, затем 
<кликните-потяните> текст.



 
 

EXPEDITION PCB INTRODUCTION E-1 

E Создание Деталей (Parts)
Эта глава является введением в создание детали - 
добавление связи с компонентом, такой как ссылка 
схемного логического символа на ячейку посадочного 
места компонента и назначение номера детали.
Рассматриваются темы:
- Что такое Деталь?
- Вызов Редактора PDB
- Окружение Редактора PDB
- Базовая последовательность работы
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Что такое Деталь?
"Детали" хранятся в Базе Данных Деталей или "PDB". В 
Центральной Библиотеке может быть одна или более 
PDB. Деталь содержит наибольшую часть связанности 
компонента.
Деталь содержит информацию, которая связывает 
символ с ячейкой по свойству названному "Part Number" 
(Номер Детали). Для данного Номера Детали, PDB 
содержит информацию о том какой символ и какая 
ячейка связанны с этим номером, как номера пин 
физических ячеек отображаются в логические имена пин 
символа и также определяют будут ли пины и логические 
вентили  для детали "переставляемыми" на плате. PDB 
файл может также быть использован для назначения 
других свойств в деталь, такие как цена детали, значение 
сопротивления или емкости, имя модели для 
моделирования и т.д.

Вызов Редактора PDB
Редактор PDB вызывается из Менеджера Библиотек 
если <кликнуть> на иконку Parts Database. Редактор 
будет редактировать PDB  в разделах PDB Центральной 
библиотеки.

В Expedition PCB Редактор PDB вызывается командой 
Setup>PDB Editor. Редактор будет редактировать 
библиотеку PDB  в локальной директории 
Топологического проекта.
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 Окружение Редактора PDB
Редактор PDB состоит из главного диалога, где 
вводятся PDB и хранятся. Здесь есть под-
диалог в котором вводят другую важную 
информацию о детали.

Меню
Меню File содержит команды, чтобы Сохранить 
PDB и покинуть Редактор PDB. Здесь есть также 
команды для записи выбранных элементов в 
ASCII файл или чтения элементов из ASCII 
файла.
Меню Units выбирает единицы измерения 
используемые по умолчанию при создании PDB.
Меню Verification содержит команды, чтобы 
разрешить или выполнить проверку свойств 
PDB, чтобы удостоверится что PDB элементы 
имеют корректные свойства для использования 
в прикладных программах.
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Базовая последовательность работ

Открытие или создание раздела
Поле Раздела показывает имя активного в данный 
момент раздела. <Кликните> на стрелку вниз чтобы 
изменить раздел. <Кликните> на иконку Редактора 
Разделов чтобы создать новый раздел.

Редактирование существующего элемента PDB
Чтобы редактировать существующий элемент PDB, 
выберите его из списка. Вся информация о этом 
элементе будет загружена в диалог для редактирования.

Ввод нового элемента PDB
Чтобы начать новый элемент PDB, <кликните> на иконку 
New. Новая строка откроется в списке с "заполнителем" в 
полях Number и Name.

Номер Детали
Номер Детали это главное что ищется в файле Базы 
Данных Деталей. Когда Вы запускаете утилиту на 
проекте схемы, система читает свойство Part Number 
назначенное на каждый символ. Упаковщик затем ищет 
по разделам PDB совпадающий Номер Детали. Если 
совпадение найдено, свойства из PDB назначаются 
(обратно аннотируются) в схемный символ. Номер 
Детали должен быть номер появляющийся в 
документации проекта, таких как сборочный чертеж или 
список используемых материалов. Номер Детали может 
быть до 32 знаков. Позволенны любые знаки.
Номер Детали должен быть уникальным в Центральной 
Библиотеке. Номер Детали обязателен.

Имя Детали
Свойство Part Name Упаковщик ищет в файле Базы 
Данных Деталей если не назначенно Part Number на 
схемный символ. Если использованно Part Name для 
поиска Номера Детали, "используемое по умолчанию" 
Part Number для этой Part Name будет использованно 
автоматически Упаковщиком. Part Name часто это общее 
имя детали, такое как ALS00 (в противоположность Part 
Number, которое должно быть типа SN74ALS00A/n). Part 
Name может быть до 32 знаков.
Part Name может повторятся, в этом случае Part Number 
ассоциированное с этим Part Name должно быть 
отмеченно как "используемое по умолчанию". Part Name 
обязателен. 
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Метка Детали (Part Label)
Метка Детали это путь назначить более знакомое имя 
для детали, например номер каталога для  Dual Bipolar 
Operational Amplifier должно быть  MC33178P, в то время 
как Вы можете сослаться на него как 5MHzOPAMP, 
который будет Меткой Детали. Другой пример:  резистор 
может иметь Номер Детали D55342K07B1E00R (военная 
спецификация), Имя Детали может быть общим RM1206, 
в то время как Метка Детали может быть описательной 
1.00K_1%_250W_RM1206. Метка Детали может быть до 
32 знаков.
Метка Детали может повторятся. Метка Детали не 
обязательна. 

 

 

 

Свойства Компонента
По умолчанию список компонентов показывает свойства 
необходимые для "Типа" компонента. Свойства 
компонента будут красного цвета до тех пор пока Вы не 
дадите им действительные значения, тогда цвет 
переключится в черный. Чтобы определить добавочные 
свойства компонента, <кликните> на иконку New, которая 
открывает пустое поле свойства компонента. Вы можете 
затем кликнуть на пустое поле и получить ниспадающее 
меню свойств из которого выбрать нужное.
Заметьте свойство Type. Оно использованно для 
проверки свойств. Тип может быть резистор, IC, емкость 
и т.д. и должно быть установленно соответственно виду 
создаваемой детали. Также свойство Tech должно быть 
установленно согласно технологии детали.

Описание (Description)
Поле Описания включенно в список используемых 
материалов.  Это поле не обязательно, однако, оно 
должно использоваться для полного определения 
детали.

Префикс Reference Designator
Префикс Reference des. использован Упаковщиком для 
задания префикса при упаковке. По умолчанию префикс 
U.  Он должен редактироваться согласно типу детали 
(например R для резистора и т.д)
Номер после префикса будет добавлен соответственно 
при упаковке.
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Pin Mapping
В диалоге Редактора PDB 
кликните на кнопку Pin 
Mapping, чтобы вызвать 
диалог Pin Mapping. Этот 
диалог имеет три цели:
- Назначить символы

Design Capture, которые 
могут быть упакованы в 
деталь.

- Назначить ячейки
Expedition PCB , 
которые могут быть 
использованны для 
детали.

- Связать пины символов
Design Capture и пины  
ячеек Expedition PCB.
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Назначение Символа
В секции Assign Symbol (Назначение Символа) кликните 
на иконку New, появится строка где вводится имя 
символа. Это возможно если символ не создан в 
Центральной Библиотеке. 

Однако если символ создан, предпочтителен метод 
импортирования символьной информации из раздела 
символов. 

Импорт
Кликните на иконку 
Import, чтобы импорти-
ровать символ из 
раздела символов 
Ц е н т р а л ь н о й  
Библиотеки.
Выберите раздел 
символов где хранится 
символ.
Наберите имя символа 
или выберите его из 
списка.
Выберите опцию, Create  
new gate information.
Введите количество 
вентилей в детали, 
которая представляет 
символ. Это будет 
стартовым пунктом в 
секции оттображения 
пинов диалога.
Опция Include pin 
properties будет 
автоматически ставить 
пинам PDB такие же 
свойства как на 
символе (input, output и 
т.д).
Если символ имеет физические номера пин, опция 
Include pin number mapping будет автоматически 
назначать эти номера пин, когда импортируется символ. 
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Назначение Ячейки
В секции Assign Package Cell (Назначение Ячейки 
Корпуса) Вы можете ввести имя Top ячейки или Bottom 
ячейки. Вы должны иметь хотя бы одну из них. Кликните 
на иконку New, появится строка где вводится имя 
Alternate ячейки. Можно ввести имя если ячейка не 
создана в Центральной Библиотеке. 

Однако если ячейка создана, предпочтителен метод 
импортирования информации ячейки из раздела ячеек. 

Импорт
Кликните на иконку 
Import, чтобы импорти-
ровать ячейку из 
раздела ячеек 
Ц е н т р а л ь н о й  
Библиотеки.
Выберите раздел ячеек 
где хранится ячейка.
Фильтр списка имен 
ячеек основан на 
Package group и 
количестве пин.
Наберите имя ячейки 
или выберите его из 
списка.
В ы б е р и т е   
импортировать  ячейку 
как Top ячейку, Bottom 
ячейку или Alternate 
ячейку.
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Вкладка Logical Gates

Когда импортирован 
символ, созданны данные 
"Логические вентили". 
Вкладка Logical в диалоге 
редактирует информацию 
о Логических вентилях. 
Эта информация 
содержит :
- Определение пин
- Назначение свопинга

пин
- Определение слотов

Свойства Пин
Каждая строка в таблице представляет пин в Логическом 
вентиле. Каждый пин можеи иметь Свойства, такие как 
Pin Type  со Значением или Supply Pin с именем 
ассоциированного сигнала.

Свопинг пин
Чтобы назначить два пина как свопируемые, выберите 
обе строки пин, затем кликните иконку Swap. Свопинг 
может быть назначен только между пинами с 
одинаковыми свойствами. Свопируемые пины 
отмеченны цветовым квадратом в первой колонке.
Слоты
В определении Логических вентилей, слот это один 
экземпляр Логического вентиля в устройстве. Каждый 
слот представлен двумя колонками в таблице.

- Одна содержит имена пинов символа. Когда
импортирован символ. Имена пинов символа будут 
автоматически введены в первый слот.

- Другая содержит Физические номера Пин из ячейки.
Это не редактируется во вкладке Логические вентили.

Любые слоты одного и того же вентиля свопируемы.
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Физические пины

Все номера пин должны быть назначенны или во 
вкладке Phisical или во вкладке Supply and NC. Таблица 
показывает определение слотов из вкладки Logical. 
Введите соответствующие номера пин для каждого 
слота.

Вкладка Physical в 
диалоге редактирует 
информацию Физических 
пин. Это обычно делается 
после определения 
Логических вентилей.
Список Физических пин 
показывает все пины 
которые не были 
отображенны для детали. 
Этот список заполнен 
номерами пин из 
импортированной ячейки. 
Когда пины назначенны 
их номера удаляются из 
списка. 
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Supply and NC Пины

После ввода номера пина, в таблицу будет 
добавлена новая колонка позволяя ввести 
добавочный пин с тем же именем питания.

Помните что ваша работа не сохранена в Редакторе 
PDB до тех пор пока Вы не воспользуетесь командой 
File>Save.

Вкладка Supply and NC 
назначает пины которые 
есть на физической 
ячейке, но их нет на 
символах Design Capture. 

Supply Пины
Чтобы назначить Supply 
Пин, введите Supply 
Name - имя сигнала. 
После ввода имени 
новая пустая строка 
будет добавлена в 
таблицу, позволяя 
ввести имя питания. 
Введите физический 
номер пина. 

No Connect Пины
Введите номер пина для No connect. После ввода 
номера пина, в таблицу будет добавлена новая 
колонка позволяя ввести добавочный No connect пин.

Сохранение
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Лаб. - Создание Детали

1.

2.

Вы должны иметь открытой Центральную 
Библиотеку "master" в Менеджере Библиотек.

<Кликните> кнопку Parts Database чтобы 
войти в Редактор PDB.

Установка

3.

4.

5.

6.

7.

В диалоге Редактора PDB установите раздел temp.

<Кликните> кнопку New. Чтобы начать новый пункт 
PDB. Измените Number в SN74ALS00AN. 
Измените Name в 54/74xxx00. Измените 
Label в 74ALS00A.

В левом-нижнем углу диалога PartsDB Редактора 
проверьте что значение свойства Component это IC.

Введите в Description IC, DIP, QUADRUPLE 2-INPUT 
POSITIVE-NAND GATES.

Определите Reference des prefix U. 

8.

9.

10.

11.

12.

13.

14.

15.

16.

17.

18.

В диалоге Редактора PDB, <кликните> кнопку  Pin 
Mapping.

В секции Assign symbol диалога (левый-
верхний угол) <кликните> кнопку Import.

В диалоге Import выберите имя символа NAND2 из 
списка.

Выберите опцию Create New gate information. 

Введите Number Slots как 4.

Выберите опцию Include pin properties.

<Кликните> кнопку  OK. Будет создан новый 
вентиль в таблице Logical с 4 слотами.

В секции Assign package cell диалога (правый-
верхний угол) <кликните> кнопку Import.

В диалоге Import выберите 14DIP из списка ячеек и 
<кликните> кнопку  OK. (Используйте DIP14 если 
Вы не закончили предыдущую "Создание Ячейки" 
лаб. работу.

Проверьте таблицу Logical внизу диалога Pin 
Mapping. Определен символ импортированный с 4 
слотами. Имена пин символа (A, B, Y) были 
импортированны только в первый слот.

Установите пин свопинг выбрав оба Input 
пина и затем <кликните> кнопку  Swap.
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A 1  9 12 
B 2  10 13 
Y 3  8 11 

 

25.

26.

27.

28.

29.

30.

31.

32.

33.

Выберите деталь SN74ALS00AN которую Вы только 
что создали и<кликните> кнопку  Copy.

Измените имя на  SN74ALS00AD.

Измените Description на IC, SOIC, QUADRUPLE 2-
INPUT POSITIVE-NAND GATES.

<Кликните> кнопку  Pin Mapping.

В секции Assign package cell диалога <кликните> 
кнопку Import.

В диалоге Import выберите 14SO из списка ячеек и 
<кликните> кнопку  OK. (Используйте SO14 если 
Вы не закончили предыдущую "Создание Ячейки" 
лаб. работу.

Логика и выходные пины точно такие же как на 
оригинальной детали, поэтому ничего делать не 
надо. <Кликните> на кнопку OK в диалоге Pin 
Mapping.

Выберите File>Save из меню.

Покиньте Редактор PDB.

Копирование Детали

20.

21.

22.

23.

24.

<Кликните> на вкладку Supply and NC.

Введите Supply Name GND и нажмите <Enter>. 
Введите Pin# 7.

В следующей строке введите Supply Name VCC и 
нажмите <Enter>. Введите Pin# 14.

<Кликните> на кнопку OK в диалоге Pin Mapping 
чтобы сохранить вашу работу. 

Выберите File>Save из меню.

 

19. <Кликните> на вкладку Physical. Введите 
следующее в выводы физических пин.

4 
5 
6 
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F  Создание Шаблона Топологии
Эта глава обсуждает базовые вопросы, почему и как 
создавать шаблон топологии (источник).
Рассматриваются темы:
- Что такое Шаблон Топологии?
- Создание/Редактирование Шаблонов Топологии
- Копирование Ячеек и Padstacks



Шаблоны и Центральная Библиотека
Шаблоны топологии Expedition PCB хранятся в 
Центральной Библиотеке. В Центральной Библиотеке 
может быть множество шаблонов топологии, которые 
могут быть использованны чтобы начать топологии с 
различными характеристиками. 
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Что такое Шаблон Топологии?
Топология Expedition PCB не может стартовать из 
пустоты. Здесь есть минимальный набор директорий и 
файлов, который должен быть представлен. Это 
названно "шаблон топологии".
Два базовых шаблона топологии Expedition PCB 
поставляются вместе с программным обеспечением. Они 
содержат минимум, чтобы начать новую топологию 
Expedition PCB. По умолчанию поставляемые шаблоны 
топологии находятся в  :  
c : \ m e n t o r \ 2 0 0 0 \ v b e x p p c b \ t e m p l a t e s \ c e n t r a l  
library\layouttemplates.
Шаблоны топологии могут также иметь множество 
предопределенных установок редактора, созданных 
пользователем слоев и не сгенеренных схемой ячеек и 
padstacks. Шаблоны топологии могут даже иметь контур 
платы и крепежные отверстия, предразмещенные детали 
и растрассированнын трассы.

Шаблоны и Expedition PCB
Шаблоны топологии посредством команды File>New в 
Expedition PCB. Опция New в Job Management Wizard 
подсказывает шаблон топологии для использования при 
создании новой топологии. Она затем копирует все 
директории и файлы из шаблона в Центральной 
Библиотеке в местоположение новой топологии. Это 
стартовая точка для директории "pcb" в проекте. 

Создание/Редактирование Шаблонов Топологии

Чтобы создать и редактировать шаблоны 
топологии, откройте нужную Центральную 
Библиотеку с помощью Менеджера Библиотек и 
запустите команду Layout Templates. 

1 Вы должны иметь открытой Центральную 
Библиотеку "master" в Менеджере Библиотек. 

В диалоге Library Manager, кликните кнопку Layout 
Templates. 

Диалог Layout Templates показывает все доступные 
шаблоны топологии в Центральной Библиотеке. 
Здесь новый шаблон 
может быть сделан из 
с у щ е с т в у ю щ е й  
топологии или 
копирован из другого 
шаблона топологии. 
Шаблоны топологии 
могут редактиро-
ваться из этого 
диалога.
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Новый Шаблон Топологии
Чтобы создать новый шаблон топологии используйте 
кнопку New в диалоге Layout Template. 

Проект источник
Source design file 
это существую-
щая топология 
Expedition PCB 
какую копировать.
Найдите .pcb 
файл в  системе 
c т о п о л о г и е й ,  
который служит 
х о р о ш и м  
шаблоном. 
Все директории и файлы ассоциированные с этой 
топологией (за исключением данных схемы) будут 
копированны в Центральную Библиотеку как новый 
шаблон топологии. 

Имя шаблона
Задайте Template name для нового шаблона топологии. 

Копирование Шаблона Топологии
Диалог Layout Template имеет команду copy для 
копирования из существующего в списке шаблона 
топологии. 

2 В диалоге Layout Templates, выберите в 
списке 4 layer template и кликните кнопку 
Copy Template. 

Переименуйте копированный шаблон в training. 

Редактирование Шаблона Топологии
Редактирование шаблона топологии из диалога Layout 
Template открывает Expedition PCB. В Expedition PCB 
шаблон топологии показывается как любая нормальная 
топология платы за исключением того что здесь нет 
источника проекта (нет схемы и CDB). 

3 С выбранным новым шаблоном training 
кликните кнопку Edit Template. 

Будет запущен Expedition PCB. Кликните на кнопку OK в 
двух сообщениях "Forward annotation has been disabled" и 
"Back annotation has been disabled". 
Однажды Expedition PCB запущенно, кликните на кнопку 
OK чтобы закрыть диалог Tips of the Day если он 
появится.

На этой стадии могут быть выполнены какие-либо 
предустановки не связанные со схемой. 
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 Копирование Ячеек и Padstacks
Ячейки и padstacks не связанные со схемой могут быть 
копированны в шаблон топологии.  Это позволяет 
обращаться к этим ячейкам и padstacks из любой 
топологии платы которая использует этот шаблон 
топологии.

Ячейки
Механические ячейки и чертежные ячейки не 
аннотируются прямо из источника проекта в топологию 
платы ... но они могут быть копированны в шаблон 
топологии для легкого доступа позднее, в течении 
процесса создания топологии.
Ячейки Тестовых Точек могут быть легко извлечены из 
Центральной Библиотеки в течении процесса создания 
топологии, поэтому нет необходимости копировать их в 
шаблон топологии. 

Padstacks
Via, Fiducial и Mounting Hole также могут быть легко 
извлечены из Центральной Библиотеки в течении 
процесса создания топологии, с одним исключением - 
padstack Via должен существовать в локальной 
библиотеке в течении процесса создания топологии 
когда используете диалог  Net Classes and Clearance 
(Net Classes будут обсуждаться позднее в курсе). 

Файл проекта
Для того чтобы иметь доступ к текущей Центральной 
Библиотеке, должен быть отмечен файл проекта для 
шаблона топологии. Доступ к этому файлу проекта 
имеется через диалог  Project Integration.
Замечание: Файл Проекта и Интеграция Проекта 
обсуждаются более детально позднее в курсе. 

4 Пока редактируете шаблон топологии training в 
Expedition PCB, выберите из меню Setup>Project 
Integration. 

Кликните на кнопку Edit the Project File вверху диалога 
Project Integration.
Кликните на кнопку Browse for Central Library вверху 
диалога Project Editor.
Найдите текущую Центральную Библиотеку, master.lmc в 
c:\mgtraining\common\libraries\master.
Кликните на кнопку OK в диалоге Project Editor чтобы 
сохранить установки Файла Проекта.
Кликните на кнопку Close в диалоге Project Integration.
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Файл проекта
Library Services позволяет копировать Symbols, Parts, 
Cells, Padstacks и IBIS Models из одной Центральной 
Библиотеки в другую. Если Library Services вызван из 
шаблона топологии, Ячейки и Padstacks и Детали могут 
быть копированны (импортированны) в локальную 
библиотеку шаблона топологии из Центральной 
Библиотеки.

5 Пока редактируете шаблон топологии training в 
Expedition PCB, выберите из меню Setup>Library 
Services. 

Кликните на кнопку OK на сообщение "Forward annotation 
is not allowed ...".
В диалоге Library Services  кликните на вкладку Cells. 
Выберите раздел misc из ниспадающего списка Import 
from partition.
В списке Cells in import partition <двойной-клик> на 
ячейках #4NUT, #4SCREW, #4WASHER и Mentor logo, 
передвигая их в список Cells to import.
Кликните на кнопку Apply внизу диалога Library Services, 
чтобы копировать ячейки в локальную библиотеку ячеек 
шаблона топологии.
Кликните на вкладку Padstacks.
Скопируйте следующие padstacks, как вы сделали ячейки:
25th via pad
25th via pad, tented
40th via pad
40th via pad, tented
Кликните на кнопку Close в диалоге Library Services.
Покиньте Expedition PCB.
Покиньте Library Manager.
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G Обзор Редактора Топологии
Эта глава вкрадце обьясняет где хранятся  данные платы и 
также введение в окружение редактора Expedition PCB.
Рассматриваются темы:
- Директории и имена файлов
- Интерфейс пользователя
- Panning & zooming
- Display Control
- Режимы Place/Route/Draw
- Выбор обьектов
- Нахождение Деталей и Цепей
- File Viewer
- Help
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Директории и имена файлов
Директории и файлы для проекта Expedition PCB легко 
устанавливаются и управляются на комьютерном 
накопителе.

Директории
Сначала необходимо 
вручную установить общее 
пространство проекта, такое 
как c:\project. Все будущие 
проекты затем могут быть 
размещены в этом 
пространстве (смотрите 
примеры 2001 и 2101 
показанные справа).
Когда стартуете новую 
работу платы, автоматически 
создается структура 
директории "pcb" для этого 
проекта (как показанно). В 
течении процесса создания 
топологии сгенеренные 
файлы сохраняются в 
соответствующих под-
директориях.

Имена файлов
.PRJ
Схемы Design Capture и базаданных Expedition 
PCB зацентрированны вокруг "файла проекта".
Файл проекта обычно хранится со схемой, в 
специфической директории проекта и принимает 
имя этого проекта с расширением .prj.

1 Используя Windows Explorer перейдите в 
c:\mgtraining\project\2101, <двойной-клик> на 2101.prj. 

Должен вызваться Design Capture и открыт проект.
Осмотритесь в Design Capture, если хотите. Выберите 
File>Exit из меню и не сохраняйте какие-либо изменения.  

Замечание: Файл проекта обсуждается в 
больших деталях в разделе "Старт Топологии 
Платы".
.PCB
Главный файл для базыданных платы хранится в 
поддиректории pcb проекта. По умолчанию имя 
файла принимает имя проекта с расширением 
.pcb.
Замечание: Файл .pcb не является законченной 
базой данных платы. Задействованно много 
других файлов и директорий.

2 Используя Windows Explorer перейдите в 
c:\mgtraining\project\2101\pcb, <двойной-клик> на 
2101.pcb. 

Должен вызваться Expedition PCB и открыта база данных 
платы для редактирования.



 G-3 
 E XPEDITION PCB INTRODUCTION  WG2000 

 

 

 

 

Выпадающе Меню
Содержит большинство 

команд для работы: 
Setup, Place, Route, 
Analysis и Output.

Панель
Содержит обычно 

используемые команды. 
Разместите курсор на 

кнопке для отображения 
имени команды.

Строка заголовка

Рабочее пространство

Клавиши действий
Динамически 

изменяющиеся опции 
активной команды. Могут 

быть вызванны с помощью 
функциональных клавиш.

Строка состояния
Показывает информацию, 

установки, статус и 
подсказки.

Путь и Проект
Текущая открытая 
топология (и проект).

Считываемые координаты
Абсолютные (xy) и Относительные 
(dxdy) координаты.

Интерфейс пользователя
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PANNING & ZOOMING 

 

Использование мышки
Panning и zooming в Expedition 
PCB используя среднюю 
клавишу мышки.

Увеличение
Чтобы немного увеличить, <средний-клик> в 
рабочем пространстве .

Уменьшение
Чтобы немного уменьшить, <Shift><средний-клик>.

Масштабирование площади
Чтобы увеличить площадь, <Shift><средний-клик-
тянуть> слева направо, прорисовывая 
прямоугольник. 
Чтобы уменьшить площадь, <Shift><средний-клик-
тянуть> справа налево.

Панорамирование
Чтобы динамически панорамировать вид, <средний-
клик-тянуть>.

Fit Board / Previous View
Чтобы переключаться между видом всей платы и 
вернуться обратно в предыдущий вид, 
<Ctrl><средний-клик>.

Добавочные команды вида

Чтобы масштабировать до размера Контура 
Платы, выберите из меню View>Fit Board или 
кликните кнопку Fit Board.

Fit Board

Чтобы масштабировать до размера всей 
графики, выберите из меню View>Fit All.

Fit All

Чтобы перейти к масштабу использованному 
ранее, выберите из меню View>Previous 
View или  View>Next View или кликните 
кнопку на панели.

Предыдущий Вид / Следующий Вид

3 Поэкспериментируйте со всеми функциями 
масштабирования и панорамирования показанными 
здесь. 

Кликните кнопку на панели Fit Board. Кликните кнопку на 
панели Previous View и Next View. 
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 Управление Изображением
Диалог Display Control главным образом использован 
для управления изображением графики, но имеет и 
некоторые другие уникальные функции. Оставьте 
диалог открытым на рабочем столе в процессе 
создания топологии для удобства.

4 Выберите из меню View>Display Control или 
кликните кнопку на панели Display Control. 

Не делайте каких-либо изменений в диалоге пока. 

Большинство графических элементов перечисленных в 
диалоге имеют пункт видимости и цветную кнопку для 
изменения цвета.

Видимость и цвет

Многие графические элементы перечисленных в 
диалоге устроенны в "группы". 
Графика для целой группы может быть включена и 
выключена за один раз используя пункт группы.
Чтобы упрастить диалог, группы элементов 
могут быть свернуты, таким образом 
отображается только заголовок группы.

Группы

Схемы Управления Изображением
Видимость обьекта и цвет обьекта могут быть 
сохранены используя Display Control Schemes. Не 
ограниченное количество схем может существовать 
для быстрого отображения специфической графики, 
такой как графика слоя 1, графика шелкографии, 
графика чертежа сверления и т.д.
Эти схемы могут находится локально (только с текущей 
топологией) или в системе (доступные для всех 
топологий открытых на отдельном компьютере). 

5 В левом-нижнем углу диалога Display Control 
кликните кнопку Save Scheme. 

В диалоге Save Scheme задайте Имя Схемы temp. 
Включите Save locally with job и выключите  Save with 
PCB system files. Кликните кнопку OK.
Замечание: В реальном случае Вы можете захотеть 
просто использовать Save with PCB system files. 

Чтобы вызвать сохраненную схему, выберите ее из 
выпадающего списка существующих схем.
Чтобы удалить сохраненную схему, выберите ее 
из выпадающего списка (который активизирует 
схему) и затем кликните кнопку Delete Scheme. 
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Вкладка Layers диалога 
Display Control имеет дело с 
фильтрами размещения, 
графикой трасс/площадок, 
активным трассировочным 
слоем, и различными 
другими переключателями и 
установками цвета.

Слои
Позволяет/запрещает 

выбор детали на 
соответствующей 

стороне платы.
(Обсуждается в главе 

"Размещение Деталей").

Переключатель графики 
для всех Трасс и всех 

Площадок.

Переключатель графики  
и установка цвета для 

физических слоев 
платы. Здесь может 

быть установлен актив-
ный трассировочный 

слой.
Кнопка "свертывания" 

группы.

Переключатель графики 
группы.

Установки цвета для 
Выбранных и Подсвеченных. 

Переключатель только для 
изображения Только 

выбранных и подсвеченных 
элементов ("Выбор" и 

"Подсветка" обсуждаются 
обсуждаются позднее в этой 

главе.).

"Активный" слой. 
Трассы и Площадки для 
активного слоя не могут 
быть выключенны.

Трассы на слое. 
Переключатель графики 
и установка цвета.

Площадки на слое. 
Переключатель графики 
и установка цвета.

Группа Линии Цепей и 
Линии Классов. 
Переключатель 
видимости Линий Цепей 
и Линий Классов.
Группа Сетка. 
Переключатель 
видимости сетки.

Группа Площадки. 
Переключатель видимости 
площадок, переходов и 
тестовых точек. Сквозные 
площадки и переходы могут 
также быть Одного Цвета.

Группа Плоскости. 
Переключатель 
видимости данных 
плоскостей, контуров и 
заполненности.
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Вкладка General диалога 
Display Control имеет дело с 
графикой не относящейся к 
цепям и деталям и 
некоторыми смешанными 
установками редактора.

Общая

При включении Auto 
Pan, вид автоматически 

панорамируется когда 
тяните обьект (трасса, 

деталь и т.д) рядом с 
краем рабочего 

пространства.

Кнопка "свертывания" 
группы.

Переключатель графики 
группы.

При включении Full 
Cursor, курсор в виде 

перекрестья будет 
отображаться когда 

двигаете деталь.

Группа Пользовательские 
Чертежные Слои. 
Пользовательские cлои 
определенные в Setup Parameters.
Группа Элементы 
Платы. Переключатель 
видимости графики 
платы.

Группа Слои 
Изготовления. 
Переключатель 
видимости графики 
soldermask, solderpaste 
и drill drawing.

Установка Чувствительности 
Панорамирования. Чтобы 
замедлить действия 
панорамирования уменьшите 
установки.
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Вкладка Parts диалога 
Display Control контролирует 
изображение графики 
родственной к детали.

Детали Переключатель 
основной графики для 
всей графики Верхней 

и/или Нижней стороны.
Колонка  графики 
Верхней стороны.

Колонка  графики 
Нижней  стороны.
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Вкладка Nets диалога Display 
Control позволяет назначить 
уникальные цвета для 
каждой цепи и Класса Цепей.

Цепи
Разрешает или 

запрещает уникальные 
цвета назначенные 

Классам Цепей и цепям 
перечисленным ниже.

Назначаетцвет и 
разрешает видимость 

цвета для каждого 
Класса Цепей в 

проекте.

Назначаетцвет и 
разрешает видимость 

цвета для каждой Цепи 
в проекте.

Выберите какая графика 
должна изображаться 
уникальным цветом 
назначенным Классам Цепей 
и цепям перечисленным ниже.
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Режимы Размещение/Трассировка/Рисование

В Expedition PCB есть три режима работы - "Route", 
"Place" и "Draw". Определенные команды и функции 
доступны только в соответствующих режимах. 

Режим Размещения
Только в режиме Размещения можно передвинуть, 
повернуть, "толкнуть" или "опросить" компонент. 
(Режим Размещения обсуждается в больших деталях 
в главе "Размещение Компонентов").
Замечание: Режим Размещения имеет собственную 
панель и по умолчанию определенные команды 
Клавиш Действия.
Режим Трассировки
Только в режиме Трассировки можно выбрать цепи и 
растрассировать или модифицировать трассы. 
Только в режиме Трассировки доступна информация 
линий цепей, пинов и трасс. (Режим Трассировки 
обсуждается в больших деталях в главе 
"Трассировка").
Замечание: Режим Трассировки имеет собственную 
панель и по умолчанию определенные команды 
Клавиш Действия.
Режим Рисования
Режим Рисования использован для добавления 
текста, передвижения текста (включая условное 
обозначение) и рисование/копирование контуров 
платы, границ трассировки и т.д. Режим Рисования 
также использован для добавления/редактирования 
любой графики родственной чертежу.
Замечание: Режим Рисования имеет собственную 
панель и диалог Свойства, который отображается в 
Режиме Рисования.

Переключение режимов
По умолчанию Expedition PCB запускается в режиме 
Трассировки. Есть несколько путей для переключения 
режимов:

- Кликните подходящую кнопку панели.
- По умолчанию, Клавиша Действия 12 переключает

между режимами Трассировки и Размещения. Когда 
ярлык Клавиши Действия есть Place, кликните на нее, 
чтобы войти в режим Размещения и наоборот.

- Определенные команды меню автоматически
переключают режимы (такие как Edit>Place Part 
переключает в режим Размещения).

6 На Стандартной панели кликните 
каждую кнопку режима и проследите
за соответствующими панелями и изменениями 
Действующих Клавиш. 

Режим Рисования должен также показать диалог 
Свойства. Если этот диалог не появился, кликните кнопку 
на панели Draw Mode.
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Выбор обьектов
В зависимости от режима (Place, Route или Draw) 
определенные обьекты становятся выбираемыми. На 
выбранный обьект действуют различные команды 
режима.
Детали только выбираемы в Режиме Размещения, 
обьекты родственные цепи (трассы, пины и линии цепей) 
только выбираемы в Режиме Трассировки, обьекты 
чертежного типа только выбираемы в Режиме 
Рисования.
Выбранный обьект использует Выбранный цвет 
определенный в диалоге Display Control в соответствии с 
оригинальным цветом обьекта.

В режиме Размещения можно выбрать одну или 
несколько деталей. Для некоторых команд 
редактирования размещения детали должны быть 
выбранны перед выполнением команд.
Выбранная деталь может быть идентифицированна по 
Выбранному цвету Контура Размещения.

Выбор деталей

Чтобы выбрать деталь, кликните на ней. Выбор 
предыдущих выбранных деталей будет отменен.
Чтобы выбрать добавочные детали, удерживайте 
клавишу <Ctrl> и кликните на них. Этот <Ctrl><клик> 
может быть использован для выбора или отмены 
выбора деталей, без воздействия на другие 
выбранные перед этим детали.
Чтобы легко отменить выбор всех деталей, просто 
кликните где-нибудь где нет деталей.

Единичный выбор

Выбор группы
Чтобы выбрать группу деталей, <кликните-потяните> 
область выделения вокруг них с помощью левой 
клавиши мышки. Детали полностью или частично 
покрытые областью выделения будут выбранны.

Другие методы выбора
Когда в режиме Размещения, команда Edit>Select All 
будет выбирать все ячейки (детали).
Подменю Edit>Add to Select Set содержит добавочные 
команды для выбора "Fixed" и "Locked" деталей (Fix  и 
Lock изучаются позднее в этом курсе).
Команда Edit>Find  имеет опцию Select которая может 
быть применена к деталям после нахождения их. ("Find" 
изучается позднее в этом курсе).

7 В диалоге Display Control обратите внимание на цвет 
Selected вкладки Place & Route. 

Проверьте что включено Placement Outlines во вкладке 
Parts. Кликните кнопку панели Place Mode. Теперь 
кликните на любой детале в топологии. Если вы ближе 
рассмотрите контур размещения детели, будет виден 
Selected цвет.
Попробуйте различные техники выбора изученные здесь. 
Используйте кнопку панели Undo если вы двигаете 
деталь.
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Выбор цепей и трасс
В режиме Трассировки можно выбрать одну или более 
линий цепей, пин или трасс. После выбора можно 
использовать команды для трассировки, 
перетрассировки, улучшения (glossing), настройки и 
даже удаления
Выбранный обьект цепи может быть 
идентифицированна по Выбранному цвету 
заштрихованному цветом обьекта.

Выбор группы
Чтобы выбрать группу обьектов относящихся к цепи, 
<кликните-потяните> область выделения вокруг них с 
помощью левой клавиши мышки. Линии цепи, пины и 
сегменты трасс полностью или частично покрытые 
областью выделения будут выбранны. Выбор любых 
элементов цепи до этого будет отменен.
Чтобы выбрать добавочные элементы цепей используя 
групповой отбор, при этом поддерживая текущий выбор, 
<Ctrl><клик-тянуть> вокруг нужных элементов цепей.
Замечание: Может быть использована любая 
комбинация единичного/двойного/тройного и группового 
выбора.

Единичный клик на пине выбирает этот пин. Любые 
линии цепи присоединенные к этому пину будут также 
выбранны.
Единичный клик на линии цепи для выбора ее.
Единичный клик на трассе, чтобы выбрать этот сегмент 
трассы. Добавочный второй клик в другом месте этой 
трассы, выбирает все сегменты трассы между первым 
и вторым кликом. 

Единичный выбор

Двойной выбор
<Двойной-клик> на трассе для выбора всех сегментов 
трассы между пинами и/или Т пересечениями. 

Тройной выбор
<Тройной-клик> на пине, линии цепи или трассе для 
выбора всех пин, линий цепи и трасс этой цепи. 

 

Другие методы выбора
Когда в режиме Трасировки, команда Edit>Select All 
будет выбирать все трассы, пины и линии цепей.
Подменю Edit>Add to Select Set содержит добавочные 
команды для выбора "Fixed" и "Unfixed" трасс и 
переходов, в соответствии с другими обьектами 
относящимися к цепям (Fix  и Unfix для трасс изучаются 
позднее в этом курсе).
Команда Edit>Find  имеет опцию Select которая может 
быть применена к Цепям, Классам Цепей и Пинам 
Деталей после нахождения их. ("Find" изучается позднее 
в этом курсе).

8 Пока еще в Режиме Размещения выберите деталь. 
Теперь кликните кнопку Route Mode и отметьте что 
все пины на этой детали стали выбранными.

Кликните в пустом месте для отмены выбора. Теперь 
поэкспериментируйте с другими методами выбора 
изученными здесь.
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В режиме Рисования можно выбрать один или 
несколько объектов рисованного типа. Для выбранных 
объектов можно изменить их Свойства или удалить эти 
объекты.
Выбранный рисованный объект может быть 
идентифицированна по Выбранному цвету 
заштрихованному цветом обьекта. Внизу список типов 
прорисованных объектов.

Выбор рисованных объектов
Клик на рисованном объекте выбирает его. 
Чтобы выбрать добавочный рисованный объект или 
отменить выбор определенных рисованных объектов, 
<CtrlL<клик> на каждом из объектов. 

Единичный выбор

Выбор группы
Чтобы выбрать группу рисованных обьектов <кликните-
потяните> область выделения вокруг них.
Предупреждение! Графика трасс и деталей может быть 
выбрана в Режиме Рисования и модифицирована 
командами рисования.
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"Выделение" это размещение "заполнителя" на этот 
объект, чтобы в дальнейшем его выбрать. Детали, 
пины, трассы и линии цепей могут быть выделены.
Также как "Выбранный" объект, выделенный объект 
может быть идентифицирован по Выделенному цвету 
(определенному в диалоге Display Control) 
заштрихованному цветом обьекта. Если объект 
одновременно и "выделен" и "выбран", отображаются 
оба цвета вместе с цветом объекта.

Выделение
Чтобы выделить деталь или объект цепи, они
должны быть сначала выбранны. После выбора
используйте Edit>Highlight из меню или кликните
на кнопку панели. Можно потом отменить выбор (и 
снова выбрать) без эффекта на их статус выделения.

Выделить

После других задач редактирования которые 
затрагивают выбор и отмену выбора, выделенные 
перед этим объекты могут затем быть легко снова 
выбранны используя Edit>Add to Select 
Set>Highlighted Items из меню.

Выбрать выделенное

Выделенные объекты остаются выделенными пока с 
них не будет специально отменено выделение.
Чтобы снять выделение на выбранных объектах, 
используйте Edit>Unhighlight из меню.
Чтобы снять выделение со всех выделенных 
объектов, используйте Edit>Unhighlight All из 
меню или кликните на кнопку панели.

Отмена выделения
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Поиск деталей и цепей
Команда "Find" использована для поиска детелей, пинов 
деталей, цепей и классов цепей (группы цепей) в 
топологии платы.

9 Выберите Edit>Find из меню или кликните на кнопку 
панели Find. Оставьте для удобства открытым 
диалог Find на рабочем столе. 

Кликните на заголовке колонки для сортировки 
элементов, переключаясь между возрастающим и 
убывающим порядком.
Кликните на любом элементе в колонке и затем нажмите 
первую букву (на клавиатуре) требуемого элемента, 
чтобы быстро прокрутить к или близко к нужному 
элементу.

Графические опции (Graphic options) использованны 
когда при нахождении детали или цепи, нужно ее 
Выбрать, Выделить и/или "Показать на весь 
экран".
Режим Размещения против режима Трассировки
- В течении поиска Цепей или Классов Цепей, Expedition

PCB автоматически переключается в режим 
Трассировки.

- В течении поиска Деталей в режиме Размещения,
любые Графические опции будут использовать Контур 
Размещения детали.

- В течении поиска Деталей в режиме Трассировки,
любые Графические опции будут использовать все 
пины детали.

- В течении поиска Деталей в режиме Размещения, с
выбранным из списка Пин номером пина, Expedition
PCB  переключается в режим Трассировки и любые 
Графические опции будут использовать этот 
определенный пин.

10 В диалоге Find найдите Цепь или Деталь используя 
Графические опции Select и Fit view. 

Используйте кнопку Apply для каждого поиска, чтобы 
держать диалог открытым. Будьте внимательны, в каком 
режиме Вы находитесь при выполнении поиска.
Закройте (Cancel) диалог Find, когда закончите ваш поиск. 

Замечание: В Режиме Трассировки множество 
элементов может быть выбранно в диалоге Find.
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Средство Просмотра Файлов
Большинство процессов в Expedition PCB генерят файл 
протокола. Всегда читайте файл протокола для данного 
процесса, чтобы быть уверенным что здесь нет проблем.
"File Viewer" это средство просмотра тектовых файлов, 
доступное в Expedition PCB. Оно видит файлы с 
расширением .txt и .log для текущей топологии.

11 Выберите File>File Viewer из меню или кликните
на кнопку панели. 

Кликните на файл в списке и просмотрите его содержание 
в окне вида. Закройте диалог File Viewer  когда 
просмотрите несколько файлов. 

По умолчанию отображается последний файл протокола.
Файлы протокола можно распечатать или удалить из File 
Viewer.

Помощь
Как и другие программы Windows, Expedition PCB имеет 
расширенную оперативную систему помощи.

Справочник команд
Чтобы вызвать "Справочник команд" напрямую, 
выберите Help>Contents из меню или используйте 
Клавишу Действия 1 Help (<F1>).

Проводник Процессов
Чтобы вызвать "Process Guide" для топологии 
Expedition PCB, выберите Help>Process Guide из 
меню.

Помощь связанная с  контекстом
При выполнении любого диалога команд, ищите 
кнопку Help для вызова Справочника Команд для
этой команды или диалога.
Клавиша <F1> также доступна в любое время для 
помощи связанной с контекстом.
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H Запуск Топологии Платы
Эта глава обьясняет передачу  данных из схемы Design 
Capture платы в топологию Expedition PCB.
Рассматриваются темы:
- Источник проекта
- Создание нового задания платы

Шаблоны 
ТопологииСимволы Детали Ячейки PadstacksИмпорт Импорт

Размещение символа

Размещение Детали

Упаковщик
Локальные 

детали
Локальные 

детали
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ячейки
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padstacks

Прямая 
аннотация

Схема Общая 
База 

данных

Топология 
платы

Прямая 
аннотация

Обратная аннотация

Размещение 
Компонента

Проект

Компиляция

Поглощение

Центральная Библиотека
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Источник проекта
Слово "интеграция" используется когда связываете 
схему Design Capture или ASCII список цепей с базой 
данных Expedition PCB.

Общая База Данных
Интеграция между Design Capture и Expedition PCB 
управляется через Общую Базу Данных или "CDB". 
Expedition PCB напрямую читает из и записывает в CDB, 
а не схему.

CDB изначально создана из схемы Design Capture и 
содержит любые связи, условные обозначения и номера 
деталей, которые были назначенны в схеме. CDB может 
содержать также различные свойства компонентов и 
свойства цепей. Физически CDB это иерархия файловых 
директорий с электронной информацией запасенной в 
двоичном формате для быстрого доступа.
Замечание: Специфика создания CDB это проблема 
Design Capture и не будет рассматриваться в этом курсе. 
Компилированные заранее схема Design Capture и CDB 
будут данны. Это общий сценарий "реального мира" - 
инженер электроник снабжает инженера тополога 
данными схемы.

Подготовка Источника проекта
Первая вещь которая должна быть сделана чтобы 
стартовать проект Design Capture (схема) и/или 
топологии платы, иметь область проектируемого проекта 
на диске компьютера, чтобы хранить информацию.
Если источник проекта это список цепей, тогда должна 
быть создана специальная директория для данных 
топологии.
Если источник проекта это схема Design Capture и этот 
схемотехнический проект в работе, тогда специальная 
директория проекта уже существует, и содержит 
необходимые поддиректории и файлы. Для топологии 
платы нужно просто продолжать существующий проект.
Если кто-либо другой чем проектировщик топологии 
сгенерировал данные схемы, один сценарий доступа к 
этим данным это совместно использовать их по сети. В 
этом случае специальная директория проекта должна 
существовать на локальном компьютере для данных 
платы. Другой сценарий это передвинуть данные схемы 
локально и затем продолжить работу с топологией платы 
здесь. Оба сценария имеют плюсы и минусы, но оба 
работают. В этом курсе данные схемы будут уже 
существовать локально.
Следующие несколько глав будут затрагивать вопрос 
создания связи между схемой и топологией.
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 Создание Новой Работы Платы
Создание новой работы платы затрагивает определение 
местоположения схемного источника проекта или списка 
цепей, копирование шаблона платы и прямую 
аннотацию.

"Мастер" управления работ
Job Management Wizard это инструмент Expedition PCB 
использованный чтобы начать новую топологию платы и 
выполнить Прямую Аннотацию.

1 Кликните кнопку Start в Windows и перейдите в 
Programs>Mentor Graphics 2000.0>Expedition PCB

и выберите Job Management Wizard из меню. 

Job Management Wizard также удобен для копирования, 
переименования/передвижения, очистки и удаления 
работ (проектов). Для этих опций топология платы 
должна уже быть создана в работе.

2 В диалоге Welcom удостоверьтесь что выбрана 
опция Create. Кликните кнопку Next, чтобы начать

процесс создания платы. 
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Проект
Схема Design Capture создается на основе "проекта". 
Для Design Capture "Файл Проекта" будет содержать 
список различных блоков схемы использованных в 
проекте, указатель на CDB и указатель на Центральную 
Библиотеку.

3 В диалоге Create кликните кнопку Browse
и перейдите в c:\mgtraining\project\2001. 

Откройте 2001.prj. Проверьте что поле Source project 
filename содержит требуемый путь и имя проекта. 

Интеграция источника проекта Design Capture и 
топологии Expedition PCB это просто вопрос совместного 
использования Файла Проекта.
Замечание: Если использован другой источник проекта 
чем схема Design Capture, Файл Проекта еще требуется. 

4 В диалоге Create кликните кнопку Edit,
чтобы заглянуть в Файл Проекта. 

Просмотрите диалог Project Editor. 

Редактор Проекта использован здесь прежде всего 
чтобы видеть указатели на Центральную Библиотеку и 
источник проекта Список Цепей (схему) для проекта. Эти 
указатели были установлены ранее, когда была создана 
схема. 

Редактор Проекта

Если использован другой источник проекта чем схема 
Design Capture, такой как ASCII Список Цепей, его 
необходимо указать здесь. 
Замечание: Только одна Центральная Библиотека в 
единицу времени может быть связана с проектом. 
Изменение в другую Центральную Библиотеку не 
рекомендуется в данной точке.

5 В диалоге Project Editor кликните кнопку Close, (или 
кнопку Cancel если вы сделали изменения). 

Вернитесь в диалог Create, кликните кнопку Next для 
продолжения. 

Копирование файлов Платы
Местоположение схемы определено, теперь проекту 
необходимо знать где хранить файлы топологии платы. 
Местоположение по умолчанию в директории PCB 
внутри пути текущего проекта. Должен быть выбран 
шаблон платы из Центральной Библиотеки.

6 Далее в диалоге Create определите New PCB design 
filename и PCB layout template. 

Выберите training шаблон топологии платы из списка (он 
создан в предыдущей лаб. работе).

Кликните кнопку Next.

Файлы шаблона копированны в определенную 
директорию PCB, и ждут наполнения информацией по 
деталям и цепям.
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 Прямая аннотация

7 В диалоге Create проверьте что опция 
Forward annotation включена и затем кликните  

кнопку Start or Continue Process. Проследите за 
Статусом Процесса.
Если случайно использовали кнопку Finish информируйте 
об этом вашего инструктора. Прямая аннотация может 
быть законченна позднее в редакторе Expedition PCB. 

Прямая аннотация это процесс переноса электронной 
информации (детали и связи) из CDB схемы или Списка 
Цепей в Базу Данных топологии платы.
Диалог Create имеет опцию Compile CDB (компилировать 
CDB) и Forward annotation. Если процесс создания схемы 
Design Capture выполнен корректно, нет необходимости 
в опции Compile CDB и она недоступна.

Загрузка Базы Данных
Загрузка Базы Данных проверяет CDB и определяет 
каждое ли устройство имеет Номер Детали и этот 
Номер Детали существует/совпадает в Центральной 
Библиотеке.
В дальнейшем CDB проверяется, законченна ли и 
корректна ли упаковка, основанная на деталях в 
Центральной Библиотеке.
Когда все хорошо, специфические детали извлекаются 
из Центральной Библиотеки и сбрасываются в 
локальную "определенного проекта" библиотеку, а 
также в базу данных топологии.
Ячейки вызваемые каждой деталью извлекаются из 
Центральной Библиотеки и сбрасываются в локальную 
библиотеку, вместе с необходимыми padstacks.

Загрузка цепей
В заключение, Загрузка Цепей извлекает информацию 
о цепях (связи, имена цепей, свойства цепей и т.д) из 
CDB и сбрасывает ее в топологию платы.
Обратитесь к диаграмме последовательности 
операций в начале этой главы, чтобы лучше понять что 
происходит.
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Протокол Прямой аннотации
После каждого процесса Прямой аннотации генерится 
протокол. (Прямая аннотация имеет место также в 
процессе создания топологии, если сделанны изменения 
в источнике проекта) Всегда просматривайте протокол на 
предмет предупреждений и\или ошибок.

8 После окончания процесса кликните  кнопку View 
Process Report Files, чтобы открыть протокол

Forward Annotation. 
Просмотрите протокол Forward Annotation. Не должно 
быть "errors" (ошибок), только предепреждения (warnings) 
: Net "abc" is being added to Layout.
Закройте протокол (Notepad) когда все сделаете.

Если есть какие-либо ошибки они могут быть 
исправлены позднее без создания новой топологии.
Некоторые наиболее общие ошибки это различие в 
Номере Детали между схемой (СDB) и Центральной 
Библиотекой или деталь\ячейка отсутствует в 
Центральной Библиотеке.

9 В диалоге Create кликните  кнопку Finish. 
Просмотрите диалог Summary и затем кликните

кнопку Close.

Открытие топологии платы
Все компоненты и цепи из источника проекта (схемы) в 
вашей базе данных платы, готовы для размещения и 
трассировки.

Используйте Windows Explorer чтобы переместиться 
в директорию c:\mgtraining\project\2001\pcb

<Двойной-клик> на файле 2001.pcb чтобы вызвать 
Expedition PCB  открыть вашу новую базу данных платы.

10
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I Установка Топологии
Эта глава обьясняет предварительные установки и правила 
необходимые для топологии платы.
Рассматриваются темы:
- Установка Параметров
- Обзор Классов Цепей
- Обзор Свойств Цепей
- Управление Редактором
- Резервирование Проекта
- Восстановление из Резервной копии
- Создание Иконки на Рабочем Столе
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Установка Параметров
Когда начинаете новую топологию, некоторые 
специальные установки необходимо определить в "Setup 
Parameters". Они включают физические установки, такие 
как последовательность слоев и электрические 
установки, такие как назначение цепей питания.
Замечание: Не все установки Setup Parameters будут 
рассмотренны в данном курсе.

1 Откройте вашу топологию "2001" если она уже не 
открыта. Выберите Setup>Setup Parameters.

В диалоге Setup Parameters кликните на каждой из 
вкладок и поверхностно посмотрите какие виды установок 
могут быть сделанны. (Ничего не изменяйте пока). 

Физические слои
Нужно определить количество физических слоев - 
идеально в начале процесса создания топологии.

2 В диалоге Setup Parameters кликните вкладку 
General. 

Задайте Number of physical layers 6 вместо 10. Кликните 
кнопку Remap Layers.

Number of physical layers можно изменить в любое время 
в течении создания топологии с сохранением верхнего и 
нижнего слоя. Также можно поменять порядок 
внутренних слоев используя диалог Remap Layers.

Физические слои
Целый слой платы может быть выделен в слой питания, 
делая его запрещенным (по умолчанию) для сигнальных 
трасс. Это должно быть установленно перед 
трассировкой. Данные слоя питания могут быть 
сгенерированны как "позитивная" или "негативная" 
графика.

3 В диалоге Setup Parameters кликните вкладку 
Planes. 

Найдите Layer 3 в списке Plane Assignments. <Двойной-
клик> в поле Layer Description для этого слоя и выберите 
Plane из выпадающего списка. Таким же способом 
измените Plane Type из Positive в Negative.
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Цепи поверхностей
Когда изменяете слой Signal на слой Plane, можно 
назначить  поверхность для любой цепи.

4 Пока выбран Layer 3 в списке Plane Assignments,
кликните на любую цепь в списке Excluded Nets. 

Нажмите клавишу <G> на клавиатуре. Должна выбраться 
цепь GND.
Кликните кнопку единичной стрелки направо, чтобы 
передвинуть GND в список Included Nets с права (или 
просто <двойной-клик> на имени цепи).

Shield Net, цепь наверху списка Excluded Nets 
использована для генерации данных плоскостей не 
связанных с какими-либо пинами.

Использование Route Border
Данные плоскости могут быть сгенерены по 
нарисованным вручную Plane Shape в топологии 
или по Route Border. Route Border это главным 
образом площадь внутри которой трассируются 
сигнальные трассы. 
Замечание: Route Border будет обсуждаться в 
главе "Определение Геометрии Платы".  Plane 
Shape и Plane Data будет обсуждаться в главе 
"Генерация Плоскостей".

5 C цепью GND в списке Included Nets включите 
кнопку слева от GND. 

Route Border будет служить как контур поверхности на 
этом слое.

Зазоры поверхностей (plane clearances)
Зазоры поверхностей можно установить для каждой 
цепи поверхности. Это минимальный зазор между 
двумя поверхностями или между поверхностью и 
крепежным отверстием.

6 Для слоев поверхностей обычно требуется большие 
зазоры. Кликните в поле Clearance для GND и 

измените зазор по умолчанию из 8 в 12.

Замечание: Значение зазора по умолчанию 
получается из установок Net Class Clearances (будет 
рассмотрено позднее в этой главе). Если изменить 
значение, то большее из двух значений (Net Classes и 
plane clearances) будет использованно когда 
обрабатываете данные поверхности.
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Установки для Разделенных Поверхностей
"Split plane" это слой поверхности содержащий более 
чем одну цепь поверхности. Split Plane может быть 
сгенерен как "позитивная" или "негативная" графика.

7 Найдите Layer 4 в списке Plane Assignments. Как в 
предыдущем назначении поверхности, измените 

Layer Description в Plane и Plane Type в Positive (если уже 
не установленно).

Все нужные цепи для split plane должны быть заданы, 
чтобы автотрассировщик не пытался трассировать их 
как сигнальные трассы на другом слое.

8 Выберите VCC из Excluded Nets. Удерживая
клавишу <Ctrl> выберите VDD и VEE. Когда все три

эти цепи выбраны, кликните кнопку единичная правая 
стрелка чтобы передвинуть их в список Included Nets.

Использование Route Border и Split Planes
На любом одном слое, только одна цепь поверхности 
может использовать Route Border как контур 
поверхности.

9 В списке Included Nets включите кнопку рядом с цепью 
VCC. Route Border будет использовано как контур 
поверхности на этом слое для цепи VCC только.

Также установите Clearance между каждой цепью 12th. 

10 В диалоге Setup Parameters, кликните на вкладку 
Vias.

Кликните на поле Padstack для существующего интервала 
под Via span definition and clearances. Из выпадающего 
списка выберите 25th via pad.

Переходы по умолчанию
Переходы действуют как соединения между слоями, 
когда трассируете трассы. Необходимо выбрать из 
локальной библиотеки padstacks, единичный padstack 
перехода как используемый по умолчанию для 
топологии.

Различные переходы можно 
назначить в различные группы цепей 
имея в виду Классы Цепей 
(изучаются дальше). Эти 
используемые по умолчанию 
переходы будут использоваться при 
авто и ручной трассировках когда не 
назначенны специальные переходы 
для цепи. Показанный в диалоге 
интервал перехода это 
представление поперечного сечения 
сквозного перехода.
Замечание: Добавочные интервалы перехода можно 
установить здесь для технологий "blind" (слепой) и 
"buried" (скрытый). Здесь всегда будет сквозной 
интервал перехода.

11 В диалоге Setup Parameters, кликните на кнопку OK, 
чтобы сохранить все ваши установки. На короткое

время появится сообщение Reloading layout database.
Запомните "Setup Parameters" ... вы вернетесь сюда 
снова.
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Обзор Классов Цепей
Цепи можно сгруппировать в "Классы Цепей". Классу 
цепи затем можно назначить собственный переход, 
ширину трасс, слои правила зазоров трасс. Классы 
Цепей можно установить в течении фазы создания 
схемы и\или фазы топологии.
Класс цепи назначается для цепи используя "Net 
Properties" (Свойства Цепи). 

12 Проверьте правила Net Class, пришедшие из схемы, 
выбирая Setup>Net Classes and Clearance из 
меню. 

Имена Классов Цепей
В верхней левой части 
диал ога  спис ок  
существующих Классов 
Цепей.
Можно создать здесь Класс 
Цепей используя кнопки New 
Net Class и Copy Net Class 
или удалить используя 
кнопку Delete Net Class. 

"Default" Класс Цепей существует всегда и не может 
быть удален. Любой Цепи которой не назначен 
определенный Класс Цепей, назначается Default Net 
Class.
Выбор имени Класса Цепей в списке отображает 
установки для этого Класса Цепей в наборе диалогов.

Трассировочные слои Класса Цепей
В секции Width & Impedance by Layer диалога можно 
выключить слои, чтобы запретить любую трассировку в 
дальнейшем для выбранного Класса Цепей. 

13 С выбранным Default Net Class в списке, выключите 
Layer 3 и Layer 4. 

Кликните на power Net Class в списке 
(этот Net Class был установлен ранее в 
Design Capture). Выключите Layer 2, 
Layer 3, Layer 4 и Layer 5 для этого  Net 
Class (картинка только для примера) 
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Ширина трасс Класса Цепей
В секции Width & Impedance by Layer диалога можно 
определить ширину трасс (и значение импеданса) по 
слоям, для выбранного Класса Цепей. 
Typical Width это главная ширина трасс, которая будет 
использована для трассировки цепей в этом Классе 
Цепей.

Интервалы переходов Класса Цепей
В секции Attributes диалога Класса Цепей может иметь 
специальный padstack перехода назначенный в каждый 
интервал перехода (подменяя интервал padstack 
перехода заданный ранее в диалоге Setup Parameters). 

14 С выбранным power Классом Цепей, выберите 
новый Via for This Net Class из выпадающего списка  

справа. Выберите 40t via pad.

Правила зазоров
Диалог Net Class Clearances использован для 
установки правил зазоров "Net Class to Net Class" также 
как общие правила зазоров.

15 Кликните на вкладку Clearances вверху диалога Net 
Classes and Clearances чтобы проверить правила  

зазоров установленные ранее.

Как и все установки Класса Цепей, эти зазоры также 
можно задать на этапе создания схемы.
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Общие зазоры
Секция General Clearances rules  диалога не связанна с 
Классами Цепей. Она главным образом для установки 
зазоров между компонентами, площадками 
компонентов, крепежными отверстиями, контуром 
платы и т.д.

16 General Clearances rules возможно требуют 
изменений. Сами измените то что на ваш взгляд  

нужно изменить.

Зазоры Класса Цепей
Создание правил зазоров
В секции Clearances rules for Net Classes  диалога 
можно задать имя правила и значения зазоров для 
трасс\площадок\переходов. В проекте могут 
существовать несколько этих проименованных 
правил использующих различные зазоры (смотри 
пример ниже).

Как default via и default Net Class, default правила 
зазоров использованны когда не определены другие 
правила зазоров. Default Rule всегда существуют и 
не могут быть удалены.

Использование правил зазоров
В секции Net Class to Net Class  диалога можно 
применить ранее заданные правила зазоров между 
двумя Классами Цепей (или внутри того же Класса 
Цепей) на определенном слое.

Пример выше переводится как: Зазор между любой 
цепью в high speed Net Class и любой другой цепью в 
high speed Net Class на Layer 2 должен использовать 
правило fine line.
Снова, правило default Net Class всегда существует и 
оно переводится как: Все Классы Цепей ко Всем 
Классам Цепей на всех слоях должны использовать 
Default Rule. Когда правила Классов Цепей 
перекрываются выигрывает наиболее 
ограничивающее.

17 Кликните кнопку OK в диалоге Net Classes and 
Clearances чтобы сохранить изменения и закрыть  

диалог.
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Обзор Свойств Цепей
"Net Properties" (Свойства Цепи) в Expedition PCB 
содержит главные ограничения трассировки по 
целостности сигнала, такие как Net Order (Порядок 
Цепи), Timing & Differential Pairs (Временные и 
Дифференциальные Пары), Crosstalk (Помехи) Delay 
Formulas (Формулы Задержки) которые назначенны для 
цепи. 

18 Выберите Setup>Net Properties из меню.  Во 
вкладке Net Rules кликните на каждой из четырех 

под-вкладок чтобы посмотреть какие виды правил 
целостности сигналов можно установить (Ничего не 
изменяйте). 

Назначение цепям Класса Цепей
Свойства Цепи затрагивают назначенный Класс Цепи. 
Также как Класс Цепи, Свойства Цепи можно 
установить при создании схемы.
Замечание: Свойства Цепей это добавочная 
информация. Этот курс рассматривает их только в 
контексте Классов Цепей. 

19 В под-вкладке Net Order кликните на  заголовке 
колонки Net Class для сортировки списка цепей по

Net Class. Если power Net Class не появится наверху 
списка, снова кликните на заголовок колонки, чтобы 
поменять порядок.

В реальной ситуации для цепей земли и питания 
должны быть более широкие трассы и большие 
переходы. Чтобы сделать это просто определите Класс 
Цепей для них. 

20 Цепям GND и VCC уже назначен power Net Class. 
Найдите в списке цепь VDD. Кликните в поле Net

Class для цепи (первая колонка) и выберите power  из 
списка. Повторите процесс для VEE также.

Замечание: Как и в большинстве списков в Expedition 
PCB, множество элементов можно выбрать и изменить 
одновременно, используя <Shift><click> в конце ряда 
выбора. 

21 Кликните кнопку OK внизу диалога чтобы 
сохраниться и покинуть Net Properties. 

Кликните кнопку Save на панели Standard в Expedition
PCB чтобы сохранить вашу топологию.

Поскольку топология сохранена, изменения в 
свойствах Цепей обратно аннотируются в CDB, наряду 
с изменениями Параметров Установок и Классов 
Цепей. 
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Управление Редактором
"Editor Control" содержит добавочные установки которые 
часто изменяют в процессе создания топологии, они 
включают : интервал сохранения, поведение 
трассировки, правила размещения, сетки и т.д. 
Замечание: Только базовые установки Editor Control 
будут рассмотренны в этом курсе.

22 Выберите Setup>Editor Control из меню 
(или кликните кнопку панели).  В диалоге  

Editor Control кликните на каждую вкладку и кратко 
просмотрите какие виды установок можно сделать (ничего 
не изменяйте). 

Интервал сохранения
Когда работаете в Expedition PCB изменения хранятся в 
памяти и должны быть сохранены на диске. Время 
"AutoSave intervals" может быть заданно чтобы 
автоматически сохранять топологию.

23 В диалоге Editor Control кликните на вкладку 
General. Проверьте в секции AutoSave intervals что    

Interactive save установлено 60  минут. Задайте  Auto 
Route save 10 минут. Кликните кнопку OK.

Установки Interactive сохраняют базу данных 
топологии. Это также как выбрать File>Save из меню.
Установки Auto Route сохраняют "checkpoint" файл. В 
случае не адекватного выхода из Expedition PCB, 
после открытия топологии снова, появится подсказка, 
спрашивающая хотите ли вы восстановится из файла 
checkpoint. 

Управление Редактором
Создание резервной копии в процессе топологии, 
конечно очень важно. При выполнении большого 
количества операций прямой\обратной аннотации и 
изменении номеров условных обозначений, 
восстановление из резервной копии это единственный 
путь отказаться от плохого результата эксперимента.

Выберите File>Save Copy из меню. Кликните кнопку 
Yes когда будет подсказка сохранить вашу работу   

на диск. Читайте следующие шаги внимательно.
24
Команда "Save Copy" копирует проект, таким образом 
схема и CDB копируются вместе с топологией, 
поддерживая синхронизацию.

В диалоге Job Management Wizard Copy кликните в 
поле New project filename и введите   

c:\mgtraining\project\2001start\2001.prj (или скопируйте 
из поля Source project filename и сделайте 
соответствующие изменения).
Теперь кликните в поле New PCB design filename чтобы 
заполнить его автоматически.

25

Рекомендуется трактовать резервную копию как 
отдельный проект, выделяя ему собственную 
директорию. Для простоты восстановления оставьте имя 
проекта таким же.

Кликните кнопку Finish чтобы сделать копию. 
Прочитайте и закройте диалог Summary.   26

Кликните кнопку панели Exit и покиньте Expedition PCB.
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Восстановление из Резервной Копии
Восстановление из резервной копии проекта делается 
также как для старта топологии через "Job Management 
Wizard". Далее следуют общие шаги восстановления из 
резервной копии проекта в его оригинальное имя (это не 
элементы лаб. работы).

1. Покиньте Expedition PCB и откройте диалог Job
Management Wizard.

2. Используйте опцию Delete чтобы удалить текущий
"не хороший" проект.

3. Используйте опцию Copy чтобы копировать
резервный проект в место оригинального.

Создание Иконки на Рабочем Столе
Иконку вызова базы данных новой топологии можно 
разместить на Рабочем столе Windows для удобства 
вызова.

Используя Windows Explorer переместитесь в 
директорию c:\mgtraining\project\2001\pcb.

<Правый-клик-тянуть> на файле 
2001.pcb и киньте его где-нибудь 
на Рабочем столе Windows. 
Когда появится меню выберите 
Create Shortcut(s) Here.

27

Иконка вызова в Windows содержит маленькую 
стрелку в левом-нижнем углу иконки. Иконка 
вызова не является реальным файлом данных 
.pcb, просто указатель к нему.Чтобы быстро 
открыть определенную топологию платы, просто 
<двойной-клик> на иконке.
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Определение Геометрии Платы

Эта глава обьясняет графику платы, которая будет 
необходима при размещении и трассировке.
Рассматриваются темы:
- Обзор координат
- Контур Платы
- Крепежные отверстия
- Точки Начала координат
- Зоны Запрета Размещения
- Граница Трассировки
- Зоны Запрета Трассировки



Импортирование Контура 
Контур Платы можно создать импортированием DXF 
графики из внешних чертежных прикладных программ, 
таких как MicroStation или AutoCAD. После 
импортирования эта графика может быть преобразована 
в графику Контура Платы.
Замечание:  Графика должна быть создана как 
"ломанная линия" во внешней чертежной прикладной 
программе.
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Обзор координат
Поскольку глава о создании графики платы, важно знать 
как читать координаты и повороты.

Декартовы Координаты 
Декартова координатная система для двухмерного 
чертения состоит из положительной и отрицательной оси 
X и положительной и отрицательной оси Y.

Абсолютные 
C абсолютными координатами, 
все в топологии имеет абсолютное 
местоположение X/Y. Где 
пересечение оси X и оси Y это 
"0/0".

Относительные 
Относительные координаты работают по той же X/Y  
концепции, но только в привязке к существующим 
координатам, обще используемые для сдвига объекта 
или продолжение ломанной линии от предыдущего 
местоположения.

Полярные координаты

Полярные координаты используются 
совместно с относительными 
координатами для определения 
углов когда поворачиваете объекты 
или продолжаете ломанную линию в 
определенном направлении.

Контур Платы
Контур Платы в Expedition PCB это закрытый 
многоугольник, который использован как пространство 
для размещения компонентов в топологии.
Независимо от простоты, каждая база данных платы 
содержит один Контур Платы.
Контур Платы нельзя удалить - создание нового Контура 
Платы замещает существующий.

Создание Контура 
Альтернативно, Контур Платы можно создать с нуля 
используя инструменты рисования внутри Expedition 
PCB. Этот метод объясняется здесь.

Откройте вашу топологию платы "2001", если она 
уже не открыта.

Слегка уменьшите (совет: <Shift><средний-клик>). 
Выберите из меню Edit>Place>Board Outline.

1
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Команда Place Board Outline переключает Expedition PCB  
в Режим Рисования и изображает диалог Properties.
Вверху диалога Properties, поле Type перечисляет 
текущий тип объекта для рисования - который, конечно, 
Board Outline. Команда рисования многоугольника 
активна.
Замечание: Нет 
н е о б х о д и м о с т и  
закрывать диалог 
Properties, он закроется 
автоматически при 
переключении в другой 
режим. Если диалог

Properties не
изображен,
кликните снова 

на иконку Draw Mode 
панели, или кнопку 
Properties на панели 
Draw чтобы отобразить 
его.

Точность ввода
Контур Платы можно 
нарисовать визуально 
задавая мышкой точки 
вершин или вводя 
а б с о л ю т н ы е  
координаты используя 
диалог Properties или 
любую комбинацию 
двух.

В таблице Vertices диалога Properties, кликните в 
пустом поле в колонке X (vertex 1) и введите -100 и

нажмите клавишу <Enter>. Текстовый курсор теперь 
должен быть в колонке Y - введите -100 снова и нажмите 
<Enter>. Будет добавлен новый пустой vertex 2.
Продолжите ввод восьми X и Y координат как показанно 
ниже, нажимая <Enter> после каждой. Если ввели не 
правильное значение, просто продолжите ... вы можете 
изменить их позднее. Используйте механический чертеж 
в начале главы для справки.

Подождите! Последняя координата еще не определена.

2

Должен быть добавлен конечный сегмент Board Outline, 
заканчивая многоугольник, используя один из методов. 
Или определяя туже координату как vertex 1 или ...

 

<Правый-клик> в пространстве рисования и затем 
выберите Close Polygon из всплывающего меню

чтобы автоматически закрыть многоугольник Board 
Outline.

3



Передвижение меток конечных точек
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Изменение Контура Платы
Board Outline это рисованный объект который можно 
изменять, двигая, добавляя и удаляя вершины. Можно 
также в вершинах применить скругления (fillets) и скосы 
(chamfers).
Рисованный объект должен быть выбран перед тем как 
делать изменения. После выбора объекта появляются 
метки на нем.

Метка конечной точки (vertex)

Метка средней точки

Метка стартовой точки
(начало координат объекта)

Выбранная метка конечной точки

Замечание: Большинство команд рисования 
рассмотреных в этой главе можно использовать на 
большинстве рисованных объектов.
Передвижение по сетке

Кликните на кнопке-стрелке Set Snap Grid на 
панели Draw mode.

Выберите 25 из списка предустановленной сетки.

4
Snap Grid

(вкл.\выкл. 
по сетке)

Set Snap Grid
(Установить 
размер сетки)

Удаление меток конечных точек

Метку конечной точки (вершина) можно двигать 
сначала выбрав объект, затем <кликнуть-потянуть> 
нужную метку конечной точки (квадратной формы) в 
новое место.
Метку конечной точки можно двигать на координату 
используя диалог Properties.

Если вы сделали какие-либо ошибки когда вводили 
координаты, выберите графику Board Outline  и

измените подходящее значение в диалоге Properties. 
Кликните кнопку панели Fit Board чтобы увидеть
всю плату.

5

Чтобы вставить метку конечной точки сначала 
выберите объект, затем <Ctrl><клик-тянуть> метку 
средней точки (в форме ромба) сегмента нужной 
линии.

Вставка метки конечной точки

Чтобы удалить метку конечной точки сначала 
выберите объект, затем выберите нужную метку 
конечной точки. Выбранная метка конечной точки 
изображается заполненной. В заключение 
кликните на кнопку Delete Endpoint Handle
на панели Draw.
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Скосы (Chamfers)
Вершину можно изменить из 90 угла в 45 скос 
определенного размера.

Выберите Board Outline  если уже не выбрана. В 
диалоге Properties тяните вниз список Vertex Type и

выберите Chamfer.

Тяните вниз список Chamfer Cut 
(непосредственно справа 
Vertex Type). Введите 125 в нижнем
поле и затем нажмите <Enter>.

Тяните снова вниз список Chamfer Cut и проверьте что 
125 теперь в списке и оно также выбранно. 

6

После того как размер скоса определен и установлен 
как текущий, он может быть применен к вершине 
объекта.

Выберите метку конечной точки в вверхнем-правом 
углу Board Outline (посмотрите в начале главы).

Измените  Vertex Type в Chamfer в диалоге Properties. 
Если произошла отмена выбора метки до того как вы 
смогли выбрать другой Vertex Type, просто выберите 
заново метку и попробуйте снова.
Таким же образом поменяйте нижний-правый угол Board 
Outline.
Замечание: Самый простой путь восстановится 
после ошибки здесь, кликнуть кнопку панели Undo.

7

Последнее использованное расстояние скоса будет 
оставаться активным когда создаете будущие скосы. 
Все заданные пользователем расстояния будут 
оставаться в списке Chamfer Cut для текущей 
топологии.

С еще выбранной графикой Board Outline выберите 
размер Chamfer Cut 50 из списка в диалоге

Properties. 
Примените 50th скос к двум углам печатного контакта на 
левой стороне Board Outline (посмотрите в начале главы).

8
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Скругления (Fillets)
Вершину можно изменить из угла в скругление 
определенного размера.

С еще выбранной графикой Board Outline выберите 
Round из списка Vertex Type в диалоге Properties.

Добавьте 62 в список, как вы сделали ранее для скосов.
Примените эти 62th скругления к двум внутренним углам 
на левой стороне Board Outline (посмотрите в начале 
главы).

9

Скругленные вершины это дуги и содержат единичную 
метку. Чтобы изменить радиус, выберите метку и затем 
выберите другой радиус из списка в диалоге Properties.

Если вы хотите начать другую Board Outline потому 
что испортили эту, просто перерисуйте ее и

предыдущая Board Outline исчезнет.
Если вы удовлетворены созданной Board Outline, 
кликните кнопку панели Save.
Замечание: С этого шага вы получите несколько 
напоминаний сохранить топологию - заведите привычку 
делать это.

10

Граница Трассировки
Route Border (Граница Трассировки) это пространство 
для трассировки в топологии платы.
Также как Board Outline каждая база данных платы 
содержит одну Route Border. Route Border нельзя 
удалять - создание новой Route Border замещает 
существовавшую.

Создание Route Border 
Также как Board Outline, Route Border можно создать с 
нуля используя инструменты рисования. Эта команда в 
меню Edit>Place>Route Border.

Копирование Board Outline 
Более удобный и простой метод для создания Route 
Border это копирование Board Outline.
Как большинство рисованных объектов, один объект 
можно скопировать в другой, сначала выбрав объект 
источник, затем <Ctrl><двойной-клик>  на этом объекте.

В Draw Mode выберите графику Board Outline. 
Заметьте появится диалог Properties с выбранным

Type объекта Board Outline.
Теперь <Ctrl><двойной-клик> на выбранной Board Outline. 
Если диалог Properties отображает Type как Draw Object, 
тогда процесс прошел успешно. Новый объект теперь 
выбран. Удостоверьтесь и оставьте его выбранным.

11
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Тип объекта 
Вновь копированный объект всегда общий "Draw Object" 
(Рисованный Объект) и выбранный. Выбор различных 
Type объекта в диалоге Properties динамически изменяет 
выбранный объект в этот тип - также как  Route Border.

Пока копированный объект еще выбран, потяните 
вниз список Type в диалоге Properties и выберите

Route Border. Заметьте что старое Route Border исчезнет
Продолжайте оставив объект выбранным.

12

Замечание: Если более чем один рисованный объект 
расположен друг под другом, выберите один из них и 
затем нажмите  клавишу <Tab> чтобы переключаться по 
ним, в это же время следя за полем Type в диалоге 
Properties.

Сжатие\Увеличение 
Копирование рисованного объекта таким путем создает 
дубликат непосредственно сверху оригинала и затем 
выбирает объект. Можно легко изменить размеры 
выбранного объекта вводя значение в поле Grow/Shrink 
диалога Properties. Положительное значение будет 
увеличивать объект и отрицательное значение сжимает 
его.

Пока копированный объект еще выбран определите 
Line width 0 и растояние Grow/Shrink -50 в диалоге 

Properties (внизу диалога) и затем нажмите клавишу 
<Enter>.

13

Замечание: Выбор каждого прорисованного объекта 
будет отображать информацию об этом объекте в 
диалоге Properties.

Крепежные отверстия
Mounting Holes это специальные padstacks которые 
представляют металлизированные и не- 
металлизированные отверстия в топологии платы. 
Крепежные отверстия доступны напрямую из 
Центральной Библиотеки.
Замечание: Крепежные отверстия выбранные из 
Центральной Библиотеки автоматически копированны и 
использованны в локальной библиотеке проекта.
Размещение Крепежных Отверстий 

Выберите Edit>Place>Mounting Hole из меню. 
В диалоге Place Mounting Hole выберите из 

выпадающего списка Padstack Central: 62th tooling hole.
14
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Имя Цепи 
Для металлизированного крепежного отверстия можно 
назначить цепь, выбрав из списка цепь в проекте.
Эта опция не доступна для не металлизированных 
крепежных отверстий. Как обсуждалось ранее, 
Отверстия внутри padstack есть где установлен Plated 
статус.

Местоположение
Если известно точное местоположение крепежного 
отверстия, можно ввести абсолютные координаты X и 
Y.

Определите местоположение крепежного отверстия 
в X:0 и Y:0 (это разместит его в начале координат

топологии).
Кликните кнопку Apply чтобы разместить крепежное 
отверстие в топологию. Посмотрите не него? Если вы 
сделали ошибку, не беспокойтесь, позднее вы получите 
шанс сдвинуть его или удалить.
Пока открыт диалог, добавьте второе 62th крепежное 
отверстие на X:0 Y:2550. Кликните кнопку Apply.

15

Если предпочитаете размещать крепежные отверстия 
используя мышку, тогда нужно оставить поля X и Y 
пустыми. Клик на кнопку OK или Apply присоединит 
padstack Крепежного Отверстия к курсору для ручного 
размещения.

Статус Блокировки
Крепежное отверстие можно разместить как Fixed 
(Фиксированный) или Locked (Блокированный). Оба 
удерживают крепежное отверстие от случайного сдвига
Элементы критического местоположения, такие как 
крепежные отвестия, гарантируются статусом Locked. 
Locked позволяет временно использовать команды Fix 
и Unfix без воздействия на "locked" крепежные 
отверстия.

Нужно добавить еще два крепежных отверстия. 
Выберите Central: 96th tooling hole из 

выпадающего списка Padstacks. Разместите его в X:3000 
Y:100 и назначте статус блокировки Locked.
Разместите другую на X:3000 и Y:2450.
Кликните кнопку Cancel в диалоге Place Mounting Hole. 
Ваша топология должна совпасть с показанной в начале 
главы.

16

Фиксированные крепежные отверстия отображаются 
заштрихованными и Блокированные отображаются не 
заполненными.
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Свойства Крепежных Отверстий
Крепежными отверстиями, уже размещенными в 
топологии, можно манипулировать используя диалог 
Padstack Properties.

Пока в Route Mode, <правый-клик> на одном из 
меньших 62th крепежных отверстий (c левой

стороны топологии) и выберите Properties из 
всплывающего меню.

17

Изменение padstacks
Размещенные крепежные отверстия можно 
поменять на другие, выбирая другой padstack из 
списка Padstacks.
Передвижение крепежных отверстий
Чтобы сдинуть крепежное отверстие, введите 
новые координаты местоположения - Абсолютные 
или Относительные.
Блокирование крепежных отвестий
Статус Блокировки крепежного отверстия можно 
изменить на Fixed, Locked и None.

Если вам нужно задать другой padstack и\или 
сдвинуть крепежное отверстие, делайте это сейчас.

В диалоге Padstack Properties выберите padstack и\или 
редактируйте поле Location (основываясь на предыдущих 
пунктах).
Когда готовы, измените Lock статус в Locked. Кликните 
кнопку Apply.
При открытом диалоге Padstack Properties, выберите 
другую графику 62th крепежного отверстия и сделайте 
похожие изменения. Кликните кнопку Apply.

18

Чтобы изменить или сдинуть padstack крепежного 
отверстия,Статус Блокировки нужно установить в  
None и затем применить.

Пока открыт диалог Padstack Properties выберите 
каждый из 96th крепежных отверстий (с правой

стороны топологии), делая необходимые изменения. 
Помните применить изменения Lock статуса до и после 
любых изменений Padstack или Location.
Кликните кнопку OK или Cancel чтобы закрыть диалог.

19
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Точки начала координат
Точки начала координат определяют абсолютную точку 
0\0 для местоположения и отчета графики и данных 
внутри топологии. В Expedition PCB используются две 
отдельных точки начала координат.

Начало координат Платы
Board Origin это начало координат базы 
данных. Все отображение и отчеты в 
абсолютных координатах в топологии (за 
исключением NC-Drill) основанны на этой 
точке.

Начало координат Сверления
NC-Drill Origin используется в отчетах 
координат для данных NC-Drill.

Сдвиг Начала координат
Каждый из Board Origin и NC-Drill Origin можно 
сдвинуть в любое время везде в топологии. По 
умолчанию NC-Drill Origin расположен в том же место 
что Board Origin.

Выберите из меню Edit>Place>Origin. Если нужно 
кликните на кнопку Fit Board чтобы видеть точку

начала координат в левом-нижнем углу платы.
20

Когда определяете новое местоположение для NC-Drill 
Origin координаты относительно текущей Board Origin.

В диалоге Place Origin установите origin Type в  
Board. Задайте новое Location X:-400 Y:-100.

Кликните кнопку OK и подождите пока база данных 
настроится на новое начало координат.
Замечание: С этой точки все координаты базируются на 
новом начале координат. Абсолютные координаты 
использованные в создании Board Outline теперь 
корректированны в базе данных.

21
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Зоны заперта размещения
"Placement Obstruct" необходимо разместить в 
топологии где есть ограничения по высоте компонентов 
или где вообще запрещены компоненты.
Также как команда Place Board Outline, команда Place 
Placement Obstruct переключает Expedition PCB в "Draw 
Mode" (Режим Рисования).

Выберите из меню Edit>Place>Placement Obstruct. 
Это активизирует Draw Mode и вызывает диалог

Properties.
22

Свойства
Диалог Properties 
устанавливает Type в 
Placement Obstruct.
Нужно задать Слой 
запрета (сторону) Top 
(Верх) или Bottom 
(Низ).
Нужно задать запрет Высоты (Height). Высота 0 
означает запрет компонентов внутри зоны запрета. 
Если высота отличается от 0 то проверка правил 
проектирования (DRC) сравнивает высоту ячейки 
компонента  с высотой Placement Obstruct и помечает 
любые нарушения.

В диалоге Properties проверьте что Type стоит 
Placement Obstruct, Layer стоит Top и Height в 0.

Установите Line width в 0 если уже не установленно.
23

Рисование Зоны запрета
Команда Place Placement Obstruct активизирует
инструмент рисования Add Polygon.
Также как Board Outline, Placement Obstruct можно 
создать вводя абсолютные координаты в диалоге 
Properties и\или визуально распологая вершины.

В сборочном чертеже компоненты запрещены 100th 
от верхнего и нижнего края платы, с обеих сторон.

Выберите инструмент рисования Add Rectangle 
(ниже площади рисования) и нарисуйте 
прямоугольник, 100th ширина, вдоль нижнего края 
платы. Советуем установить 50th сетку и\или 
использовать dxdy координаты считывания на строке 
заголовка для руководства вами. Допустим выход за 
Board Outline.
Кликните на инструмент рисования Add Rectangle снова 
и создайте похожую зону запрета для верхнего края 
платы.

24

Одна Placement Obstruct манипулирует только одной 
стороной платы.

Placement Obstruct еще нужна для нижней стороны 
платы.

Выберите одну из созданных вами зон запрета. Теперь 
<Ctrl><двойной-клик> на ней, чтобы сделать копию и 
оставить ее выбранной. В диалоге Properties измените 
Type в Placement Obstruct и установите Layer в Bottom.
Повторите процесс для другой зоны запрета.

25

Одна Placement Obstruct манипулирует только одной 
стороной платы.
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Зоны запрета трассировки
Участки топологии можно ограничить от трассировки 
размещая Route Obstructs  - столько сколько нужно.

Выберите из меню Edit>Place>Route Obstruct. Это 
активизирует Draw Mode и вызывает диалог

Properties.
26

Свойства
Диалог Properties 
устанавливает Type в 
Route Obstruct.
Единичную зону запрета 
можно разместить на 
любом одном 
трассируемом Слое или 
на Всех (All) слоях.
Тип Запрета может быть Via (переход), Trace 
(трасса) или Both (оба).

В диалоге Properties проверьте что Type стоит Route 
Obstruct, Layer стоит All и Obstruct Type стоит Both.27

Рисование Зоны запрета

Route Obstruct это рисованный объект и редактируется 
также как Placement Obstract, Board Outline и т.д.
Route Obstruct может быть линия, дуга, ломаная линия, 
многоугольник, прямоугольник или круг.

В сборочном чертеже трассы запрещены 100th от 
верхнего и нижнего края платы.

Выберите инструмент рисования Add Line 
и нарисуите линию вдоль нижнего края платы,
100th от края платы (также как Placement 
Obstruct).  Допустим выход вне Board Outline.
Кликните на инструмент рисования Add Line снова и 
создайте похожую зону запрета вдоль верхнего края 
платы.

28

Замечание: Видимость Route Obstruct контролируется 
через вкладку General диалога Display Control.

Сделайте резервную копию выбрав File>Save Copy 
из меню. В диалоге Job Management Wizard Copy

задайте c:\mgtraining\project\2001board\2001.prj в New 
project filename.

29
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Размещение Деталей
Эта глава обьясняет размещение физических компонентов 
на плату, вместе с манипулированием этими компонентами 
после того как они размещены.
Рассматриваются темы:
- Размещение Деталей и Ячеек
- Сдвиг\Поворот\Перемещение Деталей
- Обмен Пин & Вентилей
- Обратная Аннотация
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Размещение Деталей и Ячеек
После успешной загрузки и определения Board Outline, 
можно физически размещать детали на плате.

Откройте вашу топологию платы "2001", если она 
уже не открыта.

Необходимо задать snap grid. Выберите из меню 
Setup>Editor Control (или кликните кнопку панели Editor 
Control). В диалоге Editor Control кликните вкладку 
Grids. Введите 25 в поле Primary part grid и  
Secondary part grid.
В диалоге Editor Control кликните вкладку Part. 
Удостоверьтесь что опция Online DRC стоит в Warning.
В диалоге Editor Control кликните кнопку OK чтобы 
закрыть его и сохранить изменения.
Во  вкладке Part диалога Editor Control выключите опцию 
Fill Placement Outlines. Так будет легче видеть детали 
для размещения.
Выберите из меню Place>Place Parts and Cells
(или кликните кнопку панели если Place Mode)
чтобы отобразить список доступных деталей 
для размещения в графику.

1

Сортирует и фильтрует 
список деталей

Детали в базе данных 
топологии на основании 
установок сортировки и 
фильтров

Активный список : 
Детали выбранные для 
немедленного 
размещения

Опции размещения и 
удобства

Кликните кнопку Apply 
чтобы начать размещение 
деталей из Активного 
списка
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Фильтр списка деталей 
Верхняя порция диалога Place Parts and Cells содержит 
фильтры и сортировки для отображения списка деталей 
в базе данных платы.

Включить 
Любую комбинацию опции Include можно использовать 
для фильтрации списка деталей.

Не размещенные 
Опция Unplaced перечисляет список не 
размещенных в графику деталей.

Рассредоточенные 
Опция Distributed перечисляет список размещенных 
в графику деталей, но вне Board Outline.

Размещенные 
Опция Placed перечисляет список размещенных в 
графику деталей внутри Board Outline.

В диалоге Place Parts and Cells включите опцию 
Unplaced. Проверьте что включена опция Distributed

and Placed.
2

Критерий 
Детали перечисляются основываясь на выбранном 
критерии.

Связанные с Размещенными 
Опция Connected to Placed сортирует детали 
основываясь на количестве связей они имеют с 
ранее размещенными. Отображаются условное 
обозначение и номер детали.

Цепи & Классы Цепей 
Net & Net Classes перечисляет все цепи и классы 
цепей в проекте и использованно для 
идентификации деталей для размещения которые 
присоединены к определенным цепям.

Условное обозначение 
Ref Des сортирует детали по их условному 
обозначению и также отображает соответствующий 
номер детали.

Номер Детали 
Part Number перечисляет все детали основываясь 
номерах деталей использованных в проекте. 
Несколько могут быть доступны под одним номером 
детали.

Фильтр критерия 
Рядом со выпадающим списком Criterion есть поле для 
фильтрования выбранного критерия. Пример: С Criterion 
установленным в Ref Des введите U в этом поле, 
отображаются условные обозначения начинающиеся с 
буквы "U".
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Размещение разъемов 
В диалоге Place Parts and Cells нужно установить 
Criterion  Ref Des.

В списке выберите J1 и J2 и затем кликните
кнопку стрелка вниз, чтобы перенести их в 
список Active.

В списке Active выберите J1 и кликните кнопку 
Properties в нижнем-левом углу диалога Place Parts 
and Cells.

В диалоге Properties установите Absolute 
местоположение x: 0 y: 1900 и Rotation 270. Задайте 
Locked status - Locked.

Кликните кнопку OK для размещения J1 как 
определенно. Заметьте что площадки разъема 
теперь не заполненные, указывая что деталь "fixed" 
или "locked".

Если сделали ошибку и разъем помещен на 
неправильное место или угол поворота, <двойной-
клик> на графике разъема чтобы отобразить диалог 
Properties для него. Сделайте необходимые 
настройки.

Вернитесь в диалог Place Parts and Cells, выберите 
J2 из списка Active. Кликните кнопку Properties и 
разместите на x: 3100 y: 1800, Rotation 270 и Locked. 
Будет сообщение Warning в строке текущего 
состояния потому что детели перекрывают Board 
Outline. Все нормально.

3.

4.

5.

6.

7.

8.

9.

Размещение деталей "Памяти" 
В диалоге Place Parts and Cells нужно установить 
Criterion  Part Number.

Выберите 74ALS655_SOP и затем кликните
кнопку стрелка вниз, чтобы перенести эти 4 
детали (U9 - U12) в список Active.

Внизу диалога введите 270 в поле Active angle и 
установите Method в Sequence.

Кликните кнопку Apply. Разместите U9, U10, U11 и 
U12 в верхнем-левом углу платы, как показанно на 
первой странице этой главы.

10.

11.

12.

13.
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Размещение "высоко частотных" компонентов 
В диалоге Place Parts and Cells нужно установить 
Criterion  Nets & Net Classes.

Выберите  списке высоко частотные цепи HS(0) - 
HS(7). Совет:  Кликните на любой цепи в списке - 
нажмите клавишу <H>, кликните на цепь HS(0), 
затем <Shift><клик> на цепь HS(7).

Кликните кнопку стрелка вниз, чтобы перенести 
4 детали связанные с этими цепями в список 
Active.

Выберите U16 и кликните Apply. Разместите их к 
левому-нижнему углу платы. Посмотрите на рисунке 
на первой странице главы как их разместить.

Выберите RN1 и RN2 и разместите их поближе 
справа U16.

В заключение выберите и разместите U15 рядом с 
RN2.

14.

15.

16.

17.

18.

19.

Размещение Микросхем 
В диалоге Place Parts and Cells нужно установить 
Criterion  Part Number. Проверьте что Active angle 
стоит 270.

Передвиньте все микросхемы серии 54ALS и 74ALS  
в список Active. Сортируйте и выбирайте в списке 
Active по собственным критериям, чтобы разместить 
микросхемы. Всегда используйте рисунок в начале 
главы для справки. Также следите за линиями цепей 
когда размещаете, поддерживая минимальную 
длину цепей.

Чтобы сдвинуть любую размещенную деталь, 
выберите ее и нажмите <F2>.

Разместите кристалл CTX071-ND согласно с 
линиями цепей.

Разместите операционник OP215A вне контура 
платы в данный момент, топому что вы должны 
поперемещать некоторые дискретные компоненты 
вокруг него позднее. Уменьшите (<Shift><средний-
клик>) если необходимо, чтобы иметь достаточное 
рабочее пространство.

Кликните кнопку панели Save для сохранения 
вашей работы.

20.

21.

22.

23.

24.

25.
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Размещение дискретных компонентов 
Передвиньте потенциометр 3296P-103-ND в список 
Active и разместите его. Деталь нужно повернуть так 
чтобы регулировка указывала на право. Нажмите 
<F3> (Клавиша действия Rotate 90) чтобы повернуть 
его. Поместите его ниже разъема J2. 

Передвиньте емкости PCAP-3M7343-100U в список 
Active. Разместите одну около верхнего конца J2 
(разъем 9-пин). Разместите другую около нижнего 
конца J1 (краевой разъем). 

Разместите 4 сопротивления RES-SMD1206-3K. При 
размещении каждого сопротивления, нажмите <F5> 
(Клавиша действия Push) чтобы передвинуть их на 
нижнюю сторону платы. Основываясь на линия 
цепей разместите два из них вне Board Outline около 
U13.

Устали делать "push" ...? Поскольку набор 
сопротивлений и емкостей нужны на нижней стороне 
платы, в диалоге Place Parts and Cells установите 
Active layer в Bottom. Разместите резистор RES-
SMD1206-100K вне Board Outline около U13.

Разместите емкости CAP-SMD0603-100P. 
Основываясь на линия цепей разместите четыре из 
них вне Board Outline около U13 и разместите один 
около потенциометра R5.

Разместите емкости CAP-SMD0805-5P. Разместите 
C19 рядом с U14. Разместите другие ближе к пинам 
кварца Y1 (следите за линиями цепей).

26.

27.

28.

29.

30.

31.

Размещение Развязывающего сопротивления 
В диалоге Place Parts and Cells нужно установить 
Criterion в Nets & Net Classes.

Передвиньте цепь VDD в список Active. Заметьте что  
пин 8 на U13 "выбран цепью", показывая что он 
принадлежит этой цепи. Разметите емкость С28 
около этого пина.

Повторите предыдущий шаг для цепи VEE.

В заключение кликните на кнопку двойной 
стрелки и передвиньте оставшиеся цепи 
(детали) в список Active. Проверьте что 
Active angle все еще 270 и измените Active layer в 
Bottom.

Кликните кнопку Apply и разместите единичную 
емкость под каждую микросхему (исключая U13).

32.

33.

34.

35.

36.
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Сдвиг\Вращение\Перемещение деталей 
Кликните кнопку Close в диалоге Place Parts and 
Cells. 

Увеличьте вокруг аналоговой схемы, U13 и 
связанные с ней компоненты (<Shift><центральный-
клик-тянуть>), которые в данный момент вне Board 
Outline. 

Выберите U13 и нажмите Клавишу Действия <F3> 
чтобы повернуть ее на 90 (пин 1 теперь должен быть  
в нижнем-левом как U5).

Двигайте и вращайте сопротивления и емкости 
вокруг U13 чтобы очистить линии цепей. 
Используйте картинку ниже как справку если хотите. 
(Не беспокойтесь .. вы очистите расположение 
условных обозначений позднее).

37.

38.

39.

40.

При включенных 
фильтрах Top и 
Bottom в Display 
Control, выберите 11 
А н а л о г о в ы х  
компонентов (<клик-
тянуть> область 
выделения вокруг 
них) и нажмите <F2> 
чтобы сдвинуть их 
как  группу.  
Разместите их прямо 
слева от J2 (как 
показанно). Если 
н а р у ш е н и я  
р а з м е ш е н и я  
ограничивают вас от 
сдвига группы 
к о м п о н е н т о в ,  
передвиньте их 
меньшей группой 
и\или индивидуально.

41.

Настройте точнее набор размещения. По вашему 
усмотрению двигайте и вращайте детали чтобы 
очистить линии цепей. Ваше размещение сделано.

Кликните кнопку панели Save чтобы 
сохранить работу.

42.

43.
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Ручной обмен пин 
Если в определенную деталь (в Parts Database) были 
встроенны обмениваемые пины и\или вентили, 
можно сделать ручную оптимизацию топологии.  
Сначала кликните кнопку панели Find  и 
выберите RN1 и RN2 из списка Part Ref 
Des. Выключите опцию Select и включите 
опцию Fit view. Кликните кнопку OK.

Пока увеличение на RN1 и RN2, 
выберите Route>Swap>Pins из меню 
(или кликните кнопку панели в Режиме 
Трассировки). 

Следите за подсказкой! Подсказка в строке 
состояния (внизу окна) говорит Select first pin to Swap 
(Выберите первый пин для Обмена). На RN2 
выберите пин 2 (второй пин сверху). Становятся 
видимыми все обмениваемые пины внутри этой 
детали и подсказка говорит Select second pin to Swap 
with 2 (Выберите второй пин для Обмена с 2). 
Выберите на RN2 пин 9 (второй пин снизу). Пины 2 и 
9 теперь выбранны и подсказка говорит Confirm 
Swap (Подтвердите Обмен). Кликните в 
пространстве рисования чтобы подтвердить это (или 
<правый-клик> чтобы отменить выбор второго пина и 
выбрать другой). Вы должны теперь видеть чистые 
линии цепей идущие от таких же пин на RN1.

Пока активна команда Swap Pins продолжите с RN2 
обменивая пин 3 и 8. Здесь есть автообмен, который 
будем делать позднее поэтому <правый-клик> в 
пространстве рисования чтобы отменить команду.

44.

45.

46.

47.

48.

49.

50.

51.

Используйте команду Find чтобы увеличить 
вокруг Part Number 74ALS32_SOP. (В диалоге 
Find кликните заголовок колонки Part Number 
чтобы сортировать список так что его легко найти).

Закройте диалог Find если он открыт. 
Отмените выбор любых деталей, котороые 
стали выбранными в процессе поиска. 
Пока увеличение вокруг U18 (74ALS32_SOP), 
выберите из меню Route>Swap>Gates (или кликните 
кнопку панели в Режиме Трассировки).

Следите за подсказкой! Подсказка говорит Select pin 
of first gate to Swap (Выберите  пин первого вентиля 
для Обмена). На U18 выберите пин 6 (в левой 
колонке второй пин снизу). Будут видны 
эквивалентные пины все обмениваемых пинов (на 
всех деталях с одним Part Number). Подсказка 
говорит Select pin from second gate to Swap 
(Выберите  пин второго вентиля для Обмена). На 
U18 выберите пин 11 (в середине правой колонки). 
Видно два вентиля и подсказка говорит Confirm 
Swap. Кликните в пространстве рисования чтобы 
закончить обмен и проследите за передвижением 
линий цепей.

Если хотите, попробуйте другой обмен или Undo 
последний обмен и сделайте его заново. Не тратьте 
много времени на это, потому что есть 
автоматический путь сделать это.

Ручной обмен вентилей 
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Автообмен пин & вентилей 
Кликните кнопку панели Fit Board. и 
затем панорамируйте графику платы 
(<средний-клик-тянуть>) в левую сторону 
вашего рабочего пространства.

Выберите Place>Automatic>Swap by Part Number 
из меню. Сдвиньте диалог Automatic Swap by Part 
Number в правую сторону рабочего пространства. 

В диалоге Automatic Swap by Part Number 
кликните кнопку двойная стрелка направо 
(Include All) чтобы передвинуть все 
Excluded (Исключенные) Part Number в список 
Included (Включенные).

Потяните вниз список Swap Items и выберите Gates. 
При этом включите опцию Exhaustive swap.

Кликните кнопку Apply и следите за изменениями 
линий цепей на плате.

Теперь потяните вниз список Swap Items и выберите 
Pins. Кликните кнопку Apply и снова следите за 
изменениями линий цепей на плате.

Повторите пункт 53 по 55 и посмотрите есть ли 
какие-либо дальнейшие улучшения.

Кликните кнопку Close в диалоге Automatic Swap by 
Part Number.

Кликните кнопку на панели File Viewer и 
просмотрите AutoSwap.txt. Закройте File 
Viewer когда сделаете.

52.

53.

54.

55.

56.

57.

58.

59.

60.

61.

62.

63.

64.

65.

66.

Посмотрите на размещение и линии цепей. Можно 
ли сделать какие-либо улучшения, такие как 
вращение дискретных компонентов, ручной обмен 
пинов или вентилей и т.д. Потратьте несколько минут 
чтобы улучшить размещение.

Когда вы удовлетворены размещением, нужно 
Обратно Аннотировать изменения обмена в CDB, 
так что схема будет отображать новые номера пин. 
Выберите Setup>Project Integration из меню.

В диалоге Project Integration, заметьте индикаторы 
Shematic status. Красный означает "нет" и зеленый 
означает "да". Мораль истории такова: Схема и 
топология не синхронизированны и выши последние 
изменения топологии ограничивают Прямую 
Аннотацию. Кликните кнопку Back Annotate.

После Обратной Аннотации, заметьте что все 
индикаторы Shematic status теперь зеленые. 
Кликните кнопку Close в диалоге Project Integration.

Кликните кнопку на панели File Viewer и 
просмотрите BackAnnotation.txt. Закройте 
File Viewer когда сделаете.

Покиньте Expedition PCB и сохраните 
изменения если будет подсказка. 
Замечание: Сохранения топологии 
автоматически запускает Обратную Аннотацию если 
вы забыли.

Обратная Аннотация 
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L  Проверка Топологии
Эта глава обьясняет Проверку Правил Проектирования, 
сравнение топологии с набором размеров и правил зазоров, 
используя программу Batch DRC. Batch DRC рассмотрен 
здесь, но используется на различных этапах разработки 
топологии (трассировки, обработки поверхностей, и т.д).
Рассматриваются темы:
- Окно DRC
- Пакетный режим (Batch) DRC
- Анализ Нарушений Правил (DRC Hazards)
- Статус Проекта
- Проверка Библиотеки проекта



 L-2 
 E XPEDITION PCB INTRODUCTION  WG2000 

 

 

 

Пакетная Проверка DRC
Откройте вашу топологию платы "2001", если она 
уже не открыта.

Если уже открыта и есть не сохраненная информация, 
рекомендуется сохраниться перед запуском Batch DRC.
Выберите Analys>Batch DRC из меню (или 
кликните кнопку панели).
В диалоге Batch DRC включите опцию Connectivity and 
special rules. Выключите опции Net Class clearances and 
rules и Plane clearances and rules. Должна быть включена 
только опция General and element to element rules.
Включите все опции Pad to pad checks.
Справа в списке Layers выберите только Layer 1 и Layer 
6.
Кликните на вкладку Connectivity and special rules. 
Выключите все опции Traces, все опции Nets и все опции 
Planes, все опции Holes/pads/vias за исключением опции 
Min annular ring. Включите опцию Parts.
Сохраните схему локально, назвав ее proximity.
Кликните кнопку OK в диалоге Batch DRC, чтобы 
запустить проверку топологии. Кликните кнопку OK в 
подсказке Batch DRC engine completed successfully.

1
Окно DRC
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Анализ Нарушений Правил

Анализ Нарушений в Оперативном режиме

Анализ Нарушений в Пакетном Режиме
Кликните кнопку панели File Viewer и проверьте 
Drc.txt. Когда закончите закройте File Viewer.

Выберите Analys>Review Hazards из меню (или 
кликните кнопку панели).
В диалоге Review Hazards выберите Batch>Proximity из 
меню и должен появится список нарушений. Если нет 
нарушений то вы сделали что-то не так. Не выбирайте 
какие-либо нарушения в списке. В списке должно быть 
покрайней мере 2 нарушения - 2 разъема слишком 
близко от Board Outline. Вы должны оставить эти 
нарушения. Любые другие нарушения вы со временем 
исправите. Могут быть другие нарушения Mounting Hole, 
Parts Pad.
Чтобы анализировать эти нарушения по одному, 
включите опции графики Select и Fit View внизу диалога. 
Без выбора нарушений в списке, кликните кнопку Review 
чтобы графически увидеть первое нарушение. 
Передвиньте диалог в сторону, если это необходимо.
Просмотрите Description (Описание) нарушения, когда 
смотрите на действительное нарушение. Кликните кнопку 
Review для следующего нарушения.

2

Продолжайте кликать кнопку Review после просмотра 
каждого нарушения. После просмотра последнего 
нарушения, список переключается обратно на первое 
нарушение. 
После того как поймете что такое нарушения, кликните 
кнопку Close в диалоге Proximity hazards. Потратьте 
несколько минут чтобы исправить несколько нарушений 
(конечно за исключением нарушений 2 разъемов). Если 
есть необходимость передвиньте детали. 
Если нужно измерить расстояние, выберите 
Edit>Review>Minimum Distance из меню. Используйте 
Клавишу Действия для переключения между режимами 
Edge-To-Edge и Center-To-Center.
Если вы сделали какие-либо изменения топологии, тогда 
1) сохраните топологию 2) пере-запустите Batch DRC и 3) 
анализируйте список нарушений снова. Повторите 
процесс до тех пор пока останется только 2 нарушения 
разъемов Board Outline, Placement Outline.
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Статус Проекта Проверка Библиотеки Проекта
Выберите File>Save Copy из меню и кликните 
кнопку Yes для сохранения топологии.

В диалоге Job Management Wizard Copy кликните в поле 
New project fi lename и введите 
c:\mgtraining\project\2001placed\2001.prj (вы можете 
скопировать из поля Source project filename и сделать 
соответствующие изменения). Сразу кликните в поле New 
PCB design filename и затем кликните кнопку Finish.
Закройте диалог Summary.

3
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M Трассировка Трасс
Эта глава обьясняет установки для трассировки и 
трассировку топологии платы используя автоматические, 
полу-автоматические и ручные инструменты, а также другие 
утилиты для редактирования трасс.
Рассматриваются темы:
- Установки Трассировки
- Обзор Трассировки
- Соединение с Поверхностями
- Ручная Трассировка
- Полу-автоматическая трассировка
- Автоматическая трассировка
- Изменение Ширин Трасс
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Установки Трассировки
Диалог Editor Control содержит много установок для 
ручной и авто трассировок. Если небходимо эти 
установки можно часто менять в процессе трассировки.

Откройте вашу топологию платы "2001", если она 
уже не открыта.

Выберите Setup>Editor Control из меню (или 
кликните кнопку панели).
В диалоге Editor Control кликните вкладку General если 
она уже не показана.

1

Замечание: В диалоге Editor Control опции отмеченные 
звездочкой (*) воздействуют только на ручную 
трассировку (за исключением вкладки Grids).

Управление Редактора - Общие (General) 
Помимо рассмотренного ранее AutoSave intervals, 
вкладка General в Editor Control содержит управление 
ручной трассировкой, склонности к направлению и 
парности слоев.

Ручная Трассировка 
Установки Interactive Routing контролируют поведение 
трассировщика в сеансе ручной трассировки. В 
большинстве случаев установки по умолчанию работают 
хорошо.
Установка Effort определяет относительное количество 
усилий, использованных в течении сеанса ручной 
трассировки. Чем выше уровень усилий, тем более 
комплексный путь трассировки может быть.
Установка Layer bias определяет относительную 
трудность трассировки в отношении склонность слоя 
против размещения перехода. Чем выше склонность 
слоя, тем труднее трассировать  трассу в отношении 
склонности.
Установка Via cost определяет относительную цену 
добавления перехода в путь трассы.
Установка Max vias added  определяет количество 
позволенных переходов в течении каждой операции 
ручной трассировки.
Опцию Trace and via shoving allowed можно выключить, 
не позволяя двигать существующие трассы при ручной 
трассировке.
Опция Double-click to add via позволяет использовать 
мышку для добавления перехода при переключении 
внутри пар слоев.
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Трассировка & Склонность Направления
Диалог Editor Control можно 
использовать чтобы легко включить 
или выключить целый слой для 
трассировки. Конечно, лучше 
использовать установки Net Class, 
которые позволяют или запрещают 
трассировку на конкретном слое.
Можно определить для каждого слоя 
direction bias, Horizontal 
(Горизонтальный)  или Vertical 
(Вертикальный).
Автоматический и полу-автоматический трассировщик 
будет затем трассировать в этом основном 
направлении для данного слоя.

В секции Enable routing & direction bias, включите 
все шесть слоев для трассировки.

Также установите Bias направления основанный на 
вашем размешении. Если ваше размещение совпадает с 
предыдущей лабораторной, установки показанные выше 
работают хорошо.

2

Пары слоев

Можно так установить Layer Pairs что при 
нажатии пробела или двойного-клика будет 
размещаться переход и трассировка 
продолжается на "парном" слое.
Замечание: Изменение слоев при 
трассировке будет обсуждаться позднее в этой 

Для установки Pairs слоя, кликните на слое 
1 и затем на слое 6. Поставте пары как показанно.

Замечание: Чтобы отделить пару слоев, кликните на 
номере слоя и затем кликните в пустой строке. Для 
обмена слоями между парами, кликните на номере слоя 
внутри пары и затем кликните на номере слоя из другой 
пары.

3
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Управление Редактором - Трассы 
Вкладка Routes диалога Editor Control содержит 
некоторые общие правила трассировки.

Трассы 
По умолчанию для авто и ручной трассировки стоит 
Allow 45 degree corners. Если эта опция выключена 
любые добавляемые трассы будут трассироваться 
только прямоугольно.
Можно включить здесь какие-либо или все три Plow 
modes (режимы ручной трассировки), чтобы они были 
доступны при ручной трассировке. Характеристики 
каждого  plow mode обсуждаются позднее.

В диалоге Editor Control кликните на вкладку 
Routes. В секции Routes в верхнем-левом углу 

диалога, проверьте что включены только режимы Forced 
и Route.

4

Переходы 
Эти правила переходов воздействуют на ручную и авто-
трассировку.
Максимальное количество переходов заданное для цепи 
в Net Properties, можно заменить в Allow one additional 
via per SMD pin.
Опция Use place outlines as via obstructs 
предотвращает размещение переходов под 
компонентами.
Опция Enable fanouts of single pin nets совместно с  
Assign single pin nets to unused pins из Project Integration, 
позволяет fanout все пины.
Max pins per plane fanout via устанавливает количество 
пин которые могут совместно использовать один переход 
fanout.
Max fanout lenght on restricted layers позволяет 
сделать для SMD пин fanout на запрещенных слоях. 
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Опция Правила Цепей
При ручной трассировке можно отключить установки 
Net Classes касающиеся Layer restrictions и установки 
Net Properties касающиеся Stub lengths, Via 
restrictions и Max delay & lengths.

Подключение площадок и расширение
При назначении уникальной Min Width (ширина 
подключения к площадке) в Net Class, при авто и 
ручной трассировке контролируется Min distance at the 
pad entry width. 
При назначении 
уникальной 
Expansion Width 
в Net Class, 
Min distance at same width контролирует длину 
минимального сегмента до того как можно расширить 
трассу при авто и ручной трассировке. Эта опция 
используется только при ручной трассировке если 
включена опция Expand traces и всегда используется 
при автотрассировке в проходе Expand.

Управление Редактора - 
Подключение к Площадке
Вкладка Pad Entry в Editor Control использована для 
установки правил trace-to-pad entry и позволено ли 
размещение перехода под площадкой, для каждого 
вида площадок использованного в топологии.

Чтобы установить правила для конкретных площадок 
есть фильтр Select Pads для отбора форм площадок 
или групп форм площадок .
Опции Rules for all rectangular pads и Rules for 
selected pads позволяют установить предпочтения 
по подключению к площадке и разрешение 
размещения перехода под площадкой.

В диалоге Editor Control кликните на вкладку Pad 
Entry. Выберите (All Rectangular Pads) вверху 

списка. Выключите опцию Prefer 
внизу Rules for selected pads.

5

Если необходимо кликните кнопку Reset Selected Pads 
To Defauls для возвращения установок по умолчанию 
для выбранного подключения к площадке.
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Управление Редактора - Сетки
Expedition PCB это бессеточный трассировщик и сетка 
ему не нужна. Вкладка Grids в Editor Control позволяет 
установить опции Route grid и Via grid. Не устанавливая 
сетки для трассировки и переходов можно добиться 
лучших результатов трассировки.

Управление Редактора - Фильтр
Вкладка Filter в Editor Control позволяет внести цепь в 
список Included (Включенные) или Excluded 
(Исключенные) для выбора, ручной трассировки и т.д. 
Не смотря на то что цепи были исключены, все цепи 
считаются включенными до тех пор пока не включена 
опция Enable filter. 
Опция  Apply filter to netlines выключает видимость 
линий цепей для всех исключенных цепей.  

В диалоге Editor Control кликните кнопку OK для 
сохранения установок и закрытия диалога. 

Чтобы увидеть всю топологию кликните кнопку панели Fit 
Board.
Кликните кнопку панели Display Control если 
необходимо. Так как диалог Display Control нужен 
при выполнении лабораторной сдвиньте его на одну 
из сторон.
Во вкладке Layer диалога Display Control включите All 
Open Netlines (в середине диалога), если уже не 
включено.
Во вкладке Part диалога Display Control выключите Part 
Items для обеих Top и Bottom.

6

Обзор Трассировки

Существует три базовых подхода при трассировке в 
Expedition PCB; "ручной", "полу-автоматический" и 
"автоматический". Границы между ручным и полу-
автоматическим и между полу-автоматическим и 
автоматическим размыты. Семантика не важна ... Она 
просто помогает в объяснении использования 
трассировщика.

Ручная
Ручная трассировка это прокладка трасс руками 
(Plowing) и размещение переходов (изменение слоев) 
где необходимо.

Полу-автоматическая
Это использование функций автотрассировки на 
короткое время. Например: выбор цепи и 
выполнение команды Route или Fanout.

Автоматическая
Это использование диалога Auto Route для установки 
стратегии трассировки. Автотрассировку можно 
использовать как для целой платы, так и для части 
ее.

Замечание: Лучше всего использовать комбинацию 
ручной, полу-автоматической и авто трассировок. 
Например: в ручную растрассировать критические цепи 
используя при этом полу-автоматические команды для 
ускорения процесса. Затем автоматически 
трассировать набор трасс.
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Подключение к Поверхностям

Одна из философий для трассировки много-слойной 
платы это сначала подключить каждое устройство к 
питанию, до того как разместить какую-либо медь на 
плату. При этом гарантируется питание даже если 
плата не может быть растрсссированна на 100%.

Fanouts (Фэноуты)
Фэноут это короткая трасса и переход привязанные к 
SMD пину с целью вывести эту цепь на другой слой, 
такой как слой поверхности.
Пины нужно выбрать сначала, чтобы генерить фэноуты 
полу-автоматически. Затем из меню выбрать 
Route>Interactive>Fanout или использовать Клавишу 
Действия Fanout.
Команда Find дает широкие возможности выбрать 
конкретную цепь чтобы фэноут ее.

Сделайте фэноуты для SMD пин, которые связанны 
с внутренними поверхностями используя шаги: 

Кликните кнопку панели Find. В диалоге Find кликните 
на вкладку Net Class. Выберите Power в списке Net 
Class. Включите только опцию графики Select и 
кликните кнопку Apply. Оставьте диалог открытым, но 
сдвиньте его в сторону.
Заметьте что теперь выбранны все пины VCC, VDD, VEE 
и GND (Класс Цепей Power). Нажмите <F2> (Клавиша 
Действия Fanout) чтобы фэноут все выбранные пины.
Найдите какие-либо потерянные фэноуты из-за проблем 
размещения. Используйте диалог Review Hazards 
(Online>Open Fanouts)как помощь в нахождении 
потерянных фэноутов для цепей Power.
Cдвиньте какие-либо фэноут если вы чуствуете что они 
блокируют каналы трассировки. Чтобы сдвинуть фэноут, 
просто кликните-потяните переход на новое место. 

7
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Фиксирование Трасс & Переходов
Если нужно провести трассы (и переходы) по 
определенному пути в топологии, их трассируют и 
сразу "Фиксируют", сохраняя таким образом их путь. 
Зафиксиррованные трассы и переходы нельзя двигать 
и удалять.

Фиксирование / Отмена фиксирования

Чтобы зафиксировать трассу, сначала выберите ее, 
затем выберите из меню Edit>Fix (или кликните 
кнопку панели). Чтобы отменить фиксацию трассы, 
сначала выберите ее, затем выберите из меню 
Edit>Unfix (или кликните кнопку панели).
Нужно выбрать объекты перед использованием 
команд Fix и Unfix. Помните много способов выбора 
объектов, которые мы рассмотрели в начале курса? 
В меню есть Edit>Add to Select Set>Unfixed Traces 
или Edit>Add to Select Set>Unfixed Vias. Похожее, 
в меню есть Edit>Add to Select Set>Fixed Traces 
или Edit>Add to Select Set>Fixed Vias.
Фиксированные трассы и переходы отображаются  
заштрихованными, а не заполненными, для легкой 
идентификации.

Половиная фиксация
Полу-фиксация (Edit>Semi-fix) действует точно также 
как фиксация, за исключением того что трассы и\или 
переходы еще можно двигать в ручную. Любое 
проталкивание\расталкивание другими трассами не 
воздействует на полу-фиксированные трассы \ 
переходы.
Замечание: При выходе из топологии полу-
фиксированные трассы\переходы становятся не 
фиксированными.

Когда все фэноуты размещенны, выберите снова 
Класс Цепей Power в  диалоге Find. Кликните кнопку

OK для выбора фэноутов.
Кликните кнопку панели Fix затем кликните в пустом 
пространстве чтобы отменить выбор всего. Увеличьте 
чтобы лучше видеть. 
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Также как Детали и Крепежные Отверстия 
использованные ранее в курсе, трассы и переходы 
можно "заблокировать". Статус Locked гарантирует 
критическое местоположение конкретных трасс и 
переходов. Locked позволяет временно использовать 
команды Fix и Unfix без воздействия на 
заблокированные трассы.
Заблокированные трассы и переходы изображаются не 
заполненными.

Фиксирование / Блокирование



При выполнении команды Plow выберите пин 
компонента, трассу, или переход чтобы начать 
трассировку. Так как ожидаемая трасса следует за 
курсором, разместите точки изгиба (кликнуть) для 
продолжения трассировки трассы.
При трассировке и размещении точки изгиба, "теневое" 
место размещения перехода показывается в графике 
указывая возможное место перехода. Теневой переход 
соблюдает установки Via Grid в диалоге Editor Control - 
Grids.
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Ручная Трассировка
Ручная трассировка это прокладка трасс руками, 
установка переходов и разнообразные команды 
редактирования трасс\переходов. Конечно, для ручной 
трассировки Expedition PCB должен быть в режиме 
Route.

Ручная трассировка новой трассы это "plow" эту трассу. 
Plow трассировка может стартовать на любом пине 
компонента который имеет назначенную цепь или 
стартовать на существующей трассе\переходе.

Plowing в общих чертах
Чтобы вызвать команду Plow выберите из меню 
Route>Interactive>Plow -или- измените режим в Route 
и кликните кнопку панели -или- измените режим в 
Route и выберите Клавишу Действия Plow.
Команду Plow можно вызвать на ранее выбранный пин 
или трассу или Команду Plow можно вызвать до 
выбора пина или трассы.
Быстрейший путь трассировать plow одну или 
несколько трасс это: вызвать команду Plow, кликнуть на 
пин (или трассу) чтобы стартовать трассировку с него, 
кликнуть на нужные точки изгиба на пути трассы, затем 
кликнуть на конечный пин (или трассу), что 
автоматически оканчивает трассировку. Сразу 
выберите следующий пин (или трассу) чтобы начать 
новую трассировку. Окончательно, когда 
растрассировали нужную трассу, правый-клик чтобы 
отменить команду Plow.

Plowing в общих чертах

Plowing в деталях

Замечание: Если в диалоге Display Control выключено 
All Open Netlines, определенные линии цепей будут 
автоматически отображаться когда трассируете эту 
цепь.

Увеличьте аналоговую схему (U13 и 
ассоциированные компоненты). Измените режим в

Route если необходимо и кликните Клавишу Действия 
Plow.
Кликните на пине одного из сопротивлений или 
емкостей ассоциированных с U13 который имеет 
прикрепленную линию цепи. Теперь кликните на 
другой пин прикрепленный к этой цепи если он близко 
чтобы закончить трассировать. Вы должны быть 
готовы трассировать больше трасс.
Если трассировка не закончилась, попробуйте 
трассировку ее снова, но разместите точки изгиба 
(клик) по пути для установки пути для трассы. Если 
трассировка закончилась, но вам не нравится, 
используйте команду Undo попробуйте снова 
размещая точки изгиба. 

9
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Есть четыре режима plow которые можно выбрать 
при ручной трассировке: Forced Plow, Route Plow, 
Angle Plow и Dyna-Plow. Каждый имеет 
специальные характеристики и может быть 
использован попеременно.
После вызова команды Plow, выберите <F3> 
Клавишу Действия Toggle Plow Modes для 
переключения режимов. Какие Режимы Plow будут 
доступны для переключения основываются на том 
какие режимы включены в диалоге Editor Control - 
Routes.

Режимы Plow

Forced Plow
Forced Plow это режим по умолчанию. Это 
наиболее основной режим ручной трассировки и 
использован для создания "принудительных" 
путей трасс. Переходы не будут размещаться 
автоматически. Будущая трасса отображается 
как эластичное соединение.
Route Plow
Route Plow это режим более интелектуальный, 
использующий преимущества алгоритмов полу-
автоматической трассировки. Он принимает во 
внимание склонность направления слоя и если 
необходимо будет ставить переходы и изменять 
слои. Route Plow можно использовать для 
интелектуального покрытия длинного 
расстояния между точками изгиба. Будущая 
трасса отображается как прямая линия 
эластичного соединения.
Замечание: На Route Plow непосредственно 
влияют установки Interactive в диалоге Editor 
Control - General.

Angle Plow
Angle Plow позволяет трассировку под любыми 
углами. Трассы под углами другими чем 45 и 90 
не будут расдвигаться и расталкиваться, 
поэтому используйте Angle Plow редко. Также 
установки gloss (обсуждаются позднее) не 
действуют при Angle Plow.
Замечание: Angle Plow по умолчанию выключен 
в диалоге Editor Control - Routes.

Dyna-Plow
Dyna-Plow это уникальный plow режим похожий 
на Forced Plow. Он не переключается с 
помощью Клавиши Действия, вместо этого он 
активизируется используя <клик-тянуть>. Dyna-
Plow полезен для очистки пути раздвигая другие 
трассы.
Чтобы использовать Dyna-Plow выберите 
начальную точку (пин, трасса или переход) и 
кликните-потяните левой клавишей мыши. 
Трасса динамически прокладывается при 
движении курсора. Отпустите клавишу мыши 
для размещения точки изгиба.
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Когда прокладываете трассу, Expedition PCB 
динамически очищает путь трассы, удаляя не 
нужные изгибы. Это называется Gloss.
Gloss имеет три режима для выбора: Gloss On, 
Gloss Partial и Gloss Off. Каждый имеет спец. 
характеристики и может быть использован 
попеременно. При выполнении команды Plow, 
доступна  Клавиша Действия <F4> Toggle Gloss 
Mode для переключения режимов.  

Режимы Gloss

Gloss On
Gloss On это gloss режим по умолчанию. Он 
автоматически удаляет неровности и острые 
углы с трассы для изготовления. Также, если 
возможно, изменяются подключения трасс к 
площадкам, в соответствии с предпочтениями 
Pad Entry  в диалоге Editor Control.

Gloss Partial
Gloss Partial размещает трассу в точности где 
вы кликните. Не будет никакой авто-очистки.

Gloss Off
Gloss Off действует также как Gloss Partial, за 
исключением того что сегменты трасс 
добавленные в этом режиме становятся полу-
фиксированными и они не могут быть сдвинуты 
при выполнении команд ручной и 
автотрассировок в течении этой сессии 
редактирования.
Помните! Любую часть трассировки можно 
сдвинуть в ручную. Закрытие топологии платы и 
открытие ее вновь изменяет статус этих 
сегментов трасс - они становятся не 
фиксированными.

Когда прокладываете трассу можно отменить 
предыдущую точку изгиба используя команду Undo. 
Команда Redo востанавливает отмененную точку 
изгиба. Наиболее удобно использовать Клавиши 
Действия Undo и Redo.  

Undo / Redo

Когда трассируете в ручную есть несколько 
способов измнения слоев трасс. Изменение слоев 
при прокладке трасс автоматически добавляет 
переход.
После размещения точки изгиба при прокладке 
трассы, отображается тень перехода, указывая 
размер и положение если пользователь сразу 
изменяет слои. Когда изменяете слой, вновь 
размещенный переход может отодвинуть другие 
переходы и трассы в сторону.  

Изменение слоев

Когда прокладываете трассу нажмите пробел 
или дважды-кликните или используйте Клавишу 
Действия Add Via чтобы автоматически 
разместить переход и изменить в парный слой 
(пары слоев устанавливаются в Editor Control). 
Трассировка продолжается непрерывно на 
новом слое.  

Между парами слоев

Когда прокладываете трассу кликните на другой 
слой во вкладке Layer диалога Display Control 
или нажмите клавишу вверх\вниз (смотрите на 
строку состояния) чтобы автоматически 
разместить переход и изменить слои. 
Трассировка продолжается непрерывно на 
новом слое.  

В любой слой
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При прокладке трассы, правый-клик для 
отображения всплывающего меню с подменой 
ширины и перехода.
Пункты меню Change Width позволяют временно 
установить ширину трассы в Minimum, Typical или 
Expansion заданные для этого Класса Цепи.
Пункт меню Change Next Via позволяет выбрать 
любой доступный padstack перехода как 
следующий размещенный переход, не обращая 
внимания на то что назначенно в Net Class. После 
размещения, произойдет возврат к переходу 
назначенному по умолчанию в Net Class.  

Изменение ширин\переходов

Закончить автоматически
Чтобы автоматически закончить соединение (или 
попробовать закончить) при прокладке трассы, 
используйте Клавишу Действия Auto Finish. Это 
хорошо работает когда конец пути предсказуем и 
вы хотите сохранить клик или два.
Auto Finish это действительно функция полу-
автоматической трассировки которая использована 
при ручной трассировке.  

Ручной фэноут
При прокладке трассы можно разместить 
единичный фэноут перехода. Выберите пин для 
начала трассировки и затем не размещая точку 
изгиба кликните Клавишу Действия Fanout.  
Остановка Plow
Чтобы закончить любую команду трассировки, 
такую как Plow просто сделайте правый-клик. 
Некоторые команды могут содержать несколько 
уровней, поэтому каждый правый-клик возвращает 
на один уровень команды. Если появилось меню, 
вы полностью вышли из команды.   

Передвижение трасс\переходов
Чтобы двигать существующие трассы и переходы, 
Expedition PCB должен быть в Режиме Route, но не 
в какой-либо команде трассировки, такой как Plow.
Клик-тянуть на переходе, сегменте трассы или 
вершине трассы чтобы сдвинуть их. Другие трассы 
и переходы будут отодвинуты в стороны если здесь 
нет пространства и если они не полу-
фиксированны, фиксированны или блокированны. 
Обычно трассы и переходы можно сдвинуть так что 
перепрыгнуть существующие трассы и переходы и 
пины компонента, если нет нарушений зазоров.
Замечание: Иногда сдвиг (и перепрыгивание) 
вовлекает слишком много объектов или слишком 
комплексное чтобы закончиться. В этом случае, 
попробуйте покрыть меньшее растояние или 
попробуйте другой подход. 

Использование клавиши Shift
Использование  <Shift><клик-тянуть> чтобы 
двигать сегмент трассы присоединенный к 
площадке позволяет обойти правила 
подключения к площадке.
Использование  <Shift><клик-тянуть> чтобы 
двигать переход фэноут помогает выпрямить 
присоединенный сегмент трассы. 

Перемещение трасс на другой слой
Чтобы переместить сегменты трасс на другой слой 
и автоматически разместить необходимые 
переходы, сначала выберите нужный сегмент(ы) 
трассы. Затем выберите слой назначения из 
вкладки Display Control - Layers (или с помощью 
клавиш вверх\вниз). Наконец используйте Клавишу 
Действия Push Trace.
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Копирование трасс\переходов
Существующие трассы и переходы можно 
копировать для сохранения времени и усилий. 
Конечные точки копированных трасс нужно 
выровнять с новыми пинами\трассами той же цепи. 
Копия возмет новое имя цепи.
Чтобы копировать трассы сначала выберите их, 
кликните кнопку панели Copy Trace. Теневое 
изображение трассы будет присоединено к курсору. 
Разместите его. Непохожие цепи имеют конфликты 
металла, поэтому может произойти некоторый 
сдвиг\раздвижка.  

Удаление трасс\переходов
Чтобы легко удалить все не фиксированные трассы 
и переходы, выберите Route>Delete All Traces and 
Vias из меню.
Как обсуждалось ранее в курсе, любые выбранные 
сегменты трасс можно удалить используя клавишу 
Delete или кнопку панели Delete.  

Сдвиг трассированных компонентов
Если трассы присоединены к пинам компонента, 
его все еще можно двигать, поворачивать и 
перемещать. После того как компонент помещен на 
новое место, трассы будут стараться пере-
трассироваться сами. 
Замечание: Компонент имеющий фиксированные 
или заблокированные  трассы присоединенные к 
его пинам, не может быть сдвинут, повернут или 
перемещен.

Трассируйте все короткие трассы в U13 аналоговой 
схеме. Возможно вам нужно будет сдвинуть и\или

повернуть компоненты.
Подсказка: Когда трассируете между SMD и сквозными 
пинами, сначала начинайте на SMD пине чтобы легко 
установить правильный активный слой.
Оптимизируйте все пути трасс по своему. Область 
выделения вокруг новых трасс и кликните кнопку 
панели Fix Selected Items.
Не забудьте сохранить вашу топологию! 
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Трассирование

Команды которые нельзя отнести только к ручной или 
автоматической трассировке, такие как Fanout, Multi-
Plow, Route, Reroute, Tune и Gloss считаются полу-
автоматическими. Чтобы работали эти команды 
необходимо сначала выбрать пины, трассы, переходы 
и\или линии цепей.
При ручной трассировке, команды Auto Finish и Push 
также считаются полу-автоматическими. 
Проталкивание и расталкивание трасс\переходов при 
ручной трассировке\редактировании в 
действительности является полу-автоматической 
перетрассировкой. 
Замечание: Команды Multi-Plow и Tune не 
рассматриваются в этом курсе. 

Полу-автоматическая Трассировка

Можно быстро растрассировать трассы выбирая пины 
и используя Клавишу Действия Route. При этом 
вызывается базовый алгоритм авто-трассировки. Этим 
способом можно быстро растрассировать любой 
выбранный пин, переход, трассу и линию цепи. 

Используйте команду Find для увеличения кварца 
Y1. Уменьшите немножко, если необходимо, чтобы

видеть другие компоненты связанные с ним (U14 и т.д).
Тройной-клик на одном из пинов Y1 для выбора всей 
цепи. Кликните Клавишу Действия Route для 
трассировки всех пинов этой цепи. Модифицируйте 
новые трассы как хотите.
Тройной-клик на пине снова для выбора всей цепи и 
затум кликните кнопку панели Fix Selected Items.
Трассируйте (и фиксируйте) другие пины Y1 похожим 
способом.

11

Замечание: На команду Route непосрественно влияют 
установки Interactive в  диалоге Editor Control - General. 

Перетрассировка
Когда оттрассированная трасса стала не оптимальной 
в результате последовательной трассировки и 
редактирования, выберите трассу и затем кликните 
Клавишу Действия Reroute чтобы позволить Expedition 
PCB перепроверить путь трассы и перетрассировать 
ее.
Замечание: На команду Reroute непосрественно 
влияют установки Interactive в  диалоге Editor Control - 
General.
Gloss
Клавиша Действия Gloss можно вызвать на выбранную 
трассу для очистки ее для изготовления. Команда 
Gloss не будет сдвигать или удалять переходы, и 
перетрассировывать трассы вокруг различных 
площадок. 

Попрактикуйтесь в ручной трассировке. 
Растрассируйте несколько линии цепей в вашей

топологии используя различные режимы Plow, измените 
слои (размещая переходы), двигайте и 
перетрассировывайте трассы и т.д.
Когда попрактикуетесь, выберите Edit>Delete All Trace 
and Vias из меню, таким образом останется работа для 
автотрассировки. Не беспокойтесь, выши фиксированные 
трассы и переходы останутся без изменений.

12
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Автоматическая Трассировка
Expedition PCB может автоматически трассировать всю 
топологию, выбранные цепи, отфильтрованные цепи и 
специфические цепи. 

Автоматическая против Ручной
Как обсуждалось ранее иногда нужно трассировать в 
ручную, иногда автоматически. 

Автоматически трассировать можно в любое время в 
процессе разработки топологии. Можно использовать 
исключительно автотрассировку или смешанно с 
ручной трассировкой. 

Смешивайте их

Не смешивайте их
В автотрассировке использованы такие же алгоритмы 
как в полу-автоматической и ручной. При 
автотрассировке можно устанавливать различные 
проходы трассировки, таким образом иметь больше 
контроль и потенциально выше процент 
законченности в меньшее время. 

Выберите Route>Auto Route из меню (или кликните 
кнопку панели в режиме Route) чтобы вызвать

диалог Auto Route.
13
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Диалог Auto  Route

Список проходов 
авто-трассировки, 

выполняемых 
сверху вниз. 

Отметка 
выполнения. 

Статус трассировки. 

Сохранение (и 
удаление) схем 

трассировки. 

Вызов диалога Auto 
Route Options. 

Вызов диалога 
Interrupt Auto Route. 

Открытие файла статуса текущей авто-
трассировки AutoRouteReport{xx}.txt 
используя Windows Notepad. 

Уменьшение диалога 
Auto Route в Mini Status. 

Старт авто-трассировки 
основываясь на проходах 
для выполнения. 

Сдвиг выбранного 
прохода в списке. 

Добавление нового 
прохода авто-трассировки. 
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Проходы авто-трассировки
Кликните кнопку New Pass в диалоге Auto Route для 
добавления прохода трассировки (строки) в список. В 
списке могут существовать несколько проходов одного 
Pass Type но заданных различных уровней усилий, 
цепей, слоев, и т.д.
Можно изменить порядок выполнения проходов, т.к 
автотрассировщик выполняет список сверху вниз. 
Сначала выберите проход в списке и затем кликните на 
кнопку Move Up или Move Down в диалоге Auto Route.

Проходы для выполнения
Отметка Pass использована для разрешения 
прохода для трассировки. После выполнения 
прохода при автотрассировке разрешение прохода 
автоматически отменяется.

Типы проходов
Каждый Pass Type использован для получения 
специфических результатов трассировки в течении 
этого прохода и дополняет другие типы проходов, 
которые выполнены до и после него.
Замечание: Доступные типы проходов зависят от 
лицензирования Expedition PCB.

Memory (Память)
Проход Memory оптимизирован для трассировки 
матриц памяти ... пин в пин на похожих 
компонентах. Переходы не размещаются.

Fanout (Фэноут)
Проход Fanout соединяет площадки SMD и 
переходы, позволяя последующим проходам 
трассировки присоединяться на других слоях.

No Via
Проход No Via делает общие горизонтальные и 
вертикальные соединения к площадкам и 
переходам. Переходы не размещаются.
Route
Проход Route трассирует любые связи, обычно 
соблюдая склонности слоев и размещая 
переходы где необходимо.

Tune
Проход Tune пробует настроить все цепи 
которые имеют заданные правила 
времени\длинны.
Via Min
Проход Via Min убирает переходы при 
перетрассировке.

Smooth
Проход Smooth перетрассировывает трассы для 
исключения извилин (удаляя не нужные 
вершины).

Expand
Проход Expand расширяет трассы, где 
возможно, если заданна Expansion Width в Net 
Classes.

Spread
Проход Spread растягивает трассы, где 
возможно, чтобы увеличить зазоры правил до 
2Х .



M-18 
 E XPEDITION PCB INTRODUCTION  WG2000 

Элементы для трассировки
Для каждого прохода, Items to Route может быть All 
Nets(Все Цепи), Filtered Nets(Отфильтрованные 
Цепи), Selected Nets(Выбранные Цепи), Tuned Pin-
Pairs(Настроенные Пары-пин), Differential 
Pairs(Дифференциальные Пары) или конкретные 
Nets из списка.
Уровни усилий
Для каждого прохода можно назначить уровень 
Effort. Чем выше уровень усилий, тем больше 
усилий будет тратить трассировщик для 
выполнения задания. Высокие уровни усилий не 
всегда подходят, так как они могут создать 
нежелательные пути трасс и\или блокировать 
каналы трассировки. Ниже показанны уровни 
усилий для каждого Pass Type:

Memory = 1 по 3
Fanout   = 1 по 3
No Via   = 1 по 3
Route    = 1 по 5
Tune      = 1
Via Min  = 1 по 5
Smooth  = 1 по 3
Expand  = 1 по 3
Spread  = 1 по 3

Для каждого прохода нужно задать Start и End 
уровни усилий. Уровень усилий End должен быть 
равен или выше чем уровень усилий Start. Если 
уровень усилий Start для  прохода установлен в 1 и 
уровень усилий End установлен в 3, то этот проход 
будет выполнятся три раза последовательно, один 
для каждого усилия, перед переходом к 
следующему проходу.

Старт
Нижние уровни усилий Start использованны на 
проходах которые не были выполнены ранее и\или 
на мало трассированной топологии. Высшие уровни 
усилий Start использованны где много топологии 
уже растрассированно.

Конец
Высшие уровни усилий End использованны на 
топологиях с большой плотностью и\или после 
выполнения других проходов (Pass Types). В 
конкретных случаях, высшие уровни усилий будут 
игнорироваться если этот конкретный Pass Type 
ничего больше не может сделать.
Теперь
Колонка Now отображает выполняемый в данный 
момент уровень усилий.

Начинайте на нижних уровнях усилий на свежой 
топологии и сдержанно работайте на высших уровнях 
усилий.
Предупреждение! Уровень усилий 5 для Типа Прохода 
Route будет делать все возможное чтобы сделать 
соединения. Используйте его расчетливо.



В диалоге Auto Route кликните кнопку Save 
Scheme. В диалоге Save Scheme введите 

Scheme name. Включите опцию Save locally with job и 
выключите опцию Save with PCB system files. Кликните 
кнопку OK для сохранения схемы.

15

M-19 
 E XPEDITION PCB INTRODUCTION  WG2000 

 

Слои
Для каждого прохода можно установить 
трассировочные Layers(Слои) в All Enabled(Все 
доступны) или определенные Enabled Layers 
(Доступные Слои).
Сетки Трассировки\Переходов
Для каждого прохода можно установить Rte. Grid 
(сетка трассировки) и Via Grid (сетка переходов) в 
диалоге Editor Control - Default, значение None(нет) 
или определенное значение.
Fix (Фиксация)
После каждого прохода можно автоматически 
фиксировать трассы растрассированные в этом 
проходе.
Pause (Пауза)
После каждого прохода можно сделать паузу в 
автотрассировке. Это позволяет посмотреть и даже 
вручную редактировать трассированные трассы 
перед продолжением следующего прохода. Чтобы 
возобновить автотрассировку, кликните кнопку 
Route снова.

В диалоге Auto Route кликните кнопку New Pass. В 
список проходов добавится строка.

Кликните кнопку Move Down до тех пор пока новый 
проход не окажется внизу списка.
Для этого последнего прохода измените Pass Type в 
Smooth.

14

Схемы автотрассировки
После установки проходов Auto Route, Scheme для 
Auto Route можно сохранить для использования 
позднее. Как и с другими схемами в Expedition PCB, 
есть опции Save locally with job(сохранить 
локально с работой) или Save with PCB system 
files (сохранить с системными файлами).

Опции автотрассировки
Кликните кнопку Options для вызова диалога Auto 
Route Options.
Опции Allow Via Min, Smooth, Expand and Spread if 
not routed to 100% могут блокировать каналы 
трассировки в дальнейшем.
Установите время Auto Save interval для Auto Route 
здесь или через диалог Editor Control.



M-20 
 E XPEDITION PCB INTRODUCTION  WG2000 

 

Проверьте что все проходы в колонке Pass 
включены и Items to Route установленно в All Nets

для всех проходов.
Кликните кнопку Route в диалоге Auto Route для 
трассировки остатка топологии. Когда появится подсказка 
Save current changes before Routing? кликните кнопку Yes.

16

Выполнение автотрассировки
После установки диалога Auto Route кликните кнопку 
Route чтобы по выбору сохранить топологию и 
начать автотрассировку.

Проходы выполняются начиная с верха списка. 
Отметка Pass очищается когда этот проход закончен.
При выполнении автотрасировки, законченные 
трассы динамически добавляются в графическое 
отображение. Доступны все функции 
масштабирования и панорамирования. Элементы 
графики можно включить или выключить используя 
диалог Display Control.
Кликните кнопку Mini Status в диалоге Auto Route 
чтобы отобразить меньший диалог Auto Route Mini 
Status, делая большую площадь для визуализации 
графики.

Прерывание автотрассировки
При выполнении автотрассировки кликните кнопку 
Interrupt в диалоге Auto Route чтобы остановить 
трассировку или создать контрольную точку 
пользователя (временное сохранение).

Растрасированно ли 100%? Кликните кнопку 
Report в диалоге Auto Route. Проверьте отчет 

трассировки и закройте его (Notepad) когда сделаете.
Кликните кнопку Close в диалоге Auto Route. Потратьте 
несколько минут для детализации вашей топологии, 
сдвига и возможно перетрассировки трасс и переходов.

17
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Изменение Ширин Трасс
В идеале ширины трасс нужно контролировать через Net 
Classes, но иногда нужно изменить индивидуальные 
сегменты трасс.
Чтобы вручную изменить ширины трассы для выбранных 
сегментов трассы, выберите Route>Change Width из 
меню (или кликните кнопку панели).
В диалоге Change Width, введите New Width или 
выберите ранее заданную ширину из выпадающего 
списка. 

Изменение множества ширин
Если было выбранно более одной ширины трасс, эти 
ширины будут отображаться в поле Current width 
разделенные косой чертой. Задайте New Width для 
каждого, также разделяя их косой чертой (т.е 8/10/12). 

Изменение в ширину по умолчанию
Чтобы изменить выбранные сегменты трасс обратно в 
их ширины Класс Цепей, выберите Net Class Width из 
выпадающего списка New Width. 
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Теперь когда топология растрассированна, вам 
нужно проверить ее.

Сохраниет топологию и затем кликните кнопку панели 
Batch DRC.
В диалоге Batch DRC, вкладка DRC Settings, включите 
следующие опции (обратитесь к лабораторной "Проверка 
Топологии" для предыдущих установок Batch DRC):

Net Class clearances and rules
В диалоге Batch DRC в списке Layers выберите только 
Layer 1, Layer 2, Layer 5, и Layer 6.
В диалоге Batch DRC вкладка Connectivity and Special 
Rules включите следующие опции:

Все опции Traces
Все опции Nets
Опции Holes/Pads/Vias:

Danling vias / jumpers
Vias under... SMD pads

В диалоге Batch DRC кликните кнопку Save scheme 
чтобы сохранить схему Batch DRC только локально 
назвав ее routes. Теперь кликните кнопку OK чтобы 
выполнить Batch DRC топологии.
Кликните кнопку панели Review Hazards. В диалоге 
Review Hazards выберите выпадающее меню Batch и 
проанализируйте каждый тип риска сбоя в этом меню. 
Игнорируйте любые Unrouted/Partial Nets риски сбоя 
связанные с цепями GND, VCC, VDD и VEE.
Исправьте  какие-либо другие имеющиеся проблемы 
трассировки. Закройте диалог Review Hazards, сохраните 
топологию, и перезапустите Batch DRC. Проанализируйте 
риски сбоя снова.

18 Выберите File>Save Copy... из меню и кликните 
кнопку Yes для сохранения вашей топологии.

В диалоге Job Management Wizard Copy кликните в поле 
New project fi lename и введите 
c:\mgtraining\project\2001routed\2001.prj (вы можете 
копировать из поля Source project filename и сделать 
соответствующие изменения). Сразу кликните в поле New 
PCB design filename и затем кликните кнопку Finish.

19



EXPEDITION PCB INTRODUCTION N-1

N Генерация Поверхностей
В этой главе обсуждается как генерить позитивные и 
негативные поверхности на выделенных слоях поверхностей 
и на трассированных сигнальных слоях.
Рассматриваются темы:
- Что такое Поверхность
- Негативный против Позитивного
- Контуры Поверхностей
- Обработка Поверхностей
- Удаление Данных Поверхности
- Проверка Данных Поверхности
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Что такое Поверхность (Plane)

Поверхности это заполнения металлом, обычно 
связанные с цепью питания или земли. Слой платы 
может быть выделенным "слоем поверхности" 
ассоциированным с одной или несколькими цепями (split 
plane - разделение поверхности) или это может быть 
растрассированный сигнальный слой содержащий 
области поверхности. Может существовать несколько 
поверхностей, назначенных в несколько различных 
цепей в одной топологии.
Сквозные площадки и переходы которые 
ассоциированны с одной и той же цепью как и 
поверхность, автоматически связываются с 
поверхностью. Площадки и переходы которые не 
ассоциированны с одной и той же цепью как и 
поверхность, автоматически обеспечиваются зазорами с 
поверхностью.
Поверхности должны быть обработанны после полного 
размещения и трассировки. Если произошли изменения 
в размещении и\или трассировке, такие как внедрение 
Engineering Change Order, поверхности нужно 
переработать чтобы позволить местоположения новых 
пин и трасс и связей. 

Откройте вашу 2001 топологию, если она уже не 
открыта.

Выберите Setup>Setup Parameters из меню и кликните 
вкладку Planes. Выберите Layer 3 и проверьте что цепь 
GND назначенна в него. Выберите Layer 4 и проверьте 
что цепи VCC, VDD и VEE назначенны в него. Добавьте  
цепи VDD и VEE в Layer 4 если уже не назначенно и 
установите Clearance в 12. Закройте диалог Setup 
Parameters когда сделаете это.
Чтобы видеть что вы делаете, выключите некоторые 
графические объекты используя диалог Display Control.
- Во вкладке Parts выключите обе опции Top и Bottom.
- Во вкладке General выключите Route Obstructs и Origin 
- NC Drill.
- Во вкладке Place & Route включите Plane Data и Fill 
Plane Shapes (группа Options). Выберите Lyr 4 и затем 
выключите обе Pads и Traces для всех других слоев (но 
оставьте включенными главные опции Pads и Traces).
Сохраните только локально схему Displaу Control 
назвав ее layer 4.

1



N-3 
 E XPEDITION PCB INTRODUCTION  WG2000 

 

 
 

 

 

 

Негативный против Позитивного
Данные поверхности можно создать в двух 
разновидностях - негативный и позитивный. Конкретный 
слой поверхности будет содержать или негативные 
данные поверхности или позитивные данные 
поверхности... не обе. 

Негативные поверхности обрабатываются так что 
изображение фотоплотера это изображение не меди. 
Тогда для изготовления платы используется негативное 
изображение слоя.
Графика негативной поверхности 
для не присоединенных площадок 
показывает кольцо зазора вокруг 
площадок которые не 
контактируют с поверхностью. 
Графика для тепловых контактов 
показывает пустоту меди между 
спицами соединий. 

Негативные поверхности

Позитивные поверхности обрабатываются так что 
изображение фотоплотера показывает действительные 
области меди поверхности. Позитивные поверхности 
нужно использовать когда заполняете медь вокруг трасс 
и площадок или когда необходима штриховка.
Графика позитивной поверхности 
прорисованна используя контур 
вокруг области зазора 
окружающего площадку, затем 
поверхность заполнена. Графика 
для тепловых контактов обычно 
содержит спицы соединений от 
площадки к заполненной области. 

Позитивные поверхности

Контуры Поверхностей
Plane Shape это "удерживающая внутри" область 
использованная при обработке данных поверхности и 
должна быть назначенна в определенную цепь. Route 
Border  можно использовать как контур поверхности 
чтобы содержать данные поверхности одной цепи на 
данном слое. Если нужно более чем одна цепь 
поверхности на конкретном слое или Route Border не 
использована как контур поверхности, тогда нужно 
создать необходимые контуры поверхности и каждой 
назначить цепь.
Контуры поверхности это рисованный объект, поэтому 
должен использоваться Режим Draw для создания и 
манипулирования контурами.

Выберите Edit>Place>Plane Shape из меню (или 
Route>Planes>Place Shape). Это переведет режим

в Draw и в диалоге Properties будет готов Type как 
Plane Shape. Если диалог Properties не появился, 
кликните кнопку Properties на панели Draw.

2
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Диалог Properties в Режиме Draw позволяет назначить 
несколько установок в конкретный контур поверхности. 

Свойства контура поверхности

Контур поверхности должен быть назначен в 
физический Layer.

Layer (Слой)

Контуру поверхности должена быть назначена Net из 
цепей содержащихся в базе данных. Когда цепь 
выбрана из списка, любые видимые площадки 
присоединенные к этой цепи будут "выбранны цепью" 
(временно выделенны) в графике.
Цепь Shield Area (вверху списка) использована когда 
нужена заполненная поверхность но не связанная с 
какими-либо площадками.

Net (Цепь)

Контур поверхности можно заполнить менее чем 
100%, используя особенные шаблоны "штриховки", 
такие как 45 или 90 перекрестные линии. Контуру 
поверхности можно назначить Hatch Type (шаблон), 
Hatch Width (ширина линии) и Hatch Distance 
(растояние между центрами линий). Опция Default 
шаблон использует установки шаблона из Plane 
Processor (обсуждается позднее).

Hatch (Штриховка)

Контур поверхности может дополнительно 
действовать как Route Obstruct (установлено по 
умолчанию). Когда создаете контуры поверхности 
вокруг трасс и переходов, выключите опцию Route 
Obstruct - в противном случае будут запрещены 
каналы трассировки внутри контура.

Route Obstruct (Препятствие трассировки)

Должна быть нажата кнопка Snap Grid на 
панели Draw указывая что включено "движение 

по сетке". Проверьте также что сетка стоит 25.
Во вкладке Nets диалога Display Control, включите опцию 
Color by net. В списке Net Names, включите цепи VCC, 
VDD и VEE. Назначьте уникальный цвет в каждую из трех 
цепей.
Поле Layer диалога Properties должно быть установлено 
в 4P (активный слой). В поле Net диалога Properties 
выберите VDD из выпадающего списка. Увеличение 
вокруг выделенных площадок. Нарисуйте многоугольник 
вокруг выделенных площадок VDD избегая площадки 
VCC и VEE (это может быть не удобно - у вас буде шанс 
изменить контур в следующем пункте лабораторной). 
Помните, чтобы автоматически закончить последний 
сегмент многоугольника, правый-клик и выберите Close 
Polygon из всплывающего меню.
Кликните кнопку Add Polygon на панели Draw чтобы 
вновь инициализировать команду для того чтобы 
нарисовать второй контур поверхности. 
В диалоге Properties измените поле Net в VEE и 
повторите процесс рисования для этой цепи, 
избегая площадки VCC и VDD.
Замечание: VCC будет использовать Route Border 
как контур поверхности на этом слое.

3
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Для изменения самого контура поверхности можно 
использовать любые команды Режима Draw для сдвига 
вершин, добавления вершин или удаления вершин.
Замечание: Если два контура поверхности 
перекрываются, будут поддерживаться соответствующие 
зазоры из Setup Parameters делая вырезы в большем из 
двух контуров. При включенной опции Fill Plane Shapes в 
Display Control, графика будет моделировать на что будут 
похожи конечные обработанные поверхности.
Чтобы изменить свойства контура поверхности, такие как 
назначение другой цепи в контур, выберите контур и 
затем сделайте необходимые изменения в диалоге 
Properties. 

Изменение Контура Поверхности Важно! Кликните в пустоте для отмены выбора 
каких-либо контуров поверхности перед 

выискиванием диалога Properties.
Если нужно изменить контур поверхности, выберите его и 
затем клик-тянуть любую его метку конечной точки или 
средней точки. 
Совет: Чтобы добавить вершину в многоугольник, 
<Ctrl><клик-тянуть> метку средней точки. Для удаления 
вершины, выберите нужную вершину, затем кликните 
кнопку Delete End Point Handle на панели Draw (или 
наоборот).
Теперь выберите один из контуров поверхности и 
проверьте правильная ли цепь назначенна в него, через 
диалог Properties. Если неправильные площадки 
выделены с выбранным контуром, просто измените цепь 
назначенную в него. Выберите другой контур поверхности 
и убедитесь что все правильно.
В заключении, в 
ожидании следующего 
движения инженера, вы 
можете захотеть 
растянуть эти контуры 
поверхности чтобы 
окружить дискретные 
Analog детали (как 
показано). Включите 
видимость Pads для 
слоя 6 чтобы видеть их. 

4
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Контур поверхности можно нарисовать на сигнальном 
слое до и после трассировки. Конечно обработка этих 
поверхностей должна быть сделана после того как вся 
трассировка закончена.
Замечание: По умолчанию, контуры поверхности 
установлены действовать как препятствия трассировки, 
это в дальнейшем ограничивает редактирование трасс и 
переходов внутри контура. 

Контура Поверхности и Трассы

Инженер хочет теперь защитный экран GND вокруг 
схемы Analog на нижней стороне топологии. 

В Display Control вкладка Place & Route включите главную 
опцию Pads. Выберите Lyr 6  и затем выключите Pads и 
Traces для слоев 3 и 4.
Используйте команду Find для увеличения вокруг 
детали U13. Когда будете там, уменьшите масштаб 
немного чтобы видеть всю схему Analog.
Выберите Edit>Place>Plane Shape из меню.
В диалоге Properties в Режиме Draw проверьте что поле 
Layer установлено в 6 и Net это GND. Пролистайте вниз и  
выключите опцию Route Obstruct.
Нарисуйте многоугольник вокруг U13 (даже если он 
размещенна сверху) и других 12 дискретных 
компонентов. Если необходимо редактируйте 
многоугольник.

5

Обработка Поверхностей

Обработка поверхностей означает генерацию "данных 
поверхности" основываясь на определении поверхности 
в Setup Parameters и любых существующих контурах 
поверхностей внутри топологии. Когда обрабатываете 
позитивные поверхности, контуры поверхностей 
заполняются графикой. Когда обрабатываете негативные 
поверхности, будет создана графика для зазоров. 

Установка Параметров
Как обсуждалось ранее, во вкладке Planes внутри 
диалога Setup Parameters задаются Type поверхности 
(позитивный или негативный), цепь поверхности, 
зазоры между поверхностями и опция Route Border. 
Классы Цепей и Зазоры
Внутри диалога Net Classes and Clearances также 
принимается во внимание Clearance rules for Net 
Classes для поверхности. Данные позитивной 
поверхности считаются "трассами" поэтому 
используются зазоры Trace-Trace, Trace-Pad и Trace-
Via. Данные негативных поверхностей используют 
только зазоры Trace-Trace, т.к определение padstack 
использовано для зазоров для площадок и 
переходов. 
Padstacks
В padstack можно встроить "зазор" поверхности и 
"тепловые зазоры". Если эта информация не 
встроенна в padstack, будут использованы установки 
по умолчанию Plane Processor. 

Выберите Route>Plane>Processor из меню (или 
кликните кнопку панели) для вызова диалога 

Planes Processor.
6
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Plane Processor генерирует "данные поверхности". 
Обработчик Поверхностей

Список Plane Layers отображает любой слой, который 
или был определен как слой поверхности в Setup 
Parameters или имеет контур поверхности на этом слое.
Отметка рядом с каждым слоем использована для 
переключения обрабатывать или не обрабатывать этот 
слой в текущей сессии Plane Processor. 

Слои Поверхности

В диалоге  Plane Processor проверьте что 
включенны для обработки 3 Negative, 4 Positive 

(отличаясь от показанной  картинки), и 6 Positive в списке 
Plane Layers.

7

Выбор слоя в списке Plane Layers (не отметка обработки) 
дает доступ к каждой цепи внутри этого слоя из списка 
Nets for Selected Layer. Каждая цепь также имеет 
собственную отметку обработки.
Каждая цепь имеет собственные установки Option for 
selected plane net в нижней половине диалога Planes 
Processor.

Цепи Для Выбранного Слоя

Кликните на 3 Negative, и заметьте что только 
GND назначена в этот слой и включена для 

обработки. Остаток диалога теперь принадлежит только 
этой цепи.

8
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Когда обрабатываете только данные негативной 
поверхности, доступна опция  Negative clearance pads for 
layer. Опция Anti-Pad не добавляет площадку на этот 
слой в то время как Donut создает площадку, даже хотя 
площадка не связанна с поверхностью. 

Площадки негативного зазора

Поскольку здесь Route Border будет использовано 
как Plane Shape и на 50th меньше чем Board Outline 

(смотрите главу "Определение Геометрии Платы"), для 
уверенности задайте 75 для Negative plane fill distance 
beyond route border.

9

Когда обрабатываете только данные негативной 
поверхности, доступна опция  Negative plane fill distance 
beyond route border. Данные негативной поверхности это 
в действительности зазоры или графика "не-металл", 
поэтому графику нужно размещать вне Route Border для 
предотвращения металла рядом с краем платы при 
изготовлении.

Расстояние заполнения негативной поверхности

Набор определений в секции Option for selected plane net 
диалога уникален для каждой цепи на каждом слое. 

Опции для выбранной цепи поверхности

Если площадки тепловых зазоров и зазоров заданы 
в padstack, тогда обе обработки и позитивных и 
негативных поверхностей будут использовать эти 
площадки (или по крайней мере их спецификации) 
по умолчанию. Если не заданны в padstack, тогда 
предпочтение установкам Default via connection и 
Default non-via из Planes Processor.
Опция Use thermal definition from padstack 
доступна только для позитивных поверхностей. 
Позитивные поверхности имеют опцию не 
использовать тепловые зазоры из определения 
padstack, даже если они существуют. 

Определение тепловых зазоров

Опция Use route border for plane shape переносит 
установки заданные в Setup Parameters для 
использования Route Border как контур 
поверхности. Это можно изменить здесь.
Предупреждение! Только одна цепь на слой может 
использовать Route Border для этих целей. 
Включение этой опции будет автоматически 
выключать ее для других цепей на этом же слое. 

Использование Route Border
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Зазор Contour использован для освобождения 
данных поверхности от всех контуров (вырезы 
платы) на определенное растояние.
Растояние зазора Other object можно 
дополнительно использовать между объектами 
похожими на площадки/трассы и данные 
поверхности.  Будут использованы наибольшие 
зазоры из Other object и Net Class Trace-Pad.
Растояние зазора Plane "только-для-чтения" и 
приходит из зазоров поверхности в Setup 
Parameters. Будут использованы наибольшие 
зазоры из Plane и Net Class Trace-Trace.
Замечание: Если двум областям поверхностей 
назначенна одинаковая цепь, можно установить 
зазор поверхности "0" для этой цепи в Setup 
Parameters, чтобы позволить двум поверхностям, 
имеющим различные установки обработки, 
возможность соприкасаться.

Зазоры по умолчанию
Опция Discard plane area позволяет исключить из 
обработанной поверхности All untied areas(все 
не связанные области) поверхности (островки 
поверхности) или Any areas less then(любые 
области меньше чем) определенного размера.
Если использована опция All untied areas, из 
обработанной поверхности можно также 
исключить Areas tied to single pad(области 
связанные с одной площадкой).

Отбрасывать область поверхности

В секции Discard plane area options, выключите 
опцию All untied areas. Оставьте остальные 

установки по умолчанию. Должны быть включены опции 
Anti-Pad и Use route border for plane shape. Не кликайте 
кнопку OK пока!

10
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Как говорит кнопка, Hatch options for positive planes 
доступны только для данных позитивной 
поверхности. Каждая цепь на данном слое будет 
иметь свои Hatch Options.

Опции штриховки

В диалоге Hatch Options выберите один из Patterns, 
задайте Width линии и задайте Distance центр-центр 
или Metal percentage.
По умолчанию Width основана на Typical ширине 
трассы установленной для default Net Class. По 
умолчанию Distance равна Width, делая 100% 
металла или "сплошную" поверхность. 

Позитивная повехность прямо не использует опции 
Negative clearance pads for layer или Negative fill 
distance beyond route border потому что данные 
поверхности созданны как графика "что вижу на 
экране то получу  при печати".

Остатки Обработки Поверхности

В списке Plane Layers выберите 4 Positive и 
заметьте что все три цепи включены для обработки

(если нет, включите их).
Кликните на каждую цепь в списке Nets For Selected Layer 
и заметьте что каждая из них имеет свои установки. 
Проверьте что только цепь VCC имеет включенную 
опцию Use route border for plane shape (VDD и VEE имеют 
свои контура). Также в секции Discard plane area options 
включите опцию All untied areas для каждой из трех 
цепей.
В списке Plane Layers выберите 6 Positive и сделайте 
любые нужные вам установки.
Переповерьте ваше работу выбирая каждый Plane Layer 
и каждый Nets For Selected Layer, проверьте установки 
диалога.

11
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Нажатие на кнопку OK в диалоге Planes Processor 
сохраняет установки диалога и генерит данные 
поверхности.

Обработка Поверхностей

Кликните кнопку OK в диалоге Planes Processor. 
Откройте File Viewer и проверьте протокол

PlaneProcessor.txt на наличие проблем. Закройте File 
Viewer.
Если Planes Processor не удачен, перерисуйте и 
переназначте контуры поверхности и запустите Planes 
Processor снова. Проверьте протокол он должен быть 
чистым.

12

Всегда проверяйте протокол после обработки данных 
поверхности. Некоторые общие проблемы:
Проблема: Цепь поверхности назначена в Setup 
Parameters, еще нет контура поверхности в топологии 
на определенном слое. Planes Processor не удачен.
Решение: Нарисовать контур поверхности 
основываясь на цепи и слое заданном в Setup 
Parameters -или- удалить цепь с этого слоя в Setup 
Parameters. Перезапустить Planes Processor.
Проблема: Контур поверхности не покрывает все 
площадки этой цепи.
Решение: Измените контур чтобы пократь все 
площадки для цепи и перезапустите Planes Processor -
или- руками трассируйте не связанные площадки на 
различном слое.

Общие проблемы

Кликните кнопку Fit Board. Панорамируйте и 
масштабируйте для изучения вашей новой графики

поверхности на слое 4. В Display Control выключите Fill 
Plane Shapes, если хотите видеть не обстрактный вид 
действительных данных поверхности.
Даже если вам не нравятся некоторые результаты, 
подождите до следующено пункта лабораторной.
В диалоге Display Control выберите Lyr 3 и затем 
выключите Traces и Pads для Lyr 4. Наверху вкладки 
Place & Route выключите главные опции Pads (данные 
негативной поверхности имеют свои площадки). Изучите 
графику негативной поверхности.
Сохраните локально только схему Display Control назвав 
layers 3.
Установите  изображение для слоя 6 похожим способом ( 
включите главную опцию Pads) и изучите графику этой 
поверхности. Сохраните  схему layer 6.

13
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Нет необходимости сначала удалять данные 
проверхности и пере-обрабатывать, когда изменяете 
контуры поверхности или когда делаете изменения в 
компонентах и трассировке. Запуск Planes Processor 
автоматически удаляет существующие данные 
поверхности для выбранных слоев/цепей, которые 
обрабатываются.
Предупреждение! Когда изменяете статус слоев 
поверхности (позитывный/негативный), до пере-запуска 
Planes Processor нужно сначала удалить данные 
поверхности.
Если нужно удалить данные поверхности, выберите из 
меню Route>Planes>Delete Plane Data. Используйте 
диалог Delete Plane Data чтобы Delete Plane Data by 
layer(удалить данные поверхности для слоя) (и для цепи 
для позитивной поверхности) или Delete all plane 
data(удалить все данные поверхности).

Если вы не удовлетворены данными поверхности, 
например контур поверхности блокирует связи,

исправте проблемы. Чтобы легче видеть контуры 
поверхности для редактирования, выключите Plane Data 
в Display Control вкладка Layer. Не забудьте включить их 
позднее.
Установки диалога Planes Processor остались прежними. 
Сделайте какие-либо изменения установок и снова 
запустите Planes Processor. Не изменненные слои можно 
отключить для ускорения обработки. Не забудьте 
проверить протокол.
Используйте вашу схему Display Control для анализа 
поверхности. 

14
Удаление Данных Поверхности
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После обработки поверхности, нужно проверить 
топологию с помощью Batch DRC. Некоторые общие 
проблемы:
Проблема: Не связанные цепи поверхности. Контур 
поверхности не покрывает все пины присоединенные к 
этой цепи.
Решение: Измените контур поверхности чтобы покрыть 
все нужные пины -или- в ручную трассируйте к пину на 
другом слое.
Проблема: Островки поверхности.
Решение: Если Planes Processor не был установлен для 
исключения All untied areas(всех не соединенных 
областей) для любых цепей поверхности, однако Batch 
DRC был установлен проверять островки поверхности, 
измените установки Planes Processor -или- выключите 
проверку Batch DRC.

Сначала кликните кнопку панели Save.
Кликните кнопку панели Batch DRC.

В диалоге Batch DRC, включите опцию Plane clearances 
and rules. Также выберите все слои в списке Layers.
Кликните на вкладку Connectivity and Special Rules и 
включите опции 2 Planes.
В диалоге Batch DRC кликните кнопку OK для проверки 
топологии.
Кликните кнопку панели Review Hazards. В диалоге 
Review Hazards выберите Batch>Plane Violations из 
меню. Теперь нет проблем? На всякий случай проверьте 
некоторые другие "пакетные" риски. 

15

Проверка Данных Поверхности
Сделайте резервную копию проекта выбрав из меню 
File>Save Copy.

В диалоге Job Managemet Wizard Copy, кликните в поле 
New project fi lename и наберите 
c:\mgtraining\project\2001planes\2001.prj (вы можете 
скопировать из поля Source project filename и сделать 
необходимые изменения). Сразу кликните в поле New 
PCB design filename и затем кликните кнопку Finish.
Закройте диалог Summary и покиньте Expedition PCB. 

16



 
 

EXPEDITION PCB INTRODUCTION O-1 

O Отработка Silkscreen
В этой главе обсуждается перенумерация/перемещение 
условных обозначений и добавление перечня шелкографии 
для подготовки к фотопечати.
Рассматриваются темы:
- Что такое Silkcreen?
- Перенумерация Условных Обозначений
- Передвижение Условных Обозначений
- Добавление Перечня
- Генерация графики шелкографии
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Что такое Silkscreen?

Конечный пункт в изготовлении печатной платы это 
нанесение графики "шелкографии" сборки на одну или 
несколько сторон платы. Графика шелкографии обычно 
показывает контур компонента, условные обозначения 
компонента, сборочный номер детали платы, и 
смешанную графику, такую как логотип компании.
Когда генерите графику шелкографии в течении 
топологического процесса, нужно перенумеровать 
условные обозначения и передвинуть в читаемое место 
и нужно добавить смешанную графику и перечень. Эта 
информация шелкографии затем будет переработана в 
данные Гербер для изготовления платы

Откройте вашу 2001 топологию, если она уже не 
открыта, создайте следующую схему Display Control

Во вкладке General в Display Control:
- Выключите Route Border (Board Outline и Mounting 
Holes еще должны быть включены).
- Включите группу Fabrication Layers и затем выключите 
каждую индивидуальную опцию за исключением 
Soldermask-Top.
Во вкладке Part в Display Control:
- Включите главные опции Top и Bottom.
- Должны быть включены только группы Part Items и 
Silkscreen Items.
- В группе Part Items должно быть включено только 
Placement Outlines (обе Top и Bottom).
- В группе Silkscreen Items должно быть включено только 
Oulines и Ref Des (обе Top и Bottom).
- Теперь выключите главную опцию Bottom.
Во вкладке Layer в Display Control: 
- Выключите главные опции Traces и Pads.
Должны быть видимы только контуры шелкографии и 
условные обозначения для верхней стороны платы 
вместе с контурами размещения, площадками soldermask 
и контуром платы. Сохраните схему только локально как 
silk edit top. Сделайте похожую схему для низа назвав 
silk edit bottom, делая следующее...
Во вкладке Part в Display Control:
- Включите главную опцию Bottom и выключите главную 
опцию Top.
Во вкладке General в Display Control:
Включите опцию Soldermask-Bottom (группа Fabrication 
Layers) и выключите опцию Soldermask-Top.

1
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Перенумерация Условных Обозначений

Последовательная перенумерация условных 
обозначений компонентов делает более легким 
нахождение конкретного компонента на собранной 
плате. Не изменяется местоположение компонентов, 
изменяются только из условные обозначения (например: 
U9 может измениться в U1).  

Фильтр стороны 
топологии и 

определенных 
компонентов для 
перенумерации.

Список "было есть" 
Условных Обозначений.

Выберите ECO>Renumber Ref Des из меню для 
вызова диалога Renumber Reference Designator.

Кликните вкладки Top и Bottom (на правой стороне 
диалога Renumber Reference Designator) чтобы быстро 
взглянуть на обе стороны вышей топологии.

2

Предупреждение! Эта опреация требует Обратной 
Аннотации которая воздействует на назначения 
условных обозначений в оригинальной схеме.  

Графический вид 
топологии.
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Можно отфильтровать определенные компоненты для 
перенумерации.

Фильтр

В диалоге Renumber Reference Designators, в секции 
Filter, выберите Side Top. Вы собираетесь пере-

нумеровать одну сторону топологии в единицу времени.
3

Сторона
Можно установить определенную Side(сторону) 
топологии для перенумерации 
- Top или Bottom (или Both(обе))

Окно выбора
При включенной опции Use selection window, можно 
определить окно выбора внутри вида графики вокруг 
нужных компонентов для перенумерования.

Включить в список
В процесс перенумерования можно включить Test 
Points, Spares и Jumpers.

Префиксы
Можно задать один или более префиксов условных 
обозначений для фильтрайии нужных компонентов. 
Эти префиксы могут быть частью списка Include или 
Exclude. Звездочка (*) редставляет все префиксы 
условных обозначений.
Замечание: Наберите нужные префиксы, такие как R 
или R C, и нажмите клавишу <Enter> для активизации 
фильтра. 

Правая сторона диалога Renumber Reference 
Designators содержит графический вид топологии. 
Каждый префик имеет цветовой код для легкой 
визуализации.
Текст условного обозначения отображается в графике 
где возможно. Некоторые компоненты слишком малы 
чтобы ясно отображать условное обозначение, поэтому 
когда позиция курсора на этом компоненте, условное 
обозначение временно всплывает.

Графический вид

Вкладки Top и Bottom позволяет видеть и ту и 
другую сторону топологии (вкладка Bottom стала 
недоступной т.к фильтр Side был установлен в Top 
только).

Верх/Низ

Направление для перенумерации отфильтрованных 
условных обозначений устанавливается выбором 
одной из восьми кнопок стрелок окружающих 
графический вид.

Слева Направо, Сверху Вниз
Справа Налево, Сверху Вниз
Сверху Вниз, Справа Налево
Снизу Вверх, Справа Налево
Справа Налево, Снизу Вверх
Слева Направо, Снизу Вверх
Снизу Вверх, Слева Направо
Сверху Вниз, Слева Направо

Направление
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Белые вертикальные или горизонтальные линии (в 
зависимости от выбранного Direction(направления)) в 
графическом виде, разделяют топологию на "полосы 
перенумерации". Компоненты внутри конкретной 
полосы будут перенумерованы последовательно 
перед тем как процесс перенумерации передвинется 
в следующую полосу. Поле Renumber band width 
использован, чтобы определить подходящую ширину 
полосы.

Ширина полосы перенумерации

В поле Renumber band width внизу диалога, 
задайте 750 и нажмите клавишу <Enter>. (Эти 

установки основанны на размещени использованном 
ранее в этом курсе. Если размещение сильно отличается, 
попробуйте сначала это значение и затем поменяйте 
если необходимо).
Внутри графического вида, вручную потяните линии 
ширины полосы, если нужно, чтобы оптимизировать 
какие компоненты попадают в какую полосу.

4

Если нужно чтобы ширины полос различались, можно 
индивидуально потянуть линии разделения в 
требуемую позицию.
Замечание: Какой компонент попал в какую полосу 
определяется по тому куда попала большая часть 
компонента. Для проверки какие компоненты попали 
в данную полосу, двиньте курсор мыши в полосу и 
компоненты внутри этой полосы будут временно 
выделены.

Process list это "Было есть" список для текущей сессии 
Renumber Reference Designator - Old Ref Des и New Ref 
Des.
Иконка рядом с каждым Old Ref Des отмечает на какой 
стороне этот компонент. Выбор условного обозначения в 
списке временно выделяет компонент в графическом 
виде.

Список обработки

Условное Обозначение в колонке New Ref Des можно 
модифицировать вручную по одному. Графический 
вид будет содержать Old Ref Des номер до тех пор 
пока не применят изменения.

Ручная перенумерация

Основываясь на 
фильтрах и направлении, 
условные обозначения 
можно автоматически 
перенумеровать.

Авто-перенумерация

По умолчанию Starting 
number равен 1, но 
можно задать любой 
номер чтобы начать
последовательность нумерации для текущих 
фильтрованных компонентов (пример: U100).

Стартовый номер
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Если здесь задан Prefix, все префиксы условных 
обозначений для компонентов в текущем фильтре 
будут подменены новым префиксом (например: U9 и 
U10 могут изменится в IC1 и IC2).
Предупреждение! Когда подменяете префикс, 
убедитесь и установите фильтр Prefixes в 
определенный префикс. В противном случае процесс 
Auto Renumber сделает все префиксы одинаковыми.
Добавочно может быть добавлен Suffix к условным 
обозначениям в текущем фильтре (например: U9 и U10 
можно легко изменить в U1A и U2A).

Префиксы/Суффиксы

Кликните кнопку Auto Renumber. В диалоге 
Renumber, проверьте что Start number равен 1 и не

заданы Prefix и Suffix. Кликните кнопку OK.
Проверьте графический вид справа, на предмет новых 
условных обозначений.
Проверьте Process list. Какие-либо проблемы? Двойники 
могут быть удалены когда вы переномеруете низ 
топологии.

5

Предупреждение! Когда вручную редактируете 
условные обозначения или когда используете Auto 
Renumber с доступной только одной стороной 
топологии (используя фильтр Side), возможно 
закончить с повторяемыми условными обозначениями. 
Expedition PCB не позволит вам оставить двойники, 
поэтому они должны быть убраны для того чтобы 
сохранить результаты сессии перенумерации.

Теперь перенумеруйте компоненты на нижней 
стороне делая следующее:

Установите Filter-Side в Bottom.
Установите Direction: Right to Left, Top to Bottom (т.к 
топология зеркально отображена в графическом виде).
Задайте 300 в поле Renumber band width и нажмите 
клавишу <Enter> (снова, попробуйте этот номер сначала 
и затем измените если нужно). Если нужно, вручную 
настройте линии ширины полос так что емкости и 
сопротивления попали точно в ряды для перенумерации.
Т.к здесь есть повторяемые условные обозначения, вам 
нужно обработать емкости и сопротивления отдельно 
друг от друга. Задайте C в поле Prefixes и затем нажмите 
клавишу <Enter> для применения фильтра только для 
емкостей.
Кликните кнопку Auto Renumber. В диалоге Renumber, 
задайте Starting number 3 (C1 и C2 уже использованы). 
Кликните кнопку OK.
Повторите процесс для префикса R и на этот раз задайте 
Starting number 2 (R1 уже использован).
Установите Filter-Side в Both. Задайте *  (звездочка) в 
поле Prefixes и нажмите клавишу <Enter>. Все 
компоненты на обейх сторонах должны быть доступны. 
Кликните на вкладках Top и Bottom графического вида 
чтобы проверить работу перенумерации.
Если вы удовлетворены, кликните кнопку OK в диалоге 
Renumber Reference Designator чтобы действительно 
обновить топологию.
Проверьте вашу топологию и затем сохраните ее.

6



Выберите одно условное обозначение, которое 
хотите передвинуть. Расположите курсор поверх

рамки границы выбранного текста, указующий курсор 
изменяется в курсор "перемещения". На этой точке 
<кликните-потяните>  текст туда где вы хотите. (Конечно, 
расположите условное обозначение рядом с деталью но 
вне Silkscreen Outline и вдали от площадок). Держите в 
голове следующее:
- Можно сразу передвинуть и/или повернуть несколько 
условных обозначений, сначала выбрав их (используя 
область выбора или <Ctrl<клик>).
- Установите меньше сетку перемещения, чтобы иметь 
больше контроль местоположения условных 
обозначений. Клавиши стрелок клавиатуры можно 
использовать для передвижения выбранного объекта на 
одну точку сетки за раз.
Потратьте некоторое время на передвижение и поворота 
каких-либо условных обозначений от площадок 
soldermask, улучшая топологию. Будьте осторожны не 
измените что-нибудь. еще - например Silkscreen Outlines.
Выберите схему silk edit bottom и улучшите условные 
обозначения снизу тоже.
Сохраните вашу топологию.

8
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Т.к текст это "рисованный" элемент, для манипуляции 
текстом условных обозначений нужен Режим Draw. В 
Режиме Draw, отображаются Properties выбранного 
текста, позволяя изменить фонт, размер, угол 
поворота, и т.д. (Для изменения префикса для 
перенумерации условных обозначений используется 
только команда Renumber Reference Designator).

Свойства текста

Выберите Display Control схему silk edit top.
Кликните кнопку панели Draw Mode.

Выберите какой-либо текст условного обозначения, 
которым хотите манипулировать. Выбранный текст 
должен иметь рамку границы вокруг него и в диалоге 
Режима Draw Properties его Type будет Text.
В диалоге Properties, если хотите, сделайте изменения 
угла поворота или размера.
Повторите для какого-либо другого текста условного 
обозначения. Не беспокойтесь о передвижении текста 
пока... это следующий пункт лабораторной.

7

Передвижение Условных Обозначений
При подготовке фотошаблона шелкографии, нужно 
передвинуть текст условных обозначений от площадок, 
изменить размер и повернуть если необходимо.

Замечание: Можно манипулировать несколькими 
элементами текста одновременно, сначала выбрав их 
используя область выбора или используя <Ctrl><клик>.

Выбранный текст можно переместить 1) перетягивая 
текст в новое место или 2) задавая новые Location X 
и Location Y в диалоге Properties.
Placement Outline компонента временно выделена 
когда его условное обозначение выбрано. Когда 
работаете в насыщенной топологии, включите 
графику Placement Outline чтобы отслеживать что 
условное обозначение относится к этому компоненту.

Перемещение текста
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Некоторые условные обозначение существуют на 
обеих сторонах топологии - такие как краевой разъем.
Они встроены в ячейку. Любой текст условного 
обозначения можно удалить без воздействия на 
целостность базы данных.
Замечание: Если сделаны нежелательные 
изменения с ячейкой в топологии, ячейку можно 
восстановить из локальной библиотеки командой 
Replace Cell .

Удаление текста Добавление перечня и графики
Иногда необходимо добавить свободный текст для 
шелкографии сборочных номеров платы.

Выберите схему silk edit top в Display Control.
Кликните кнопку панели Draw Mode. Если не

появился диалог Properties Режима Draw, кликните 
кнопку снова.
Кликните кнопку Add Text на панели Draw.
В диалоге Properties выберите  Silkscreen Top из 
выпадающего списка Layer. Также задайте следующие 
параметры текста:

Height: 75
Rotation: 0
Pen width: 0
String: PWA2001

Убедитесь что кнопка Mirror не нажата. Рекомендуется 
также использовать Гербер фонты.
Строка текста должна присоединится к курсору. 
Разместите его где-нибудь где есть место.

9
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Генерация графики шелкографии

Когда собираете законченную плату, краска 
шелкографии на площадках компонентов будет портить 
процесс пайки.

Выберите Output>Silkscreen Generator из меню.
Внизу диалога Silkscreen Generator выберите

следующие слои для извлечения информации для Top 
side silkscreen for selected cell types:

Silkscreen Reference Designators Top
Silkscreen Outlines Top

Также выберите следующие слои для Bottom Side 
silkscreen for selected cell types.

Silkscreen Reference Designators Bottom
Silkscreen Outlines Bottom

10

Генератор Шелкографии
Можно использовать Silkscreen Generator чтобы 
разрывать графику шелкографии прочь от площадок.

Слои проекта
Извлекается информация из выбранных слоев, 
таких как Reference Designators, Silkscreen 
Outlines и любых слоев заданных пользователем. 
Эта извлеченная информация будет затем 
помещена на отдельный слой Silkscreen как 
глухая графика, точно обрезанная от любых 
площадок и готовая для фото-печати.
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Разрыв графики и текста
Чтобы убрать шелкографию с площадок, должны 
быть заданы объекты и зазоры.

Сторона топологии
Silkscreen side to process(сторона шелкографии 
для обработки) можно установить в Top, Bottom 
или Both.
Площадки
Опцию Break silkscreen using(разорвать 
шелкографию используя) можно установить в 
Conductive Pads или Soldermask Pads для 
разрыва шелкографии.

Зазоры
Чтобы Break graphics(разорвать графику) и 
Break Text(разорвать текст) от площадок 
компонентов и переходов, должны быть заданы 
для каждой Pad clearance и Via clearance. Зазор 
или от контактной площадки или паяльной 
площадки до шелкографии. Зазор 0 (нулевой) 
определяет разрыв шелкографии на крае 
площадки.

Ширины линий
Нужно задать Width option(опция ширины) для 
Graphic lines(графических линий). Сгенеренная 
графика шелкографии будет создана используя 
эти ширины линий которые  будут в итоге 
шириной фото-плотера.

Закончите заполнять диалог Silkscreen Generator  
используя следующие установки:

Silkscreen side to process: Both
Breaking silkscreen using: Soldermask Pads
Process: All Package Groups
Включите опции Pad clearance и Via clearance для обеих 
Break graphics и Break text. Проверьте что размер зазора 
0 для этих опций.
Установите обе Widht options в 8.
Кликните кнопку OK в диалоге Silkscrenn Generator.
Используя File Viewer проверьте протокол 
SilkscreenGenerator.txt.

11

Замечание: Нужно запускать Silkscreen Generator 
после любых изменений в оригинальных условных 
обозначениях, контурах шелкографии компонента и т.д.
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Выберите схему silk edit top в Display Control снова.
Во вкладке Parts, группа Silkscreen Items выключите

Outlines  и Ref Des и затем включите Silkscreen Layer 
чтобы видеть графику сгенеренной шелкографии. Также 
выключите Place Outlines и затем сохраните это как 
новую локальную Display Control схему назвав ее silk top.
Просмотрите вашу топологию и найдите условные 
обозначения с разрывами шелкографии. Если вы нашли 
какие-либо, исправьте проблему, сначала выбрав вашу 
Display Control схему silk edit top, передвиньте условное 
обоначение от площадки, затем пере-запустите 
Silkscreen Generator.
Повторите предыдущие шаги для нижней стороны 
топологии. 

12 Сделайте резервную копию вашей топологии 
выбрав File>Save из меню.

Сохраните в c:\mgraining\project\2001silk. 
Покиньте Expedition PCB.

13
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P Генерация Данных Гербер
В этой главе обсуждается генерация выходной информации 
Гербер и и просмотр ее в GerbTool.
Рассматриваются темы:
- Обзор Фото-печати
- Выходные Данные Фото-печати
- Анализ Данных Гербер
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Обзор Фото-печати
Теперь когда вся графика топологии сделана, 
необходимо сгенерить специальные данные печати. Для 
каждой отдельной части фотошаблона необходимых для 
изготовления печатной платы (т.е слои меди, припоя, и 
т.д) нужна индивидуальная фото-печать Гербер. Эти 
данные Гербер (совместно с данными сверления и 
документацией изготовления) используются 
изготовителем чтобы сделать физическую печатную 
плату.

Апертуры & D-Коды для макетов
Невидимо для пользователя, каждому уникальному 
графическому элементу в топологии назначена апертура 
основываясь на размере/ширине элемента. Например, 
все .008" трассы в топологии будут использовать 
определенную апертуру. Каждая апертура автоматически 
определена в течении вывода и отображена в D-Кодах 
внутри данных Гербера.
Есть два базовых режима для апертур, "засветка"(flash) и 
"рисование" (draw). Апертура засветка это когда апертура 
фотокамеры засвечивает единичный контур (например: 
.025" круглый контур для конкретной площадки 
компонента). Апертура рисования это когда апертура 
фотокамеры остается открытой и прорисовывает контур, 
который обычно круглый (например .025" круглый контур 
прорисованный для ю025" трасс). В предыдущем 
примере, одинаковая .025 круглая апертура будет 
использована для обеих засветки и рисования.  

Формат Гербер Станка
Expedition PCB выдает Гербер формат в индустриальных 
стандартах "274Х" и "274D". Каждый 274Х Гербер фото-
печать включает список всех использованных апертур (D-
Кодов). При 274D, с фото-печатью должен поставляться 
внешний список апертур.  

Откройте вашу 2001 топологию, если она уже не 
открыта. Выберите Setup>Gerber Machine Format

из меню. В списке Gerber machine format files выберите 
gerbermachinefile1.gmf. Вы будете использовать этот 
файл (и эти установки) когда записываете Гербер. 
Просмотрите установки ничего не изменяя. Кликните 
кнопку Close.

1

Замечание: Диалог Gerber Machine Format просто для 
создания и редактирования файла формата станка 
Гербер. Это не там где нужный файл выбран для 
использования.  
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Выдача Фото-печати

Данные Гербер для каждой части фотошаблона 
записаны в индивидуальные файлы печати. 
Эти Гербер файлы 
печати затем 
п о с ы л а ю т с я  
и з г о т о в и т е л ю  
печатной платы.

Выберите Output>Gerber из меню чтобы вызвать 
диалог Gerber Output.2



P-4
 E XPEDITION PCB INTRODUCTION  WG2000 

 

 
 

Файл Формата Гербер Станка
Требуемый Gerber Machine Format file 
(рассмотренный ранее) должен быть выбран для 
текущей сессии фото-печати.  

Внизу диалога Gerber Output кликните кнопку 
проводника Gerber Machine Format file и

откройте gerbermachinefile1.gmf.
3

Файл Установки Гербер Печати
Gerber Plot Setup file (.gpf) будет содержать все 
определения фото-печати - какие элементы нужны в 
каждой фото-печати и какие нужно сделать файлы 
фото-печати.
Можно использовать существующий Gerber Plot Setup 
file или создать новый.    

Вверху диалога Gerber Output кликните кнопку 
проводника Gerber Plot Setup file.  В диалоге

Gerber Plot Setup file задайте новое File name 6layer и 
кликните кнопку Open. Вам будет подсказка создать этот 
файл, поэтому кликните кнопку Yes.

4

Замечание: Любые необходимые Gerber Plot Setup 
file можно разместить в шаблон заранее для легкого 
доступа позднее.    

Параметры выходного файла
Вкладка Parameters диалога Gerber Output 
использована для создания новых Output files или 
переименования существующих.  Действительное 
содержание каждого выходного файла определяется 
в другом месте. 

Файлы для обработки
Имена заданные здесь в итоге станут 
индивидуальными файлами печати хранимыми на 
диске компьютера. 

Во вкладке Parameters кликните кнопку New 
сверху списка Files to process. Кликните на имени 

нового файла New.gdo, измените имя в layer1 и затем 
нажмите <Enter>. Расширение файла добавится 
автоматически (layer1.gdo). Он в итоге будет содержать 
площадки и трассы для слоя 1.

5

Текст Заголовка/Окончания
Вкладка Parameters использована также чтобы 
вставить Header text и Footer text (коментарии) в 
каждый выходной файл Гербер. Это опции. 

Просто в случае путаницы у изготовителя платы, в 
поле Header text ниже списка, введите copper layer

1 (top). В поле Footer text наберите имя вашей компании. 
Эти коментарии будут вставлены в файл layer1.gdo.

6
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Копирование выходного файла
Для сохранения времени, определения 
существующего выходного файла можно скопировать 
и изменить если нужно. 

При выбранном файле layer1.gdo в списке Files 
to process кликните кнопку Copy (рядом с 

кнопкой New). Измените имя в layer1_1.gdo в layer2.gdo 
и также измените Header text  в copper layer 2.
Повторите процесс до тех пор пока не будете иметь все 6 
слоев, каждый с обновленным Header text.
Кликните кнопку New или кнопку Copy  и назовите файл 
masktop. Добавьте или измените Header text в 
soldermask top. Скопируйте выходной файл в 
maskbottom и измените Header text соответственно.
Кликните кнопку New или кнопку Copy  и назовите файл 
pastetop. Добаьвте или измените Header text в 
solderpaste top. Скопируйте выходной файл в 
pastebottom и измените Header text соответственно.
Кликните кнопку New или кнопку Copy  и назовите файл 
silktop. Добавьте или измените Header text в silkscreen 
top. Скопируйте выходной файл в silkbottom и измените 
Header text соответственно.

7



Вкладка Contents в диалоге Gerber Output 
использована для описания что должен содержать 
каждый из Output files (такие как Part Pads, Traces, 
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Содержание выходного файла

Текущий Output file. Набор 
диалогов использован для 
определения содержания 

этого файла. 

Board Outline, Silkscreen, Soldermask и т.д) 

Если текущий Output file это 
слой трассы или поверхности, 

тогда нужно выбрать слой 
проводника из списка. 

Список Items(элементов) 
слоя проводника для 

выбора из него. 

Board items для фото-печати 
со слоями проводников или 

ими самими (такие как 
Soldermask или Silkscreen). 

User-defined layers для 
фото-печати со слоями 

проводников или 
элементами платы или 

ими самими. 
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Кликните на вкладку Contents, выберите 
layer1.gdo из выпадающего списка Output file

Теперь выберите элементы из остатка диалогов которые 
вы хотите включить в этот файл. (Помните <Ctrl><клик> 
когда выбираете много элементов). Выберите следующее 
содержание:
*Conductors - В выпадающем списке Layer выберите 
Signal Layer 1. Нужно выбрать все Items в списке ниже 
него за исключением Via Holes.
*Board Items - Выберите только Board Outline.
*Cells - Нужно выбрать все Types.
Теперь выберите layer2.gdo из выпадающего списка 
Output file и повторите предыдущие шаги за исключением 
выбора Signal Layer 2 из выпадающего списка Layer. 
Повторите шаги для оставшихся 6 слоев.

8

В списке Output file выберите masktop.gdo. 
Выберите следующее содержание:

*Conductors - В выпадающем списке Layer выберите 
(None).
*Board Items - Выберите Board Outline и Soldermask Top 
(убедитесь что они оба выбраны).
*Cells - Нужно выбрать все Types.
Сделайте подобное для maskbottom.gdo.

9

В списке Output file выберите pastetop.gdo. 
Выберите следующее содержание:

*Conductors - В выпадающем списке Layer выберите 
(None).
*Board Items - Выберите Board Outline и Solderpaste 
Top.
*Cells - Нужно выбрать все Types.
Сделайте подобное для pastebottom.gdo.

10

В списке Output file выберите silktop.gdo. 
Выберите следующее содержание:

*Conductors - В выпадающем списке Layer выберите 
(None).
*Board Items - Выберите Board Outline и Altered 
Silkscreen Top.
*Cells - Нужно выбрать все Types.
Сделайте подобное для silkbottom.gdo.

11

Выберите каждый из Output files снова и 
проверьте их содержание. Когда будете 

удовлетворены кликните кнопку Save в Gerber Plot Setup 
file.

12
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View Window

Zoom In

Zoom Out

View All

Redraw

Pan Window

Кликните кнопку Process Checked Output Files в 
нижнем-правом углу диалога Gerber Output. 

После того как все файлы Гербер .gdo будут извлечены, 
кликните кнопку Close.
Используя File VIewer проверьте протокол GerbPlot.txt.
Закройте File Viewer когда сделаете.

13
Генерация Гербер

Кликните кнопку панели GerbTool. Это вызывает 
GerbTool и автоматически открывает новые. 

Гербер файлы.
Вы можете получить предупреждение о дугах. Можете не 
беспокоиться об этом, просто кликните кнопку Yes.

14

Проверка данных Гербер

Выберите любую кнопку из палитры Layer (1 по 12) 
и затем кликните кнопку Redraw вверху палитры. 

Кликните кнопку View All на палитре View чтобы увидеть 
всю графику.
Включайте и выключайте различные слои Гербер какие 
пожелаете (обычно по одному). Используйте кнопки 
window/zoom/pan на палитре View для изучения графики 
Гербер в деталях.

15
Когда вы будете довольны что данные Гербер 
готовы, покиньте GerbTool. В противном случае вы 

можете сделать изменения в вашей топологии или 
редактировать определения печати и затем заново 
извлеч Гербер.
Сохраните вашу топологию и покиньте Expedition PCB.

16

Переключение 
слоев Гербер. 

Перерисовка 
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Q Генерация Данных Сверления
В этой главе обсуждается генерация данных сверления для 
изготовления платы и документации.
Рассматриваются темы:
- Обзор Отверстий Padstack
- Таблица сверления
- Выходные Файлы Данных Сверления
- Экспорт DXF  
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Обзор Отверстий Padstack

Expedition PCB использует информацию об отверстии из 
padstack для генерации данных сверления.
Properties для конкретного отверстия в 
Padstack Editor определяет Type сверления и 
размер Hole. Также Drill symbol assignment 
использовано для отображения определенного 
символа сверления на чертеже сверления.
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NC DRILL

 

Вместе с данными Гербер, нужно снабдить изготовителя 
данными сверления NC (ЧПУ). Эти данные использованы 
для сверления отверстий соответствующего размера в 
определенных местах топлогии платы. Также, данные 
трассировки профиля ЧПУ можно использовать чтобы 
вырезать прорези, сделать контуры внутри области 
платы, и трассировать платы из панели. 

Откройте вашу 2001 топологию, если она уже не 
открыта. Используя диалог Display Control

выключите все элементы графики за исключением Board 
Outline и Drill Drawing - Through. Сохраните локально 
схему Display Control назвав drill dwg.
Кликните кнопку панели Fit Board.
Теперь выберите Output>NC Drill из меню чтобы начать 
процесс генерации NC Drill.

1

Генерация NC Drill
Диалог NC drill Generation использован для 
конфигурирования вывода данных сверления.  

Файл формата станка ЧПУ сверления
Используя кнопку Browse можно присоединить NC 
drill machine format file для Дюймовых единиц 
измерения или Метрических. Этот .mm ASCII файл 
контролирует формат выходных файлов сверления.  

Опции генерации сверления
Опции Sweep axis (развертка оси) и Bandwidth 
(ширина полосы) определяют порядок сверления в 
выходных файлах сверления.
Процесс NC Drill Generation создает файлы 
протокола. Summary units внутри этих файлов можно 
отобразить в English (Дюймах) или Metric (Метрике) 
согласно единиц измерения вывода сверления. 
Можно определить Machine file extension(расширение 
файла станка) выходных файлов сверления (для 
изготовителя плат). По умолчанию это .ncd 

В диалоге NC Drill Generation через проводник 
укажите NC drill machine format file. Выберите

формат... NCDrillEnglish.mmm или NCDrillMetric.mmm 
(используйте English если нет предпочтений).
Оставьте другие установки диалога по умолчанию если 
не знаете что установить.
Не нажимайте OK пока.

2
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Таблица сверления

Drill Chart использован для документации чертежа 
сверления и списка всех сверл использованных в 
топологии. Процесс NC Drill Generation автоматически 
генерит графику таблицы сверления и размещает на 
слое Drill Drawing - Through.  

В диалоге NC Drill Generation кликните кнопку Drill 
Chart Options чтобы открыть диалог Drill Chart

Options.
3

Опции Таблицы Сверления
Диалог NC Chart Options использован для установки как 
таблица сверления покажется в графике.  

Колонки
По умолчанию в таблице сверления есть колонки 
Symbol,  Diameter, Tolerance, Plated, Quantity слева 
направо. Порядок колонок можно изменить.
Можно добавить New Columns (новую колонку) - Hole 
Name (имя padstack отверстия) и Notes (пустая 
колонка для добавления текста позднее).  

Установки текста
Для текста (и графики) таблицы сверления можно 
задать Font name, Font size, Line spacing и Pen width 
(толщина линии).
Можно установить Format для размера отверстия 
чтобы отображать требуемое количество цифр с 
каждой стороны десятичной точки. Например, если 
стоит 1.3 то 34th отверстие отобразится как 0.034. 

Допуск по умолчанию
Если допуск отверстия не задан в padstack, то будет 
использовано Default tolerance заданное здесь.  

Текст Заголовок/Окончание
Можно добавить строку текста сверху и снизу 
таблицы сверления.  



Q-5 
 E XPEDITION PCB INTRODUCTION  WG2000 

В диалоге NC Chart Options измените Font size в 90, 
Format  в 1.3.

В диалоге NC Chart Options кликните кнопку OK для 
сохранения установок таблицы сверления.
Вернувшись в диалог NC Chart Options кликните кнопку 
OK чтобы обработать данные сверления и графику 
таблицы сверления.

4

Графика Таблицы Сверления
Процесс генерации сверления сначала создает 
данные сверления и протоколы, затем размещает 
символы сверления и таблицу сверления в графику. 
Верхний левый угол таблицы сверления расположен 
на начале координат платы (0/0) по умолчанию. Так 
как таблица сверления это ячейка ее можно двигать 
используя команды размещения.  

Выберите View>Fit All из меню.
Установите Режим Place и задайте область 

выбора вокруг части графики таблицы сверления, будьте 
осторожны, не выберите какую-либо топологию.

Кликните Клавишу Действия Move и переместите таблицу 
сверления в правый край топологии (как на рисунке).
Выберите View>Fit All из меню чтобы лючше видеть.

5

Используя File Viewer проверьте файлы протокола 
генерации NC Drill - NCDThruHolePlated.txt,

NCDThruHoleNonPlated.txt и NCDrill.txt.
Используя Windows Explorer переместитесь в 
c:\mgtraining\project\2001\pcb\output и откройте 
директорию ncdrill. Файлы .ncd (вместе с файлами 
Гербер созданными ранее) нужно передать вашему 
изготовителю плат.

6

Выходные Файлы Данных Сверления
Выходные файлы данных сверления необходимые для 
изготовления хранятся в директории output проекта 
платы. Также хранятся сводные файлы с остальными 
файлами протокола  
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Экспорт DXF
Чтобы добавить размеры в вашу топологию для 
документации, графику чертежа сверления нужно 
экспортировать из Expedition PCB и импортировать в 
чертежные программы, такие как MicroStation или 
AutoCAD. Это делается через файл формата DXF.  

Сохраните вашу топологию.
Выберите File>Export>DXF из меню чтобы открыть

диалог DXF Export.
7

Диалог Export DXF перечисляет все элементы графики 
использованные в топологии. Для упрощения операций 
экспорт/импорт, для эспорта нужно выбрать только 
нужные элементы графики.  

В диалоге Export DXF задайте DXF output filename 
drill (расширение .dxf добавится автоматически).8

Выберите Items Board Outline и Drill Drawing для экспорта.
Кликните кнопку OK чтобы экспортировать выбранную 
графику.
Используя Windows Explorer перейдите в 
c:\mgtraining\project\2001\pcb\output и заметьте что 
здесь хранится drill.dxf.

Сделайте конечную резервную копию топологии и 
сохраните ее в c:\mgtraining\project\2001done.9

Покиньте Expedition PCB.

Поздравляем работа сделана!  




